14:00:11 <lujinluo> #startmeeting neutron_upgrades
14:00:14 <openstack> Meeting started Thu Nov  1 14:00:11 2018 UTC and is due to finish in 60 minutes.  The chair is lujinluo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:15 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:18 <openstack> The meeting name has been set to 'neutron_upgrades'
14:00:19 <njohnston> o/
14:00:21 <lujinluo> o/
14:00:32 <ralonsoh> hi
14:00:39 <lujinluo> hi njohnston and ralonsoh !
14:01:07 <njohnston> Happy November!
14:01:23 <annp_> hi
14:01:24 <lujinluo> LOL
14:01:28 <lujinluo> hi annp_
14:01:43 <annp_> hi lujinluo
14:02:20 <lujinluo> thank you for chairing the meeting last week njohnston
14:02:25 <lujinluo> really appreciated that
14:02:35 <njohnston> Always happy to help :-)
14:02:53 <lujinluo> do we have any AIs carried from last week? if not, we can safely jump into the patches
14:03:04 <njohnston> looking...
14:03:45 <njohnston> ah that's right, nobody showed up :-)
14:03:49 <njohnston> it was just me
14:04:00 <lujinluo> oops
14:04:12 <lujinluo> sorry to hear that...
14:04:19 <njohnston> so going back a week
14:04:37 <lujinluo> two weeks ago, we have 2 AIs.
14:04:37 <njohnston> AI1: njohnston pick tests from https://review.openstack.org/609749 and step through with pdb to detect failure
14:05:10 <njohnston> I did that, but I was not able to drill down on the problem.  Still working on it in the background.
14:05:36 <lujinluo> Got it.
14:05:42 <njohnston> AI2: lujin to keep an eye on Network OVO in db_base_plugin
14:05:49 <njohnston> I think that has been happening :-)
14:06:47 <lujinluo> yeah, tuan pushed another patch set but only to resolve merge conflict
14:07:16 <lujinluo> but i believe he will finish working on to address our concerns soon
14:07:38 <lujinluo> i will follow him
14:08:11 <lujinluo> ok then, let's jump into the patches
14:08:16 <lujinluo> #topic OVO
14:08:28 <lujinluo> #link https://review.openstack.org/#/q/status:open+project:openstack/neutron+branch:master+topic:bp/adopt-oslo-versioned-objects-for-db
14:08:58 <lujinluo> #link https://review.openstack.org/#/c/579053/ Use OVO in neutron/ipam/subnet_alloc.py
14:09:12 <njohnston> I brought that one back from the dead
14:09:26 <njohnston> I pushed a change to fix the merge conflict
14:09:29 <ralonsoh> I think this is going to fail again
14:09:35 <lujinluo> on test_subnetpool_concurrent_allocation_exception ?
14:09:35 <njohnston> and now I am working on the review feedback
14:09:38 <ralonsoh> comments in PS10 and PS11
14:09:43 <njohnston> it definitely will for the reason you identified, ralonsoh
14:09:47 <njohnston> right
14:09:58 <lujinluo> i see.
14:10:11 <njohnston> the thing is I am looking for the right place to mock to create a concurrent allocation exception
14:10:31 <njohnston> but with the new code it looks like what is happening is that an IpamSubnet object is getting instantiated
14:12:34 <lujinluo> i see.
14:12:36 <njohnston> I guess the thing to do is to mock subnet_pool.update() and have that throw the exception
14:12:45 <lujinluo> so it is still how we can mock .update()
14:12:51 <lujinluo> yeah
14:14:40 <njohnston> ok, if no objections that is what I'll do
14:14:59 <njohnston> the only other alternative
14:15:40 <njohnston> is to mock update_object in the base update method https://git.openstack.org/cgit/openstack/neutron/tree/neutron/objects/base.py#n806
14:16:54 <lujinluo> well, i think it might be easier to mock update_object as it has direct db access
14:17:25 <lujinluo> as update() is only calling methods from db_api
14:18:13 <njohnston> ok
14:18:20 <njohnston> your wish is my command
14:18:54 <lujinluo> LOL, but i have not done as much research as you did. you are the master of this patch
14:19:37 <lujinluo> just my rough idea that it might be easier to mock update_object()
14:19:46 <njohnston> sounds good
14:20:21 <lujinluo> i will keep a close eye on that patch! since i am finishing all the midterms this week, so i will more bandwidth for openstack, haha
14:21:06 <lujinluo> let's move to the next
14:21:12 <lujinluo> #link https://review.openstack.org/#/c/549168/ Router OVO
14:21:31 <lujinluo> annp_: hi, i see it is still WIP, but do you have anything you want to share?
14:22:26 <annp_> lujinluo, Hi, I'm making progress on that.
14:22:39 <annp_> However, gate still red
14:23:10 <annp_> Currently, I've just cleanup something,
14:23:31 <lujinluo> yes, router is a rather big object. you change one place and it may propagate to many more.
14:24:20 <lujinluo> annp_:  sounds good.
14:24:29 <annp_> lujinluo, yes. I'm debugging some test failed related to gw_port
14:25:06 <lujinluo> got it.
14:25:37 <annp_> lujinluo, could you take a look and give me some advise if you have time.
14:25:45 <annp_> Thanks in advance. :-)
14:25:51 <lujinluo> sure. i will add it to my review list
14:26:08 <lujinluo> #action lujinluo to review https://review.openstack.org/#/c/549168/
14:26:17 <lujinluo> then let's move to next
14:26:39 <lujinluo> Use NetworkRBAC OVO in neutron/db/db_base_plugin_v2.py
14:26:41 <lujinluo> #link https://review.openstack.org/#/c/608198/
14:27:33 <lujinluo> it has been sent to the queue, and Rodolfo just rechecked Zuul failure. Let's pray for Zuul's mercy
14:27:48 <njohnston> :-)
14:28:10 <lujinluo> #link https://review.openstack.org/#/c/608628/
14:28:23 <lujinluo> may the same mercy go to ^
14:29:08 <lujinluo> #link https://review.openstack.org/#/c/610182/ Support fetching specific db column in OVO
14:29:44 <lujinluo> this patch has receive multiple +1 from our team
14:30:05 <lujinluo> let me add miguel and slawek to it and ask them to do the final check
14:30:43 <ralonsoh> lujinluo: the CI is going to be back once we have requirements updated
14:31:09 <njohnston> +1
14:32:30 <lujinluo> which patch are you talking about? ralonsoh networkRBAC or specifi db column? or maybe both?
14:32:57 <ralonsoh> lujinluo: I'm talking about the CI
14:33:24 <lujinluo> Ah, I see.
14:33:25 <ralonsoh> lujinluo: once requirements repo is updated will have the CI back
14:34:34 <lujinluo> Got it
14:36:37 <lujinluo> ok, let's move to next patch
14:36:48 <lujinluo> #link https://review.openstack.org/#/c/610184/
14:37:04 <lujinluo> Convert Subnet to OVO in ipam_pluggable_backend.py
14:37:23 <lujinluo> this patch utilize fetching specific db column
14:37:46 <lujinluo> and should wait for that one to get in first
14:38:02 <lujinluo> but the change is quite simple
14:38:43 <lujinluo> oops, i missed on patch in the between
14:38:55 <lujinluo> #link https://review.openstack.org/#/c/608638/ Use NetworkRBAC OVO in tests/unit/db/test_db_base_plugin_v2.py
14:39:31 <lujinluo> it is hit by merge conflict
14:39:43 <ralonsoh> lujinluo, waiting for the previous ones to be merged
14:39:56 <lujinluo> understood.
14:39:56 <ralonsoh> once I have the previous two patches, I'll rebase this one
14:40:04 <lujinluo> sounds good
14:40:09 <lujinluo> :-)
14:40:29 <lujinluo> next is a WIP patch
14:40:41 <lujinluo> #link https://review.openstack.org/#/c/609848/ Convert Port to OVO in db/ipam_pluggable_backend.py
14:41:39 <lujinluo> it is still pretty red. let's give it some time
14:42:00 <lujinluo> #link https://review.openstack.org/#/c/507772/ Network OVO
14:42:30 <lujinluo> still i will keep an eye on this patch and talk to tuan to see if he needs more help from our team
14:43:23 <lujinluo> #link https://review.openstack.org/#/c/610280/ Use RBACBaseObject OVO in neutron/db/rbac_db_mixin.py
14:43:53 <ralonsoh> same as previous one
14:43:59 <lujinluo> got it!
14:45:31 <lujinluo> #link https://review.openstack.org/#/c/611461/
14:45:48 <lujinluo> this is the bug fix of #1789434
14:46:12 <lujinluo> we have decided to wait for it to pass all the gate tests before reviewing it
14:46:55 <lujinluo> next is the retry decorator
14:47:02 <lujinluo> #link https://review.openstack.org/#/c/602362/
14:47:35 <lujinluo> Lajos proposed a new patch about two weeks ago
14:47:38 <njohnston> ah yes, I remember this one
14:47:43 <lujinluo> i have not review it myself yet
14:47:53 <njohnston> I can take a look at that, give a fresh eye to it
14:48:01 <lujinluo> thanks! njohnston
14:48:47 <lujinluo> next is mine
14:48:53 <lujinluo> #link https://review.openstack.org/#/c/544206/ Port Binding OVO
14:49:46 <lujinluo> I will another patch set soon to resolve the merge conflict and address Hongbin's comment
14:49:54 <hongbin> o/
14:50:01 <lujinluo> that's all the patches we have for OVO
14:50:05 <lujinluo> hi hongbin !
14:50:18 <hongbin> lujinluo: it looks the meeting is over :)
14:50:29 <hongbin> s/almost
14:50:37 <lujinluo> half of it is over, we still have another topic, lol
14:50:42 <lujinluo> #topic engine facade
14:50:45 <lujinluo> #link https://review.openstack.org/#/q/status:open+project:openstack/neutron+branch:master+topic:bp/enginefacade-switch
14:50:54 <lujinluo> although we only have one patch to discuss
14:51:20 <lujinluo> Remove context guard of Agent OVO
14:51:22 <lujinluo> #link https://review.openstack.org/#/c/611462/
14:51:26 * hongbin is lurking
14:51:47 <lujinluo> hongbin had a comment which i think makes sense
14:52:11 <lujinluo> i will revise the patch set, to add the transaction guard back in new engine facade
14:52:23 <hongbin> cool
14:52:31 <lujinluo> indeed there are two transactions opened
14:52:49 <lujinluo> and we should guard them together
14:53:07 <lujinluo> #topic open discussion
14:53:22 <lujinluo> i just noticed Berlin summit is around the corner!
14:53:29 <lujinluo> anyone from our team is going?
14:53:32 <lujinluo> have fun!
14:53:47 <hongbin> i will go there
14:53:47 * njohnston cannot make it this time, sadly
14:54:09 <lujinluo> njohnston: i am not going either. :(
14:54:17 <lujinluo> wow, have fun hongbin!
14:54:26 <hongbin> lujinluo: thanks
14:54:37 <lujinluo> does anyone have anything else to share?
14:54:50 <lujinluo> if not, let's call it a day! we only have 6 min left this time
14:55:05 <njohnston> thanks all
14:55:33 <lujinluo> thank you all for joining the meeting this time. hope to see you all next week
14:55:40 <lujinluo> #endmeeting