14:03:51 <russellb> #startmeeting nfv
14:03:51 <openstack> Meeting started Wed Jun 11 14:03:51 2014 UTC and is due to finish in 60 minutes.  The chair is russellb. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:03:52 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:03:55 <openstack> The meeting name has been set to 'nfv'
14:03:57 <russellb> hello!
14:03:59 <mestery> o/
14:04:03 <yamahata> hi
14:04:03 <russellb> who's around to chat NFV today?
14:04:03 <cdub> o/
14:04:04 <nijaba> \o
14:04:06 <cgoncalves> hi
14:04:07 <cloudon> hello
14:04:09 <aveiga> o/
14:04:10 <pcarver> hi
14:04:10 <imendl> hi
14:04:11 <heyongli> Hi
14:04:13 <sean-k-mooney> o/
14:04:16 <adrian-hoban> Howdy
14:04:17 <pczesnowicz> hi
14:04:21 <ramki> hi
14:04:28 <jmsoares> hello
14:04:30 <russellb> #link https://wiki.openstack.org/wiki/Meetings/NFV
14:04:39 <russellb> agenda is on an etherpad, feel free to add stuff to it
14:04:48 <russellb> #link https://etherpad.openstack.org/p/nfv-meeting-agenda
14:04:56 <russellb> #topic actions from last week
14:05:04 <russellb> we had a few small actions from last week
14:05:14 <russellb> I got the NFV topic added to the openstack-dev mailing list
14:05:25 <russellb> which means you should be able to subscribe to only that topic on the list instead of the full list if you want.
14:05:38 <russellb> topics aren't set up for the main openstack@ list, though
14:05:39 <russellb> just -dev
14:05:46 <russellb> the other thing was #openstack-nfv setup
14:05:53 <russellb> the channel exists, people have been joining
14:05:55 <adrian-hoban> Thanks russellb
14:06:05 <russellb> it's not officially managed by openstack-infra yet
14:06:16 <yarbel> hi
14:06:17 <russellb> that's pending cdub adding openstackinfra as a channel owner
14:06:23 <Dmitry_HUawei> What about request for incubation?
14:06:40 <russellb> Dmitry_HUawei: no incubation request needed, that's for specific projects
14:06:54 <russellb> where as this group is more of a horizontal effort spanning multiple existing projects
14:06:55 <adrian-hoban> russellb: Are we going to move future NFV meetings to that channel?
14:07:08 <russellb> adrian-hoban: no, that's just for chatter throughout the week if people would like to
14:07:17 <russellb> this channel is where we have the meetbot for logging the meeting
14:07:32 <mikebugenhagen> Russellb - has anyone posted the open link that we can all get the NFV use cases from.. it's http://www.etsi.org/technologies-clusters/technologies/nfv
14:07:47 <ramk_> hi
14:07:48 <russellb> mikebugenhagen: i think that has been posted before
14:07:56 <russellb> use cases are the next topic
14:08:06 <russellb> #action cdub to add openstackinfra as an owner of #openstack-nfv
14:08:14 <russellb> the last was a gerrit dashboard for nfv work
14:08:22 <russellb> but bauzas couldn't make it today
14:08:29 <russellb> #action bauzas to make gerrit dashboard
14:08:32 <Dmitry_HUawei> russellb: could you update please on ServiceVM cooperation?
14:08:33 <russellb> so we'll keep it on the list for next week
14:08:38 <mikebugenhagen> NFV also was developing a Standards gap list in the NFV Tech steering commitee - so they may have a openstack NFV gap list as well
14:08:42 <adrian-hoban> Direct link is here:  http://www.etsi.org/deliver/etsi_gs/NFV/001_099/001/01.01.01_60/gs_NFV001v010101p.pdf
14:08:53 <russellb> #topic use cases
14:09:05 <russellb> cdub: want to cover this one?
14:09:10 <russellb> there has been some ML discussion
14:09:15 <russellb> and some initial content has been added to the wiki page
14:09:30 <russellb> #link https://wiki.openstack.org/wiki/Meetings/NFV#Use_Cases
14:09:40 <cdub> ah beat me too it
14:10:03 <cdub> sgordon put this table together (above link)
14:10:05 <russellb> cdub: have any thoughts on next steps with this?
14:10:22 <s3wong> russellb: sgordon mentioned we should focus first on use case #5 on the doc, which in section 9.5 has a good list of "problems and issues" to start with
14:10:50 <sgordon> s3wong, there was a suggestion from itai and alan that 2 and 7 might make more sense too
14:10:53 <sgordon> im open to ideas
14:11:00 <sgordon> slash opinions :)
14:11:09 <mikebugenhagen> Before going over the use cases it may be a good idea to go over the "vitualization architecture framework" document
14:11:21 <s3wong> sgordon: sure
14:11:29 <russellb> sgordon: hey!
14:11:30 <mikebugenhagen> It lays out all the different AZ's that NFV brings into a single domain for orchestration
14:13:00 <ramk__> We are have OpenStack gap analysis documents in ETSI NFV under member only access. I can work on getting public version of the documents (at least a draft) to fuel the kick start.
14:13:02 <russellb> another thing in this area that i think would be helpful, is a couple paragraphs on this wiki page describing what NFV is
14:13:03 <cdub> mikebugenhagen: what do you mean "go over" collectively scan the doc?
14:13:08 <Dmitry_HUawei> mikebugenhagen: could you share please the link to the document (vitualization architecture framework")?
14:13:12 <russellb> i look at a lot of this as a page we can send devs / reviewers to
14:13:38 <nijaba> russellb: I can take that task
14:13:41 <s3wong> ramk__: that would also be good
14:13:45 <ggarcia> NFV architectural framework: http://www.etsi.org/deliver/etsi_gs/NFV/001_099/002/01.01.01_60/gs_NFV002v010101p.pdf
14:13:47 <mikebugenhagen> The document is #2 on that link
14:13:56 <russellb> nijaba: ok, that'd be great
14:14:15 <nijaba> #action nijaba to write up a description of what nfv is on the wiki page
14:14:20 <russellb> #action nijaba to add a paragraph or two to the wiki giving an NFV overview, targeted at OpenStack developers / reviewers
14:14:24 <russellb> heh
14:14:27 <mikebugenhagen> I would think that Open Stack NFV might want to create a gap list to track all the things the NFV is proposing that doesn't align with the current framework
14:14:28 <nijaba> sorry
14:14:31 <russellb> no worries
14:14:34 <adrian-hoban> This is good reading to help understand where OpenStack fits in ETSI-NFV terminology
14:14:37 <russellb> nijaba: now you just have to do it twice as well
14:14:43 <nijaba> lol
14:14:49 <mikebugenhagen> aka - a working list to record NFV proposed changes
14:15:08 <s3wong> mikebugenhagen: I think that is what ramk__ referred to. That the ETSI NFV group is already doing gap analysis
14:15:27 <sgordon> right, but we need visibility of that to succeed
14:15:40 <sgordon> particularly to make progress in juno for example, which is rapidly progressing
14:15:48 <s3wong> if ramk__ can give us a public version, that is a good reference
14:15:52 <mikebugenhagen> NFV has a gap list of what they think is a gap in Open stack... but I think Open stack should have a list of validated deltas... in Open stack language
14:15:54 <sgordon> (though i think we already have a good idea of the low hanging "nits")
14:16:08 <russellb> mikebugenhagen: yeah that's what this wiki page is shaping up to be, or at least that's the idea
14:16:13 <cdub> mikebugenhagen: that's very roughly what we are trying to build on the wiki page
14:16:14 <mikebugenhagen> cool
14:16:17 <s3wong> sgordon: yes, J-1 is... this week :-)
14:16:18 <adrian-hoban> The wiki is a good start, but there are deltas between the two lists
14:16:41 <sgordon> alan made some good points on list wrt sticking to the lowest common configurations too
14:16:44 <russellb> adrian-hoban: would be great to discuss those
14:16:49 <sgordon> rather than getting into some of the more exotic options
14:17:08 <mikebugenhagen> I think schema's (architecture) will provide the best view of big framework mis-alignments, then the use cases give implementation specific gaps
14:17:27 <adrian-hoban> russellb: I think that doc is available for ETSI-NFV members only, so will have to check how much we can share here right now...
14:17:36 <russellb> heh
14:17:51 <mikebugenhagen> both the use cases and architecture doc's are here - http://www.etsi.org/technologies-clusters/technologies/nfv
14:18:06 <mikebugenhagen> the gap list is a TSC item open to NFV members we'd have to liaison?
14:18:19 <adrian-hoban> The other ETSI-NFV links that have been shared are already public.
14:18:32 <adrian-hoban> mikebugenhagen: Yes, I think so.
14:18:57 <s3wong> mikebugenhagen: is there anyone attending this subteam meeting that is also working on the ETSI NFV group gap analysis?
14:19:19 <martin_t> it's good to discuss top down input from the ETSI framework, but I think we surely also need bottom up input from VNF implementers
14:19:25 <imendl> my rteam is
14:19:27 <imendl> team
14:19:35 <Dmitry_HUawei> i'm wondering about potential cooperation with ServiceVM group
14:19:41 <cdub> martin_t: do you have any specific examples?
14:19:43 <russellb> sgordon: think as a next step this week, we should start mapping blueprints to the use cases on the wiki page?  have them linked?
14:19:49 <ggarcia> I am on that gap analysis. In fact all WG are expected to contribute to the gap analysis
14:19:55 <ramk__> yes, I am looking at the ETSI NFV group gap analysis
14:20:01 <mikebugenhagen> I think Michael Brenner is the "NFV open stack" area manager so he's the guy who should be coordinating getting the gap list to Openstack..
14:20:11 <martin_t> example: session border control needs to relay 5M packets per second with low latency spread across several cores
14:20:17 <s3wong> so we have imendl ggarcia and ramk__ at least - great!
14:20:21 <cdub> Dmitry_HUawei: it's come up as well
14:20:38 <russellb> Dmitry_HUawei: we discussed it some last week
14:20:38 <adrian-hoban> russellb: I have sent a draft proposal on that mapping. alank has made the good point that we need to add more specific application considerations
14:20:39 <sgordon> russellb, yeah i agree
14:20:49 <Dmitry_HUawei> cdub: great, thanks
14:20:51 <ggarcia> All WGs are expected to contribute to the gap anaysis. The first contributions will come probably from PER EG (Performance and Portability Expert Group) once the draft is approved
14:20:51 <sgordon> russellb, in the quick glance table the requirements column is really intended for that
14:20:52 <cdub> martin_t: ok, https://wiki.openstack.org/wiki/Meetings/NFV#Use_Cases <-- has data plane in there
14:21:04 <russellb> sgordon: adrian-hoban OK great, that sounds like a good action / next step
14:21:09 <sgordon> but we could do it in the context of the more specific user stories though
14:21:24 <cdub> martin_t: best is to reply to the list thread discussing use cases (and vnf's are part of that usecase)
14:21:31 <russellb> #action sgordon to coordinate with adrian-hoban and others to continue working on use cases on wiki, mapping them to blueprints
14:22:04 <sgordon> adrian-hoban, yes - trying to refer to those to create some linkage between the two worlds
14:22:26 <sgordon> adrian-hoban, would be good to make sure we're aligned with what's happening within ETSI NFV that is not yet public (even as a draft) as well tho
14:23:08 * cdub gets pulled away, bbiab
14:23:22 <russellb> any more to discuss on this?  or should we hit some specific blueprints?
14:23:48 <adrian-hoban> martin_t: Agree that more details for the VNF implementations will really help. If we can align with the use cases even better. Use cases 2, 5 and 7 have been proposed as lead candidates
14:23:49 <ramk__> yes sgordon, that is exactly what I am trying to do and specifically for the openstack gap analysis
14:24:22 <martin_t> adrian-hoban: we have plenty of input on use case #5 re vIMS
14:24:48 <imendl> don't we need to map ETSI use cases, to gaps to BP. We have the beginning but shall we aim for it?
14:25:04 <mikebugenhagen> ramk - I just emailed the TSC chairs at the NFV TSC and asked them to bless you uploading the gaps for openstack.... I cc'd ya
14:25:55 <ramk__> mike - thanks a lot
14:25:55 <sgordon> thanks mikebugenhagen, ramk__
14:26:04 <sgordon> will make it much easier to demonstrate to the wider community
14:26:05 <adrian-hoban> mikebugenhagen: Good stuff
14:26:07 <ggarcia> the gap analysis won't be available until the end of the year
14:26:20 <sgordon> even draft material would be extremely helpful though
14:26:36 <s3wong> ggarcia: would be good to gain some access to drafts
14:27:02 <russellb> yes, the earlier the better, otherwise we're more likely to diverge
14:27:03 <ggarcia> s3wong: OK
14:27:08 <russellb> now that momentum is building in openstack
14:27:09 <adrian-hoban> ggarcia: I've been following the gaps taked about in the MANO working group... Perhaps we can get agreement to share the draft list?
14:27:13 <mikebugenhagen> NFV has placed some open drafts in that link I provided
14:27:33 <mikebugenhagen> Most of the "open drafts" should be available by 1 August.
14:27:39 <ggarcia> s3wong: there 4 official documents to be downloaded here (http://www.etsi.org/technologies-clusters/technologies/nfv) with newer versions to come
14:28:06 <mikebugenhagen> http://www.etsi.org/technologies-clusters/technologies/nfv  -  Look at the "related documents section on this same link" - bottom right
14:28:15 <s3wong> ggarcia: thanks
14:28:28 <russellb> this?  http://docbox.etsi.org/ISG/NFV/Open/Latest_Drafts/
14:28:37 <ggarcia> s3wong: besides, there is a web page where stable drafts are published: http://docbox.etsi.org/ISG/NFV/Open/Latest_Drafts/
14:28:42 <adrian-hoban> Shall I update the wiki with the draft mappings of use cases to blueprints that I sent on the ML?
14:29:03 <mikebugenhagen> russelb - correct those are the latest open drafts
14:29:08 <s3wong> adrian-hoban: I think so, otherwise sending reply to email thread will easily get lost
14:29:17 <russellb> #link http://docbox.etsi.org/ISG/NFV/Open/Latest_Drafts/
14:29:22 <russellb> adrian-hoban: yes i think that sounds great
14:29:28 <adrian-hoban> ok
14:29:54 <mikebugenhagen> The MANO (management and orchestration) draft isn't there yet - expect 2 more weeks before you can see that one
14:29:57 <sgordon> +1
14:29:58 <ggarcia> adrian-hoban: #agreed
14:30:57 <adrian-hoban> Should we have a section in the wiki to capture some of the more detailed requirements for a couple of applications we will assess more closely?
14:31:24 <russellb> adrian-hoban: that sounds useful to me
14:31:24 <imendl> adrian, are you mapping the etsi use cases or the "data plane" as an example in the wiki?
14:31:26 <ramk__> it would be also be worth adding a link to the ETSI NFV PoCs in the wiki - many of the PoCs use OpenStack - http://www.etsi.org/technologies-clusters/technologies/nfv/nfv-poc
14:31:27 <cloudon> adrian-hoban: sounds good, and happy to provide examples
14:31:32 <s3wong> adrian-hoban: have we finalized on which applications we will look more closely for Juno?
14:32:40 <adrian-hoban> imendl: The use case mapping... but I still think the application details will be more insightful.
14:32:41 <cloudon> imendl, adrian-hoban: I can provide details of specific appl example illustrarting data plane use case if that helps
14:32:57 <imendl> adrian, agreed
14:33:10 <fjramons> Well, that is not that clear in my opinion
14:33:17 <imendl> happy to work on it together
14:33:45 <imendl> cloudon, pleased o
14:34:03 <s3wong> cloudon: that sounds great
14:34:07 <adrian-hoban> s3wong: I don't think so... CPE for Enterprise, CPE for residential and EPC/IMS are the proposed candidate use cases that have been mentioned in the ML
14:34:25 <fjramons> cloudon: it sounds good
14:35:06 <adrian-hoban> cloudon: That would be great
14:35:21 <s3wong> adrian-hoban: that's plenty for Juno already :-)
14:35:58 <fjramons> s3wong, adrian-hoban: Actually, all of those use cases have the same requirements in common
14:36:26 <fjramons> All of them look like routers from the management and performance perspective
14:36:52 <imendl> fjramons, but not all NFV apps are routers...
14:37:08 <fjramons> imendl: Yes, but all that adrian-hoban mentioned do
14:37:19 <fjramons> But the IMS
14:37:27 <s3wong> fjramons: IMS seems to have many components that may not be all routers-like?
14:37:33 <imendl> well. not all epc elements are neither
14:37:39 <fjramons> Agreed
14:37:49 <jmsoares> fjramons: from performance perspective the requirements are not the same I guess
14:37:58 <fjramons> But not all of them have differential requirements either, that is the point
14:38:20 <jmsoares> at least if we compare EPC/IMS with CPE functions
14:38:27 <cloudon> IMS has plenty of control plane functions with low perf (vs data plane) but other reqs such as support for their HA models
14:38:27 <martin_t> one key IMS element is SBC which relays media packets - different from router use case as all packets are small (~100 bytes)
14:38:43 <fjramons> jmsoares: The point that I am trying to make is whether anything especial needs to be added or not to OpenStack for a given use case
14:39:05 <fjramons> If OpenStack as it is is appropriate for a given use case, then we can move on
14:39:10 <adrian-hoban> I see a lot of common base level enabling features that we need to work on for all of these use cases.
14:39:23 <fjramons> What I am suggesting is that we focus in the "gaps", if any
14:39:36 <ggarcia> imendl, fjramons, jmsoares: CPE, EPC, IMS and routers are different in terms of functionality, but when talking about requirements to OpenStack (and OpenStack user stories) all we need to differentiate is the type of workload that they are handling
14:39:47 <fjramons> Not every use case has gaps by default
14:39:58 <jmsoares> fjramons: from a functional perspective only then. ok
14:39:59 <s3wong> fjramons: that's fair. I think as adrian-hoban said, we can first focus on these couple applications, and with cloudon giving detail example and use, we can map the requirements to existing BPs
14:40:25 <imendl> Yes we should focus on gaps and on the workloads. agreed. then maps those to candidate bp. but the context for the audience seems to be imprtant
14:40:34 <jmsoares> ggarcia: agree
14:40:40 <fjramons> imedl: agreed
14:40:40 <cloudon> agree - can give examples of both control plane (IMS) and data plane (border controller) which will both have mix of generic & specific gaps
14:40:57 <imendl> I think we can
14:40:58 <s3wong> imendl: sure
14:41:01 <fjramons> Sure
14:41:09 <s3wong> cloudon: +1, please do
14:41:19 * danpb is drowning in acronyms ETSI ... TSC ... MANO ... CPE ... EPC ... IMS
14:41:20 <adrian-hoban> Let's add them to the new section in the wiki
14:41:25 <fjramons> Agreed
14:41:31 <cloudon> is ML best place ordirect to  wiki?
14:41:33 <s3wong> adrian-hoban: +1
14:41:45 <ggarcia> adrian-hoban: +1
14:41:48 <cdub> danpb: we need an acronym decoder
14:41:50 <russellb> ML is best to discuss / agree on things
14:41:57 <russellb> document results on wiki
14:42:04 <cloudon> ok
14:42:25 <russellb> but don't be afraid to update the wiki either
14:42:30 <russellb> can always be changed :)
14:44:27 <s3wong> Seems like we already got a bunch of good action items for next week
14:44:44 <russellb> Yeah, seems like it :)
14:44:48 <russellb> #topic open discussion
14:44:59 <russellb> lots of designs that need to be reviewed
14:45:11 <danpb> Please would all those active in this area please add themselves to https://wiki.openstack.org/wiki/Meetings/NFV#Who_we_are
14:45:13 <russellb> any feedback on them is useful
14:45:29 <danpb> there's so many people it isnt always obvious who everyone is from IRC nicks
14:46:14 <s3wong> danpb: we did put down our IRC nicks on the wiki table... though there are already a lot of people
14:46:21 <runarut> FYI - i don’t have permission to edit the WIKI who we are page.  i assume others are in the same boat.
14:46:36 <russellb> runarut: you should be able to if you log in
14:46:40 <nijaba> runarut: you need to login first
14:46:59 <adrian-hoban> Should we use the time to discuss some of the blueprints?
14:47:03 <runarut> i am logged in.
14:47:42 <russellb> adrian-hoban: sure, we can do that, have any particular ones you'd like to cover?
14:47:43 <runarut> edit is limited to users within a group or so the error message says.
14:47:47 <danpb> oh hmm, have you signed the OpenStack CLA ?
14:48:00 <adrian-hoban> Start from the top of the wiki if the submitter is here to discuss?
14:48:04 <russellb> sure
14:48:09 <runarut> ah, the CLA - thanks - i’ll get right to it.
14:48:21 <russellb> #link https://blueprints.launchpad.net/nova/+spec/2-if-1-net
14:48:24 <russellb> i don't see ijw
14:48:32 <russellb> there's already some feedback on the spec
14:48:43 <russellb> pretty basic feedback so far
14:49:04 <russellb> that one is "Support two interfaces from one VM attached to the same network"
14:49:11 <russellb> but no opposition so far that we need to work through
14:49:32 <russellb> next is "VLAN trunking networks for NFV"
14:49:40 <russellb> 3 blueprints on this line item
14:49:49 <russellb> #link https://blueprints.launchpad.net/neutron/+spec/nfv-vlan-trunks
14:49:52 <yamahata> servicevm team will drive it
14:49:57 <russellb> #link https://blueprints.launchpad.net/neutron/+spec/l2-gateway
14:50:03 <yamahata> At least I'll try to coordinate with Ian
14:50:03 <russellb> #link https://blueprints.launchpad.net/neutron/+spec/vlan-aware-vms
14:50:07 <russellb> yamahata: OK, cool
14:50:15 <russellb> have any info on how they're coming along?
14:50:21 <russellb> i haven't had a chance to look at these designs
14:50:30 <s3wong> russellb: all three of these are somewhat similar by nature
14:50:54 <s3wong> they all VLAN tagging on Neutron port, basically
14:51:00 <s3wong> *all want
14:51:53 <russellb> last one in this top section is "Permit unaddressed interfaces for NFV use cases"
14:51:59 <russellb> #link https://blueprints.launchpad.net/neutron/+spec/nfv-unaddressed-interfaces
14:52:15 <yamahata> Also servicevm team will work with Ian, the original auther.
14:52:23 <russellb> OK, cool
14:52:31 <yamahata> I gave feedback on it, and will work with him
14:52:54 <russellb> mestery: lots of neutron blueprints in here :)
14:53:02 <russellb> you have these on your radar?
14:53:05 <cgoncalves> how should all other blueprints in the second table be prioritized?
14:53:15 <mestery> russellb: We have most of them on our radar, we should syncup on this though.
14:53:21 <mestery> russellb: Juno-2 is looking packed :)
14:53:25 * russellb nods
14:53:28 <russellb> always
14:53:35 <russellb> all milestones get packed :)
14:53:40 <russellb> comes down to who can deliver code
14:53:45 * mestery nods vigorously in agreement.
14:53:50 <mestery> russellb: +1000
14:53:56 <russellb> i think we have enough momentum behind things in this area that hopefully we can deliver on them
14:54:05 <russellb> often code is held back until designs get approved though
14:54:08 <russellb> as it should, really
14:54:13 <russellb> but i'm quite optimistic about these items
14:54:40 <mestery> russellb: Happy to help sort through these, we should sync on this tomorrow or Friday.
14:54:49 <russellb> mestery: OK, sure
14:55:00 <russellb> mestery: and if not, we can talk more in next weeks' meeting here
14:55:12 <mestery> russellb: Perfect!
14:55:18 <russellb> great, thanks
14:55:37 <russellb> bunch of nova designs i need to review ...
14:55:56 <russellb> danpb: how blocked are you on getting spec reviews?
14:56:04 <ramk__> policy is one of the important pieces of the NFV puzzle; with that context it would be worth getting the Congress proposal in the NFV wiki
14:56:35 <cdub> ramk__: you can add it, but it's much further out
14:56:38 <russellb> ramk__: maybe a new section on related teams/projects
14:57:44 <russellb> alright, well I think that's pretty good for today
14:57:49 <russellb> thanks everyone for coming by!
14:57:55 <russellb> talk to you on the mailing list, and here next week
14:57:56 <shane-wang> bye
14:57:59 <russellb> #endmeeting