14:01:47 <russellb> #startmeeting nfv
14:01:48 <openstack> Meeting started Wed Jul  9 14:01:47 2014 UTC and is due to finish in 60 minutes.  The chair is russellb. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:49 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:51 <openstack> The meeting name has been set to 'nfv'
14:01:58 <bauzas> \o
14:02:00 <sgordon> \o/
14:02:00 <russellb> hello!  who's around to chat about NFV?
14:02:04 <s3wong> hello
14:02:04 <russellb> #chair sgordon
14:02:04 <openstack> Current chairs: russellb sgordon
14:02:07 <cloudon> hi
14:02:09 <nijaba> o/
14:02:17 <pcarver> hi
14:02:20 <JohnHaller> hi
14:02:25 <russellb> #link https://wiki.openstack.org/wiki/Teams/NFV
14:02:32 <jchapman> Hey
14:02:38 <russellb> agenda on this etherpad, feel free to add to it:
14:02:40 <russellb> #link https://etherpad.openstack.org/p/nfv-meeting-agenda
14:02:46 <davidpc> hi
14:02:52 <russellb> #topic review actions from last week
14:03:01 <russellb> action: bauzas to finish up work to automatically keep a short URL up to date for NFV gerrit dashboard
14:03:04 <russellb> bauzas: o/
14:03:10 <bauzas> russellb: 8o
14:03:13 <bauzas> oops
14:03:14 <bauzas> \o
14:03:23 <russellb> so you made some nice script progress
14:03:34 <russellb> and we have the dash auto updated now at http://nfv.russellbryant.net/
14:03:39 <russellb> #link http://nfv.russellbryant.net/
14:03:44 <bauzas> so, indeed, I finished the work but we have to land the script in there
14:03:45 <bauzas> yes
14:04:04 <russellb> what do i need to change
14:04:15 <russellb> update to the latest so it writes out the html?
14:04:22 <bauzas> one last thing is about embedding all the WSGI app inside the script so that wouldn't require to be hosted by an apache server
14:04:41 * russellb doesn't mind just using apache personally, but if you want :)
14:04:45 <bauzas> yep, the last commit was about creating an HTML file with a jinja templce
14:04:50 <bauzas> template
14:04:52 <russellb> cool
14:05:07 <russellb> #action russellb to update bauzas' script on nfv.russellbryant.net
14:05:09 <bauzas> well, take it as a homework :)
14:05:24 <russellb> so, again, really appreciate your work
14:05:30 <russellb> i've used it a lot in the last week to get reviews done
14:05:37 <russellb> we got some blueprints approved and a bunch of patches too
14:05:42 <bauzas> yeah
14:05:44 <russellb> any other notes on the dashboard?
14:06:10 <bauzas> nope, you can modify the dashboard by editing nfv.dash
14:06:20 <bauzas> and put any queries you want
14:06:34 <russellb> cool, what you have works well for me so far
14:06:41 <bauzas> that's also why I want to have it running on a WSGI app, so any people could run it on its own laptop
14:06:52 <russellb> ok
14:06:55 <sgordon> russellb, well if i wanted a pony
14:07:02 <bauzas> :)
14:07:10 <russellb> sgordon: figures you'd want a pony.
14:07:11 <sgordon> russellb, i would say we could track patches attached to bugs tagged nfv
14:07:15 <sgordon> as well
14:07:22 <sgordon> but there aren't actually many in the tags atm anyway
14:07:24 <sgordon> so a moot point
14:07:28 <russellb> cool idea though
14:07:37 <russellb> file a bug on the dashboard github project :)
14:07:43 <sgordon> mwahaha
14:07:50 <russellb> or a pull request :-p
14:07:53 <russellb> ok, moving on
14:07:56 <russellb> #topic use cases
14:07:59 <russellb> sgordon: you had this on the agenda?
14:08:11 <sgordon> only if someone has something to talk about
14:08:19 <sgordon> i dont think we have looked at this much in the last 1-2 weeks
14:08:30 <russellb> right
14:08:35 <sgordon> there was an additional example provided via the ML I have not wikified yet
14:08:43 <russellb> have a link?
14:08:52 <russellb> and anyone willing to volunteer to wiki-ify the new use case?
14:09:03 <cloudon> It was from me, so I can dfo it
14:09:32 <cloudon> Link is http://lists.openstack.org/pipermail/openstack-dev/2014-June/038556.html
14:09:36 <sgordon> yeah that one!
14:10:11 <cloudon> That gives specific examples of a control plane & data plane use case, linking to over a dozen blueprints...
14:10:27 <russellb> #link http://lists.openstack.org/pipermail/openstack-dev/2014-June/038556.html
14:10:39 <cloudon> ...do people think that's enough for now, or are there important gaps they didn't cover?
14:10:41 <russellb> #action cloudon to add newest use case to the wiki
14:10:54 <russellb> i think that's great coverage
14:10:55 <russellb> IMO..
14:11:02 <sgordon> cloudon, i think for where we are in the cycle it's great
14:11:14 <cloudon> cool
14:11:18 <russellb> thanks for the help!
14:11:40 <russellb> anything else on use cases?
14:11:49 <cloudon> I need to follow up with bauzas over group anti-affinity concept I raised
14:12:04 <russellb> ah yes, that's a good one
14:12:11 <russellb> maybe we should capture it on the wiki under "dev not yet started"
14:12:14 <russellb> that's an empty section for now
14:12:26 <russellb> but we should track ideas
14:12:35 <russellb> #topic blueprints
14:12:41 <russellb> so first, some very important dates to be aware of
14:12:45 <cloudon> Let me sync up as not clear whether it's a gap or has already been addressed - but agree with principle of tracking ideas
14:12:56 <russellb> projects are setting some deadlines for juno
14:13:06 <russellb> for neutron, specs must be posted by tomorrow (july 10)
14:13:10 <russellb> and approved by july 20
14:13:14 <russellb> for nova, the deadline to post was last week
14:13:23 <russellb> and deadline for *approval* is tomorrow (july 10)
14:13:32 <russellb> so, last call to get stuff approved for juno for nova
14:13:40 <sgordon> yeah
14:13:40 <russellb> and on that note, we got some specs approved int he last week
14:13:42 <bauzas> cloudon: sure
14:13:47 <russellb> "2 interfaces 1 net" - https://review.openstack.org/97716
14:13:53 <russellb> "Virt driver large page allocation for guest RAM" - https://review.openstack.org/93653
14:13:55 <russellb> yay!
14:14:00 <sgordon> in particular there are still a lot of specs tracked by this group that need iteration by the owner
14:14:11 <sgordon> though looks like a number were turned over in the last week which is great
14:14:16 <russellb> and we had one blueprint get fully implemented (patches merged) in the last week - https://blueprints.launchpad.net/nova/+spec/virt-driver-vcpu-topology
14:15:08 <bauzas> russellb: I'm wondering if it's worth putting the approved bps for Juno in the dashboard so we keep track of them
14:15:24 <russellb> bauzas: yes, that's a good idea
14:15:33 <russellb> bauzas: a query for merged
14:15:35 <bauzas> russellb: I mean, follow the approved topics
14:15:54 <russellb> that's already covered right?
14:16:06 <russellb> for any topic, not just approved, but that's OK
14:16:13 <bauzas> russellb: so we know we're not tempted to review other patches whose spec hasn't yet been validated
14:16:19 <russellb> would be nice to have a query for the patches and specs that are merged though
14:16:36 <russellb> sure, splitting out the approved would be helpful
14:16:46 <bauzas> russellb: nope, I mean, I'm scraping all the patches related in the wiki
14:17:05 <russellb> bauzas: random thought ... you could make this script a little more generic, so it could be pointed at *any* wiki page, so other teams could do a similar thing :)
14:17:17 <bauzas> russellb: we should probably also add a query for patches in nova/neutron whose spec has been validated with same topic name
14:17:28 <russellb> works for me
14:17:39 <bauzas> russellb: people just have to override the Scraper module :)
14:18:02 <bauzas> russellb: and do whatever they want with wikis or othes
14:18:06 * russellb nods
14:18:29 <russellb> any specific blueprints anyone wants to cover?
14:19:03 <russellb> looks like there's at least 1 nova spec without negative feedback i need to review today
14:19:29 <russellb> #topic open discussion
14:19:36 <russellb> alrighty, any other topics for today?
14:19:46 <russellb> i think we're at the point of the cycle where there's less planning to do
14:19:51 <russellb> and more execution needed
14:19:54 <russellb> so less to talk about here
14:19:54 <bauzas> :)
14:20:08 <russellb> planning will need to ramp back up as we approach the K cycle
14:20:23 <russellb> nothing wrong with short meetings in the meantime, of course
14:20:36 <sgordon> yeah
14:21:17 <russellb> thanks everyone, have a nice day!
14:21:20 <russellb> #endmeeting