14:04:20 <russellb> #startmeeting nfv
14:04:21 <openstack> Meeting started Wed Jul 16 14:04:20 2014 UTC and is due to finish in 60 minutes.  The chair is russellb. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:04:22 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:04:24 <openstack> The meeting name has been set to 'nfv'
14:04:27 <russellb> #chair nfv
14:04:28 <openstack> Warning: Nick not in channel: nfv
14:04:29 <openstack> Current chairs: nfv russellb
14:04:29 <russellb> d'oh
14:04:33 <russellb> #undo
14:04:38 <adrian-hoban> Hello
14:04:40 <russellb> #chair sgordon
14:04:41 <openstack> Current chairs: nfv russellb sgordon
14:04:56 <russellb> agenda on this etherpad:
14:04:58 <bauzas> \o
14:04:58 <russellb> #link https://etherpad.openstack.org/p/nfv-meeting-agenda
14:05:01 <russellb> feel free to add
14:05:06 <russellb> #topic review actions from last week
14:05:09 <russellb> I don't think we had any :)
14:05:18 <russellb> oh, we did ...
14:05:27 <russellb> i was supposed to update the script running on nfv.russellbryant.net
14:05:28 <russellb> i did not.
14:05:32 <russellb> :(
14:05:44 <russellb> #action russellb to update bauzas' script on nfv.russellbryant.net
14:05:50 <bauzas> russellb: no worries, I'm just improving my script :)
14:06:00 <russellb> cloudon was going to add the latest use case to the wiki
14:06:01 <bauzas> russellb: poke me when you want to do so
14:06:03 <russellb> did that get done?
14:06:26 <sgordon> i didn't see any updates from the wiki notification systemb
14:06:31 <russellb> i didn't either
14:06:37 <russellb> #action cloudon to add newest use case to the wiki
14:06:42 <russellb> will put it back on the list
14:06:52 <russellb> #topic blueprints
14:06:58 <russellb> nova blueprint deadlines have now passede
14:06:58 <atylee> cloudon sends apologies - he didn't get to do update and is on vacation this week.  Will be done by next meeting.
14:07:07 <russellb> atylee: ok, cool.  thanks!
14:07:16 <russellb> neutron spec approval deadline is july 20
14:07:25 <russellb> the etherpad has a list of specs outstanding for neutron
14:07:44 <russellb> almost all of them need iteration to have any chance
14:08:00 <sgordon> right
14:08:29 <russellb> if you're the owner, please check in on it and iterate
14:08:41 <russellb> if you're not the owner, but have interest in one of them, please help chase down the owner
14:08:50 <russellb> see if they can update, or would like help updating, whatever the case may be
14:09:04 <russellb> i feel like we did a nice job getting a lot of nova specs approved
14:09:05 <adrian-hoban> Does that mean that we use the exception process for bp's that have not yet been approved?
14:09:07 <russellb> but not so much on the neutron side
14:09:21 <russellb> adrian-hoban: maybe ... but an exception won't help if they're in this state
14:09:27 <sgordon> adrian-hoban, can certainly try but i am not sure that helps here
14:09:38 <sgordon> adrian-hoban, exception is usually only granted where they were close
14:09:55 <sgordon> adrian-hoban, -1s and -2s unaddressed in these atm
14:10:22 <sgordon> adrian-hoban, any specific ones of interest from your side that missed the cut off for nova?
14:11:13 <adrian-hoban> sgordon: Yep
14:11:21 <adrian-hoban> On the agenda
14:11:29 <pczesno> Support userspace vhost in ovs vif bindings https://review.openstack.org/#/c/95805/
14:11:58 <pczesno> we got -1s and we are working to find a solution on neutron sied
14:12:10 <russellb> looks like that one had unresolved -1s for a couple weeks before the deadline :-/
14:12:10 <pczesno> to be discussed today at ml2 subteam meeting
14:12:22 <bauzas> russellb: hold on
14:12:38 * russellb holds
14:12:39 <bauzas> russellb: as the nova specs with -2 were abandoned, we're not seeing them in the dashboard
14:12:55 * sgordon assigns bug to bauzas
14:12:57 <sgordon> ;p
14:13:04 <sgordon> adrian-hoban, ok
14:13:07 <russellb> i think it was a bad idea to abandon, personally
14:13:09 * bauzas is pleased to work on that bug
14:13:10 <russellb> i don't see the point of that
14:13:16 <bauzas> russellb: agreed
14:13:18 <russellb> i need to talk to people about that
14:14:09 <russellb> someone added a glance spec to the agenda too
14:14:13 <russellb> https://review.openstack.org/#/c/104904/
14:14:27 <russellb> ah, Adri2000
14:14:27 <sgordon> i think that might be adrian-hoban as well
14:14:28 <adrian-hoban> russellb: That was me.
14:14:30 <russellb> err, adrian-hoban
14:14:34 <sgordon> does glance have similar cut off dates?
14:14:37 <sgordon> not as familiar
14:14:45 <adrian-hoban> I don't know. Less familiar too
14:14:52 <russellb> i don't think so
14:14:56 <russellb> glance is a much less active project
14:15:03 <russellb> so doesn't need strict deadlines/process as much
14:15:31 <russellb> may need to ping markwash (glance PTL) on that one
14:15:44 <russellb> make sure he has seen it
14:15:45 <adrian-hoban> The idea behind this blueprint is to offer a method to auto import some feature requests that NFV apps may need
14:16:01 <russellb> yeah that's an interesting idea
14:16:05 <adrian-hoban> russellb: Thanks, I'll reach out to markwash
14:16:38 <sgordon> +1
14:16:44 <russellb> i like the idea at least :)
14:16:48 <russellb> hadn't considered this issue
14:17:37 <adrian-hoban> There's an additional, related bp that will target the image properties filter in Nova to leverage the additional meta-data.
14:17:40 <sgordon> it is an important piece
14:18:00 <sgordon> we concentrate a lot on the infra level but once that is in place you need to be able to share the applications
14:18:22 <russellb> yeah
14:18:42 <russellb> adrian-hoban: if you reach out to markwash, feel free to invite him here if he'd like to discuss the use cases some more
14:18:53 <adrian-hoban> I guess this Nova filter extension will not make Juno now either based on the spec cut off.
14:19:06 <adrian-hoban> russellb: Sure thing.
14:19:32 <russellb> yeah, nova has already approved more than i think we can review
14:19:38 <russellb> we'll have a hard time getting more in i think
14:20:49 * bauzas has to check if glance reviews are not filtered in the dashboard...
14:21:09 <russellb> bauzas: might not be on the wiki page yet, too
14:21:46 <bauzas> russellb: I still have to check this possible flaw :)
14:21:51 <russellb> k
14:21:57 <russellb> anything else on blueprintsw?
14:22:09 <russellb> #topic openstack summit
14:22:16 <russellb> general session submissions are open now
14:22:27 <russellb> sgordon put the info of one of the tracks on there that is very relevant to this group
14:22:30 <sgordon> i think the OVF one was on the wiki
14:22:38 <russellb> "Telco Strategies"
14:22:40 <sgordon> yes the foundation have been promoting it pretty hard on twitter
14:22:45 <sgordon> so i thought i would highlight it to this group
14:22:48 <russellb> "Telecommunications companies are one of the largest areas of growth  for OpenStack around the world. In this track, we'll feature content  relevant to these users, addressing the evolution of the network and  emerging NFV architecture, the global IaaS market and role of telcos,  industry regulation and data sovereignty, and industry cooperation  around interoperability and federation. "
14:23:01 <russellb> awesome :)
14:23:02 <sgordon> submissions for general summit sessions close on the 28th
14:23:10 <sgordon> so i assume we will all be submitting on the 28th ;)
14:23:18 <russellb> sounds about right
14:23:19 <adrian-hoban> July?
14:23:25 <sgordon> adrian-hoban, yeah
14:23:31 <sgordon> time flies when you are having fun...
14:23:33 <russellb> i think a talk on the nova specific improvements would be cool too
14:23:37 <russellb> i'm a chair on the compute track ;)
14:23:40 <adrian-hoban> :-)
14:24:34 <russellb> and once the design summit opens, we'll coordinate around that
14:24:40 <russellb> but that won't be until much closer to summit
14:24:48 <bauzas> right
14:24:55 <russellb> we don't open that earlier, as we want devs focused on finishing up Juno :)
14:25:08 <russellb> before thinking about Kilo
14:25:15 <bauzas> nah, Kourou :p
14:25:20 <russellb> speaking of Kilo, the vote for the K release name ends in a matter of hours
14:25:42 <russellb> #link http://lists.openstack.org/pipermail/openstack/2014-July/008342.html
14:25:44 <russellb> (vote for Kilo!)
14:26:03 <russellb> #topic open discussion
14:26:26 <russellb> any other topics for today?
14:26:38 <sgordon> well we kind of alluded to it earlier talking about the dash dropping -2s
14:26:49 <sgordon> i think it would be good to track everything down closer to j-3
14:27:02 <sgordon> and have a consolidated list of what did or didn't make it (or i can just update the status in the wiki i guess)
14:27:12 <sgordon> try and have a clearer picture of what we achieved
14:27:19 <bauzas> sgordon: right, I can add a section with Abandoned patches
14:27:22 <russellb> bauzas: i suppose you could have another section for state:abandoned
14:27:24 <russellb> for now
14:27:27 <russellb> bauzas: jinx
14:27:34 <sgordon> and more importantly what we didnt
14:27:35 <bauzas> :)
14:27:58 <bauzas> russellb: put me an action please
14:28:25 <russellb> #action bauzas to add a section to our dashboard for abandoned specs
14:28:51 <bauzas> on an different topic, I would like to briefly talk about the scheduler split
14:29:08 <sean-k-mooney> can i ask why they were abandoned? shouldnt that have been done by the summiter not the review?
14:29:28 <russellb> sean-k-mooney: after deadline passed
14:29:41 <russellb> i don't think they should have been abandoned, i think we have a thread on openstack-dev going about it
14:30:00 <sgordon> i have only seen the one about the fact it doesn't auto abandon after two weeks anymore
14:30:17 <bauzas> sgordon: it has been done today
14:30:31 <bauzas> sgordon: I mean by reviewer's hand (or script)
14:30:42 <sgordon> right
14:30:45 <russellb> sgordon: Tim Bell, "how to continue spec discussion"
14:30:47 <sgordon> which is a separate issue
14:30:49 <sgordon> ah right
14:31:19 <bauzas> yeah, that's a global question
14:31:48 <bauzas> not exactly saying why the patches have been abandoned
14:32:00 <bauzas> I guess it's for reviewers dashboard clarity
14:32:30 <russellb> meh
14:32:35 <russellb> you can filter those out easily
14:32:56 <bauzas> russellb: I'm not saying it's the good thing, I'm just saying that's probably the reason :p
14:33:02 <russellb> heh, right.
14:33:09 <russellb> anyway, i think we've covered everything for today
14:33:12 <bauzas> nah
14:33:20 <russellb> if anyone would like to chat, #openstack-nfv is always open
14:33:20 <bauzas> just one sec, about the sched split
14:33:24 <russellb> oh sure
14:33:27 <sean-k-mooney> russellb: thanks i understand that they were -2 for passing the deadline. i think abandoning them should have been left to the origninal submitter /drafter. thanks for clarifiying
14:33:42 <bauzas> so, the rationale for the scheduler split is currently being debated
14:33:44 <russellb> sean-k-mooney: agreed fwiw
14:33:50 <sgordon> sean-k-mooney, i think we are mostly in agreement on that point
14:34:14 <bauzas> some discussion raised about why we should do that, and the possible usecases
14:35:15 <bauzas> as it was mentioned here that the split would help (and if I remember, there is one NFV spec asking for the split), it would be cool if people could provide usecases related to NFV here https://etherpad.openstack.org/p/SchedulerUseCases
14:35:32 <bauzas> the more people voice their ideas, the more we get attention here
14:36:16 <bauzas> that's it for me :)
14:36:31 <russellb> ok cool, thanks for that info, hope we can get that sorted soon enough ...
14:36:33 <russellb> thanks everyone!
14:36:35 <russellb> #endmeeting