14:00:28 <sgordon> #startmeeting nfv
14:00:29 <openstack> Meeting started Wed Jul 23 14:00:28 2014 UTC and is due to finish in 60 minutes. The chair is sgordon. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:30 <bauzas> \o
14:00:31 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:32 <sgordon> #link https://etherpad.openstack.org/p/nfv-meeting-agenda
14:00:33 <openstack> The meeting name has been set to 'nfv'
14:00:34 <smazziotta> hi
14:00:38 <sgordon> hi all
14:00:39 <ian_ott> hi
14:00:41 <bauzas> hi
14:00:45 <davidpc> \o
14:00:49 <smazziotta> hi
14:00:50 <cloudon> hi
14:00:51 <sgordon> russell let me know he is out today other than doing some j-2 tidy up
14:00:58 <sgordon> so unfortunately that means i am the chair ;)
14:01:05 <sgordon> let me know if anyone else wants to help out
14:01:19 <sgordon> #topic action items from last week
14:01:20 <bauzas> \o
14:01:33 <sgordon> bauzas, i believe the one action item from last week was on you
14:01:40 <sgordon> wrt to the dashboard and the length of the url?
14:01:43 <sgordon> any updates?
14:01:52 <bauzas> yeah, and not good ones :(
14:02:26 <bauzas> so, as I was fearing, there is no way to extend the length acceptance of Gerrit
14:02:34 <sgordon> right
14:02:41 <bauzas> so, that sucks now : http://nfv.russellbryant.net
14:02:56 <bauzas> because some news BPs have been added
14:03:04 <s3wong> hello
14:03:15 <sgordon> bauzas, so i think that points us back towards having to generate a static html page
14:03:17 <bauzas> so, there is a temporary fix which would consist in reducing dramatically the number of sections we have
14:03:37 <bauzas> I would say that's a short-term action
14:03:55 <bauzas> a mid-term action would be indeed to write a custom dashboard
14:03:55 <sgordon> bauzas, are you ok to continue driving this?
14:03:59 <bauzas> sgordon: sure
14:04:01 <sgordon> right
14:04:05 <bauzas> because I'm lazy
14:04:15 <sgordon> #action bauzas to implement short term fix of reducing sections in dashboard
14:04:28 <sgordon> #action bauzas longer term dashboard fix to generate static html
14:04:32 <sgordon> so....
14:04:33 <bauzas> there is already something there : http://status.openstack.org/reviews/
14:04:43 <sgordon> #link http://status.openstack.org/reviews/
14:04:51 <cloudon> I also had an action to update wiki with control plane use case - now done
14:04:58 <bauzas> which is an -infra project : https://github.com/openstack-infra/reviewday/
14:05:08 <sgordon> #info cloudon updated wiki with control plane use case
14:05:11 <sgordon> thanks cloudon !
14:05:27 <bauzas> so I'm volunteering to contribute to reviewday for the NFV usecases
14:05:36 <sgordon> cloudon, do you have the link to the section handy?
14:05:54 <sgordon> #info bauzas to contribute to reviewday for the NFV use cases
14:06:04 <sgordon> #link https://github.com/openstack-infra/reviewday/
14:06:09 <sgordon> excellent
14:06:12 <cloudon> #link https://wiki.openstack.org/wiki/Teams/NFV#Virtual_IMS_Core
14:06:24 <sgordon> #link https://wiki.openstack.org/wiki/Teams/NFV#Virtual_IMS_Core
14:06:24 <bauzas> I'm also taking the opportunity to have the mic for asking contributors to check their Gerrit topic names and amend if necessary
14:06:31 <sgordon> ok
14:06:39 <sgordon> i am conscious of people
14:06:47 <sgordon> 's time as we're approaching j-2 here
14:06:55 <bauzas> we need to make sure that the gerrit topic name needs to be identical to the blueprint url
14:07:09 <sgordon> ok
14:07:18 <sgordon> #info gerrit topic name needs to match blueprint url
14:07:22 <bauzas> that's really necessary for making sure we're not loosing our review bandwidth by missing important BPs
14:07:31 <sgordon> i guess i would ask whats the solution when it doesnt because it will inevitably happen ;)
14:07:58 <sgordon> can continue that discussion outside the meeting though
14:08:00 <sgordon> #topic spec freeze exceptions
14:08:01 <bauzas> sgordon: the good practice is to correctly mention the BP name in the commit message
14:08:17 <bauzas> sure, I'm glad to help if contributors have questions
14:08:22 <bauzas> ppl can ping me
14:08:26 <sgordon> so i see there were some updates from neutron on the ML today
14:08:34 <sgordon> #link http://lists.openstack.org/pipermail/openstack-dev/2014-July/040969.html
14:08:49 <sgordon> the window for spec freeze exceptions there is quickly closing due to the volume of work already approved
14:09:10 <sgordon> at this time it is likely that to be approved any further items will need to be:
14:09:10 <sgordon> - targeting stability and scalability for Neutron FOSS framework
14:09:11 <sgordon> - have a "community" interest. By that I do not mean necessarily targeting
14:09:11 <sgordon> the FOSS bits, but necessarily have support and interest from a number of
14:09:11 <sgordon> teams of neutron contributors.
14:09:46 <sgordon> with that said i did pull out a short list of BPs for which exceptions have been requested which seem relevant to this group
14:09:57 <sgordon> please chime in if you are the owners of any i miss here...
14:09:57 <adrian-hoban> sgordon: Thanks for bringing this up
14:10:14 <sgordon> the first two relate to DPDK enablement
14:10:29 <sgordon> #info [openstack-dev] [nova][Spec Freeze Exception]Support dpdkvhost in ovs vif bindings
14:10:34 <sgordon> #link http://lists.openstack.org/pipermail/openstack-dev/2014-July/040660.html
14:10:35 <sgordon> and
14:10:41 <sgordon> #info [openstack-dev] [Neutron] [Spec freeze exception] ml2-use-dpdkvhost
14:10:46 <sgordon> #link http://lists.openstack.org/pipermail/openstack-dev/2014-July/040877.html
14:11:16 <sgordon> so the two of these have an inter-relationship which makes things sticky
14:11:35 <sgordon> it was originally proposed as a nova spec only and then as a result of review feedback broken out
14:11:49 <adrian-hoban> There has been lots of feedback on the proposal. I think we're on an agreeable path now
14:12:17 <adrian-hoban> Updated plan is in the review comments, and blueprints are being updated
14:12:22 <sgordon> the neutron guys are apparently amicable to giving it an exception if the nova guys do but the nova guys i have talked to say the opposite
14:12:27 <sgordon> (fun) :)
14:12:43 <adrian-hoban> LOL
14:12:58 <sgordon> adrian-hoban, is https://review.openstack.org/#/c/95805/ the most up to date review for the nova spec?
14:13:15 <sgordon> adrian-hoban, it still seems to have some -1s to iterate on from the original discussion
14:13:22 <sgordon> i agree though the path seems much clearer now
14:13:50 <sgordon> #link https://review.openstack.org/#/c/95805/
14:14:16 <adrian-hoban> sgordon: We hope the last set of comments in the chat from sean-k-mooney address the -1's.
14:14:20 <sgordon> #link https://review.openstack.org/#/c/107797/
14:15:00 <sean-k-mooney> hi yes i am currently updateing the nova and neuton specs with there feed back a new version should be avaiable by the end of the day
14:15:25 <sgordon> sean-k-mooney, ok thanks - might be an idea to send a mail in response to the spec exception request email to highlight it when you do
14:16:02 <sgordon> #action sean-k-mooney working to update nova and neutron DPDK enablement specs by end of day
14:16:05 <sean-k-mooney> sgordon:yes i will do that.
14:16:39 <sgordon> ok
14:16:47 <adrian-hoban> We will also reach out to the -1's to check that their comments have been resolved.
14:16:56 <sgordon> +1 yes
14:17:10 <sgordon> might also need to see if joe will remove the -2 but i suspect he will want to see core sponsors first
14:17:35 <sgordon> #info [openstack-dev] [Nova][Spec freeze exception] Solver Scheduler spec
14:17:40 <sgordon> #link http://lists.openstack.org/pipermail/openstack-dev/2014-July/040684.html
14:17:51 <sgordon> are any of those involved in the solver scheduler effort around?
14:17:55 <bauzas> \o
14:18:08 <bauzas> I'm following this spec
14:18:16 <sgordon> (not familiar enough with nicks but know we have discussed in previous meetings)
14:18:19 <bauzas> but not involved tho
14:18:30 <bauzas> Yathi is not there
14:18:34 <sgordon> bauzas, in the spec exception request email it suggests it has two cores signed up do you know if they were confirmed?
14:19:00 <bauzas> sgordon: lemme check
14:19:39 <bauzas> sgordon: as per https://etherpad.openstack.org/p/nova-juno-spec-priorities there are no cores who expressed interest
14:19:49 <sgordon> ok
14:20:03 <sgordon> i was just not sure based on the way the request was framed
14:20:11 <bauzas> there are little chances this spec would be accepted as an exception
14:20:17 <sgordon> anyway will need to take that offline
14:20:31 <sgordon> that was my understanding yeah but stranger things have happened...
14:20:33 <sgordon> #info [openstack-dev] [Neutron][Spec Freeze Exception] ml2-ovs-portsecurity
14:20:39 <sgordon> #link http://lists.openstack.org/pipermail/openstack-dev/2014-July/040838.html
14:21:15 <sgordon> so the two port security proposals got merged into this one and an exception has been requested
14:22:02 <sgordon> ijw also has https://review.openstack.org/#/c/97715/ covering unaddressed interfaces in this area which is still outstanding
14:22:03 <bauzas> sgordon: for Nova, we should get a formal response by today EOB or tomorrow morning
14:22:04 <sgordon> #link https://review.openstack.org/#/c/97715/
14:22:17 <bauzas> sgordon: for spec exceptions I mean
14:22:48 <sgordon> #link https://review.openstack.org/#/c/99873/
14:22:59 <sgordon> is the review for the ml2-ovs-portsecurity spec
14:23:07 <sgordon> it has a +2 from kyle but needs another neutron core to buy in
14:23:46 <yamahata> 'll contact Rob Kukura today for his opinion.
14:24:04 <yamahata> He added +1 for now.
14:24:19 <sgordon> right
14:24:34 <sgordon> i think it would meet the updated guidelines for any further neutron spec approvals in terms of community interest
14:24:39 <sgordon> but still needs a sponsor
14:25:07 <sgordon> #action yamahata to follow up with Rob Kukura for an opinion on sponsoring exception for ml2-ovs-portsecurity spec
14:25:41 <sgordon> i will try and catch ijw later today for his opinion on the unaddressed interfaces one - i dont think i saw an exception request
14:25:51 <sgordon> so that is the list i skimmed from the ML
14:25:57 <sgordon> does anyone have others they would like to discuss?
14:27:51 <sgordon> tumbleweeds
14:27:51 <sgordon> ok
14:27:59 <sgordon> #topic meeting time
14:28:16 <sgordon> ijw raised some concerns about the meeting time, i believe he is west coast which means 7am
14:28:59 <sgordon> typically i think we have a good spectrum across east coast US and europe
14:29:09 <sgordon> does anyone have any thoughts on moving it?
14:29:43 <sgordon> obviously we are never going to please everyone but if we're missing a significant chunk of people we may need to consider it
14:30:17 <adrian-hoban> Yes, I think if people let us know that this time doesn't work, then maybe we can cycle between earlier/later sessions to suit
14:30:49 <smazziotta> it can be only one hour later... for west coast the meeting starts at 7am
14:31:01 <sgordon> right
14:31:12 <sgordon> the other issue is the meeting channels are pretty rammed with bookings these days
14:31:22 <sgordon> but i will look into what is available and send a whenisgood to the list?
14:31:38 <sgordon> obviously we should try and cater to the broadest group we can hit
14:31:39 <s3wong> for Neutron specifically, 8am PDT is DVR, 9am PDT is ML2 and 10:30am PDT is advanced service
14:31:45 <sgordon> i just dont have a clear picture of what that is :)
14:31:50 <smazziotta> not really fair for Europe to make it later than 8am PST
14:31:55 <bauzas> sgordon: I think that's a good opportunity for debating this in the -dev ML
14:32:00 <sgordon> +1
14:32:04 <smazziotta> +1
14:32:18 <sgordon> #action sgordon to follow up on available meeting room times and poll the -dev list
14:32:19 <sgordon> agree
14:32:46 <sgordon> esp. since the aggrieved party is not actually able to be here at this time to discuss :)
14:32:52 <bauzas> sgordon: we can also think on an alternance :)
14:32:52 <sgordon> #topic other business?
14:33:08 <sgordon> so, what else do people want to discuss?
14:33:23 <sgordon> i know we have put use cases somewhat on the back burner as things heat up with the release cycle
14:33:38 <sgordon> though thanks again to cloudon for providing some updates on that front
14:34:03 <cloudon> Any desire for the group to bid for a speaking slot in Paris?
14:34:08 <smazziotta> next week I will be at ETSI NFV meeting. any thing we want to push to these guys ?
14:34:43 <ulik> They should clarify whether gap analysis can be shared already
14:34:51 <sgordon> yeah +1
14:35:04 <sgordon> the lack of transparency around the gap analysis is the main concern
14:35:16 <sgordon> although we do have some members trying to feed back and forth between the two
14:35:18 <adrian-hoban> I know work is still in progress on that in multiple ETSI-NFV working groups
14:35:20 <ulik> Yes. Do they need an official liaison?
14:36:10 <smazziotta> ok. we can ask
14:36:16 <sgordon> i believe michael brenner from ALU is the assigned liaison for OpenStack from an ETSI NFV point of view
14:36:21 <ggarcia> regarding gap panalysis, what I know is that all NFV WGs have shared their gap analysis and an integrated document is being ellaborated
14:36:34 <sgordon> he doesn't have an equivalent from the openstack community but has popped up here a few times
14:36:41 <ulik> Yes.
14:36:56 <ulik> But the gaps are known, so we could start work also on this side.
14:36:57 <smazziotta> I saw on the mailing list a bunch of them , they are now consolidating and working on aligning
14:36:58 <adrian-hoban> Yes, I believe ETSI-NFV have an appointed liason
14:37:04 <sgordon> is anyone at the IETF in toronto this week ?
14:37:17 <sgordon> i know they were having some NFV-related discussions as well
14:37:30 <ggarcia> sgordon, diego lopex is in toronto
14:37:35 <ggarcia> *diego lopez
14:38:12 <sgordon> good to know - i think the main relevant session was yesterday afternoon
14:38:20 <sgordon> haven't heard anything out of it as yet though
14:38:56 <sgordon> smazziotta, is that enough relevant feedback from our side w.r.t. gaps?
14:39:14 <sgordon> smazziotta, i think what we have previously discussed is access to the draft as soon as they have some level of comfort with it
14:39:41 <sgordon> #info smazziotta attending ETSI NFV meeting next week, requesting any feedback to take to that forum.
14:40:01 <sgordon> #info Main concern continues to be publication of draft gap analysis
14:40:14 <adrian-hoban> I suspect the timing of the availability of the gap analysis will make the input suitable for Kilo planning
14:40:34 <adrian-hoban> and discussion in an NFV BoF session at the Kilo summit
14:40:43 <sgordon> that is my hope too
14:41:19 <adrian-hoban> I'll make a request
14:41:20 <sgordon> my concern is that if we dont get that transparency in time there may be some unpleasant surprises in terms of time to action
14:41:33 <sgordon> though obviously in many areas we are likely identifying the same things
14:41:58 <ggarcia> sgordon, agree
14:42:08 <ulik> Maybe we should tell them the timeline that would help for Kilo planning
14:42:26 <sgordon> smazziotta, does that make sense ^
14:42:33 <smazziotta> yes, at least let's try to get a formal POV
14:42:43 <sgordon> obviously we dont have the release schedule but the design summit is the key date for a planning perspective
14:43:04 <sgordon> probably minus 2 to 3 weeks to allow for session proposals for major work items
14:44:03 <smazziotta> so mid october is somehow our deadline. correct ?
14:44:59 <sgordon> smazziotta, as close as we can get to one yes
14:45:04 <sgordon> anyone disagree ?
14:45:19 <ggarcia> is that the deadline to receive gap analysis and evaluate for kilo planning?
14:45:38 <sgordon> ggarcia, for major work items i would say so yes - those that are likely to need a dedicated design session slot
14:45:48 <adrian-hoban> Reasonable request
14:45:49 <sgordon> ggarcia, that isn't necessary for all enhancements though
14:46:04 <smazziotta> yes so that we can discuss it in Paris Summit
14:46:09 <sgordon> ggarcia, less controversial or simpler things dont require a full session
14:46:22 <sgordon> but whats controversial or simple is hard to tell without the list :)
14:46:38 <ggarcia> it seems reasonable
14:48:01 <sgordon> #info smazziotta to advise ETSI NFV group that major gaps to feed into Kilo planning need to be identified to OpenStack community by mid-October
14:48:26 <sgordon> i dont have anything else today
14:48:41 <sgordon> am happy to let people have 10 mins of their life back
14:48:44 <sgordon> any other business?
14:49:43 <sgordon> take that as a no
14:50:00 <sgordon> thanks all, continue in #openstack-nfv as usual if you want :)
14:50:02 <sgordon> #endmeeting