14:00:12 <russellb> #startmeeting nfv
14:00:13 <openstack> Meeting started Wed Jul 30 14:00:12 2014 UTC and is due to finish in 60 minutes.  The chair is russellb. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:14 <russellb> hello, everyone!
14:00:16 <openstack> The meeting name has been set to 'nfv'
14:00:18 <ian_ott> hi
14:00:24 <yamahata> hi
14:00:28 <cloudon> hi
14:00:31 <pczesno> hi
14:00:32 <russellb> #link https://etherpad.openstack.org/p/nfv-meeting-agenda
14:00:35 <russellb> #chair sgordon
14:00:36 <openstack> Current chairs: russellb sgordon
14:00:37 <yyywu> hi
14:00:37 <davidmck> hello
14:00:48 <russellb> #topic review actions from last week
14:00:49 <bauzas> \o
14:01:02 <russellb> sgordon: since you ran the meeting last week, would you like to cover these?
14:01:09 <sgordon> bauzas, quick update on the dashboard situation plz - we have a lot of other stuff to get to :)
14:01:15 <bauzas> sgordon:
14:01:19 <bauzas> sgordon: sure
14:01:48 <bauzas> sgordon: so, working on providing an HTML file with custom dashboard, about to finish today
14:02:24 <sgordon> k, cool - please update via the list when ready
14:02:26 <bauzas> sgordon: currently running tests, alpha version to be provided without CSS
14:02:32 <bauzas> sgordon: sure, willdo
14:02:34 <sgordon> #action bauzas to update list with link to new dash
14:02:50 <sgordon> sean mooney was going to refresh the dpdk enablement specs which i believe he did
14:02:52 <sgordon> speak of the devil
14:02:54 <sgordon> #link https://review.openstack.org/#/c/95805/2
14:03:00 <sgordon> #link https://review.openstack.org/#/c/107797/1
14:03:17 <sgordon> i did not see any further indication of yay/nay on the requests for spec exceptions though...
14:03:25 <sgordon> #link http://lists.openstack.org/pipermail/openstack-dev/2014-July/040660.html
14:03:30 <sgordon> #link http://lists.openstack.org/pipermail/openstack-dev/2014-July/040877.html
14:03:43 <russellb> getting exceptions at this point is pretty tough
14:03:53 <russellb> the projects have already been overwhelmed with how much was already approved
14:03:58 <russellb> i think it's probably unlikely ...
14:03:59 <sgordon> right
14:04:22 <sgordon> the other action was that yamahata was going to follow up with rkukura to see if he could look at  ml2-ovs-portsecurity spec
14:04:31 <adrian-hoban> russellb: Is there an exception process end date?
14:04:32 <sgordon> i think maru was looking at it too but he is at the nova midcycle atm
14:04:41 <sean-k-mooney> hi sorry for being late. am form the last nova meeting they mentioned that an excetion would only be considered if there are two core supporting the spec
14:04:47 <russellb> adrian-hoban: for nova, i believe the end was supposed to be last week
14:04:51 <russellb> not sure about neutron
14:05:36 <sgordon> not sure
14:06:06 <sgordon> neutron had a spec approval deadline but exceptions were approved after that
14:06:10 <sgordon> requirements are the same though
14:06:11 <sgordon> two core
14:06:14 <sgordon> sponsors
14:06:50 <bauzas> russellb: that's unclear when the exception deadline is
14:06:52 <pczesno> the DPDK vif spec has sponsors on neutron side
14:06:52 <sgordon> i think we have failed to make our goals clear enough particularly on the neutron side to the wider community which is why we are struggling here
14:06:57 <bauzas> russellb: for Nova I mean
14:07:09 <bauzas> russellb: as some specs have been excepted end of last week
14:07:20 <russellb> bauzas: right, but i thought the intended end of that was friday
14:07:45 <bauzas> russellb: I guess it's this friday, but anyway, that's not impacting NFV IIUC
14:07:49 <russellb> as much as i want this, i didn't sponsor because i can only realistically review so much ...
14:07:51 <sgordon> right - i think there was potential for some further discussion at the midcycle
14:07:58 <russellb> i'm already signed up to review too much
14:08:57 <sgordon> seguing over to the next topic here
14:09:00 <sgordon> #topic blueprints
14:09:56 <sgordon> #link https://wiki.openstack.org/wiki/Meetings/NFV#Active_Blueprints
14:10:07 <sgordon> i tried to update the table to reflect current state of all of these y/day
14:10:13 <sgordon> #link https://blueprints.launchpad.net/nova/+spec/multiple-if-1-net
14:10:26 <sgordon> #info multiple-if-1-net approved, code up for review
14:10:41 <sgordon> this had been languishing for a week or so with two minor pep8 issues
14:10:52 <sgordon> i corrected those late yesterday and the check jobs now pass it
14:11:32 <sgordon> danpb, since you arrived...you had actually +2'd this code submission previously btw - would appreciate if you could take another look
14:11:33 <sgordon> #link https://review.openstack.org/#/c/98488/
14:12:36 <sgordon> there are also a number of vlan related specs in the table covering related but slightly different use cases (we probably need to split them out)
14:12:56 <sgordon> they are all unapproved still but i did get some feedback from sponsors for this one:
14:12:59 <sgordon> #link https://blueprints.launchpad.net/neutron/+spec/nfv-vlan-trunks
14:13:17 <sgordon> #link https://review.openstack.org/#/c/97714/
14:13:36 <sgordon> again though as we get further past the deadlines these become less likely...
14:14:05 <sgordon> last comment from a core on the 24th
14:14:57 <russellb> seems nobody has much to say on these neutron bps :)
14:15:12 <sgordon> #link https://blueprints.launchpad.net/neutron/+spec/ml2-ovs-portsecurity
14:15:18 <sgordon> is in a similar situation to the previous one
14:15:19 <russellb> which is a problem we need to address ... need to get some neutron folks engaged more closely with this group
14:15:47 <sgordon> did get some feedback from cores late last week on an exception but have not heard anything further
14:16:06 <sgordon> (per the spec have a +2 from kyle, maru was still looking at it)
14:16:31 <sgordon> but really the above brings me to the next topic in the etherpad....
14:16:33 <sgordon> #topic Team goals and structure
14:17:25 <sgordon> i have received a lot of feedback in the last week or so, particularly around the spec deadlines, that the wider development community still dont fully understand what NFV is and why they should care about it
14:17:39 <sgordon> which is i would say a failing of this group (myself included) and something we need to work at
14:18:23 <russellb> i've been scheming on a blog post discussing some of the things that have been approved/implemented
14:18:24 <sgordon> as while we dont necessarily need core contributors in this group directly we need to be able to clearly illustrate what we are trying to achieve so that when they come to our specs they can see where we are coming from
14:18:45 <russellb> to show some concrete examples of work being done
14:18:56 <adrian-hoban> sgordon: With the telco strategies track identified for the next summit, I think some presentations to the wider community on NFV topics should start to address the issue.
14:19:01 <sgordon> so here i think our use cases are with a few exceptions largely too high level and disconnected from the actual proposals
14:19:23 <russellb> one tough thing with the summit is that with the design summit overlapping, most of the dev community misses most of the main summit
14:19:23 <sgordon> adrian-hoban, certainly i think that helps my concern is much of the development community end up missing those as they are hunkered down in session
14:19:40 <sgordon> particularly for the nova and neutron peeps who have design sessions for almost the entirety of the allocated days
14:19:49 <russellb> right
14:19:52 <russellb> that's always been my problem
14:20:02 <russellb> i can count the main sessions i've been to over several summits on one hand
14:20:04 <adrian-hoban> sgordon: russellb: Agreed
14:20:19 <russellb> and it's also the reason lots of devs don't even bother submitting talks ...
14:20:25 <russellb> anyway, not this groups problem to solve
14:20:27 <sgordon> adrian-hoban, but yes i think being able to more clearly illustrate a link between what *has* been achieved and use cases will help
14:20:29 <yyywu> I think explain the user case is important, and also comparing with IaaS model because most people in nova and neutron are familiar with Iaas model well.
14:20:41 <sgordon> adrian-hoban, but also more communication both via the M/L and nova/neutron meeting attendance
14:21:04 <sgordon> i should probably say attendance *and* contribution :)
14:21:52 <adrian-hoban> sgordon: Also a fair point.
14:22:14 <sgordon> i am guilty of falling down in this regard on the neutron side myself
14:22:22 <cloudon> Do you think the devs are at least aware there is a thing called NFV, it's just that they don't particularly understand it/are interested in it?
14:22:27 <sgordon> so not pointing fingers, just highlighting that it sounds like this is still an issue
14:22:50 <sgordon> cloudon, tbh i think the impression is "NFV turned up and is a big thing but i still dont know why and it seems to be doing a lot of uncloudy things"
14:22:59 <russellb> sgordon: yes, that.
14:23:00 <sgordon> that is just based on some of the feedback i am getting
14:23:02 <beagles> cloudon - I think there are general misconceptions about it
14:23:18 <beagles> and the uncertainty leads to hesitation etc..
14:23:18 <cloudon> sgordon: uncloudy in what ways?  too hardware-specific?
14:23:43 <sgordon> cloudon, typically specific proposals exposing too much of the detail to the end use
14:23:59 <sgordon> cloudon, it's a tough balance to strike because to a degree that is what NFV applications want in many cases
14:24:18 <danpb> sgordon: some things to bear in mind are that this is the first cycle we've done the spec process
14:24:25 <sgordon> danpb, true enough
14:24:33 <danpb> sgordon: one thing I think we did wrong is that we didn't even start reviewing specs until Juno1 was already open
14:24:38 <sgordon> danpb, and i think it has been overwhelmingly positive
14:24:40 <sgordon> fwiw
14:24:46 <danpb> so we basically lost an entire dev stage for doing work
14:24:51 <sgordon> danpb, right that goes to something i mentioned on the m/l last week
14:25:00 <bauzas> some feedback came yesterday in the Nova mid-cycle sprint about how to manage specs in the next cycle
14:25:02 <danpb> we need to front-load review for Kilo-1  to be during Juno-3
14:25:02 <sgordon> danpb, even less approved in -1 and -2 this cycle than previous ones
14:25:16 <sgordon> huge +1 on that
14:25:20 <danpb> so people actually have a chance to do useful work in Kilo-1
14:25:25 <bauzas> long story short, there will be probably less specs to be on focus for Kilo
14:25:37 <ian_ott> danpb: agreed
14:25:54 <bauzas> but on the other hand, some work don't require a spec while it has been posted
14:26:11 <adrian-hoban> sgordon: Completely agree, and we need a considerable amount of time to deep dive on BPs at the Kilo design session
14:26:14 <sgordon> #info Broader communication with wider development (nova, neutron, etc.) communities required to illustrate what NFV is and is not, current state and progress
14:26:50 <sgordon> #info Feedback from nova midcycle is that more needs to be done to front load the earlier release milestones late in the previous cycle
14:26:59 <danpb> bauzas: that sounds mad, approving even fewer specs in Kilo would be making the bad situation even worse
14:27:05 <sgordon> right
14:27:09 <ian_ott> do we need a dev only session on NFV at next summit or some other venue/vehicle to help educate wider dev community on NFV?
14:27:11 <bauzas> danpb: I'm just the messenger :)
14:27:22 <sgordon> really it should be putting stuff that has been ironed out or is noncontroversial too the front of the queue
14:27:31 <bauzas> danpb: https://etherpad.openstack.org/p/juno-nova-mid-cycle-meetup
14:27:37 <sgordon> plenty of good candidates abandoned last week that were well on their way
14:27:45 <sgordon> ian_ott, we certainly would intend to do something
14:27:54 <sgordon> ian_ott, design summit sessions not open for proposal yet
14:28:01 <sgordon> ian_ott, ideally attempt to get a cross-project session
14:28:10 <ian_ott> happy to help with that for sure
14:28:14 <sgordon> ian_ott, that said needs specific goals
14:28:14 <cloudon> +1
14:28:29 <sgordon> as one was proposed last time and not actually accepted
14:28:33 <sgordon> (think alank proposed it)
14:28:47 <danpb> sgordon: the design summit sessions were not dealt with well last time
14:29:03 <sgordon> for sure
14:29:04 <danpb> sgordon: people proposed lots of sessions for very narrow topics which inevitably got cut
14:29:23 <sgordon> yes there were several competing proposals for this
14:29:27 <danpb> we need to be co-ordinated on proposing a broad session for outstanding NFV work
14:29:31 <sgordon> none of which had a lot of detail about the goals of the session
14:29:46 <danpb> so that people see the big picture importance
14:30:02 <sgordon> i think for the most part they were cut in favor of specific sessions like sr-iov, libvirt roadmap, etc
14:30:05 <sgordon> right
14:30:20 <ian_ott> sgordon: danpb: agreed, maybe next week have an agenda item and come with topics we would include in a session
14:30:32 <sgordon> #info Cross-project design session proposal for Kilo summit needs to be co-ordinated and have specific goals to be accepted
14:30:33 <adrian-hoban> Should we have one thread in the design sessions where we work through all of the identified gaps, and if possible prefix that thread with an update from the ETSI-NFV community?
14:31:10 <sgordon> adrian-hoban, i think at a higher level we just need to communicate what NFV actually looks like on OpenStack, current state, goals for future state
14:31:25 <sgordon> not sure if ETSI-NFV update will necessarily help with the target audience
14:31:32 <sgordon> though for sure is of interest to this group
14:33:44 <sgordon> #action Bring possible topics/goals for cross-project session to next week's meeting.
14:33:45 <smazziotta> are dev aware of the nfv wiki ?
14:33:57 <sgordon> smazziotta, painfully i think is the feedback
14:34:35 <sgordon> i think we perhaps should move the mission statement up above the who we are though to make that clearer
14:34:54 <smazziotta> because we 've spent some time to document. but if they are not aware of it... it is perhaps the issue and we might want to include more 101 material in the wiki
14:36:22 <sgordon> smazziotta, i think the pov of the average reviewer outside of this group is that the spec should outline what/why to enough detail that they dont need to seek that out
14:36:54 <sgordon> smazziotta, though certainly if we can do a better job of explaining on the wiki that helps too
14:37:17 <sgordon> as i said earlier though i think the bigger issue is active engagement on our part (collectively) within the relevant projects
14:37:51 <sgordon> otherwise NFV is perceived as something being done too openstack rather than something being done organically within the projects
14:37:54 <sgordon> if that makes sense
14:38:06 <sgordon> again i am just going off the feedback i am getting at the moment
14:39:06 <sgordon> i see ijw wandered in which brings me to the other topic i had on the list...
14:39:10 <sgordon> #topic meeting times
14:39:16 <sgordon> i created a poll here: http://whenisgood.net/exzzbi8
14:39:28 <sgordon> as i want to confirm whether or not we have outgrown our meeting slot
14:39:54 <sgordon> most of the responses so far indicate for same time or earlier but i am going to keep it open till end of the week
14:40:00 <sgordon> #link http://whenisgood.net/exzzbi8
14:40:10 <sgordon> #info please vote on future meeting times by EoW
14:40:18 <sgordon> the alternative might be to have alternating meetings
14:40:28 <sgordon> if it seems like there are two distinct groupings of availability
14:40:55 <ulikleber> Whenisgood doesn't say which time zone it is talking.
14:40:55 <adrian-hoban> sgordon: Thanks, we need to make sure meeting times are not getting in the way of collaboration
14:41:15 <sgordon> ulikleber, i believe it let's you select at the top
14:41:40 <sgordon> ulikleber, the default it will appear in is UTC+5 because that is where i am but you can switch it in your response (i highlighted this in the email)
14:42:03 <adrian-hoban> ulikleber: sgordon: I could select the timezone at the top.
14:42:04 <ulikleber> Ah, understand. Sorry.
14:42:23 <sgordon> np it is easy to get confused with these :)
14:42:51 <sgordon> adrian-hoban, and yes i had some feedback from at least some people who would participate but cant so certainly something to evaluate
14:43:00 <sgordon> since this time was just something we settled on as a trial after summit
14:43:13 <sgordon> there is still lots of availability in the -3 meeting room so we have some flexibility
14:44:27 <sgordon> #topic open discussion
14:44:36 <sgordon> does anyone else have something to discuss?
14:44:51 <sgordon> ijw, we rattled through the BPs earlier but might be worth revisiting if you are available
14:44:57 <smazziotta> sorry on the topic of the poll. when is the deadline to decide for a change or not ?
14:45:24 <sgordon> in particular did you hear anything else since we last spoke about exceptions for the vlan trunking or port security proposals
14:45:36 <adrian-hoban> Also, can we discuss if there is a mechanism to help prioritise reviews of BPs that missed the Juno deadlines?
14:45:53 <sgordon> smazziotta, i suspect we may end up meeting same time next week to confirm the change (if there is one)
14:46:01 <smazziotta> ok
14:46:13 <sgordon> adrian-hoban, ack
14:46:22 <smazziotta> let's set a deadlin until next wed. ok?
14:46:24 <sgordon> adrian-hoban, so sounds like that was a topic at the nova midcycle meetup
14:46:35 <sgordon> smazziotta, sure
14:46:51 <sgordon> #action sgordon confirm future meeting times at next week's meeting
14:47:07 <sgordon> adrian-hoban, i guess for discussion on the M/L for those of us who werent there
14:47:26 <sgordon> danpb, has what you referred to earlier about trying to frontload Kilo been discussed on the M/L at all yet?
14:47:29 * sgordon may have missed it
14:49:00 <danpb> sgordon: some nova cores discussed it on irc about a week ago
14:49:30 <sgordon> tentatively definitely maybe then :)
14:49:38 <sgordon> fair enough
14:50:28 <adrian-hoban> sgordon: danpb: Was something agreed or still needs to be discussed on M/L?
14:51:00 <sgordon> adrian-hoban, sounds like it still need to be raised on the M/L
14:51:43 <danpb> adrian-hoban: amongst those discussing it there was general agreement we need to front-load more review approval to allow useful dev work during Kilo-1
14:52:00 <danpb> we didn't write any hard & fast rules around it though
14:52:20 <danpb> there is still going to be a balancing act because we'll have important bug fixing work todo at the same time
14:52:49 <danpb> so Kilo1 will still be lighter than Kilo2/3 in terms but should be better than what we had for juno1
14:53:32 <sgordon> right
14:53:58 <sgordon> i know originally it was suggested specs would be locked/not reviewed at this point
14:54:31 <sgordon> adrian-hoban, do you want to try raise this on the M/L to prod some more discussion?
14:54:49 <adrian-hoban> sgordon: Yes, give me that action :-)
14:55:24 <sgordon> #action adrian-hoban to follow up on M/L regarding potential for pre-loading the early kilo milestones
14:55:26 <sgordon> ok
14:55:35 <sgordon> so we're drawing on time for today
14:55:42 <smazziotta> FYI, currently in the ETSI meeting. we started discussion on liaison. I will be reporting to the team the outcome of the discsussion on ESTI NFV gaps next wednesday.
14:55:52 <sgordon> thanks
14:56:06 <sgordon> #action smazziotta to report on outcome of ETSI NFV gaps discussion at next week's meeting
14:56:14 <sgordon> thanks all for the discussion
14:56:19 <bauzas> thanks
14:56:48 <sgordon> let's look to make sure we are closing those gaps we talked about w.r.t. engagement with the specific projects we are working on
14:57:06 <sgordon> it's an ongoing issue that pre-dates this subteam but we need to continue to work on it
14:57:09 <sgordon> thanks all!
14:57:12 <sgordon> #endmeeting