14:03:31 <russellb> #startmeeting nfv
14:03:32 <openstack> Meeting started Wed Aug 27 14:03:31 2014 UTC and is due to finish in 60 minutes.  The chair is russellb. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:03:33 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:03:35 <russellb> anyone around for the nfv meeting?
14:03:36 <openstack> The meeting name has been set to 'nfv'
14:03:44 <lukego> howdy :)
14:03:45 <cloudon> hi
14:03:53 <yamahata> hello
14:03:57 <zuqiang> hi
14:04:00 <sean-k-mooney> hi o/
14:04:00 <russellb> #link https://wiki.openstack.org/w/index.php?title=Teams/NFV
14:04:04 <adrian-hoban> Howdy
14:04:07 <imendel> hi
14:04:08 <russellb> #link https://etherpad.openstack.org/p/nfv-meeting-agenda
14:04:21 <russellb> #topic review actions
14:04:33 <russellb> 2 items were on sgordon, who sent his regrets for this week
14:04:50 <russellb> lukego: were you able to post an update on the status of vhost-user?
14:04:57 <lukego> pressing Send now :)
14:05:02 <russellb> ok, great
14:05:29 <russellb> lukego: once it has been sent, grab the link from http://lists.openstack.org/pipermail/openstack-dev/ and we can put it in the minutes
14:05:37 <russellb> just do #link <link>
14:05:50 <russellb> #topic Juno release status
14:05:57 <russellb> feature freeze is sept 4, just a week away
14:06:11 <russellb> there's some detailed patch status on the review dashboard:
14:06:13 <russellb> #link http://nfv.russellbryant.net/
14:06:27 <russellb> there are a few blueprints under review that look to be in good shape
14:06:28 <russellb> those are:
14:06:33 <russellb> #link https://review.openstack.org/#/q/status:open+project:openstack%2Fnova+topic:bp%2Fpci-passthrough-sriov,n,z
14:06:39 <russellb> #link https://review.openstack.org/#/q/status:open+project:openstack%2Fnova+topic:bp%2Fvirt-driver-numa-placement,n,z
14:06:42 <lukego> russellb: http://lists.openstack.org/pipermail/openstack-dev/2014-August/044182.html
14:06:48 <russellb> #link https://review.openstack.org/#/q/status:open+project:openstack%2Fnova+topic:bp%2Fvif-vhostuser,n,z
14:06:53 <lukego> (is the post about vhost-user)
14:06:59 <russellb> #note lukego posted vhost-user status here: http://lists.openstack.org/pipermail/openstack-dev/2014-August/044182.html
14:07:01 <russellb> lukego: thanks!
14:07:17 <russellb> those mainly just need code review, but look promising
14:07:26 <russellb> are there are others you guys would like to look at the detailed status of?
14:08:04 <jchapman> Hey, how about this one: https://review.openstack.org/#/c/108634/
14:08:17 <russellb> looking
14:09:15 <russellb> looks like it was blocked since not all of the code had been posted for review
14:09:22 <russellb> got caught by the feature proposal freeze
14:09:34 <russellb> which is basically, "all code must be up for review"
14:10:08 <russellb> not sure there's much we can do there
14:10:12 <sean-k-mooney> that contradicts the wiki
14:10:19 <russellb> which wiki?
14:10:47 <sean-k-mooney> #https://wiki.openstack.org/wiki/FeatureProposalFreeze
14:11:26 <russellb> which part, "New patchsets for existing code reviews are OK" ?
14:11:40 <sean-k-mooney> yes
14:11:52 <russellb> that refers to revision 11 or 12 of https://review.openstack.org/#/c/108634/10 for example
14:12:01 <russellb> iterations to fix minor issues based on code review
14:12:16 <russellb> not new patches in the patch series that represent chunks of the functionality
14:12:48 <russellb> i'll see if i can talk to someone about updating that page to clarify that
14:12:53 <sean-k-mooney> the inital pactch set was uploaded before the proposal freeze for https://review.openstack.org/#/c/116096/
14:13:11 <russellb> #action russellb to talk to release management to clarify text in the FeatureProposalFreeze wiki page
14:13:54 <sean-k-mooney> https://review.openstack.org/#/c/108634/10 previously attemed to merge but required a rebase which is which are covered by the most recent patches
14:13:55 <russellb> is the rest of the code available?  could it be posted now?
14:14:06 <jchapman> russellb: its up now
14:14:29 <russellb> jchapman: i'm looking at https://review.openstack.org/#/c/116096/
14:14:32 <russellb> no patches depend on that one
14:14:35 <russellb> are they somewhere else?
14:16:08 <russellb> jchapman_: connection issues?
14:16:12 <russellb> not sure you saw my latest comments
14:16:25 <jchapman_> russellb: Ye apologies for that
14:16:27 <russellb> http://eavesdrop.openstack.org/meetings/nfv/2014/nfv.2014-08-27-14.03.log.txt
14:17:29 <russellb> hm
14:17:36 <russellb> while waiting on that, any others worth discussing status of?
14:17:43 <sean-k-mooney> russellb: you are correct no other patch depend on  https://review.openstack.org/#/c/116096/
14:17:46 <russellb> i'm happy to help guide an exception request if i think there's a chance
14:18:17 <russellb> sean-k-mooney: I think the -2 is based on "This is only part of the code we have for this feature"
14:19:00 <sean-k-mooney> https://review.openstack.org/#/c/116096/ and  https://review.openstack.org/#/c/108634/ impemnet the full feture covered by the bluepirnt
14:19:01 <russellb> as in, more patches are expected/needed
14:19:23 <russellb> sean-k-mooney: ok, then there was confusion this i suspect
14:19:27 <russellb> johnthetubaguy: you around by chance?
14:19:33 <jchapman_> russellb: Everything should be there now
14:20:42 <russellb> #action russellb to follow up with johnthetubaguy on the status of I/O based numa scheduling, as it appears code was up ahead of the freeze
14:20:46 <russellb> i'll follow up on that
14:20:51 <russellb> thanks for clarifying
14:21:00 <johnthetubaguy> russellb: hey
14:21:04 <russellb> ohai!
14:21:05 <jchapman_> russellb: Thanks Russell
14:21:24 <russellb> johnthetubaguy: basically, couple of patches for a blueprint -2d on feature proposal freeze, but they're saying those 2 patches are the full implementation
14:21:38 <russellb> johnthetubaguy: there's a comment ont he 2nd patch that makes it sound like there were more patches coming, but i guess that wasn't the case
14:22:00 <russellb> johnthetubaguy: https://review.openstack.org/#/c/116096/ and the one it depends on
14:22:02 <johnthetubaguy> russellb: ah OK, it seemed like there was more to come, based on the spec, can't remember who I asked about that now
14:22:18 <russellb> johnthetubaguy: yeah, i was confused too
14:22:44 <russellb> johnthetubaguy: but the author was just saying that's all of it
14:22:56 <sean-k-mooney> this extends work done by rehat on numa based scheduling
14:23:11 <sean-k-mooney> s/rehat/redhat
14:23:31 <johnthetubaguy> russellb: OK, cool, I will restore that then, but its getting close
14:23:41 <russellb> johnthetubaguy: agreed
14:24:23 <adrian-hoban> russellb: johnthetubaguy: Thanks
14:24:28 <jchapman_> russellb, johnthetubaguy: cheers guys
14:24:43 <adrian-hoban> Is this other bp in a similar position: https://blueprints.launchpad.net/nova/+spec/virt-driver-cpu-pinning
14:24:43 <russellb> ok great!
14:24:48 <johnthetubaguy> just reach out to me on IRC in #openstack-nova if stuff comes up like this again, happy to help
14:25:12 <russellb> adrian-hoban: i think that one just didn't make it ... a lot more work is left there
14:25:15 <sean-k-mooney> johnthetubaguy: thank we will keep that in mind
14:25:18 <johnthetubaguy> but ideally, please mark as NeedsCodeReview once all the code is up, to save my (very bad!) guessing!
14:25:53 <russellb> johnthetubaguy: it's also that you're guessing with very limited time, because you're looking over a ton of them, totally understandable
14:26:32 <russellb> adrian-hoban: adrian-hoban_ basically their hands have been completely full on the base numa support
14:26:55 <adrian-hoban_> russellb: Ok, understood
14:27:06 <russellb> more so than we expected i'd say
14:27:31 <russellb> huge pages support is in the same boat
14:27:37 <russellb> we thought there'd be time, but there wasn't
14:28:19 <russellb> #topic open discussion
14:28:25 <russellb> anything else for today?  can still bring up blueprints if you'd like
14:29:10 <imendel> do we want to discuss how are we doing with the initial goals of this group?
14:30:32 <russellb> sure, have something specific in mind?
14:30:47 <russellb> related:
14:30:49 <russellb> #link https://wiki.openstack.org/w/index.php?title=Teams/NFV#Mission_statement
14:31:39 <imendel> do we feel that the dev community is inline with NFv goals? Is the perception and understanding of NFV in the community better?
14:32:12 <lukego> I think this group is wonderful, fwiw.
14:32:57 <russellb> lukego: cool :)
14:33:17 <russellb> imendel: i think we've been largely successful, though the perception in the dev community is not always positive
14:33:55 <russellb> there tends to be a reaction of: "Those NFV people are just trying to shove a bunch of features in"
14:34:05 <russellb> which isn't false, necessarily ...
14:34:26 <russellb> need to continue to make sure we're demonstrating 1) that we've thought very hard about features and how they can be made "cloudy"
14:34:40 <russellb> and 2) that they're useful in general, not *only* NFV
14:34:43 <imendel> and also they are not "cloud" and have some specific needs
14:35:25 <imendel> If I catch the mission statement first part "This work includes identifying functional gaps, creating blueprints", how are we doing with it in your opinion?
14:35:41 <russellb> i think that's the part we've done best at, plenty of blueprints in flight
14:36:10 <russellb> of course, that's really the core of what we're doing
14:36:40 <russellb> if it doesn't result in some output (code or some type of document), then it's a useless exercise
14:36:51 <imendel> I feel that we abandon the use case analysis and the map to the features to give context and to drive the right priorities in. Maybe I got it wrong
14:37:23 <russellb> there was certainly much more of that earlier, when more planning was being done
14:37:34 <russellb> latter half of the dev cycle it's more about trying to finish executing the stuff in progress
14:37:41 <imendel> but lately (months maybe) we are working here on the make it done (which is good) of specific BP but nothing on the bigger context to the community.
14:37:42 <russellb> planning needs to ramp up again soon for the next cycle
14:38:06 <imendel> so do the developers around are better aware and supportive now?
14:38:12 <cloudon> russellb: +1, and output of ETSI gap analysis will be important
14:38:36 <adrian-hoban_> I think we really started late for Juno. Agree with russellb that we need to be ready before the next summit rather that plan work in the cycle
14:38:53 <russellb> adrian-hoban_: makes sense
14:39:09 <russellb> imendel: better aware?  yes.  better supportive?  in some cases, not all
14:39:13 <imendel> maybe it's a timing issue in Juno
14:39:28 <danpb> FWIW, the less we mention obscure NFV specific acryonyms like ETSI to people, the better the rest of the community will respond to/receive proposals :-)
14:39:57 <imendel> can you help to explain the better aware? danpb: agrre
14:39:59 <russellb> yeah, and generally, never use "because NFV needs it" as a reason
14:40:00 <russellb> heh
14:40:27 <russellb> still have to provide a full detailed justification, even if from a planning perspective, it came out of analysis of NFV use cases
14:41:03 <russellb> help explain better aware?  i think more people have been talking about it all over, and we have a nice wiki page people can reference
14:41:52 <imendel> do u feel the justification of the NFV use case is in a shape that drives the needs and the understandings? you are closer to the developers to judge, ...
14:42:03 <danpb> NFV is fine to use when illustrating example of where a feature will be used, but specs/blueprints need to explain the rationale for the features from first principals using plain terminology that any reviewer can understand
14:42:16 <lukego> I have also had the feedback that “other people don’t think NFV is as cool as you do” :) and that people react negatively to a pure “this is useful to NFV” pitch. (I am guilty of doing this again on my mail about vhost-user… it’s hard because NFV _is_ cool :))
14:42:17 <imendel> agree
14:42:28 <adrian-hoban_> In Hong Kong, there was little about NFV, in Atlanta there were quite a few references, and for Paris there is a dedicated Telco track. So I think awareness is certainly growing
14:42:57 <imendel> for developers or for the market track?
14:43:03 <danpb> eg explain the benefits that sensible NUMA placement brings to VM workloads, and then just mention that NFV is a case where it would be used
14:43:20 <imendel> danpg: agree
14:43:39 <danpb> from the design summit POV, last time around we arranged an ad-hoc meeting of NFV people at the last minute
14:43:46 <imendel> I am just not sure we have this very convincing map...
14:44:04 <davidmck> one thing I've thought is that there is still lacking a common understanding of the sorts of features NFV is driving and why - so it is clearer why we care about specific blueprints
14:44:07 <adrian-hoban_> danpb: Great point.
14:44:08 <danpb> we need to do more to publicise this upfront this time, so we can attract more of the people from nova/neutron that are on the core teams
14:44:21 <danpb> instead of merely attracting the people who are already interested in NFV
14:44:32 <imendel> agree
14:45:03 <imendel> davidmck: agree
14:45:40 <danpb> overall I think this NFV group has been pretty successful over Juno
14:45:59 <danpb> if we keep going it'll get even better for kIlo
14:46:15 <imendel> do we want to prepare something for Paris?
14:46:35 <russellb> yes, there will a project pod area again that can be used for meetups like this
14:46:58 <imendel> Do we want to increase the understanding and rational for the suggested BPs?
14:47:04 <russellb> yes?  :)
14:47:28 <russellb> if you have some specific suggestions on how to do that, that's great stuff to discuss here
14:47:47 <imendel> shall we work on the use cases and mapping of those to the BP in a clearer way?
14:48:10 <imendel> I think we have a good start there but we need to make it more friendly and clearer
14:49:00 <imendel> and inline with davidmck remark
14:49:33 <adrian-hoban_> Pods are great, but I would like to see time allocated for NFV design sessions as well. Some project specific, some cross-project
14:50:00 <russellb> adrian-hoban_: sure ... the most likely sessions to get accepted are focused on specific functionality, though
14:50:21 <russellb> imendel: can you write up a proposal for how to improve?  then maybe folks could work with you to implement it?
14:50:43 <imendel> sure. shall I sent in the mailing list?
14:50:47 <adrian-hoban_> russellb: I hope we can pick some from our wiki
14:51:00 <russellb> imendel: yeah
14:51:05 <imendel> ok
14:51:06 <russellb> adrian-hoban_: indeed
14:51:48 <russellb> ok i think we've had good coverage for today ... good discussions, thanks everyone
14:51:53 <russellb> have a nice week!
14:51:59 <imendel> tnx
14:52:07 <adrian-hoban_> Thanks folks
14:52:14 <russellb> #endmeeting