14:13:55 <russellb> #startmeeting nfv
14:13:55 <bauzas> welcome openstack !
14:13:55 <openstack> Meeting started Wed Oct  8 14:13:55 2014 UTC and is due to finish in 60 minutes.  The chair is russellb. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:13:56 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:13:58 <sgordon_> #topic action review
14:13:58 <sgordon_> #link http://lists.openstack.org/pipermail/openstack-dev/2014-October/047548.html
14:13:58 <sgordon_> #link https://wiki.openstack.org/wiki/File:NFV%2814%29000154r2_NFV_LS_to_OpenStack.pdf
14:13:59 <openstack> The meeting name has been set to 'nfv'
14:14:02 <russellb> #chair sgordon_
14:14:03 <bauzas> awesome
14:14:03 <openstack> Current chairs: russellb sgordon_
14:14:13 <sgordon_> #topic action review
14:14:13 <sgordon_> #link http://lists.openstack.org/pipermail/openstack-dev/2014-October/047548.html
14:14:13 <sgordon_> #link https://wiki.openstack.org/wiki/File:NFV%2814%29000154r2_NFV_LS_to_OpenStack.pdf
14:14:23 <sgordon_> #info discussion about etsi gap analysis
14:14:39 <russellb> (note that we actually started about 15 minutes ago, bot problems, so part of the log will be missing)
14:14:39 <sgordon_> #info need more detail on resource catalog requirement?
14:14:48 <russellb> sgordon_: +1
14:15:06 <imendel> I can touch base with Michael and clarify
14:15:07 <openstack> sgordon_: Error: Can't start another meeting, one is in progress.  Use #endmeeting first.
14:15:18 <sgordon_> thanks fungi
14:15:37 <sgordon_> anyway
14:15:41 <sgordon_> let's move on for now
14:15:48 <sgordon_> i had thrown a lot of other stuff in the agenda
14:15:53 <imendel> sgordon: got my note?
14:15:54 <sgordon_> #topic juno status
14:16:01 <sgordon_> imendel, sorry which one :)
14:16:13 <imendel> I can touch base with Michael and clarify
14:16:15 <imendel> :)
14:16:38 <sgordon_> #action imendel to touch base with Michael (ETSI liaison) and clarify resource catalog requirement
14:16:40 <russellb> #action imendel to follow up on resource catalog requirement to try to get more clarification
14:16:42 <russellb> d'oh
14:16:43 <sgordon_> -_-
14:16:44 <sgordon_> lol!
14:16:46 <russellb> #undo
14:16:47 <openstack> Removing item from minutes: <ircmeeting.items.Action object at 0x3201810>
14:16:50 <sgordon_> ok
14:17:07 <sgordon_> so i have been trying to bring the wiki page up to date
14:17:10 * russellb sits quiet
14:17:11 <sgordon_> and i came across this bp
14:17:13 <sgordon_> #link https://blueprints.launchpad.net/neutron/+spec/openvswitch-patch-port-use
14:17:26 <sgordon_> it appears to be resolved by some combination of
14:17:28 <sgordon_> #link https://bugs.launchpad.net/neutron/+bug/1331569
14:17:29 <uvirtbot> Launchpad bug 1331569 in neutron "Open vSwitch Agent should use ovs_lib to list bridges not ip_lib" [Low,Fix released]
14:17:35 <sgordon_> #link https://bugs.launchpad.net/neutron/+bug/1285335
14:17:37 <uvirtbot> Launchpad bug 1285335 in neutron "Openvswitch agent should use ovs patch ports instead veths" [Medium,Fix released]
14:17:49 <sgordon_> does anyone remember who put this on the list and might be able to verify?
14:18:50 <cloudon> Was it auto-scraped because bp text mentions NFV?
14:18:58 <sgordon_> no
14:19:12 <sgordon_> because the functionality was supposedly implemented in those bug fixes ;)
14:20:13 <sgordon_> #info openvswitch-patch-port-use appears to be resolved via bugs 1331569 and 1285335
14:20:15 <uvirtbot> Launchpad bug 1331569 in neutron "Open vSwitch Agent should use ovs_lib to list bridges not ip_lib" [Low,Fix released] https://launchpad.net/bugs/1331569
14:20:16 <uvirtbot> Launchpad bug 1285335 in neutron "Openvswitch agent should use ovs patch ports instead veths" [Medium,Fix released] https://launchpad.net/bugs/1285335
14:20:22 <sgordon_> im just hoping to verify that is actually the case
14:20:48 <sgordon_> anyway, that is all i had for juno status
14:20:58 <sgordon_> did anyone else want to raise something
14:21:00 <sgordon_> bugs perhaps?
14:21:56 * sgordon_ watches tumbleweeds
14:22:02 <sgordon_> #topic kilo planning
14:22:26 <sgordon_> so i wanted to put some focus on discussing what is the highest priority, and achievable for Juno
14:22:38 <sgordon_> a good baseline for that looks like "what was approved and juno and not finished"
14:22:39 <sgordon_> imo
14:22:55 <russellb> that, and has people still available to push on the impl
14:23:05 <sgordon_> particularly on the nova side i know there was a lot of work around NUMA topology still outstanding
14:23:05 <sgordon_> right
14:23:25 <sgordon_> #link https://etherpad.openstack.org/p/nfv-meeting-agenda
14:24:12 <sgordon_> i had compiled a list in the etherpad for now just on that basis
14:24:48 <sgordon_> on the neutron side the biggest "itches" im still hearing about is the VLAN trunking and inability to have an un-addressed port
14:24:57 <sgordon_> (one way or another)
14:25:24 <sgordon_> imendel, cloudon any thoughts?
14:25:25 <cloudon> plus some of the unfinished data plane accel stuff e.g. Snabbswitch
14:25:34 <sgordon_> right i had lumped that together under...
14:25:38 <sgordon_> VIF(s) for dpdk / vhost-user?
14:25:44 <sgordon_> although recognize that is just the nova side
14:25:56 <cloudon> ah, ok
14:26:01 <sgordon_> cloudon, are you planning to resubmit?
14:26:36 <cloudon> I wasn't the submitter - was Luke Gorrie
14:26:47 <cloudon> AFAIK he thinks he has it under control for Kilo
14:26:58 <sgordon_> ah right
14:27:02 <sgordon_> sorry :)
14:27:20 <cloudon> just wish I'd thought of it :)
14:27:38 <sgordon_> so nova-specs is technically open for business now
14:27:47 <sgordon_> tho obviously there is still focus on bedding down the release atm
14:27:51 <imendel> and there is the scheduling based on net info that I am not sure anymore where it belongs
14:27:52 <sgordon_> not sure about neutron?
14:28:09 <sgordon_> imendel, yes i have no real idea on what to do with that at this point
14:28:17 <sgordon_> imendel, best answer i ever get is "not here!" :D
14:28:38 <imendel> sgordon:.ok :)
14:28:39 <sgordon_> i think the challenge as we have discussed before it's just the first request of that type
14:28:48 <sgordon_> plenty of other resources etc people want to react to in that way
14:28:58 <imendel> right
14:29:12 <sgordon_> but for now current direction is that it has to be done with third party tools
14:29:37 <sgordon_> where openstack focuses on exposing the APIs they can call to get info or take action, in theory
14:29:44 <imendel> is it a good topic for Tuesday in the summit?
14:30:29 <sgordon_> imendel, is tuesday the cross project sessions?
14:30:38 <imendel> i thnk so, yes
14:30:55 <bauzas> yup
14:31:14 <bauzas> #link http://kilodesignsummit.sched.org/
14:31:29 <sgordon_> #link https://etherpad.openstack.org/p/kilo-crossproject-summit-topics
14:33:02 <imendel> there is: "Scheduling decisions and the need for a global holistic scheduler - Gantt project"
14:33:05 <sgordon_> imendel, im still conflicted on this - i may just send an email to the list and ask
14:33:08 <sgordon_> ahh
14:33:38 <bauzas> I'm just editing it now
14:33:43 <imendel> do u know what's the status of Gantt?
14:34:07 <russellb> sgordon_: on what, NFV?
14:34:31 <russellb> sgordon_: IMO, it's doubtful to make the cut, unless we can come up with very concrete actions we'd like to discuss
14:34:36 <bauzas> imendel: that's maybe off-topic
14:34:45 <imendel> ok
14:34:49 <sgordon_> russellb, right
14:34:58 <bauzas> imendel: feel free to ping me afterwards
14:35:00 <russellb> i wouldn't even propose it, honestly
14:35:01 <sgordon_> russellb, the problem as we continue to go round in circles
14:35:03 <russellb> BoF, for sure
14:35:16 <sgordon_> i get feedback that we need to explain what nfv is / why we care to the wider dev community
14:35:21 <sgordon_> but there is no real forum for that
14:35:29 <russellb> blogging :)
14:35:35 <russellb> markmc's blog post was good for that
14:35:37 <sgordon_> im giving a talk on the telco track but of course that is more the business side of the world
14:37:04 <sgordon_> #topic other discussion
14:37:22 <sgordon_> #action steveg to get BoF space
14:37:41 <sgordon_> does anyone have something else they would like to discuss today?
14:39:27 <sgordon_> i will take that as a no
14:39:29 <sgordon_> thanks all!
14:39:32 <sgordon_> #endmeeting