18:59:59 <shamail> #startmeeting nonatc
19:00:00 <openstack> Meeting started Thu Apr 14 18:59:59 2016 UTC and is due to finish in 60 minutes.  The chair is shamail. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:01 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:03 <openstack> The meeting name has been set to 'nonatc'
19:00:09 <shamail> #topic roll call
19:00:17 <shamail> Welcome everyone.  Can you please let us know if you're here to participate in this meeting?
19:01:05 <dc_mattj> I am
19:01:11 <shamail> hi dc_mattj
19:01:17 <dc_mattj> hey shamail
19:01:17 <shamail> emagana: are you here as well?
19:01:21 <shamail> Anyone else?
19:01:40 <pholland> pholland is here
19:01:44 <shamail> Hi pholland
19:01:54 <pholland> happy thursday
19:02:02 <shamail> seems like a light turnout today
19:02:04 <shamail> same to you!
19:02:28 <shamail> #link  https://wiki.openstack.org/wiki/NonATCRecognition#Meeting_Information is the agenda for today.
19:02:51 <shamail> Do we have enough to push forward or do we need more participation to achieve the items?
19:03:28 <shamail> What are your thoughts dc_mattj and pholland?
19:03:40 <shamail> Hi MeganR
19:03:49 <MeganR> Hi, sorry I am late
19:03:51 <shamail> np
19:04:01 <pholland> more participation would be useful; is there anything we can do with limited quorum?
19:04:15 <shamail> I was just asking whether we have enough people on to make progress on our agenda (4 of us are on)
19:05:00 <shamail> pholland: We could review the etherpad and maybe see if we can suggest initial groupings (and review with broader team over email or next meeting)
19:05:04 <dc_mattj> I think we can at least discuss ?
19:05:08 <shamail> yeah
19:05:21 <pholland> not having been at the first meeting, I'll defer to you, but I like your suggestion that we can start to group
19:05:27 <shamail> Alright! onwards to progress!
19:05:36 <shamail> #topic Review action items from last meeting
19:05:45 <shamail> 1) Modify milestone 2 to also including grouping identified members (shamail)
19:06:08 <shamail> I have modified the wiki to include gruping as an activity in phase 2
19:06:38 <shamail> I also modified the structure slightly so that the milestones are now a table.  This will help us also post relevant links associated with the milestone.
19:06:51 <shamail> 2) Share criteria used for ops recognition for the Austin summit (jproulx)
19:07:30 <shamail> Jon isn’t on today.. so we will defer reviewing this item.  I did see a link he shared that shows at least one of the criteria used (https://github.com/fifieldt/uc-recognition)
19:07:56 <shamail> I think this will be handy to review again once we start working on the next milestone (how to measure/automate)
19:08:14 <shamail> #topic Review roles/activities that should be eligible
19:08:28 <shamail> The etherpad is full of activity!  Let's take a moment to review the contents and then discuss whether we can spot any gaps.
19:08:34 <shamail> #link https://etherpad.openstack.org/p/uc-recognition-roles
19:09:02 <shamail> It is not important (yet) to determine how the activity can be quantified, that will come in milestone 3, so for now let's focus on being broad and we can eliminate (or park) activities that can be measured in the next phase.  Sound good?
19:09:17 <pholland> I'm ok with it
19:09:29 <dc_mattj> so I think there's some stuff in there that is clearly a strong candidate, which we could filter to the top straight away
19:09:43 <pholland> for operators, I think we should ensure focus is on contributions back to the community, not just use
19:10:08 <pholland> the existing bullets I think are ok given they are contribution-focused
19:10:12 <shamail> agreed with both of you dc_mattj  and pholland
19:10:30 <shamail> I like your approach dc_mattj
19:10:34 <pholland> I like the bullet about being a track chair
19:10:39 <dc_mattj> official user group organisers, working group members, hosting meetups, moderating
19:10:44 <shamail> could everyone add a +1 in the etherpad next to items they think are strong candidates?
19:11:31 <dc_mattj> track chairs already get free summit tickets, although not with any specific badge
19:11:54 <shamail> #chair maishsk
19:11:55 <openstack> Current chairs: maishsk shamail
19:12:15 <dc_mattj> shamail, there were already a bunch of +1's that weren't necessarily involved in that last discussion point
19:12:30 <shamail> agreed dc_mattj but we should still identify it since summit pass is not the only potential benefit/right associated with UC consitituency
19:12:46 <maishsk> Sorry I am late
19:12:51 <dc_mattj> kk
19:12:54 <shamail> np maishsk
19:13:17 <shamail> so dc_mattj, I like your initial list.
19:14:07 <shamail> we could add summit track chairs fairly easily too
19:14:21 <shamail> I have a feeling that they will probably already qualify through another activity
19:14:34 <maishsk> shamail: I tend to agree
19:15:08 <dc_mattj> this is kind of the approach we used for the summit presentations, get the big ticket ones out of the way first, then you can concentrate the discussion on the edge cases and possibles
19:16:03 <shamail> I added a list of activities with consensus at the bottom of the etherpad (line 61)
19:16:18 <shamail> sorry, line 63
19:16:41 <shamail> What do we think about content contributions to superuser?
19:17:12 <shamail> There was a bullet point about planet openstack but someone mentioned that the best planet openstack articles end up on superuser anyway
19:17:22 <maishsk> So I voiced my concerns there about who gets on superuser
19:17:52 <maishsk> and the criteria
19:17:57 <clarkb> (as an aside planet isn't moderated iirc and has had cooking blogs on it before)
19:18:24 <shamail> clarkb: didn’t know that :)
19:18:30 <maishsk> clarkb: that is true - but we try to clean it up when garbage starts coming through
19:18:48 <shamail> maishsk: I agree with the point, we could include other sources (and revisit how that would be measured in milestone 3)
19:18:55 <maishsk> but that usually happens because someone had their wordpress blog hacked
19:19:16 <shamail> The question for now is whether it is a topic that needs discussion before we can say it has consensus
19:19:22 <maishsk> before a blog is added to the planet - the url submitted - is checked for OpenSTack relevance
19:19:24 <dc_mattj> content contributions to superuser I think are valid
19:19:28 <shamail> I think based on the etherpad it wouldnt qualify as defacto for now
19:19:37 <pholland> who selects the content for superuser?
19:19:38 <dc_mattj> it's edited, and high quality content
19:19:46 <dc_mattj> nicole ?
19:19:49 <shamail> I tend to agree dc_mattj
19:19:53 <shamail> Yes, Nicole and Allison
19:20:01 <clarkb> maishsk: gotcha
19:20:15 <maishsk> but then again - it could be reposts of content from elsewhere
19:20:32 <dc_mattj> it would only be reposted if it was high quality content to start with
19:20:51 <maishsk> correct
19:20:56 <maishsk> for example
19:20:59 <maishsk> #link http://superuser.openstack.org/articles/how-to-use-terraform-to-deploy-openstack-workloads
19:21:00 <maishsk> and
19:21:09 <maishsk> #link http://www.stratoscale.com/blog/openstack/tutorial-how-to-use-terraform-to-deploy-openstack-workloads/
19:21:25 <shamail> It could be… recognizing superuser articles though is a centralize community publication.
19:22:05 <shamail> in this case, we could recognize the contribution because it is on superuser and if there was content that was not accepted for superuser than we could still evaluate it through the review board process.
19:22:12 <dc_mattj> shamail: agreed, superuser is a curated edited site, not a blog
19:22:29 <dc_mattj> I don't think it matters if its been posted somewhere else first
19:22:34 <shamail> The challenge with other sources though is that they may not be entirely openstack focused…. only an article (or subset) could be openstack
19:23:14 <pholland> I think if the article is posted/included in a cross-community publication, I support it... a simple post or a local publication seems a little below the bar from my point of view
19:23:21 <shamail> Getting the article on superuser would indicate that the curators saw value in the information for the entire community
19:23:25 <dc_mattj> I think there's a fairly clear initial consensus emerging on the etherpad
19:23:37 <pholland> shamail: I agree with that statement
19:23:42 <dc_mattj> shamail: v.true
19:24:08 <dc_mattj> and ultimately anyone who's written something good, and is participating in the community, could potentially submit that to superuser right ?
19:24:23 <shamail> pholland: I agree, I was thinking adding “superuser articles” is something we can agree on and then we can revisit other publications in a group discussion.  Thoughts?
19:24:29 <dc_mattj> if there's not an official mechanism to do that, then there could be
19:24:34 <dc_mattj> +1
19:24:36 <shamail> dc_mattj: correct, and sometimes, the superuser team will even reach out to them
19:25:18 <shamail> pholland, maishsk, MeganR… do you agree with adding superuser articles for now and discussing other publications in a bigger group later?
19:25:23 <dc_mattj> other publications is too vague, and there's no mechanism for assessing quality of that without disappearing down multiple rabbit holes - how many hits, how many links etc. etc
19:25:33 <maishsk> shamail: #agree
19:25:39 <pholland> dc_mattj: +1
19:25:45 <shamail> dc_mattj: +1
19:25:53 <MeganR> agree
19:26:21 <pholland> shamail: assuming superuser is moderated and we agree there is a level of quality of post, I support that; the other publications are still a question in my mind
19:26:26 <dc_mattj> shamail: can I suggest we separate out the clear favourites in the etherpad from the remainder, will make it easier to read
19:26:40 <shamail> pholland: agreed, and we will def. revisit
19:26:56 <shamail> dc_mattj: Doing that at line 48 in the etherpad
19:27:05 <dc_mattj> sorry :)
19:27:11 <shamail> left the discussion on top for context
19:27:17 <dc_mattj> missed the scroll down ;)
19:27:25 <shamail> eventually, we’ll split it out into a separate etherpad :)
19:27:42 <shamail> So does the list at line 48 look like a good starting point or any obvious gaps?
19:28:03 <shamail> I added “official” to both user groups and WGs
19:28:04 <dc_mattj> so last time we spoke, it was looking like ops contribution was going to be a separate thing ? are we now talking about both these things together ?
19:28:32 <shamail> That’s the next topic!
19:28:34 <shamail> #topic Review grouping (if any) based on roles/activities list
19:28:35 <MeganR> and I like that you add "active" to the WG one
19:28:38 <dc_mattj> given the list that's emerging, I'm not sure they should be a separate thing, but others may disagree
19:29:11 <shamail> MeganR: yes that was a good addition by someone
19:29:25 <pholland> I added the "active"
19:29:28 <shamail> There is one (or two) open items actually on user group organizers and meetups
19:29:32 <shamail> Thanks pholland
19:29:43 <MeganR> pholland: thank you!
19:29:59 <pholland> I don't think we should separate ops contributions to other contributions
19:30:05 <maishsk> I also added - for the list of meetups - listed on the official OpenStack meetup list
19:30:21 <dc_mattj> maishsk: +1
19:30:43 <maishsk> pholland: +1 - At the moment Ops contributions are not recognized by the TC - so we should give recognition here
19:31:03 <dc_mattj> that ensures things like meetups organised by a single company as a marketing ploy don't dominate
19:31:08 <shamail> definitely
19:31:27 <shamail> the question is whether we should recognize all of these are contributors or do we need to identify ops as ops, WG as WG, etc
19:31:29 <pholland> maishsk: I agree
19:31:50 <pholland> I think we are trying to give recognition to all community contributors, not just technical ones
19:31:50 <shamail> the reasoning for this is that some people stated that when it comes time to determining voting eligibility
19:32:17 <dc_mattj> there's definitely some things in that list that I'd say are more important than others
19:32:21 <shamail> they would want ops to have votes (since they are technical and use the platform) but wouldn’t want voting rights for user group organizers
19:32:24 <pholland> recognizing active ops and WG members are pieces to the overall recognitions beyond ATC
19:32:32 <shamail> not my opinion, just sharing context
19:32:35 <shamail> for the grouping discussion
19:33:05 <shamail> It basically comes down to do we recognize one group (ops, wg, user groups, all in) or do we recognize separate groups so they can have different rights/benefits
19:33:08 <pholland> I would suggest that if we do a good job with the criteria, it would be straightforward to apply the criteria to multiple needs
19:33:29 <shamail> I wish someone from UC was here today :D
19:33:31 <maishsk> shamail: I do not agree - they are contributing to OpenStack - so they should have a say
19:34:00 <maishsk> regardless if they are writing blog posts - or writing ops tools
19:34:22 <shamail> maishsk: now I will state my opinion and it is the same as yours.  Voting doesn’t require one to be technical, but rather aware and a stakeholder in the direction of the community
19:34:22 <dc_mattj> maishsk: I'm not sure most user group organisers would necessarily be as influential as some in the ops community in the overall direction of the project
19:34:38 <shamail> a marketing person could be just as involved as an operator or WG member
19:34:48 <maishsk> shamail: +1 fully agree
19:34:55 <shamail> but dc_mattj project level voting is only for contributors to the project
19:34:56 <dc_mattj> shamail: that is potentially true, as a product owner within an organisation
19:35:05 <shamail> none of us qould qualify for project level votes anyway
19:35:06 <dc_mattj> k
19:35:07 <shamail> would*
19:35:11 <dc_mattj> lol
19:35:34 <shamail> dc_mattj: I am in the same boat as you
19:35:51 <dc_mattj> user groups are about spreading the word, ops and wg contributions are about actually getting involved in the internal workings of the project
19:36:04 <shamail> I think the majority here is advocating for a single recognition (encompassing all) and equal rights/benefits
19:36:08 <maishsk> especially since this is the OpenStack charter - I do not see why a member of the community will not be able to vote
19:36:09 <shamail> Is that right?
19:36:21 <dc_mattj> not saying that's should necessarily be treated differently, but there definitely is a difference in those two things
19:36:25 <maishsk> #link https://wiki.openstack.org/wiki/Open#Open_Community
19:36:40 <shamail> Agreed with the roles dc_mattj
19:36:53 <maishsk> “The technical governance of the project is a community meritocracy with contributors electing technical leads and members of the Technical Committee”
19:37:08 <shamail> yep
19:37:23 <shamail> maishsk: +
19:37:25 <maishsk> Contributor - at the moment is a vary narrow term - which I think is totally wrong
19:38:11 <shamail> maishsk: yeah, so if we say everyone has the same benefits in the charter then the definition of contributors evolves
19:38:44 <shamail> So do we no longer need to group by role?
19:39:04 <maishsk> I think not
19:39:09 <pholland> I don't think we should group by role but by category of contribution
19:39:25 <pholland> all the contribution categories are treated equally
19:39:43 <pholland> and then we work to quantify how to measure it
19:39:44 <shamail> pholland: you mean as in operator, user group, working group, content creator?
19:40:06 <pholland> not really...
19:40:17 <pholland> what contribution is an operator really making?
19:40:20 <shamail> Can you give an example please?
19:40:53 <pholland> is it the "use" of OpenStack? the "feedback" to the community to make it better? the "content" into some presentation or survey? etc
19:41:22 <shamail> In my example it would be: Moderating at Ops Meetup, Contribution to Ops repositories
19:41:26 <shamail> I get it now pholland
19:41:32 <shamail> Thank you
19:41:41 <pholland> I would think that user group and working group would be similar... maybe in a broad sense an active member of a "committe" or "working group" (assuming user group is one type of working group)
19:42:05 <dc_mattj> I disagree
19:42:11 <dc_mattj> these things are entirely different
19:42:56 <shamail> Do you have an alternate proposal dc_mattj?
19:42:59 <dc_mattj> I organise one of the user groups in the UK, and it's an entirely different activity from the other contributions I make to the upstream community
19:43:12 <shamail> (just trying to brainstorm and get all options in the log)
19:43:16 <pholland> dc_mattj: I must admit I know the least about the user group so it may make sense to treat UG and WG differently
19:43:37 <pholland> but I would propose we categorize by type of contribution, not the place where the contribution happens
19:43:56 <dc_mattj> user groups don't involve thinking about the implications of your activities, they are just generally about promoting openstack
19:44:02 <dc_mattj> which is valuable and worthwhile
19:44:16 <dc_mattj> but contributing in the way we are doing right now is a totally different activity
19:44:25 <shamail> UG and WG would indeed be different… UG is more about sharing the knowledge and building local networks
19:44:26 <dc_mattj> as is being involved in the operators community
19:44:33 <dc_mattj> shamail: exactly
19:45:11 <dc_mattj> I think there's a clear separation between the user group, superuser stuff and the ops, wg stuff
19:45:11 <shamail> WG is more about bringing actionable feedback into the community and working more inside the community to achieve desired objectives
19:45:26 <pholland> is there more similarity then between the user group and active meetups?
19:45:30 <dc_mattj> exactly
19:45:33 <shamail> pholland: yes
19:45:36 <shamail> user groups are meetups
19:45:44 <maishsk> bikeshed ????
19:45:50 <shamail> but just official ones listed on groups.openstack.org
19:45:54 <dc_mattj> +1
19:46:16 <dc_mattj> and also some mechanism for making sure they are active, have members etc.
19:46:36 <dc_mattj> although meetup is increasingly populated by strange bots who I haven't quite worked out what their purpose is
19:47:02 <shamail> So do we want to identify a way to group contributions or let any activities from the various roles qualify as a single contributor type
19:47:39 <shamail> I think grouping will help people determine how to get involved as a contributor
19:47:54 <maishsk> shamail: I think that at well
19:47:56 <shamail> but, at the same time, it shouldn’t make a difference in terms of recognition
19:48:06 <dc_mattj> given where we've simplified the list to, my view is there are clearly two different types of participants here - those promoting the community to the outside, and those actively participating in the community internally
19:48:16 <dc_mattj> and agree it shouldn't be more or less
19:48:24 <shamail> dc_mattj: ++
19:48:25 <dc_mattj> if we get the quantification process right
19:48:32 <pholland> +1
19:48:43 <dc_mattj> which I think we're getting down to the brass tacks of in this discussion
19:48:58 <shamail> We are not only defining the constituency to make sure those that are already active get recognized but also to help share what is needed in the community
19:49:12 <dc_mattj> most other stuff on the etherpad is too hard to quantify or qualify
19:49:16 <maishsk> And both groups are recognized equally - dc_mattj - that sounds good
19:49:33 <dc_mattj> maishsk: both groups are needed
19:49:41 <shamail> #agree dc_mattj: given where we've simplified the list to, my view is there are clearly two different types of participants here - those promoting the community to the outside, and those actively participating in the community internally and agree it shouldn't be more or less
19:49:49 <dc_mattj> although not everyone will agree that their contributions are equal ;)
19:50:21 <shamail> true dc_mattj but everyone will agree that its greater than not counting at all :D
19:50:22 <pholland> it will be important to recognize key community contributions and help others understand what is valued as a contribution
19:50:40 <shamail> pholland: +1
19:50:58 <shamail> This was a great discussion
19:51:01 <maishsk> :)
19:51:06 <shamail> changing topics in the last 10 minutes
19:51:10 <shamail> #topic Discuss potential agenda topics for next meeting
19:51:17 <dc_mattj> shamail: indeed. Having been around open source for most of the last 20 years, the success of any project depends on all of those groups
19:51:31 <shamail> Unfortunately, Edgar isn’t here… otherwise I was going to ask him about his session at the ops-meetup
19:52:01 <shamail> #link https://etherpad.openstack.org/p/AUS-ops-Ops-Recognition
19:52:03 <dc_mattj> I was also hoping Edgar would be here as apparently we are moderating the Ceph session in Austin ;)
19:52:27 <shamail> He currently is slated to moderate a session about “ops recognition: what is it”
19:52:32 <dc_mattj> lol
19:52:39 <dc_mattj> we need to work quickly then !
19:52:41 <shamail> and I wanted to ask him if we could turn it into a session for this WG
19:52:44 <shamail> and make it broader
19:52:57 <shamail> lol, indeed
19:53:21 <shamail> Otherwise, this WG has no working session in Austin
19:53:31 <dc_mattj> look, I reckon whichever way you slice this there is always going to be some outliers who will say there contribution is more valid
19:53:32 <shamail> and I think the topic and WG compliment each other
19:54:14 <dc_mattj> agreed
19:54:15 <shamail> I could see that dc_mattj
19:54:36 <shamail> Does anyone have any topics that we should focus on for the next meeting?
19:55:02 <shamail> I would like to recap the discussion (and top items) identified today to hopefully get input from more participants
19:55:16 <shamail> and then, if Edgar agrees to share the session, determine what we can work on while in Austin
19:55:21 <dc_mattj> +1
19:55:29 <shamail> maishsk: any suggestions?
19:55:38 <maishsk> How about quantifying and laying out the criteria for one of the groups that have concensus
19:55:50 <maishsk> such as User Meetups
19:55:56 <shamail> We can do that!
19:56:06 <maishsk> Start with the low hanging fruit
19:56:07 <dc_mattj> we've formalised most of that today, so not too difficult
19:56:10 <shamail> It will almost be like a preview of what we are getting ourselves into for milestone 3
19:56:11 <dc_mattj> +1
19:56:21 <maishsk> and if we have more time do the same for Working group participants
19:56:22 <shamail> once we have agreement on the topics discussed today
19:56:22 <dc_mattj> always start with the low hanging fruit ;)
19:56:39 <shamail> the next phase is to establish criteria, and more importantly, how to validate it
19:56:58 <shamail> dc_mattj: ++
19:57:02 <pholland> +1 agreed
19:57:08 <shamail> WG participants will be a deeper topic maishsk
19:57:13 <dc_mattj> do you get people participating in WG's who don't actually add anything ?
19:57:16 <shamail> each WG has their own way of tracking participantion today
19:57:28 <dc_mattj> the WG stuff is new to me, this is the first one I've been on
19:57:47 <shamail> not often dc_mattj but some times you will see people show up for a specific need and then not re-engage
19:58:06 <dc_mattj> difficult to track on IRC other than word count ;)
19:58:12 <shamail> yeah
19:58:17 <shamail> and not all WGs use IRC
19:58:24 <shamail> some use etherpads and conference bridges
19:58:29 <dc_mattj> right
19:58:37 <shamail> #topic Open
19:58:42 <MeganR> and not all are comfortable with IRC  :)
19:58:46 <shamail> Anyone have any other topics to add or discuss?
19:58:59 <dc_mattj> good discussion folks :)
19:59:00 <shamail> MeganR: true true
19:59:07 <pholland> thank you
19:59:08 <maishsk> Nothing from my side - (as usual - great discussion)
19:59:11 <shamail> agree!  productive!
19:59:26 <shamail> Appreciate the passion, 5 people filled the hour :)
19:59:34 <dc_mattj> would be great to continue this F2F in Austin if we can
19:59:39 <shamail> dc_mattj: +1
19:59:46 <shamail> and welcome pholland  :)
19:59:48 <MeganR> +1
19:59:49 <dc_mattj> its an important topic
19:59:53 <shamail> (you said you didn’t make the first one)
20:00:05 <shamail> absolutely
20:00:07 <MeganR> on both the F2F in Austin and welcome!
20:00:11 <shamail> alright, ending the meeting
20:00:13 <shamail> #endmeeting