19:02:37 <shamail> #startmeeting nonatc
19:02:38 <openstack> Meeting started Thu May 12 19:02:37 2016 UTC and is due to finish in 60 minutes.  The chair is shamail. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:02:40 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:02:41 <ivar-lazzaro> bye
19:02:43 <openstack> The meeting name has been set to 'nonatc'
19:02:48 <igordcard> bye
19:02:58 <shamail> Hi everyone, who is here for the recognition meeting?
19:03:00 <dabukalam> o/
19:03:00 <rkukura> bye
19:03:04 <maishsk> 0/
19:03:06 <carolbarrett> o/
19:03:11 <dabukalam> maishsk: big head
19:03:11 <SumitNaiksatam> shamail: sorry for the delay in ending!
19:03:13 <shamail> #chair maishsk
19:03:14 <openstack> Current chairs: maishsk shamail
19:03:20 <shamail> Np SumitNaiksatam!
19:03:26 <MeganR> o/
19:03:28 <maishsk> dabukalam: :)
19:03:35 <shamail> maishsk: do you mind leading this session?
19:03:55 <maishsk> shamail: I can give it a shot but will need your help every now and again
19:03:57 <shamail> I am trying to put out an internal fire that just started before I need a fire extinguisher
19:03:57 <pholland> o/
19:03:58 <shamail> :)
19:04:08 <shamail> I'll monitor the meeting and chime in as needed
19:04:46 <maishsk> #agenda https://wiki.openstack.org/wiki/NonATCRecognition
19:04:57 <maishsk> #topic Review outcomes from F2F working session
19:05:05 <shamail> Thanks!
19:05:34 <maishsk> Unfortunately I was not at the summit - so if someone would like to take the lead on giving us a summary of what was discussed?
19:05:58 <shamail> #link https://etherpad.openstack.org/p/uc-recog-m2-output
19:06:11 <shamail> #link https://etherpad.openstack.org/p/uc-recognition-roles
19:06:25 <shamail> The team used the same etherpads from milestone-2 during the F2F
19:06:30 <dabukalam> yes, we ran through those, and discussed
19:06:48 <shamail> In general there was agreement with the approach and definition of activities (with the new addition of AskOpenStack)
19:07:17 <shamail> I wanted to finalize the name of this WG based on the session
19:07:18 <dabukalam> We also gained insight into how the Ops tag was generated for badges pre-summit
19:07:29 <shamail> dabukalam: +1
19:07:52 <maishsk> Was the Ops tag beneficial in the summit?
19:08:05 <dabukalam> maishsk: I think there was mixed response. I liked it, others didn't.
19:08:30 <maishsk> those that did not - was there any particular reason?
19:08:35 <dabukalam> Many were unsure how it ended up on their badge
19:08:49 <dabukalam> (it was also given to anyone who completed the user survey)
19:09:06 <maishsk> hrmmm.
19:09:10 <dabukalam> or I believe anyone who was involved in organising an active usergroup
19:09:26 <dabukalam> the idea being that it takes 30 mins to complete that survey, but we also covered that at the summit meeting
19:09:42 * shamail has to step away for a few minutes
19:09:48 <maishsk> Perhaps with the outcome of the WG - the criteria will be clearer
19:10:00 <dabukalam> I think the general view was that while we appreciate filling in the survey, it's probably not going to end up on our list of contributions
19:10:12 <shamail> Good point Dabukalam, i think we agreed to not inclide user survey completion for now
19:10:21 <dabukalam> As Shamail already linked, this was the final list https://etherpad.openstack.org/p/uc-recog-m2-output
19:11:17 <maishsk> Anyone else have anything to add to readout?
19:11:52 <maishsk> if not then let’s move on to the next item
19:12:05 <dabukalam> cool
19:12:07 <maishsk> #topic Close out milestone-2 and move to milestone-3
19:12:30 <dabukalam> So milestone 2 is "Identify which community members are included in constituency and group-related activities into roles"
19:12:55 <maishsk> Are we all satisfied with the list that was proposed on the output?
19:13:13 <maishsk> #link https://etherpad.openstack.org/p/uc-recog-m2-output
19:13:18 <shamail> I think based on the session, we should be able to close this milestone there is agreement
19:13:23 <dabukalam> shamail: +1
19:13:28 <MeganR> +1
19:14:12 <shamail> Can you add a #agree message Maishk?
19:14:15 <maishsk> #agreed List of contributors to be recognized are as noted on the etherpad above
19:14:25 <maishsk> #agree List of contributors to be recognized are as noted on the etherpad above
19:14:52 <pholland> what about organizing community events? should that be included?
19:15:13 <dabukalam> pholland: this was already covered and is part of the existing list I believe
19:15:18 <maishsk> pholland: does that not fall under - Official User Group organizers?
19:15:23 <shamail> That is included but for the first phase it will only be officially recognize organizers and contributors
19:15:44 <pholland> I don't see it on the etherpad
19:16:28 <dabukalam> pholland: https://etherpad.openstack.org/p/uc-recog-m2-output
19:16:29 <maishsk> line #11
19:16:31 <dabukalam> bullet point 1
19:16:53 <maishsk> although it only says organizers - not contributors
19:16:55 <pholland> ok - that wasn't obvious to me
19:17:26 <dabukalam> maishsk: I think we can safely say that anyone who contributes to the organisation of a user group falls under "organizer"
19:17:29 <maishsk> contributors - are defined as what role then?
19:18:03 <maishsk> dabukalam: I would agree
19:18:21 <maishsk> so on to the next item then?
19:18:44 <dabukalam> yes please
19:18:45 <maishsk> #topic Obtain volunteers to research metrics collection methods for various activities
19:19:09 <maishsk> milestone-3 is defined as “Provide recommendations on how to gather identified metrics (favoring automation whenever possible)”
19:19:26 <shamail> I will help with this task.
19:19:30 <maishsk> So let’s take the list one from above one by one
19:19:49 <maishsk> User group organizers - is there an official list?
19:20:05 <dabukalam> maishsk: there is a list of official usergroups
19:20:12 <MeganR> is this something Tom can help us with - he was pulling some metrics during the meeting
19:20:12 <pholland> there are a number of OpenStack groups on meetup.com
19:20:13 <dabukalam> but not an official list of organisers
19:20:15 <dabukalam> so, whoever volunteers to do this will need to co-ordinate with fifieldt and mrmartin to
19:20:18 <dabukalam> get this information
19:20:24 <dabukalam> MeganR: +1
19:20:30 <shamail> We should also try to reuse the work Tom did for operator recognition. I don't have the link to the repository handy at the moment.
19:20:51 <dabukalam> shamail: not only that, but turn it into a structure that can be automated and openly visible
19:21:04 <maishsk> So who would like to take this one?
19:21:12 <shamail> +1
19:21:20 <dabukalam> shamail: perhaps also talk to the maintainer of stackalytics to see if that's something that he can easily add to his web interface
19:21:25 <shamail> I'll take it
19:21:30 <dabukalam> stackalytics feels like a good place for this to belong
19:21:39 <MeganR> I agree
19:21:51 <maishsk> #action shamail to follow up on item #1 User group organizers
19:22:05 <maishsk> Next up - Active members of official UC Working Groups
19:22:33 <maishsk> So the group chairs should know who the active members are
19:22:44 <maishsk> Do we have a list of official UC working groups?
19:24:09 <maishsk> I would assume that the members of the UC have a list of working groups ?
19:24:36 <maishsk> And one more thing - are there WG’s that do not belong to the UC ?
19:25:15 <dabukalam> there is a list here, I don't know how up to date it is https://wiki.openstack.org/wiki/Governance/Foundation/UserCommittee
19:26:10 <MeganR> That list looks right to me, or at least nothing glaring is missing
19:27:14 <maishsk> Would anyone like to take this point then?
19:27:44 <maishsk> OK then…
19:27:52 <shamail> Not to my knowledge
19:27:58 <MeganR> do we need to reach out to the WG leaders?
19:28:07 <shamail> There are cross project teams but they fall under ATC generally
19:28:22 <shamail> Yes, we do meganr
19:28:22 <MeganR> just making certain they are active, I can also look at Wiki pages and meting notes
19:28:25 <maishsk> MeganR: I would start there - and come up with a recommendation on how this can be quantified
19:28:36 <maishsk> and hopefully automated
19:28:36 <dabukalam> maishsk: are you looking for a volunteer to research into metrics for each bullet? I assumed shamail was volunteering to research into metrics for all contributors?
19:28:40 <MeganR> ok: I can take that item
19:29:06 <shamail> WG don't have a standard meeting method some use IRC and others don't so we need to A) find membership and B) find out how they meet so we can try to automate collection in the future
19:29:08 <maishsk> #action MeganR Provide recommendations on how to gather identified metrics for Active members of official UC Working Groups
19:29:15 <maishsk> dabukalam: that is correct
19:29:25 <shamail> I did indeed volunteer for all as a first step
19:29:37 <shamail> But fine with dividing the load
19:29:44 <maishsk> shamail: I am sure that we can all pitch in
19:29:48 <shamail> While I focus on alignment with Tom
19:29:50 <maishsk> next one Ops meetup moderators
19:30:04 <maishsk> This should be pretty easy - Tom should have a list
19:30:40 <shamail> +1
19:30:49 <dabukalam> I think our goal should be to discuss how we can take all of this information and put it in a centralised location so that it updates itself automatically
19:30:49 <shamail> There is a google spreadsheet that he used
19:31:11 <maishsk> #action maishsk - Provide recommendations on how to gather identified metrics for Ops meetup moderators
19:31:17 <shamail> dabukalam: +1, one off collection is fine but we need long term solutions too
19:31:37 <maishsk> dabukalam: +1 but to do that I think we first have to identify where all the info is
19:31:41 <dabukalam> shamail: right, the one of collection can be our seed db
19:32:07 <maishsk> Next item - Contributions to any repository under UC governance (ops repositories, user stories repository, etc.)
19:32:08 <dabukalam> but then we need to find a way to automate that, which may involve mandating that various groups document things differently from now on
19:33:06 <maishsk> Stackalytics - could be the way to get this
19:33:11 * dabukalam can see the conversation happening now. WG Organiser: "Well, why didn't I get a <something> tag on my badge, or recognition?" ATCWG: "Well, did you update the wiki page with your name as an organiser?"
19:33:38 * persia expresses a worry that polling data from repos ends up confusing things, because repo contribution is the criteria for ATC, so suddenly the person isn't non-ATC anymore
19:33:41 <dabukalam> maishsk: I think Stackalytics is one potential place for it to be, yes, but someone needs to talk to Ilya about how that swould work
19:34:08 <maishsk> persia: mind elaborating?
19:34:08 <MeganR> is there anything in Stackalytics for "non-technical" contributions, or something along those lines, or would something need to be built out?
19:34:17 <maishsk> not all repos qualify for ATC
19:34:47 <dabukalam> MeganR: I think there are currently non-technical metrics in stackalytics
19:34:53 <maishsk> MeganR: I don’t see why it cannot cover all OpenStack repos as well
19:35:03 <dabukalam> for example http://stackalytics.com/?metric=emails
19:35:09 <persia> Ah, if there is no overlap between repos that qualify for ATC and repos for this agenda item, I have no worries.
19:35:41 <shamail> We will need to build it
19:35:47 <MeganR> ty
19:35:54 <shamail> Once we identify what we are capturing metrics wise
19:36:08 <shamail> I have to drop off, sorry everyone :(
19:36:13 <shamail> I'll review etherpad
19:36:19 <MeganR> ah that makes sense - I am trying to jump ahead
19:36:22 <shamail> Please feel free to assign action items to me as needed
19:36:30 <MeganR> bye Shamail and good luck
19:36:41 <maishsk> dabukalam: do you want to take a crack at this item?
19:37:03 <dabukalam> maishsk: yes, I can take a look
19:37:04 <maishsk> thanks shamail
19:37:25 <dabukalam> I'm also happy to look at the next one, track chairs
19:37:41 <maishsk> #action dabukalam - Provide recommendations on how to gather identified metrics for Contributions to any repository under UC governance
19:38:05 <maishsk> #action dabukalam - Provide recommendations on how to gather identified metrics for Track chairs for OpenStack Summits
19:38:08 <maishsk> Thanks
19:38:23 <maishsk> Next one - Contributors to Superuser (articles, interviews, user stories, etc.)
19:38:52 <dabukalam> Nicole runs Superuser afaik
19:39:21 <maishsk> Any takers? If not then I will grab this one
19:39:22 <dabukalam> I expect she will have a list/sheet somewhere with past/planned articles
19:39:59 <maishsk> #action maishsk - Provide recommendations on how to gather identified metrics for Contributors to Superuser
19:40:11 <maishsk> Next item - Submission for eligibility to review panel
19:40:23 <maishsk> Someone mind explaining some context ?
19:41:08 <dabukalam> maishsk: Sorry, I actually can't recall what that is
19:42:01 <dabukalam> Ah, perhaps it is an "other" section?
19:42:02 <MeganR> is that regarding reviewing the "additional" submissions
19:42:14 <maishsk> MeganR: not sure
19:42:17 <maishsk> perhap
19:42:18 <maishsk> s
19:42:28 <pholland> I think that was the "other" category where a significant contribution could come from a category not previously listed
19:42:35 <dabukalam> pholland: yes, that makes sense
19:42:59 <dabukalam> so that's relatively easy, and doesn't require gathering metrics, but rather formation of a panel
19:42:59 <pholland> and that there would be a review panel to evaluate
19:43:20 <maishsk> So what I understand from this is a set of criteria / metrics that will allow people to submit their nomination ?
19:43:45 <dabukalam> maishsk: I think it needs to be a catchall
19:43:48 <dabukalam> so hard to have metrics for that
19:43:50 <maishsk> So that would be coming up with a recommendation of what these criteria would be.
19:43:56 <maishsk> dabukalam: +1
19:44:05 <dabukalam> maybe the action here should be to investigate what a panel should look like
19:44:16 <persia> Using a mechanism like extra-ATC is probably the easiest: where there is a list of identities in some repo, and gerrit is used to decide if changes are acceptable.  Folk who might qualify are proposed for the list and voted by the panel.
19:44:29 <MeganR> we wouldn't need metrics though, these would be evaluated case by case
19:44:31 <maishsk> I think that is already part of milestone-4
19:44:35 <pholland> yes, I think it would include the list of criteria/metrics for everything else and then an explanation of where to submit a significant contribution not covered in the other categories
19:44:39 <maishsk> “Establish/identify review board for self-nominated members”
19:44:46 <dabukalam> maishsk: ah yes, you're right
19:44:58 <dabukalam> persia: that does seem like a logical way
19:45:05 <dabukalam> it's basically extra-AUC
19:45:40 <maishsk> persia: Do you want lead this point then?
19:46:21 <persia> maishsk: That wouldn't be a good idea: I almost never get to any of my todo items
19:46:39 <maishsk> Any other takers?
19:46:42 <persia> I'd be happy to provide a couple pointers to someone else if they need a hand finding info about extra-ATC
19:46:49 <dabukalam> I can look at that as well
19:46:54 <maishsk> dabukalam: thanks
19:47:05 <maishsk> #action dabukalam - Provide recommendations on how to gather criteria / metrics for “extra-AUC”
19:47:15 <maishsk> Last one - Active moderators on ask.openstack
19:47:53 <maishsk> This information probably exists - just have to find out how to collect it
19:48:31 <dabukalam> maishsk: yes, we discussed the moderator system there
19:48:43 <maishsk> I am going to pass this one off to shamail
19:48:45 <dabukalam> I believe a.o.o already has metrics and a class/rewards system
19:49:28 <maishsk> #action shamail - Provide recommendations on how to gather identified metrics  for Active moderators on ask.openstack
19:49:42 <maishsk> And that concludes the list (for now)
19:49:49 <dabukalam> maishsk: cool
19:50:22 <maishsk> We have 10 minutes left
19:50:31 <dabukalam> maishsk: we don't have to use them :)
19:50:37 <maishsk> dabukalam: +1
19:50:55 <maishsk> #topic Free-for-all
19:51:15 <maishsk> Anyone have anything else that they want to raise / discuss?
19:51:23 <pholland> no, thanks
19:51:43 <MeganR> I'm good
19:51:49 <maishsk> Ok then
19:52:06 <maishsk> So that concludes my first time a meeting chair :)
19:52:16 <MeganR> excellent work!
19:52:17 <maishsk> Thank you all !
19:52:36 <dabukalam> maishsk: cool, thanks for taking over and running it
19:53:40 <maishsk> #endmeeting