21:02:32 <vishy> #startmeeting nova
21:02:33 <openstack> Meeting started Thu Sep 13 21:02:32 2012 UTC.  The chair is vishy. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:02:34 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:02:35 <openstack> The meeting name has been set to 'nova'
21:02:40 <markmc> yo
21:02:44 <dansmith> foo
21:02:45 <mikal> Morning
21:02:47 <sandywalsh_> o/
21:02:49 <dprince> hi
21:02:57 <gatuus> what up?
21:03:07 <maurosr> hey
21:03:30 <jog0> hi
21:03:34 <vishy> hi guys
21:03:39 <sdague> howdie
21:03:40 <vishy> #link http://wiki.openstack.org/Meetings/Nova
21:04:05 <jk0> o/
21:04:14 <vishy> #topic Risky Reviews
21:04:32 <vishy> so i there are couple of reviews which seem risky but also could be quite useful
21:04:42 <vishy> i want to have some discussion on what we should do with them
21:04:46 <vishy> the first is:
21:04:56 <vishy> #link https://review.openstack.org/#/c/10797/
21:05:23 <vishy> The way we handle msysql disconnects is very fragile and inefficient
21:05:30 <vishy> this fix is a much better way to do it
21:05:30 <bcwaldon> I initially said no to that as it didnt have any testing and its a pretty integral codepath that is changing
21:05:37 <mikal> This review has been kicking around a long time
21:05:46 <dansmith> man, removing the SELECT 1 pinging sure seems hard to ignore
21:06:04 <bcwaldon> dansmith: is that a positive or negative reaction?
21:06:52 <vishy> so I really want the fix but I'm concerned about potentially blowing things up
21:07:26 <mikal> A few cores have +2'ed it along the way
21:07:44 <dansmith> bcwaldon: meaning, removing it seems too good to ignore :)
21:07:46 <mikal> At least three that I see
21:07:47 <markmc> it certainly looks risky
21:07:53 <dprince> Yeah.
21:08:01 <dprince> Not something to put in at the last minute.
21:08:01 <bcwaldon> dansmith: right, just wanted to verify that
21:08:19 <dprince> Couldn't you let it sit in Grizzly for awhile and then backport to Folsom for a point release or something?
21:08:51 <dprince> Of course this is just an RC1.
21:09:13 <dansmith> dprince: or do the opposite, let it fester in the rc releases whilst people are doing all their testing :)
21:09:30 <dansmith> s/rc releases/early rc releases/
21:09:31 <sdague> I like the grizzly idea and consider it for backport
21:10:04 <vishy> so i see two approaches
21:10:22 <vishy> 1) merge it for rc-1 and if it causes explosions we can back it out for rc-2
21:10:34 <vishy> or 2) merge in grizzly and backport later
21:10:38 <vishy> 2) is safer
21:10:47 <mikal> How angry will the mob be if RC1 doesn't work?
21:10:50 <vishy> so i am leaning there
21:11:02 <dansmith> 2 might mean some different behavior midway through folsom, right?
21:11:17 <dansmith> someone who is using and happy with folsom (or hacked around things) and suddenly it changes a bit..
21:11:36 <markmc> it's pure bugfix territory
21:11:45 <markmc> no API changes, user-visible behavioural changes
21:12:03 <markmc> only question from stable branch would be whether it's a serious enough bug to warrant the risk
21:12:16 <markmc> and it probably is, if it's been well tested in grizzly
21:12:19 <dansmith> it's database access patterns though.. I don't think it's invisible to the admins
21:12:38 <sdague> markmc: yeh, but that can be a part 2 question.
21:13:00 <markmc> dansmith, I don't see how this one can impact admins, really
21:13:21 <vishy> so it sounds like no one is really arguing for 1
21:13:22 <sdague> agree, it will just drop some largely no op queries
21:13:31 <vishy> the question is just whether the backport is ok
21:13:32 <dansmith> markmc: okay
21:13:46 <sdague> vishy: right, but we don't need to make the backport call today
21:14:01 <vishy> if we do not want to backport it I might be for pushing it in now rather than dealing with crummy sql for the whole folsom release
21:14:06 <sdague> see how it does in grizzly, then make the call at the first update
21:14:22 <vishy> but I just had a bunch of coffee so I want to merge everything
21:14:25 <vishy> :)
21:14:26 <sdague> :)
21:14:49 <markmc> heh
21:14:51 <vishy> #action wait on https://review.openstack.org/#/c/10797/
21:15:01 <markmc> I think it's a reasonable candidate for stable after some soaking on master
21:15:05 <vishy> #link https://review.openstack.org/#/c/11923/
21:15:37 <dprince> vishy: has anyone floated that by danpb
21:15:42 <vishy> ok this is fixing some stuff that should have been fixed a long time ago
21:16:09 <vishy> the bug that it is fixing is not super critical, but I really want to get rid of legacy nw info
21:16:25 <vishy> my thinking on this one is the same grizzly and backport after we are sure it doesn't break anything
21:16:44 <markmc> hmm
21:17:01 <markmc> not super critical, lots of risky refactoring ... doesn't sound like such a good stable candidate
21:17:26 <vishy> markmc: it doesn't sound like a straight bug fix for the issue is easy unfortunately
21:17:35 <markmc> yeah
21:17:48 <vishy> markmc: so we just keep the bug as a known issue for the whole folsom release?
21:18:14 <markmc> vishy, assuming it's not super critical and we can't find a less invasive fix, yeah
21:18:49 <vishy> markmc: ok we will delay that one until grizzly then
21:19:01 <vishy> #action wait on https://review.openstack.org/#/c/11923/
21:19:40 <vishy> #topic cinder/nova sync status
21:19:49 <vishy> markmc: any idea where we are on this?
21:20:13 <markmc> #link http://etherpad.openstack.org/cinder-to-nova-sync
21:20:22 <markmc> jgriffith says he's updated the etherpad
21:20:24 * markmc looks
21:20:27 <jgriffith> :)
21:20:40 <jgriffith> yes, everything on the pad is *in* except for the clone images
21:20:48 <jgriffith> jdurgin: is on it as we speak
21:20:53 <jgriffith> Should be in later today
21:21:11 <vishy> looks like 2 left cool
21:21:14 <dprince> markmc: Do you also keep a list of what needs syncing from Nova to Cinder?
21:21:21 <vishy> I think we are good on that side then
21:21:37 <markmc> jgriffith, anything you feel needs to be in for rc1 that's still in review?
21:21:55 <markmc> jgriffith, thought we were going to have an rc1 targeted bug for those?
21:21:56 <jgriffith> On the nova side, just my recent change to delete on startup
21:22:11 <jgriffith> There is, just not being used :*
21:22:12 <jgriffith> :(
21:22:14 <markmc> dprince, nope
21:22:49 <jgriffith> markmc: 1049381
21:23:04 <dprince> markmc: Okay. I suppose that is something we'd talk about in the Cinder meeting. Still... there are a couple things missing. The xensm driver for instance: https://review.openstack.org/#/c/12843/
21:23:23 <markmc> dprince, well ... I think we're in reasonable shape on actual volumes stuff being in sync between nova and cinder
21:23:41 <jgriffith> dprince: Yes, that's another story and I think I'm going to punt on it unless you have new news (we can talk later)
21:23:41 <markmc> dprince, I'm more thinking of non-volumes core stuff changes in nova that haven't been synced to nova
21:23:54 <markmc> #link https://code.launchpad.net/bugs/1049381
21:23:56 <uvirtbot> Launchpad bug 1049381 in cinder "sync nova-volume and cinder" [Critical,In progress]
21:25:09 <dprince> jgriffith: sure. We can talk about the missing xensm driver in Cinder at another time.
21:26:06 <jgriffith> markmc: Everything in both directions should be merged or in review barring the two mentioned earlier
21:26:47 <markmc> ok, sounds good
21:28:17 <jgriffith> markmc: Sorry, missed your question earlier.  Anything in review is RC1 from my perspective
21:28:48 <markmc> jgriffith, we should add all the reviews to the bug, I guess
21:28:52 * markmc starts doing that
21:29:14 <jgriffith> good idea
21:29:26 <vishy> ready for the next topic then?
21:29:36 <jgriffith> aye
21:29:39 <vishy> #action mark to add reviews to cinder sync bug
21:31:10 <vishy> #topic RC1 buglist
21:31:40 <vishy> #link https://launchpad.net/nova/+milestone/folsom-rc1
21:32:10 <vishy> looks pretty good
21:32:14 <vishy> mostly just in need of reviews
21:32:20 <vishy> does someone want to take? https://bugs.launchpad.net/bugs/1046054
21:32:21 <uvirtbot> Launchpad bug 1046054 in nova "Security groups leak across tenants for admin users" [Medium,Triaged]
21:32:46 <vishy> it should be pretty easy, just limit security groups by project even for admins
21:32:53 <eglynn__> I can grab that tmrw
21:33:00 <vishy> eglynn__: cool thanks
21:33:09 <vishy> is there anything else on there that is stuck?
21:35:07 <vishy> belliott_ took the unassigned bug so i think we are good
21:35:10 <vishy> #topic outstanding reviews
21:35:27 <vishy> the main thing is to stay on top of reviews for the bugs on the list
21:35:56 <vishy> anyone know of stuck reviews?
21:36:05 <jog0> vishy: this isn't on the list but https://bugs.launchpad.net/nova/+bug/872899
21:36:07 <uvirtbot> Launchpad bug 872899 in nova "VMs cannot be terminated if compute host is dead" [Medium,In progress]
21:36:23 <jog0> vishy:  I have a fix stuck in review
21:36:54 <jog0> https://review.openstack.org/12231
21:37:01 <vishy> yeah that one seems fine to me
21:38:08 <jog0> vishy: thanks
21:38:13 <vishy> ok
21:38:18 <vishy> #topic open discussion
21:38:22 <vishy> anyone have anything?
21:38:48 <jog0> man pages?
21:39:24 <vishy> jog0: as in someone should write them ?
21:39:25 <vishy> :)
21:39:43 <jog0> yes, its about time nova has some
21:40:25 <vishy> that would be nice
21:40:27 <vishy> volunteers?
21:40:31 <jog0> vishy: I can start writing a few but we do have 22 binaries
21:40:32 <russellb> --help | help2man
21:40:42 <vishy> russellb: :)
21:41:00 <russellb> help2man does exist.  it's a starting point at least.
21:41:04 <vishy> jog0: maybe start and put out a request for help on the ml
21:41:07 <russellb> fun part is then keeping them up to date
21:41:14 <sdague> jog0: if you get started I'll throw in a bit on them. I think my name is still at the bottom of the xm man pages in xen somewhere :)
21:41:31 <vishy> i think we are done. Thanks guys
21:41:35 <markmc> laters
21:41:36 <vishy> #endmeeting nova