21:14:30 <vishy> #startmeeting nova
21:14:31 <openstack> Meeting started Thu Sep 27 21:14:30 2012 UTC.  The chair is vishy. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:14:32 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:14:33 <openstack> The meeting name has been set to 'nova'
21:14:41 <sdague> russellb: is there an easy way to sort on component?
21:14:44 <vishy> (well 3 bugs actually)
21:14:52 <russellb> sdague: click the header
21:14:53 <sdague> never mind
21:14:59 <sdague> yep, just figured that out :)
21:15:03 <russellb> :-p
21:15:08 <markmc> hey
21:15:39 <russellb> actually 19 submissions ... 2 were put in twice
21:15:46 <vishy> #link http://wiki.openstack.org/Meetings/Nova
21:15:58 <vishy> #topic Folsom Celebration
21:16:03 <vishy> \o/
21:16:05 <vishy> we released
21:16:08 * sdague pops champagne
21:16:18 <russellb> <("<)  ^("^)  (^")^  (>")>
21:16:21 <markmc> yay
21:16:27 * markmc pours himself a whiskey
21:16:56 * sdague thinks markmc should bring some to summit
21:17:18 <vishy> #topic Summit Planning
21:17:26 <vishy> who has a link handy to the proposals page?
21:17:31 <markmc> http://summit.openstack.org/
21:17:37 <markmc> #link http://summit.openstack.org/
21:18:46 <markmc> the non-design summit schedule is pretty packed btw
21:18:49 <markmc> #link http://openstacksummitfall2012.sched.org/
21:19:09 <vishy> i haven't even started looking at them yet
21:19:11 <vishy> http://summit.openstack.org/cfp/topic/4
21:19:16 <vishy> but help reviewing would be great
21:19:25 <vishy> does anyone else have the ability to review stuff?
21:19:33 <sdague> it's forbidden for me
21:19:35 <russellb> that link is forbidden for me
21:20:16 <mikal> Ditto
21:20:21 <vishy> ok maybe i will try to get ttx to add some permissions so others can help review
21:20:22 <vishy> markmc can you hit it?
21:20:31 <markmc> vishy, nope
21:20:36 <vishy> (wonder if your openstack-common powers gives you help)
21:20:37 <markmc> vishy, I can just review openstack-common ones
21:20:54 <vishy> #action vishy to ping ttx about adding other reviewers
21:21:24 <russellb> can you add private comments when reviewing?
21:22:05 <vishy> you can add comments that are only visible to reviewers and author
21:22:11 <vishy> * proposer
21:22:15 <russellb> ah gotcha.
21:22:56 <vishy> i don't really have anything else
21:23:05 <vishy> anyone have cool topics to discuss?
21:23:10 <dansmith> I do
21:23:11 <vishy> #topic Open Discussion
21:23:13 <dansmith> oh wait.. cool?
21:23:43 <dansmith> I'm headed out of town again tomorrow early,
21:23:47 <sdague> notably missing is really any API discussions. It seems like we should have some talk about resolving some of the inconsistencies, and what should go into a v3
21:23:51 <dansmith> and mauro needs this for cloudpipe testing: https://review.openstack.org/#/c/13787/
21:24:12 <mikal> We've also kind of failed at hypervisor feature parity
21:24:16 <mikal> Perhaps we don't care about it any more?
21:26:04 <russellb> mikal: probably needs someone to step up and push on it
21:26:13 <russellb> i think that should be an ongoing goal of the project
21:26:44 <mikal> Yeah, there was talk about it at the last summit, but we haven't actually taken much action
21:26:50 <mikal> I'm as guilty as the next person
21:26:52 <vishy> sdague: sounds like something good to discuss, although i don't think we will want to start on v3 until post grizzly
21:26:54 <mikal> Perhaps we just need a plan
21:26:56 <russellb> everyone should push it to some degree ... like this bittorrent xen driver patch
21:27:10 <sdague> vishy: yep, that's fine, there is a lot of inconsistency that needs to be looked at
21:27:26 <russellb> mikal: more big projects we can talk about than people with the time to do them in a given cycle :)
21:27:30 <vishy> mikal: a lot of parity has been added for sure, although there is stuff needed
21:28:03 <sdague> like 200 vs 202 being a little arbitrary, error codes being a little arbitrary. I created a blueprint to try to start tagging things that pop up during sample api testing
21:28:11 <vishy> mikal: for example: https://blueprints.launchpad.net/nova/+spec/improve-block-device-handling
21:28:29 <eglynn> sdague: yep, it would be great to clean up all those response code inconsistencies
21:28:33 <sdague> #link https://blueprints.launchpad.net/nova/+spec/v2-api-inconsistencies
21:28:34 <vishy> sdague: so i guess it would be good to have a session about what to do in the meantime
21:28:39 <vishy> as in do we do v 2.5
21:28:57 <vishy> or way scaled down 3.0 that is just consistency and nothing else
21:29:16 <sdague> vishy: yes, perhaps we can call it a clarifying API. No new function, just changes for consistency
21:29:17 <eglynn> the consensus seemed to be that response code changes would need a v3.0
21:29:26 <markmc> if we do backwards incompat changes it probably has to be 3.0
21:29:30 <markmc> even if no new features
21:29:33 <vishy> eglynn: the number isn't really important
21:29:44 <vishy> eglynn: it is more the scope of changes i was referring to
21:30:00 <eglynn> vishy: got it
21:30:05 <vishy> markmc: are we moving extensions into core/ deprecating useless stuff like personalities etc.
21:30:07 <markmc> as soon as you open the door for 3.0, though
21:30:17 <markmc> folks will ...
21:30:19 <vishy> markmc: yeah, that is why i wanted to call it 2.5 :|
21:30:22 <sdague> markmc: well, unless you hold the door hard :)
21:30:28 <markmc> that's what I was about to say
21:30:35 <markmc> vishy, the number isn't important :-P
21:30:45 <russellb> zing
21:30:56 <vishy> we could call ig 2.01 and then at the last minute change it to 3.0
21:30:58 <vishy> !
21:31:10 <markmc> now there's a cunning plan
21:31:18 * vishy goes to delete the irc logs
21:32:01 <vishy> homework for next week
21:32:15 <mikal> Heh
21:32:17 <vishy> come up with important summit sessions so we can discuss what is still missing
21:33:27 <russellb> cake is missing
21:33:34 <sdague> it's a lie
21:35:25 <vishy> ok we're done
21:35:28 <vishy> thanks everyone
21:35:32 <vishy> #endmeeting nova