21:01:29 <russellb> #startmeeting nova
21:01:30 <openstack> Meeting started Thu May 30 21:01:29 2013 UTC.  The chair is russellb. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:01:31 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:01:33 <russellb> hello!
21:01:34 <openstack> The meeting name has been set to 'nova'
21:01:37 <russellb> who's here?
21:01:43 <dripton> hi
21:01:46 <devananda> \o
21:01:46 <melwitt> hi
21:01:48 <n0ano> o/
21:01:48 <cyeoh> hi!
21:01:51 <cburgess> present
21:01:51 <russellb> #link https://wiki.openstack.org/wiki/Meetings/Nova
21:02:15 <alaski> o/ and at an OS meetup so may be spotty
21:02:20 <dansmith> o/
21:02:45 <russellb> #topic blueprints
21:02:49 <russellb> so, havana-1 was released today!
21:02:51 <russellb> #link https://launchpad.net/nova/+milestone/havana-1
21:02:59 <russellb> 16 blueprints and 214 bugs closed
21:03:02 <russellb> :-)
21:03:20 <russellb> so now our next milestone is havana-2, with a target of July 18
21:03:21 <comstud> o/
21:03:23 <russellb> #link https://launchpad.net/nova/+milestone/havana-2
21:03:38 <russellb> so, total 100 havana blueprints right now, 16 in havana-2, and 69 targeted to havana-2
21:03:43 <russellb> probably optimistic :-)
21:04:05 <jog0> o/
21:04:10 <russellb> but take a look, see what you have on here, make sure it's still current
21:04:18 <russellb> and if anything is missing, let's get it filed
21:04:36 <russellb> a lot got pushed from havana-1 to havana-2, so there are a lot already up for review
21:04:52 <russellb> any particular blueprints anyone wants to dicuss?
21:04:57 <russellb> or process questions?
21:05:28 <comstud> crickets
21:05:33 <russellb> alrighty!
21:05:36 <russellb> #topic bugs
21:05:45 <russellb> #link https://wiki.openstack.org/wiki/Nova/BugTriage
21:05:56 <comstud> I need to re-open that sys_meta not being deleted bug
21:05:57 <russellb> so, as discussed over the last couple weeks, we've started a slightly modified process for triage
21:05:59 <comstud> or should I file a new one?
21:06:05 <russellb> to help distribute the load
21:06:11 <comstud> (since I reverted the previous fix)
21:06:15 <russellb> comstud: good question ... re-open i guess?
21:06:20 <comstud> i thought re-open
21:06:23 * russellb nods
21:06:23 <comstud> but i dunno :)
21:06:24 <comstud> ok
21:06:27 <russellb> yeah, works for me
21:06:46 <russellb> so if you take a look at the Nova/BugTriage page, we still have some holes in the sign-up list.
21:06:56 <russellb> could use some more people to take ownership of triage for a given tag
21:07:13 <jog0> russellb: yeah, what review times
21:07:13 <jog0> were the numbers you posted accurate in the end?  And how do we do a better job?
21:07:48 <russellb> jog0: yeah, the numbers are pretty accurate now ... current numbers here: http://russellbryant.net/openstack-stats
21:08:07 <russellb> so if we look at ... http://russellbryant.net/openstack-stats/nova-openreviews.txt
21:08:29 <russellb> I think we are keeping up overall ... people seem to agree that < 4 days is a very good goal, and we're meeting that
21:08:37 <russellb> we obviously have some that seem to get neglected and wait much longer
21:09:04 <russellb> dolphm wrote a nice 'next-review' tool that helps pick a review to do, giving priority based on age, but filtering out stuff you've already looked at and such
21:09:12 <russellb> so that's worth looking at ...
21:09:15 <jog0> not sure how this factors into the numbers but I have seen several patches expire with +1s etc
21:09:28 <russellb> yeah, that's not good
21:09:38 <russellb> actually, do reviews really expire even with no negative feedback?
21:09:41 <russellb> that doesn't seem ideal.
21:10:04 <dripton> the submitter can always revive them so it's not a *huge* deal
21:10:05 <dansmith> yeah, I didn't think they would
21:10:10 <jog0> https://review.openstack.org/#/c/23207/
21:10:30 <russellb> ugh
21:10:44 <devananda> wow...
21:10:49 <jog0> not sure if that only happens on stable
21:10:55 <comstud> i think it happens everywhere
21:11:08 * jog0 just restored teh patch from the dead.
21:11:10 <russellb> #action need to follow up on whether it makes sense to expire changes with no negative feedback
21:11:24 <devananda> might explain why the "oldest review" has been stable just under 14 days
21:11:46 <russellb> IMO that should only happen for reviews with -1/-2 and no updates for X days
21:11:51 <russellb> so i'll follow up on that ...
21:12:15 <cyeoh> there are reviews which are older than that around, just that someone has commented on it in the last 2 weeks.
21:12:18 <russellb> probably just post to the ML
21:12:38 <russellb> cyeoh: the script shouldn't reset the timer because of a comment
21:12:44 <russellb> cyeoh: only if you got a -1/-2
21:12:51 <cyeoh> russellb: yea agreed
21:12:52 <russellb> otherwise it's time since (roughly) when you submitted it
21:13:16 <russellb> the other tool to use to help pick reviews is reviewday
21:13:29 <russellb> http://status.openstack.org/reviews/
21:13:42 <russellb> that helps prioritize things based on other criteria ... test results, bug/blueprint priority
21:14:02 <russellb> so basically, using one of these tools instead of going after low hanging fruit will help smooth things out
21:14:06 <jog0> russellb: can we get that to personalize?
21:14:20 <russellb> it's all open source :)
21:14:27 <russellb> but reviewday, not right now
21:14:36 <russellb> next-review is personalized
21:14:43 <russellb> based on what you've already commented on and such
21:15:07 <russellb> https://github.com/dolph/next-review
21:15:26 <russellb> feel free to hack on it ... i submitted some tweaks today
21:15:37 <jog0> sounds good, I will redirect my rantings to the ML as this isn't nova only
21:15:47 <russellb> k :-)
21:15:52 <russellb> but yeah, i'm all for improvement in this area
21:15:58 <russellb> i ended up going on quite the stats kick this week ...
21:16:07 <cyeoh> I think it would help if we made a concious effort to do extra review effort about 2 weeks out from H2. To help reduce the last minute rush
21:16:08 <russellb> because it was killing me not having good data on how well we were keeping up with reviews
21:16:19 <russellb> cyeoh: +1
21:16:48 <russellb> with all that said ... the review burden for nova vs other projects is *considerably* higher, so kudos for at least doing as well as we have :)
21:17:04 <russellb> but more to do ...
21:17:12 <russellb> alright, let's jump to subteam reports
21:17:15 <russellb> #topic sub-team reports
21:17:27 <russellb> who's here to give a report?  raise hand and i'll call on you to go
21:17:29 <dripton> db
21:17:34 <n0ano> scheduler
21:17:41 <devananda> baremetal
21:17:51 <russellb> dripton: alright, you're up
21:18:10 <dripton> db meeting failed to happen today.  But we got a bunch of good commits in this week.
21:18:23 <dripton> boris's db-improve-archving commits all went in
21:18:24 <russellb> yeah, db-improve-archiving got finished up
21:18:26 <harlowja> taskflow
21:18:27 <russellb> :)
21:18:36 <dripton> and Roman and Sergei got some extra tests in
21:18:41 <russellb> great
21:18:43 <dripton> that's all
21:19:01 <russellb> kthx!
21:19:04 <russellb> n0ano: scheduler!
21:19:27 <n0ano> good discussion on whole host allocation (allocating all of a host to one VM, not bare metal but related a little)
21:19:34 <n0ano> expect to see more on that in the future
21:19:56 <russellb> cool
21:19:59 <n0ano> no one appeared to talk about host directory service, I'm still curious on what exactly that is
21:20:13 <n0ano> that was pretty much it for this week, as always, check the logs for details.
21:20:24 <russellb> cool thanks
21:20:31 <russellb> devananda: baremetal / ironic!
21:20:52 <devananda> pasting a bunch (i actually prepraed something!)
21:21:00 <devananda> two open-critical bugs in baremetal, both waiting for reviews:
21:21:00 <devananda> #link https://bugs.launchpad.net/nova/+bug/1178092
21:21:01 <uvirtbot> Launchpad bug 1178092 in nova "second boot during baremetal deploy does not configure netboot : will hang unless the machine attempts PXE automatically" [Critical,In progress]
21:21:02 <devananda> #link https://bugs.launchpad.net/nova/+bug/1180178
21:21:03 <uvirtbot> Launchpad bug 1180178 in nova "Instance IP addresses are re-used even when previous instance could not be powered off" [Critical,In progress]
21:21:21 <devananda> Several bugs may be related / consolidated into this one:
21:21:25 <devananda> #link https://bugs.launchpad.net/nova/+bug/1184445
21:21:25 <russellb> should target them against havana-2
21:21:28 <uvirtbot> Launchpad bug 1184445 in tripleo "deploy / delete fragility" [High,Triaged]
21:21:37 <devananda> k, will target :)
21:22:06 <devananda> Ironic is continuing to move forward. More folks are welcome, we've been discussing how to better split up the work
21:22:22 <devananda> and we have an API spec now \o/
21:22:27 <russellb> getting reasonable amount of help/participation?
21:22:42 <devananda> redhat's contributed 2 guys to the API so that is moving well
21:22:58 <russellb> oh, cool, i should have known that, lol.
21:23:04 <devananda> and we (HP) are mostly taking the internal bits
21:23:17 <devananda> there's some work refactoring nova/cinder's glance-client and image manipulation
21:23:20 <devananda> into oslo
21:23:32 <devananda> being tracked here
21:23:36 <devananda> #link https://blueprints.launchpad.net/ironic/+spec/image-tools
21:23:59 <devananda> that's about it!
21:24:31 <russellb> cool, sounds like lots of good activity and progress!
21:24:39 <russellb> harlowja: taskflow!
21:24:43 <harlowja> yo yo!
21:25:03 <harlowja> thanks to devananda
21:25:05 <harlowja> "Taskflow is continuing to move forward. More folks are welcome, we've been discussing how to better split up the work."
21:25:11 <harlowja> :-P
21:25:17 <devananda> hehe
21:25:37 <harlowja> haha, just continuing onwards, db & distributed backend getting done by a couple rackspace folks,
21:25:48 <harlowja> more testing, stackforge nearly there
21:26:15 <harlowja> figuring out new use-cases in ironic and nova, and seeing how taskflow can help there
21:26:17 <harlowja> *and cinder*
21:26:46 <harlowja> more people getting involved with different backends
21:26:48 <harlowja> so all good
21:27:00 <harlowja> thats about its :) more nova folks always welcome ;)
21:27:01 <russellb> cool stuff, and meeting is just before this one if anyone is interested
21:27:05 <harlowja> yuppers
21:27:15 <russellb> annnnnnnnd... hartsocks: vmware!
21:27:27 <hartsocks> hey
21:27:33 <hartsocks> #link http://eavesdrop.openstack.org/meetings/vmwareapi/2013/vmwareapi.2013-05-29-17.01.html
21:27:43 <hartsocks> So we've got 2 blueprints targeted for H-2
21:28:10 <hartsocks> And we have about 4 "critical" bugs/patches we did not make for H1 that will get pushed to H2 now.
21:28:39 <russellb> btw, on reviews on that driver ...
21:28:40 <hartsocks> We're also getting more blueprints in from other folks out side of the regular crowd.
21:28:54 <russellb> i mostly don't touch it if i see you haven't touched it yet
21:29:03 <russellb> would like to see your +1 first
21:29:08 <hartsocks> Thanks.
21:29:17 <hartsocks> I am humbled by your trust
21:29:17 <russellb> if there's others I should consider the "maintainer" like that, let me know
21:29:24 * hartsocks bows
21:29:30 <russellb> doesn't mean I blindly +2 after that :-p
21:29:39 <hartsocks> Good to know. :-)
21:29:47 <russellb> just saying there was at least one waiting over a week, but i hadn't reviewed because i was hoping you would first
21:30:08 <hartsocks> I will try and cycle through the reviews faster.
21:30:31 <russellb> all good ... just letting you know how i think, i guess
21:30:42 <russellb> and the one i was thinking about you have reviewed already now
21:31:13 <hartsocks> I've also worked through the bug lists and prioritized most stuff.
21:31:18 <russellb> target bugs to havana-2 if you want to try to get them in
21:31:23 <russellb> awesome, much appreciated
21:31:49 <hartsocks> So, VMware stuff is starting to pick up steam here.
21:32:15 <hartsocks> I should have a few new developers coming on line in the next few weeks from our VMware team too. (just BTW)
21:32:24 <russellb> cool, good to hear
21:32:32 <russellb> i like maintained code :)
21:32:37 <hartsocks> yep.
21:32:41 <russellb> anything else?
21:32:49 <hartsocks> That'll cover it. :-)
21:32:52 <russellb> thanks!
21:32:57 <russellb> #topic open discussion
21:33:03 <russellb> any misc topics?
21:33:15 <cyeoh> yep!
21:33:43 <cyeoh> I'd like to talk about trying something to make reviewing all the ported v3 API extension changesets about to come through easier
21:34:05 <russellb> cool, have an idea?
21:34:33 <cyeoh> at the moment the changesets look pretty big because although a lot of the code is the same as in V2 its a new file and so the diff looks large
21:35:06 <cyeoh> so what I'd like to do for the remaining extensions in contrib (and there are about 60!) is to do a giant copy of paste from contrib to plugins/v3
21:35:30 <russellb> so how long should we be supporting v2?
21:35:35 <cyeoh> the code would essentially be "dead" in there. as neither the v2 nor v3 extension code will attempt to load them
21:35:43 * russellb is thinking about the cost/benefit to any refactoring to cut down on copy/paste
21:35:47 <cyeoh> russellb: I guess for at least one full cycle
21:35:59 <dansmith> cyeoh: so one big copy/paste that doesn't work,
21:36:11 <dansmith> cyeoh: then a bunch of small patches with just deltas for v3-ness?
21:36:17 <cyeoh> dansmith: yes
21:36:19 <dansmith> and we just "ignore" the big ugly first one?
21:36:20 <russellb> so ... if we "completed" v3 in havana ... could have it removed in I, ok ...
21:36:32 <russellb> that's actually pretty clever, heh
21:36:33 <dansmith> cyeoh: that's an interesting appraoch
21:36:35 <cyeoh> yep and similarly for the tests too because they have a similar review issue
21:36:45 <russellb> makes the reviews sound much more pleasant (after that)
21:36:53 <russellb> though I would feel so so so dirty approving that first one
21:37:04 <cyeoh> yea I realise its rather ugly and will probably need some updates when people update the V2
21:37:05 <dansmith> cyeoh: could we try it with a couple of extensions first?
21:37:19 <dansmith> like, get three patches up, the big one, plus two conversions on top of it so we can see?
21:37:29 <cyeoh> dansmith: sure
21:37:33 <russellb> and if that works
21:37:35 <dansmith> I'm +1 for that
21:37:35 <russellb> could do 1 at a time
21:37:40 <russellb> so each conversion is just 2 changes
21:37:47 <dansmith> well,
21:37:50 <russellb> 1 copy/paste that isn't used yet ... another that converts it
21:38:00 <russellb> would help prevent things from getting too out of sync
21:38:00 <dansmith> we could do that too, I guess
21:38:03 <dansmith> yeah
21:38:18 <dansmith> and we rubber stamp the first in each pair, if we approve the second?
21:38:24 <comstud> I'd be +1 on that approach
21:38:27 <russellb> and also doesn't leave dead code in the tree for longer than <gate job time> or whatever
21:38:28 <cyeoh> yep, I'm happy to do that too.
21:38:40 <dansmith> cool
21:38:47 <dansmith> then I can feel like less of a slackass
21:38:52 <russellb> :)
21:39:04 <cyeoh> I'm just aware that 60 or so reviews in the next 6 weeks is actually adding a reasonable amount of review load so want to make it as easy as possible :-)
21:39:11 <russellb> same here ... i didn't start looking at v3 patches until it was too late for havana-1 ... sorry
21:39:14 <russellb> way too many reviews out there
21:39:18 <russellb> (or so I feel)
21:39:27 <russellb> cyeoh: much appreciated
21:39:30 <cyeoh> heh np. They're starting to flow in now :-)
21:39:32 <russellb> cyeoh: let's see how it goes on the first couple
21:39:41 <russellb> and then adjust the approach if needed
21:39:58 <russellb> it sounds like it'll make it pretty easy to review these
21:40:11 <jog0> cyeoh: do you have a doc on the high level changes in V3 that dives into the details to? so we know what to look for during a reviwe
21:40:42 <cyeoh> jog0: Mauro posted a link to a wiki page a couple of weeks ago. I'll have to go dig it up
21:41:03 <russellb> https://wiki.openstack.org/wiki/NovaV3API
21:41:04 <russellb> ?
21:41:09 <russellb> that's just from google, heh
21:41:40 <melwitt> I found this in ML: https://etherpad.openstack.org/api-v3-review-guide
21:41:49 <russellb> melwitt: nice
21:42:15 <cyeoh> melwitt: yea, thats it. We need to add a few other things.
21:43:04 <cyeoh> everything that is intentionally changed (like return codes) should be explicitly stated in the changeset comment, but would also help to have a separate list of things we're meant to consider during the port (like json/xml inconsistencies for example)
21:43:37 <jog0> cyeoh: ahh
21:43:39 <cyeoh> given the number of different blueprints which can apply to the same extension there may be multiple passes though.
21:44:40 <russellb> cyeoh: random thing ... there is a versions.py in the api code that lists the APIs we're serving up ... v3 isn't in there yet, will need to be added, and have its status set to something that indicates its a WIP
21:45:00 <cyeoh> I don't want anyone to consider the v3 API to be in anyway "fixed" until late in the H cycle
21:45:06 <russellb> yep
21:45:26 <russellb> so not even making it discoverable (even if marked as WIP) until later probably isn't bad
21:45:27 <cyeoh> russellb: yea I have been holding off on the versions stuff because of the discussion around discoverability
21:45:33 <russellb> is v3 configurable?
21:45:36 <russellb> as in, can it be disabled?
21:45:42 <russellb> should do that too if not already
21:45:54 <russellb> and maybe even have it disabled by default until it's "done"
21:45:58 <cyeoh> hrm do you want a config option because you can just remove it from the paste file
21:46:17 <russellb> yeah, a config option i think ... because ideally we don't want anyone to have to edit the paste files
21:46:19 <cyeoh> from /etc/nova/api-past.ini
21:46:23 <russellb> paste files are more like code than config IMO
21:46:45 <russellb> glance had (has?) a similar option for the v2 API
21:46:46 <cyeoh> ok. I'll add something to disable it by default for now
21:46:50 <russellb> cool
21:47:39 <russellb> i *usually* don't like having to develop a "feature" in tree like this ... but this is so massive, don't see any other way
21:47:49 <russellb> a well justified exception, i think
21:48:15 <cyeoh> yea keeping in sync with V2 changes is a bit of work as it is.
21:48:27 * russellb nods
21:48:44 <russellb> so, we have a plan then?
21:48:48 <russellb> for now at least?  :)
21:48:54 <cyeoh> yep, thanks! That's it from me :-)
21:49:34 <russellb> cool!
21:49:36 <russellb> anything else?
21:49:51 <jog0> cyeoh: will you be addressing http://www.mail-archive.com/openstack@lists.launchpad.net/msg23320.html in v3? are those the JSON/XML issues you mentioned?
21:51:21 <cyeoh> jog0: that's the kind of thing we need to catch. If you could file a bug report or add an entry to the blueprint for those that you are aware of, that would really help.
21:52:15 <jog0> cyeoh: I will add an entry in the BP, sadly I am not aware of how often/where this happens
21:52:33 <cyeoh> there are a few cases where JSON does one thing and xml does something different  too
21:53:03 <cyeoh> jog0: yea, ivanzhu is doing a scan to try to pick up as many as possible, but its an easy enough thing to miss
21:53:06 <jog0> cyeoh: which blueprint would this  go under  https://blueprints.launchpad.net/nova/+spec/v3-api-inconsistencies ?
21:53:26 <cyeoh> jog0: yea, that will do
21:54:28 <russellb> alright, thanks everyone ... more discussion in #openstack-nova is welcome as always
21:54:37 <russellb> jog0: cyeoh: let's just continue over there if needed
21:54:39 <russellb> bye!
21:54:41 <russellb> #endmeeting