21:01:07 <russellb> #startmeeting nova
21:01:08 <openstack> Meeting started Thu Jun 27 21:01:07 2013 UTC.  The chair is russellb. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:01:09 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:01:11 <openstack> The meeting name has been set to 'nova'
21:01:14 <russellb> Hello!
21:01:17 <russellb> who's around to talk about nova?
21:01:19 <mriedem> hello
21:01:19 <devananda> \o
21:01:22 <cyeoh> russellb: hi
21:01:22 <alaski> ji
21:01:23 <dansmith> me
21:01:25 <alaski> hi
21:01:28 <harlowja> yo, quickly brb, but i'll be there
21:01:28 <bpb> me
21:01:38 <bnemec> o/
21:01:43 <mrodden> me
21:01:47 <russellb> welcome all
21:01:53 <hartsocks> \o
21:01:54 <russellb> #topic blueprints
21:02:07 <russellb> #link https://launchpad.net/nova/+milestone/havana-2
21:02:12 <russellb> havana-2 is set to be released in 3 weeks
21:02:20 <russellb> which means the merge deadline is about 2.5 weeks away
21:02:38 <russellb> i started moving blueprints to havana-3, starting with ones still marked as "Not Started"
21:02:42 <russellb> we still have 74 :-)
21:03:01 <russellb> so, let's spend some time going through some of them and talk about their status
21:03:21 <russellb> cyeoh: hi!  we've got lots of v3 api blueprints.  i believe we were originally targeting to finish it by havana-2
21:03:26 <russellb> cyeoh: how is it looking?
21:03:54 <cyeoh> well not too bad, I don't think that all will get merged by H2
21:04:03 <cyeoh> but certainly most will be in review
21:04:18 <russellb> ok.  so if it'll all be in review, then feel very confident about havana-3 at least?
21:04:23 <cyeoh> I think we have probably around 60 or so changesets in the review queue at the moment? I haven't had a close look today
21:04:28 <russellb> wow
21:04:50 <cyeoh> yea, that was my main reason for setting a fairly aggressive H2 goal - to make sure we make H3
21:04:52 <russellb> #help biggest hold-up on v3 api blueprints' progress is getting reviews.  close to 60 in the queue
21:05:15 <russellb> at least most of the conversions are pretty easy to review IMO
21:05:25 <cyeoh> the things at the end that are more uncertain are the increased tempest testing and documentation
21:05:48 <cyeoh> but we had that discussion around xml/json - and it will be a matter of prioritising what is most important
21:05:51 <russellb> so, how about novaclient support?
21:05:53 <russellb> is that on the radar at all?
21:06:16 <cyeoh> we don't really have anyone explicitly assigned for novaclient work.
21:06:32 <cyeoh> Will need to see how things look post H2
21:06:36 <russellb> #action need to create a v3 api novaclient blueprint and find someone to work on it
21:07:13 <russellb> as for docs, primarily the api docs part right?
21:07:37 <cyeoh> yes, and smaller things like guides on how to write a v3 extension
21:07:50 <russellb> hopefully much of the api part can be autogenerated like we do for v2, but it will be some work
21:08:05 <russellb> at least it could be worked on late if needed
21:08:09 <cyeoh> yes, have to sort out exactly what we need and the changesets will be big if anything like v2
21:08:31 <russellb> so biggest thing you need is reviews?
21:08:33 <russellb> anything else?
21:08:35 <cyeoh> is this an ok time to bring up the status of nova-network? It does sort of impact exactly what needs to be ported for v3
21:08:43 <cyeoh> (yes reviews is the biggest thing)
21:08:49 <russellb> vishy: you around?
21:08:56 <russellb> vishy has the "deprecate-nova-network" blueprint
21:08:56 <vishy> yeah
21:09:13 <vishy> multitasking
21:09:45 <vishy> so there hasn't been much progress so far
21:10:00 <russellb> afaik, not a ton of progress there, so it's a little up in the air ...
21:10:02 <russellb> i'm still of the opinion that we should assume quantum for v3
21:10:03 <russellb> v2 isn't going away yet
21:10:04 <russellb> and hopefully we can kill it when we kill nova-network
21:10:05 <russellb> happy to hear other opinions if someone wants to argue otherwise ...
21:10:12 <russellb> sorry, had a network blip
21:10:12 <cyeoh> it looks like there are some extensions around which don't support quantum and only nova-network. If we don't have nova-network in Havana then do they need to be ported?
21:10:17 <vishy> russellb: +1
21:10:25 <russellb> vishy: ok cool
21:10:37 <vishy> i would leave all the network stuff out of v3
21:10:47 <cyeoh> ok thanks
21:10:49 <russellb> ok great
21:10:56 <russellb> cyeoh: anything else?
21:10:59 <bpb> I have a status update on the Cinder volume encryption blueprint https://blueprints.launchpad.net/nova/+spec/encrypt-cinder-volumes
21:11:09 <bpb> We (APL) are currently working with Cinder folks to store encryption metadata (e.g., an encryption key id) with the volume
21:11:20 <bpb> This is needed to support special Cinder features
21:11:24 <cyeoh> russellb: just that re: the proposed in/out of core - anything without a -1 (which I think is everything now) we're just going ahead with
21:11:29 <bpb> We expect to submit an updated version of our code next week, but it will be tight for getting it accepted into Havana-2
21:11:29 <cyeoh> other than that nothing else
21:11:43 <russellb> cyeoh: ok, i'd like to review each of those if i can, so tag me on the reviews
21:11:58 <russellb> bpb: ok, cool.  sounds like good progress, though!
21:12:04 <cyeoh> russellb: ok
21:12:24 <russellb> bpb: should we leave it on the havana-2 list, or go ahead and bump it?
21:13:24 <russellb> bpb: well just let me know
21:13:27 <russellb> comstud: you around?
21:13:35 <russellb> comstud: you have a high prio blueprint on havana-2 for the native mysql db driver
21:13:43 <comstud> i am
21:13:46 <bpb> Russel: We're still shooting for Havana-2 - sorry for the spamming
21:13:47 <russellb> comstud: that going to show up?  or should we bump it?
21:13:54 <russellb> bpb: cool, sounds good, thanks!
21:14:03 <comstud> well
21:14:19 <russellb> bpb: i'm afraid a batch of stuff will get bumped because of review bandwidth in the last days ... so we'll see
21:14:19 <comstud> no, it's not going to make 2 i guess
21:14:24 <russellb> ok
21:14:47 <russellb> still havana-3?
21:14:55 <comstud> yeah, i'll make it happen.
21:15:00 <russellb> ok cool
21:15:22 <russellb> dansmith: you have a ton of objects patches coming through, want to give an update?
21:15:23 <comstud> i wanted objects to be stablized a bit before doing the work
21:15:28 <russellb> even though it's not targeted at havana-2
21:15:28 <comstud> well, committing the work...
21:15:30 <dansmith> russellb: yeah
21:15:34 <russellb> comstud: makes sense
21:15:56 <dansmith> russellb: I was actually going to say, I'm pretty sure "objectify all the things" isn't going to make all of H anyway,
21:16:03 <comstud> but to satisfy some people, I probably should also prove sqlalchemy is a huge problem.
21:16:06 <comstud> heh.
21:16:12 <comstud> (more than I already have)
21:16:16 <dansmith> so maybe we should cut up some smaller sub-blueprints to go underneath the main one
21:16:34 <russellb> dansmith: yeah, or rescope the main one you have now to what you think is achievable for havana
21:16:41 <dansmith> "make all of H" ?  "make H"
21:16:46 <russellb> and then we can have icehouse-objectification or whatever
21:16:52 <dansmith> russellb: sure, I can do that
21:16:58 <russellb> ok cool, sounds good to me
21:17:01 <dansmith> russellb: I'd like to try to get something small targeted for H2,
21:17:04 <dansmith> to show progress,
21:17:09 <dansmith> but I'm not sure what that would be right now
21:17:16 <russellb> dansmith: ok, feel free to create a blueprint if you can think of something
21:17:19 <dansmith> okay
21:17:20 <comstud> gosh i really hope I can step up my game here soon wrt objects
21:17:21 <russellb> convert instance or something?
21:17:29 <dansmith> comstud: me too, sheesh man! :P
21:17:34 <comstud> i know, right?
21:17:42 <dansmith> russellb: nah, that's too big I think
21:17:48 <russellb> dansmith: k
21:17:56 <russellb> well, just let me know what you come up with :)
21:17:57 <dansmith> russellb: "nova-api uses objects" maybe
21:17:59 <dansmith> yeah
21:18:04 <russellb> but i like the idea of having something in havana-2
21:18:05 <dansmith> comstud: just kidding <3
21:18:10 <russellb> comstud: he's not kidding
21:18:10 <comstud> i know
21:18:13 <comstud> i'm not
21:18:13 <comstud> :)
21:18:18 <comstud> hehe
21:18:18 <dansmith> haha, nah, I am, I promise
21:18:19 <russellb> ok, on to something else
21:18:20 <russellb> we've got a ton
21:18:37 <russellb> alaski: hey, you've got a high prio one
21:18:49 <russellb> making scheduler queried instead of a proxy service
21:19:15 <alaski> There's one review up for a new scheduler call
21:19:39 <alaski> Working on making conductor use it now.
21:19:53 <alaski> But all the work should be under review soon
21:19:56 <russellb> nice
21:19:59 <russellb> sounds good then!
21:20:04 <russellb> need anything?
21:20:08 <russellb> (other than review on what you have up..)
21:20:08 <comstud> money
21:20:12 <russellb> i'd take money too
21:20:17 <alaski> same as everyone else, reviews
21:20:24 <russellb> yeah, i feel like we're behind on reviews
21:20:34 <russellb> sort of a different topic though ... maybe we can come back to it
21:21:14 <russellb> timello: hey, i saw you join
21:21:22 <russellb> timello: how about your cold migrations to conductor refactor?
21:21:31 * johnthetubaguy waves
21:21:39 <russellb> johnthetubaguy: hi!
21:21:56 <russellb> johnthetubaguy: and your live migrations to conductor refactor?
21:22:16 <johnthetubaguy> in a related front, live-migrate has got some stuff in, other bits are in reviews, little bits not done yet
21:22:33 <johnthetubaguy> main sorry is the orchestration with the TaskFlow lib, can't see that getting in too soon
21:22:48 <russellb> i wasn't considering that part of this personally
21:22:57 <johnthetubaguy> yeah, its probably next time sadly
21:23:03 <russellb> could reconsider it in the Icehouse release
21:23:16 <johnthetubaguy> I was hoping to get tasks that detected the service got restarted, but yes, that should be I now
21:23:31 <johnthetubaguy> its looking more like H-3 I guess
21:23:33 <russellb> still havana-2 achievable?
21:23:36 <russellb> ok, i can move it
21:23:42 <johnthetubaguy> well, its damm close at least
21:23:53 <johnthetubaguy> leaving H-2 for now may help the reviews :P
21:24:11 <johnthetubaguy> there is stuff to review now at least, and bits to finish off
21:24:19 <johnthetubaguy> anyways, was wondering about the cold migration
21:24:42 <russellb> yeah, pinged timello
21:24:51 <russellb> timello: speak up if you're back and we can come back to cold migrations
21:24:59 <johnthetubaguy> cool
21:25:00 <russellb> anyone else have a blueprint you'd like to give an update on?
21:25:05 <russellb> or one you'd like to ask about?
21:25:23 <russellb> in general, please help me out by making sure your blueprint status is accurate
21:25:24 <mrodden> https://blueprints.launchpad.net/nova/+spec/user-locale-api is "pretty much done"
21:25:38 <mrodden> just waiting on reviews and a change to merge in Oslo
21:25:44 <harlowja> johnthetubaguy let me know about how i can help make sure taskflow helps u :)
21:25:51 <russellb> mrodden: cool, so need review ...
21:25:53 <harlowja> at your service ;)
21:26:01 <russellb> looks like we have it marked properly
21:26:10 <johnthetubaguy> harlowja: will do, just looking like I now
21:26:10 <russellb> and hopefully we can get it reviewed..
21:26:29 <mrodden> yea. if it gets bumped to H3 if we don't have enough review bandwidth
21:26:40 <mrodden> could we bump the priority up in that case?
21:26:47 <harlowja> johnthetubaguy agreed
21:26:59 <russellb> mrodden: yeah, that happened in G, right?  that's fine
21:27:03 <mrodden> yep
21:27:08 <russellb> mrodden: you'll have to remind me
21:27:17 <mrodden> np, i have people reminding me daily...
21:27:19 <mrodden> :)
21:27:29 <russellb> heh
21:27:38 <russellb> anyone else?
21:28:27 <russellb> alright, next topic
21:28:28 <russellb> #topic bugs
21:28:36 <russellb> #link https://wiki.openstack.org/wiki/Nova/BugTriage
21:28:48 <russellb> we have about 60 new nova bugs, and 47 novaclient bugs
21:29:06 <russellb> we really need someone to take on triage of novaclient, kind of like we have owners for tags
21:29:08 <comstud> dan and I filed a lot of bugs for work that needs to happen for objects
21:29:08 <russellb> anyone willing?
21:29:17 <comstud> not sure how many we left 'new'
21:29:24 <comstud> (fyi)
21:29:25 <russellb> comstud: cool, have a tag for them?
21:29:27 <comstud> yes
21:29:29 <russellb> comstud: objects?
21:29:29 <comstud> unified-objects
21:29:33 <russellb> k
21:29:44 <russellb> so, i also noticed that my filter i've been using for untagged bugs is silly
21:29:59 <russellb> it misses stuff if someone added their own tags
21:30:06 <johnthetubaguy> doh
21:30:15 <russellb> like grizzly-backport-potential, or whatever random tags they come up with
21:30:17 <dansmith> russellb: yeah, do you know how to get that tag to show up in the list on the right?
21:30:18 <russellb> so some cleanup to do ...
21:30:27 <russellb> dansmith: i do, i have to make it an official tag
21:30:36 <dansmith> oh, pretty please?
21:30:36 <russellb> dansmith: ping me later and i can
21:30:39 <dansmith> okay
21:30:47 <russellb> so, in addition to really needing someone to own novaclient
21:30:56 <russellb> network could use some work ... 17 network untriaged bugs
21:30:58 <russellb> arosen: ^^^
21:31:02 <alaski> russellb: I'll help with novaclient bugs
21:31:07 <russellb> s/work/help/
21:31:17 <russellb> alaski: awesome!!!  much appreciated, it's something we've long neglected
21:31:25 <russellb> alaski: can you update the wiki page?
21:31:30 <alaski> sure
21:31:34 <russellb> cool.
21:31:41 <russellb> another is libvirt, 9 new bugs to triage there
21:31:56 <russellb> api has 6 to triage
21:31:56 <russellb> cyeoh: ^
21:32:01 <russellb> and compute has 5
21:32:15 <russellb> melwitt1: ^
21:32:23 <russellb> hartsocks: 4 on vmware
21:32:28 <hartsocks> I see 'em
21:32:37 <johnthetubaguy> do we want a bug day post H-2 to try and tidy up a bit?
21:32:37 <russellb> 4 for volume integration ... nobody has taken that tag yet
21:32:50 <johnthetubaguy> or should that be, pre H-2, maybe
21:32:53 <russellb> johnthetubaguy: not a bad idea ... bug days seem to be helpful ... as long as they're not too often
21:33:04 <johnthetubaguy> +1 for not too often
21:33:07 <russellb> we had a really good one, then another the next week and nobody did anything :)
21:33:14 <dansmith> heh
21:33:28 <russellb> so we stopped, and then came up with this tagged approach to split up the work
21:33:35 <russellb> so anyway, triage!
21:33:38 <johnthetubaguy> yeah, I remember now
21:33:41 <russellb> any specific bugs worth talking about?
21:33:54 <russellb> i found this one while triaging today: https://bugs.launchpad.net/nova/+bug/1194093
21:34:06 <russellb> have a fix for master written i think, just need to add tests
21:34:25 <russellb> either i'm totally missing something, or this hasn't worked in ages
21:34:32 <comstud> guessing the latter
21:34:51 <alaski> Quick question on triaging:  if it's a feature request what's the best way to "close" it?
21:34:54 <johnthetubaguy> hmm, that was the feature no one remembered getting added right
21:35:12 <russellb> alaski: good question ... typically put it as Confirmed+Wishlist if it seems reasonable
21:35:28 <russellb> johnthetubaguy: has been there since the dark ages of 2011 at least
21:35:34 <johnthetubaguy> ah
21:35:42 <russellb> alaski: more detailed notes on that kind of thing on the main BugTriage wiki page
21:35:43 <alaski> Ok.  I've been using Invalid+wishlist, but confirmed is nicer :)
21:36:03 <russellb> alaski: yeah ... and then we have a BugTriage task on the main page to go back and close out old wishlist bugs
21:36:13 <russellb> or, mark them Opinion+Wishlist i think
21:36:22 <russellb> which is effectively closed
21:36:22 <johnthetubaguy> cool, that answers my question
21:36:23 <melwitt1> yeah, I think we said invalid means like never look at again
21:36:38 <russellb> Opinion is like ... "maybe"
21:36:48 <russellb> "it's not you, it's me"
21:37:07 <russellb> any other bugs?
21:37:07 <melwitt1> haha
21:37:38 <russellb> (i know we have plenty of them, but rather, any that you want to discuss?)
21:37:59 <russellb> alright, subteam time them
21:38:01 <russellb> #topic subteams
21:38:09 <russellb> hartsocks: sup!
21:38:12 <hartsocks> yo
21:38:24 <n0ano> o/
21:38:33 <hartsocks> So I'll spam y'all again with our reviews on Friday… on the mailing list. Fun right?
21:38:46 <russellb> fine with me
21:38:48 <harlowja> \o/
21:39:02 <hartsocks> groovy.
21:39:11 <russellb> so you need reviews :)
21:39:14 <russellb> need anything else?
21:39:22 <hartsocks> Some of us need to clean up our acts… after the last reviews :-)
21:39:48 <russellb> heh
21:39:53 <hartsocks> We're hashing out some of our BP's and such. H2 is going to be optimistic at the rate we're moving.
21:40:04 <russellb> hartsocks: ok.  let me know what should be bumped
21:40:10 <hartsocks> I'll keep beating the drums.
21:40:24 <russellb> i like drums
21:40:36 <hartsocks> Our highest priority BP is: https://blueprints.launchpad.net/nova/+spec/multiple-clusters-managed-by-one-service
21:40:45 <hartsocks> But we're still hashing out how to pull it off.
21:41:05 <russellb> thought there was a patch up already?
21:41:12 <johnthetubaguy> ah, we were thinking cells at one point
21:41:14 <russellb> just still WIP?
21:41:22 <russellb> johnthetubaguy: yeah i'm still thinking that long term...
21:41:34 <johnthetubaguy> russellb: gotcha
21:41:49 <russellb> johnthetubaguy: still some design work to do there to define a driver layer
21:42:02 <hartsocks> The review is up. IIRC there's still one point to work out.
21:42:09 <russellb> hartsocks: ok
21:42:29 <russellb> johnthetubaguy: i'm interested in it, but haven't made much progress ... more just looking around and thinking about it some
21:43:39 <johnthetubaguy> russellb: cool, its a tricky one, think comstud mentioned federated cloud stuff too, probably worth trying for both
21:43:49 <russellb> yeah
21:44:00 <russellb> so ... may end up a design summit brainstorm session
21:44:06 <russellb> we'll see
21:44:10 <johnthetubaguy> anyways, yes, lets not get distracted
21:44:14 <russellb> k :)
21:44:18 <russellb> hartsocks: anything else?
21:44:27 <hartsocks> Nope.
21:44:31 <russellb> kthx
21:44:34 <russellb> n0ano: hi!
21:44:37 <russellb> scheduler!
21:45:15 <n0ano> hi, not much to say, we had a very quiet week, I just came here to tell everyone nothing to tell :-)
21:45:36 <russellb> k :)
21:45:40 <russellb> harlowja: what's up
21:45:44 <harlowja> hey hey!
21:45:45 <russellb> devananda: preemptive ping, you're up next
21:46:18 <harlowja> so mainly just continuing stablizing, and hoping to get 0.1 release out for h2 so that cinder can integrate, keeping in touch with heat folks about back and forth on heat usage
21:46:41 <russellb> ok, and sounding like we won't be ready to look at using it soon ...
21:46:42 <harlowja> thinking it'd be nice to get more nova folks that have some ideas on what or how nova could use it involved
21:46:58 <russellb> been busy getting the code into the right places where it could be considered
21:47:02 <harlowja> agreed
21:47:09 <harlowja> which is step #1 i think
21:47:12 <johnthetubaguy> harlowja: hopeing to get some time to help with that
21:47:19 <harlowja> thx much johnthetubaguy  :)
21:47:42 <harlowja> so thats about it :)
21:47:45 <russellb> cool
21:47:47 <russellb> devananda: around?
21:47:55 <devananda> russellb: hi!
21:47:59 <russellb> \o/
21:48:03 <russellb> how goes ironic / baremetal?
21:48:23 <devananda> so, not much to report progress wise. I'll be out next week (EuroPython) and we're probably not going to have anything ready for H3
21:48:36 <russellb> until h3?
21:48:38 <devananda> kind of in that middle-slump period right now :(
21:48:39 <russellb> or not anything for h3?
21:48:44 <devananda> not anything for H3
21:48:50 <devananda> iow, not until early "I" at this point
21:48:54 <russellb> ok
21:49:07 <russellb> so, need to look over these baremetal havana blueprints that were kind of pending what happens with ironic
21:49:23 <russellb> no rush, but when you have some time, let me know what we should do with them (if you can't update them yourself)
21:49:30 <devananda> nova baremetal continues to get worked on by a few folks, particularly they have been adding better redhat support
21:49:45 <russellb> yeah, saw a patch go up today from dprince i think
21:49:47 <devananda> ack. i'll try to get to the BPs in the next week
21:49:52 <russellb> cool
21:50:06 <russellb> need anything?
21:50:21 <devananda> not from nova
21:50:26 <devananda> i have a ping out to glance folks for some reviews :)
21:50:31 <russellb> k
21:50:37 <russellb> is the db team still meeting?
21:50:50 <devananda> dripton ostensibly took that over, but i haven't heard anything in a bit
21:50:53 <russellb> ok
21:50:56 <russellb> he's out this week
21:50:59 <devananda> if it's not meeting and folks need me to restart it, let me know
21:51:05 <russellb> boris-42 (and his team) has been doing a bunch
21:51:14 <russellb> code wise i mean
21:51:15 <boris-42> hiii
21:51:16 <boris-42> )
21:51:22 <devananda> yea! i've been trying (and failing) to keep up with their flood of reviews :)
21:51:27 <boris-42> I will write today a big mail
21:51:30 <boris-42> in mailing list
21:51:33 <russellb> boris-42: on status?
21:51:42 <boris-42> where I would like to describe not only status=)
21:51:47 <boris-42> but also future plans=)
21:51:50 <russellb> cool
21:51:52 <russellb> sounds good
21:51:52 <boris-42> and not only in nova=)
21:52:02 <boris-42> I think that IRC is not good enough for it=)
21:52:06 <russellb> heh, just be careful not to make plans so big that you can't make progress :)
21:52:08 <russellb> baby steps!
21:52:20 <boris-42> yeah=) I will write our baby steps!=)
21:52:25 <russellb> cool
21:52:29 <russellb> and while you're here
21:52:32 <russellb> PCI passthrough?
21:52:35 <boris-42> yeah
21:52:35 <russellb> working on that?
21:52:41 <boris-42> I publish yesterday
21:52:44 <russellb> oh, cool
21:52:44 <boris-42> bunch of botch+)
21:52:50 <boris-42> didn't sllep for 2 days=)
21:53:07 <boris-42> to get all work + meeting + this stuff=)
21:53:07 <russellb> hardcore
21:53:18 <boris-42> And now I am not able to sleep
21:53:35 <boris-42> and I drink already a lot of alcohol but it seems doesn't help=)
21:53:42 <devananda> lol
21:53:43 <boris-42> to fat=)
21:53:51 <boris-42> for alchol=)
21:54:02 <russellb> yeah ummm
21:54:13 <russellb> hope you're able to sleep soon then :)
21:54:18 <boris-42> =)
21:54:33 <russellb> #topic open discussion
21:54:48 <russellb> so one thing that was mentioned a bunch was needing reviews
21:54:54 <johnthetubaguy> so, xenapi: no update really anyways
21:54:57 <boris-42> I hope we will have enough time in Havana to provide UC and DB Archiving in Cinder and Glance*
21:55:01 <russellb> johnthetubaguy: sorry!
21:55:13 <russellb> i came up with these stats to help determine if we were keeping up: http://russellbryant.net/openstack-stats/nova-openreviews.txt
21:55:17 <johnthetubaguy> russellb: no worries, its quite quiet, I got a few bits in
21:55:23 <russellb> and have a goal of having average of < 4 days
21:55:30 <russellb> according to the stats, we're "keeping up"
21:55:41 <boris-42> nice
21:55:45 <russellb> but, 296 open
21:55:48 <boris-42> lol=)
21:55:58 <boris-42> I have about 7=)
21:56:04 <russellb> some probably keep getting rebased and stuff, and that resets the counter
21:56:04 <johnthetubaguy> do we track anything from the last non-WIP or draft to merge?
21:56:21 <johnthetubaguy> I get lots of forced rebases, which might make it look like I was waiting less?
21:56:26 <russellb> johnthetubaguy: the numbers are the wait time on the current patch rev
21:56:32 <russellb> update it, restarts the counter
21:56:39 <russellb> right.
21:56:45 <boris-42> by the way Russell
21:56:47 <johnthetubaguy> yeah, just wonder if its worth checking the other one too?
21:56:49 <russellb> so ... not sure how to account for that
21:56:50 <boris-42> test-db-api is almost finish!
21:56:55 <russellb> boris-42: awesome!
21:57:08 <russellb> johnthetubaguy: from the last non-WIP/draft to now?
21:57:10 <boris-42> https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:master+topic:bp/db-api-tests,n,z
21:57:17 <boris-42> ^ 3 patches on review
21:57:20 <russellb> johnthetubaguy: yeah, might be an interesting alternative stat to have to see how it differs
21:57:24 <johnthetubaguy> russellb: yeah, that might be worth tracking, see if it means anything
21:57:33 <boris-42> there should be I think 1 or 2 more pathces
21:57:38 <boris-42> And we will finish this BP
21:57:41 <johnthetubaguy> russellb: thinking thinking about my patch that took over a month
21:57:41 <russellb> but ... happy to hear any ideas people have on improvements in this area
21:57:42 <boris-42> it was really hard=)
21:57:56 <russellb> boris-42: yeah, has been a lot of patches
21:58:12 <johnthetubaguy> russellb: it looks good though
21:58:16 <mriedem> is there any way to query on the LOC in a review?
21:58:28 <mriedem> i.e. if it's small, maybe quick to review but you don't know from the message...
21:58:35 <boris-42> =)
21:58:37 <russellb> btw, how come the patch waiting the longest is mine?
21:58:40 <russellb> harsh guys
21:58:40 <boris-42> small doesn't mean simple
21:58:53 * hartsocks nods
21:58:54 <mriedem> no, but trying to think of 'low-hanging-fruit' reviews
21:58:56 <russellb> mriedem: not that i know of
21:59:11 <mriedem> i.e. i had a docstring fix that sat for a week
21:59:23 <boris-42> I think that all patches should be reviewed
21:59:26 <mriedem> not that i care about it getting merged, but it's an easy one and getting it merged would get it off the list
21:59:28 <boris-42> in the same priority
21:59:28 <jog0> mriedem: the only way I know of is bring it to #openstack-nova and ask and hope
21:59:30 <russellb> mriedem: though i generally don't want to give weight to low hanging fruit
21:59:39 <russellb> mriedem: that results in harder stuff never getting attention
21:59:48 <boris-42> no.. i think that LOC shouldn't be priority
21:59:52 <boris-42> =)
21:59:54 <russellb> boris-42: agreed, ideally
22:00:02 <mriedem> agree, was just thinking about metrics, not pushing to spend time on easy stuff...
22:00:03 <russellb> sort of depends on the reviewer too though
22:00:12 <mrodden> does a +1 or 0 score reset the timer at all?
22:00:19 <boris-42> I think yes
22:00:20 <mrodden> or just last upload/ -1
22:00:22 <russellb> mrodden: no
22:00:25 <boris-42> oO
22:00:28 <russellb> last upload or -1
22:00:38 <mrodden> ok. makes sense
22:00:44 * johnthetubaguy looks at watch
22:00:49 <russellb> (actually, it's when jenkins gives its check report, not upload, because stupidly upload time isn't available)
22:01:07 <russellb> so jenkins is the next best timestamp :(
22:01:12 <johnthetubaguy> doh
22:01:16 <bnemec> russellb: You have a question from sdague on that review that should probably be answered. ;-)
22:01:29 <mrodden> accurate enough... most people wait for jenkins anyways
22:01:30 <russellb> bnemec: ha
22:01:36 <bnemec> Probably explains the long wait.
22:01:42 <russellb> right.
22:01:43 <russellb> oops.
22:02:20 <hartsocks> I was considering carving time to help with reviews. From how metrics work, sounds like I should only −1 things if I want to help? (I'm not core)
22:02:34 <russellb> hartsocks: +1 is helpful too
22:02:48 <boris-42> dansmith ping
22:02:49 <jog0> hartsocks: definitly
22:02:52 <russellb> because as you build up trust with the team, others don't have to spend as much time revieweing after they see your +1
22:02:55 <jog0> (to +1)
22:03:04 <hartsocks> okay
22:03:04 <russellb> that's effectively the patch to nova-core
22:03:08 <russellb> path*
22:03:18 <hartsocks> I'll patch the path.
22:03:22 <russellb> sweet
22:03:44 <mriedem> russellb: maybe another way of phrasing my thoughts on the review metrics, say there is 'low-hanging-fruit' reviews that have been +1'ed by a few people, they just need some eyes from cores, but i don't want to bug people,
22:03:45 <russellb> but i definitely pay attention to +1/-1 from *everyone*
22:03:51 <dansmith> boris-42: is it something for the meeting? else, we should talk in -nova I think
22:03:52 <russellb> and consider them differently depending on who it is
22:03:55 <mriedem> or does that go back to not wanting to spend time on those types of reviews?
22:04:06 <boris-42> dansmith yes about unified models
22:04:10 <boris-42> and PCI Passthrough
22:04:14 <boris-42> russellb ^
22:04:17 <dansmith> boris-42: okay
22:04:20 <boris-42> I would like to finish it=)
22:04:36 <russellb> mriedem: in those cases, people ping in #openstack-nova a lot ... and that's fine
22:04:38 <boris-42> so probably could we merge it as is now? and then I will move to unified models
22:04:55 <mriedem> russellb: ok, i wasn't sure, didn't want to get a reputation for asking cores to look at stuff like that in -nova
22:04:58 <boris-42> because there is a two others group that would like to improve my current soultion
22:05:01 <mriedem> if it was a bad thing
22:05:04 <boris-42> and they are blocked=)
22:05:05 <russellb> yeah, i mean, honestly it does bug me sometimes
22:05:09 <russellb> if it's a ping to me directly
22:05:12 <boris-42> dansmith ^
22:05:13 <russellb> but maybe it's just because i get them constantly
22:05:22 <mriedem> i'll bug dansmith :)
22:05:22 <dansmith> boris-42: well, I didn't -2 it, but I was just saying it would be nice to avoid adding new conductor methods just to remove them again soon
22:05:28 <russellb> but just a general comment in nova not directed at me isn't as annoying :)
22:05:42 <mriedem> ha, ok
22:05:55 <dansmith> russellb: it's cool, I can smack him around behind the firewall :)
22:06:00 <russellb> dansmith: nice
22:06:08 <russellb> alright, well, we're a bit over time
22:06:12 <russellb> lots of good discussion today
22:06:14 <boris-42> russellb dansmith so I should move to unified models?
22:06:16 <russellb> thanks a lot everyone for coming!
22:06:21 <russellb> we can keep chatting in #Openstack-nova
22:06:31 <russellb> boris-42: let's chat over in -nova
22:06:34 <russellb> #endmeeting