21:02:10 <russellb> #startmeeting nova
21:02:11 <openstack> Meeting started Thu Oct  3 21:02:10 2013 UTC and is due to finish in 60 minutes.  The chair is russellb. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:02:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:02:15 <melwitt> k
21:02:16 <russellb> hello, everyone!
21:02:16 <openstack> The meeting name has been set to 'nova'
21:02:25 <russellb> who's around?
21:02:32 <alaski> hi
21:02:35 <comstud> o/
21:02:40 <dripton> hi
21:02:40 <melwitt> hi
21:02:50 <beagles> yo
21:03:03 <russellb> alright, cool, and some other lurkers i'm sure
21:03:08 <russellb> #topic havana status
21:03:14 <dansmith> o/
21:03:17 <russellb> havana-rc1 for nova went out today \o/
21:03:24 <russellb> #link https://launchpad.net/nova/+milestone/havana-rc1
21:03:30 <russellb> 5 blueprints and 167 bug fixes in rc1
21:03:31 <beagles> 254364
21:03:47 <beagles> uh sorry.. new yubikey
21:03:51 <russellb> ah, ok.
21:03:58 <russellb> so, at this point we do not have an rc2 planned
21:04:06 <russellb> but we have 2 weeks until the scheduled havana release
21:04:19 <russellb> so for any bugs that might be worth including in an rc2, please tag them with "havana-rc-potential"
21:04:20 <comstud> a 2 week vacation sounds great.
21:04:30 <russellb> and if something comes up that you feel justifies an RC2, please talk to me
21:04:40 <russellb> i wouldn't be surprised if we hit *something* in 2 weeks
21:05:09 <russellb> any questions about havana status or process?
21:05:55 <russellb> last thing, if you have some time, please take a look at bug triage
21:06:01 <russellb> we need to regularly look there for any potential release blockers
21:06:06 <russellb> next topic ...
21:06:08 <russellb> #topic Icehouse
21:06:24 <russellb> the master branch is now open for Icehouse development, feature freeze is over
21:06:35 * comstud claps.
21:06:37 <russellb> yay
21:06:46 * johnthetubaguy smiles
21:06:55 <russellb> if you -2'd stuff for the feature freeze, it's worth a pass through your review list to remove those
21:07:03 <russellb> looks like most of mine expired already, so hoping people will ping me ...
21:07:08 <russellb> i posted to the ML as a reminder
21:07:50 <russellb> If you have blueprints, feel free to start targeting them to icehouse milestones you intend to deliver them in, and blueprint review will kick off soon (probably mostly after the summit though)
21:07:59 <russellb> speaking of the summit!
21:08:02 <russellb> summit.openstack.org
21:08:14 <russellb> please propose sessions by the havana release, oct 17
21:08:20 <russellb> #note please propose design summit sessions by oct 17
21:08:30 <russellb> 23 proposals for nova so far, 32 time slots
21:08:34 <russellb> for reference, 31 time slots in portland
21:08:42 <russellb> i suspect a bunch more proposals will come in
21:08:53 * johnthetubaguy has a few sessions to submit tomorrow
21:09:01 <russellb> johnthetubaguy: cool :)
21:09:08 <russellb> i'm sure there's a lot left to come
21:09:19 <russellb> which brings me to ... i'd like help putting together the schedule
21:09:46 <johnthetubaguy> I can probably help if thats useful?
21:09:46 <russellb> i did it mostly on my own last time, which probably wasn't a great idea
21:09:50 <russellb> definitely
21:09:58 <russellb> i'd like to gather more input for the hard decisions that have to be made
21:10:02 <russellb> what sessions are in vs out
21:10:30 <russellb> we have tools at our disposal ... like merging sessions together, or just deciding that something is non-controversial or easy enough that just a mailing list thread is sufficient
21:10:49 <russellb> so, i guess i'd like to know who all would be interested
21:10:53 <russellb> and then, the best way to work together
21:11:05 <russellb> like ... just comment on the proposals?  (it's public though)
21:11:18 <russellb> used a google spreadsheet to rate them?  have some meetings?
21:11:23 <russellb> or any other ideas?
21:11:49 <johnthetubaguy> I wondered about a doodle poll, but its not expressive enough
21:11:57 <russellb> (this is a very good thing to jump in and help with if you have interest in leadership/PTL positions in nova or other projects in the future)
21:12:20 <russellb> johnthetubaguy: hm, i haven't used doodle for something like this
21:12:35 <russellb> i suppose it depends on how many people want to work on it
21:12:42 <russellb> if it's just a few, we could hop on the phone
21:12:46 <johnthetubaguy> russellb: yeah, probably a bad idea, just thinking out loud, yeah depends how many
21:12:58 <russellb> if a lot of people want to rate proposals, then we should probably just have some sort of simple voting set up
21:13:08 <russellb> and see how that shakes out
21:13:20 <mrodden1> google form would be how i would probably attack that issue...
21:13:23 <johnthetubaguy> yeah: +1 to that, depends on the number of people
21:13:45 <russellb> ok, so I guess I'll post to the mailing list to get a wider audience to the question and figure out how many people want to provide input
21:14:19 <russellb> i suspect if i do that we'll get a bunch of people saying they'd like to vote ...
21:14:56 <johnthetubaguy> yeah, thats true, but then someone group has to read through the vote, and combine duplicate sessions to start with I guess
21:15:17 <cyeoh> if voting might be worth allowing everyone -2/-1/0/+1/+2 not to actually block or approve but get a better feeling of how strongly they feel about a session
21:15:27 <johnthetubaguy> I wondered about putting it up in gerrit, lol
21:15:32 <russellb> ha
21:15:46 <russellb> how would we do that ... a new "project" and each session is a gerrit change?
21:15:52 <russellb> that's kinda funny.
21:16:02 <russellb> and i kinda like it
21:16:12 <johnthetubaguy> it could actually work
21:16:20 <russellb> indeed
21:16:31 <clarkb> you don't even need a new project. just a magical nova branch
21:16:37 <russellb> clarkb: ooh
21:16:41 <johnthetubaguy> nice
21:16:53 <johnthetubaguy> summit/icehouse
21:17:00 <russellb> clarkb: how do you create the branch?  just push it?
21:17:02 <clarkb> (though that might be interesting to sort out gate jobs for)
21:17:05 <russellb> heh
21:17:07 <russellb> noop
21:17:10 <cyeoh> There is also something like: http://zookeepr.org/ - which we've used for linux.conf.au paper review but might be overkill for this...
21:17:26 <clarkb> russellb: no, you need to create it in UI. I should think the branch idea through a little more
21:17:33 <russellb> clarkb: ok
21:17:34 <clarkb> just to make sure it doesn't make zuul stuff more painful
21:18:00 <russellb> clarkb: ok, should I start a thread on the infra list?  or just let you ponder it for a while?
21:18:10 <clarkb> russellb: a thread would be great
21:18:14 <russellb> ok
21:18:38 <russellb> #action russellb to start a thread on the infra list to explore possibility of using gerrit to gather summit proposal feedback
21:18:48 <russellb> you know ... that could result in sessions becoming a popularity contest
21:18:55 <russellb> email your company and ask them all to go +1 your thing
21:18:56 * russellb sighs
21:19:21 <comstud> only +2s from cores count
21:19:27 <comstud> that's wrong too
21:19:29 <comstud> heh
21:19:37 <russellb> yeah, crossed my mind, but there's a whole bunch of +1s i'd want to count
21:19:42 <comstud> yep
21:19:44 <russellb> if only we could limit it to nova ATCs
21:19:53 <comstud> nod
21:19:53 <johnthetubaguy> maybe attendees only, but thats harder to do I guess
21:20:06 <comstud> maybe gerrit needs a +1, +2, and +3
21:20:19 <comstud> hehe
21:20:35 <russellb> well, we have about 2 weeks to sort out the method used for this
21:20:36 <dansmith> have we had anyone throw a fit in the past because their session was maliciously ignored in the schedule?
21:20:42 <tjones> Can u toss votes from people who r not ATC?
21:20:45 <russellb> dansmith: ummm, sort of
21:20:54 <dansmith> russellb: okay then :)
21:21:08 <russellb> dansmith: i got lots of grumbling about sessions getting merged, mostly
21:21:17 <dansmith> sigh
21:21:34 <russellb> so this time i think i'd actually lean more towards saying no than merges (except for obvious duplicates)
21:21:54 <russellb> find more cases where a live discussion doesn't seem really useful (the ones where it's an obvious good idea)
21:22:33 <russellb> and yeah, i think some people were offended when i rejected theirs
21:22:40 <cyeoh> if you decide to have a vote, probably a good idea to say up front if you'll follow the results of the vote strictly or just use it as guideline for what you decide to include
21:22:41 <russellb> it's mighty political :-)
21:22:49 <russellb> cyeoh: +1
21:23:04 <russellb> so if you want to get more involved in the political side, come right up!
21:23:24 <russellb> well it's not political to me, but people take it that way
21:23:42 <russellb> but anyway, it's really quite a bit of work, so i'd like to get help and include more people on the decisions :-)
21:23:59 <russellb> and generally thing the more open the better
21:24:05 <russellb> think*
21:24:28 <johnthetubaguy> all sounds good
21:24:31 <russellb> cool.
21:24:37 <russellb> I think that's really all I had on Icehouse right now
21:24:40 <russellb> just getting things moving there
21:25:01 <russellb> #topic sub-team reports
21:25:09 <russellb> haven't done this in a few weeks, sorry
21:25:15 <russellb> anyone want to give a report on a specific area?
21:25:31 <russellb> johnthetubaguy: tjones1
21:25:44 <johnthetubaguy> no xenapi update really, planning the roadmap session next week
21:26:23 <johnthetubaguy> smokestack is proving useful, looking at tempest based stuff too
21:26:40 <russellb> so you think we should include plugin versioning if we do an rc2?
21:27:07 <johnthetubaguy> its probably worth it, just to help support people with that first time setup
21:27:19 <johnthetubaguy> its low risk, given smokestack worked
21:27:23 <russellb> johnthetubaguy: ok, i'm sort of neutral on it, but with your support i'm good with it
21:27:38 <russellb> johnthetubaguy: help me remember if we make rc2 though :)
21:27:51 <johnthetubaguy> yeah, its a close call, I will try to :)
21:28:05 <russellb> k, i should remember when i go over the havana-rc-potential list, so shouldn't have to worry ...
21:28:17 <johnthetubaguy> cool
21:28:24 <russellb> there was talk of smokestack eventually gating
21:28:28 <russellb> is that still moving?
21:28:39 <johnthetubaguy> I think so, not totally sure what the blocker is now
21:28:51 <dripton> Is smokestack fast enough to get to every change in time yet?
21:29:00 <johnthetubaguy> I think thats the issue, thinking about it
21:29:10 <russellb> there seemed to be concerns at first about it not being official infrastructure
21:29:16 <johnthetubaguy> it used to be, its just that the gate got faster recently
21:29:18 <russellb> but that was at the beginning of the conversation, and i haven't followed
21:29:41 <johnthetubaguy> yeah, I kinda lost track of that, leaving BobBall to push it though, I will follow up with him and Dad
21:29:43 <johnthetubaguy> lol
21:29:45 <johnthetubaguy> Dan
21:29:47 <russellb> kinda seems like the same sorts of tests should just be run under the same job scheduler (jenkins, zuul) ...
21:29:51 <russellb> ok
21:30:01 <russellb> well definitely glad it's at least running non-gating, so we get heads up
21:30:08 <russellb> i'm happy with that for all the drivers
21:30:10 <johnthetubaguy> yeah, I kinda like it doing tempest and devstack, but there are issues down that route
21:30:35 <russellb> cool, well thanks for the updates
21:30:39 <russellb> tjones: tjones1 around?
21:30:41 <tjones> We are very  close to posting +1 for changes that pass our CI tests. We just have some small issues to take care of.
21:30:44 <russellb> do you know how the vmware CI is coming?
21:30:44 <russellb> ha
21:30:51 <russellb> good to hear
21:30:53 <russellb> how about -1s?
21:31:12 <tjones> We will do that too once we are confident in the results
21:31:17 <russellb> cool
21:31:23 <tjones> Making sure our infra is solid
21:31:24 <russellb> one thing to consider short term is something that smokestack did
21:31:30 <russellb> which is for -1s, they had to be manually reviewed
21:31:35 <russellb> and if approved, a -1 got posted
21:31:42 <russellb> it may still work that way, not positive
21:31:45 <dansmith> tjones: and logs of runs too, I hope?
21:31:52 <russellb> dansmith: +1
21:31:56 <tjones> Yes exactly. Don't want false negatives. Yes - with logs
21:32:00 <dansmith> cool
21:32:27 <russellb> alexpilotti: you aren't around by chance are you?  curious about CI on hyper-v.  ping me later to chat if not around now
21:32:43 <russellb> i know there's active work on CI for baremetal with the other triple-o elements
21:32:52 <alexpilotti> russellb: hi
21:32:56 <russellb> alexpilotti: hi there :)
21:33:09 <russellb> alexpilotti: was just talking through hypervisors and CI status, was wondering about hyper-v
21:33:15 <russellb> since that's something we want to require before the icehouse release
21:33:35 <alexpilotti> russellb: primeministerp is coordinating this effort
21:33:51 <russellb> ah ok
21:33:55 <alexpilotti> russellb: I can tell you anyway that we will have it ready
21:34:02 <russellb> ok great :-)
21:34:12 <alexpilotti> russellb: what's the deadline
21:34:23 <alexpilotti> russellb: I3 or the actual Icehouse release :-)
21:34:27 <alexpilotti> ?
21:34:29 <russellb> good question
21:34:38 <russellb> i suppose the idea was that if it's not done we'd be pulling drivers out
21:34:49 <russellb> so really needs to be done by feature freeze, or shortly after
21:34:58 <russellb> so, icehouse-3 ideally
21:34:58 <alexpilotti> russellb: oki
21:35:03 <russellb> with a little bit of slack
21:35:31 <russellb> docker is a new driver in havana
21:35:44 <alexpilotti> russellb: is there a common design / implementation among the driver's CIs?
21:35:45 <russellb> they added devstack suppot (i asked for it so we'd have an easy path to CI)
21:36:09 <russellb> alexpilotti: no, the idea is just to use gerrit's interface for voting for test results
21:36:32 <alexpilotti> russellb: ok, and for the rest each driver can do whatever is needed?
21:36:40 <russellb> alexpilotti: you basically could either try to get hooked into jenkins/zuul, join in with smokestack, or build your own (like vmware is doing)
21:36:42 <russellb> yes
21:37:00 <alexpilotti> russellb: yep, the zuul part is clear
21:37:05 <russellb> i don't mind, if it's easier to build your own thing, i'm OK with that, as long as the test results are available
21:37:14 <russellb> basically, act like smokestack
21:37:35 <russellb> but really, the *best* thing IMO is see if you can work with the infrastructure team
21:37:36 <alexpilotti> russellb: are there requirements, like doing a triple-o deployment
21:37:37 <dansmith> russellb: and the goal is 'running tempest' right?
21:37:46 <russellb> dansmith: good point, yes
21:37:56 <russellb> i guess i haven't been especially clear on details here :)
21:37:58 <dansmith> because that's not what smokestack does, just to be clear
21:38:12 <russellb> dansmith: good point ...
21:38:12 <dansmith> and while it's a good step, I definitely think running tempest is what we should shoot for
21:38:12 <alexpilotti> dansmith: yep, we're already working on tempest
21:38:18 <dansmith> alexpilotti: cool
21:39:20 <russellb> so on docker, it *should* be easy to add to the existing infra
21:39:30 <russellb> blocker i hit was that the images we use right now don't have a new enough kernel
21:39:54 <russellb> so either i need to convince infra to upgrade the kernel in the image everything uses, or get a new image created just for the docker runs
21:39:54 <alexpilotti> russellb: during H3 I saw a real massive peak of jobs
21:40:00 <russellb> alexpilotti: for sure :)
21:40:18 <russellb> and i would prepare for even more in icehouse
21:40:33 <alexpilotti> russellb: do you know how many bare metal servers are being used for smokestack?
21:40:35 <russellb> more contributions, and an improved infrastructure will result in a bunch more, just like havana
21:40:45 <russellb> alexpilotti: talk to dan prince for details on smokestack
21:40:55 <alexpilotti> russellb: I will, tx
21:40:57 <russellb> np
21:41:23 <russellb> only driver we haven't discussed is powervm
21:41:40 <russellb> i've heard rumors of CI for that being worked on, don't know details or status though
21:41:47 <dansmith> mriedem: mrodden ?
21:41:52 <mrodden> :)
21:41:52 <mriedem> muwahaha
21:41:57 <mriedem> was just about to head out
21:42:05 <russellb> too bad, now you have the spotlight
21:42:07 <mriedem> it's a WIP, working with dansmith's old team on details
21:42:21 <mriedem> we already run something like smokestack and tempest internally
21:42:21 <dansmith> mriedem: really?
21:42:44 <mriedem> dansmith: yup, it's a bit *confused* at the moment
21:42:57 <dansmith> humkay :)
21:43:02 <mrodden> the biggest worry is being able to keep up with community patchsets coming it at the moment
21:43:18 <russellb> yeah, it's quite a flow
21:43:19 <mrodden> coming in*
21:43:25 <russellb> and only going to increase
21:43:48 <mrodden> thats true
21:44:13 <russellb> well, let me know if you  need anything from me
21:44:19 <russellb> #topic open discussion
21:44:27 <russellb> any other topics you fine folks would like to discuss?
21:44:34 <beagles> ahem
21:44:40 <russellb> zuul is really bored
21:44:52 <dansmith> I'm about to fix that
21:44:52 <russellb> so we should go review or write more code, heh
21:44:53 <beagles> I do.. actually
21:44:59 <russellb> beagles: cool! what's up
21:46:07 <beagles> okay, so I've been out in quantum/neutron land for the past. The idea was to provide some continuity or something but that quickly got subverted by...
21:46:09 <beagles> other thiings
21:46:53 <jog0> russellb: what happens when this deadline passes http://www.mail-archive.com/openstack-dev@lists.openstack.org/msg00835.html
21:47:10 <russellb> jog0: pull the drivers out of the tree IMO
21:47:21 <russellb> jog0: that's why i'm trying to over-communicate about this to the driver maintainers
21:47:25 <beagles> anyways, the goal of bringing it up to snuff and deprecating nova-networking afaik remains
21:47:34 <jog0> russellb: ++ it may be worth making that public since that is only 6.5 months away
21:47:40 <russellb> jog0: OK
21:47:47 <jog0> err more public
21:47:49 <russellb> #action russellb to send an update on the driver CI requirement to the ML
21:47:51 <beagles> there is no actual roadmap for that... so I've started trying to make sense of that
21:48:12 <beagles> I started a doc https://docs.google.com/document/d/1E9CiG8fmcn0FMI15zpE0dRQ1CcFhXV8TxL7mU7vgWv8/edit
21:48:32 <russellb> wow
21:48:37 <beagles> the notion is to start a productive conversation around what it is going to take to meet that goal
21:49:00 <russellb> sidenote: can we move it to the wiki?  :-)
21:49:24 <beagles> there is still a lot of librarian work to do on cataloging particular points... but that is perhaps besides the point
21:49:26 <beagles> (yes)
21:49:37 <dripton> That is a ton of detail to absorb.  Can we all read it and discuss again next week?
21:49:38 <jog0> beagles: I didn't see tempst anywhere in that doc, a little surprised
21:49:46 <beagles> dripton, yes
21:49:47 <jog0> tempest*
21:49:49 <russellb> beagles: how would you like feedback on this?
21:49:55 <beagles> jog0, it is implied
21:50:03 <beagles> at the bottom
21:50:18 <russellb> #note Check out beagles' doc on nova-network and neutron --> https://docs.google.com/document/d/1E9CiG8fmcn0FMI15zpE0dRQ1CcFhXV8TxL7mU7vgWv8/edit
21:50:24 * jog0 doesn't do well with implicit
21:50:28 <russellb> yeah, i need some time to read through it
21:50:32 <beagles> russellb, not sure really. Does the wiki provide mechanisms for comments
21:50:40 <russellb> beagles: no
21:50:47 <russellb> does google?  i haven't used that if so
21:50:51 <beagles> jog0: :) truth be told I didn't get to the point of pointing all tha tis broken
21:50:59 <beagles> russellb, I think so
21:51:02 <russellb> heh
21:51:16 <tjones1> yes google does
21:51:45 <russellb> just trying to keep everything in one place is all
21:51:49 <beagles> fwiw: when I started this doc, it was meant to be a four pager, but each time I bring it up I find out something else that needs to be at least summarized
21:52:03 <russellb> so doesn't have to move now, can move later when you have collected feedback if that works best
21:52:10 <beagles> russellb, k
21:52:20 <russellb> Ok, so, we should all review this and discuss next week?
21:52:42 <beagles> yup.. feel free to email me or comment or ping me on irc or whatever
21:52:46 <russellb> cool
21:53:08 <jog0> beagles: is there a summery anywhere?
21:53:17 <russellb> but this is by far the most detail on the topic i've seen, so nice work
21:53:23 <jog0> ++
21:53:29 <beagles> jog0: not at the moment... it will need a blueprint
21:53:32 <russellb> jog0: the end has a section on what to do from here
21:53:40 <jog0> russellb: ahh nice
21:54:02 <russellb> beagles: gathering feedback from the neutron side as well?
21:54:54 <russellb> guess that's a silly question
21:54:58 <beagles> russellb, yes... I introduced this earlier this week.. no feedback yet. I'm also planting seeds that any discussions of Icehouse endeavors for neutron have to take this into account very seriously
21:55:24 <beagles> planting seeds? no, I've just said it outright actually :)
21:55:31 <beagles> and will continue to do so
21:55:38 <russellb> huge +1
21:55:43 <russellb> i feel like we as a project sort of dropped the ball on this in havana
21:56:35 * beagles shrugs
21:56:42 <russellb> beagles: well thanks a lot for bringing this up, and i'll be sure to read soon
21:56:48 <johnthetubaguy> +1 we need to make progress on this, this looks like a good step forward :)
21:57:17 <beagles> no hurry for the weekend, rewrites in progress :)
21:57:45 <beagles> s/for/before/
21:57:56 <russellb> alrighty
21:58:01 <russellb> well, good meeting everyone, thanks a lot!
21:58:10 <russellb> bye for now
21:58:12 <russellb> #endmeeting