21:00:49 <mikal> #startmeeting nova
21:00:50 <openstack> Meeting started Thu Jun 19 21:00:49 2014 UTC and is due to finish in 60 minutes.  The chair is mikal. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:52 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:55 <openstack> The meeting name has been set to 'nova'
21:00:58 <mspreitz> o/
21:01:00 <mikal> So, who is around?
21:01:02 <alaski> o/
21:01:03 <mriedem> hi
21:01:04 <mriedem> again
21:01:05 <tjones> hi
21:01:06 <alex_xu> hi
21:01:07 <angdraug> o/
21:01:12 <melwitt> o/
21:01:12 <yjiang5> o/
21:01:14 <dansmith> o/
21:01:23 <xarses> o/
21:01:28 <leifz> o/
21:01:36 <jogo> o/
21:01:47 <mikal> Ok, so let's get started then
21:01:52 <russellb> o/
21:01:54 <mikal> #topic Juno-2
21:02:01 <mikal> #info Juno-2 is 24 July
21:02:13 <sdague> o/
21:02:16 <mikal> Which is just before our midcycle meetup
21:02:30 <mikal> #info Proposed spec review day on 26 June
21:02:43 <mikal> John and I like the idea of trying to do a spec review day on 26 June
21:02:56 <mikal> People hang out in openstack-nova, and we try to iterate on specs faster than we have so far
21:03:09 * russellb out that day on PTO
21:03:18 <mikal> We think this is important because we need to get specs approved before very early July if they're going to make it into Juno
21:03:23 <mikal> PTO?
21:03:28 <russellb> paid time off
21:03:29 <mikal> Is that American for vacation?
21:03:31 <russellb> yes
21:03:38 <sdague> only some americans :)
21:03:41 <mikal> Fair enough
21:03:52 <mikal> So... Is there another day that week that works better for people?
21:04:14 <mikal> John and I are thinking of a proposal freeze for specs of July 2, so we need to do this before that
21:04:37 <mspreitz> 25 or 27 are better than 26 of June for me
21:04:39 <mikal> With the end goal being to try and prioritize spec implementations for review by July 10ish
21:04:46 <mikal> (These dates to be announced in email soon)
21:05:05 * mikal looks up what days of the week those are
21:05:14 <mikal> So, Wednesday or Friday work better for people?
21:05:26 <mikal> I think Friday is bad because its Saturday for Asian devs
21:05:27 <mriedem> friday is a bad idea right
21:05:28 <tjones> wednesday
21:05:45 <mikal> Yeah, I think Wednesday might be the winner there
21:05:49 <mriedem> hump day for reviews
21:05:54 <mikal> #info Spec review day on 25 June, in #openstack-nova
21:06:48 <mikal> So yeah, just wanting to reinforce the general plan: we do a review day to clean up; have a proposal freeze soon after; and then triage things so we have a prioritized list for review as things land
21:07:01 <mikal> Any concerns with that plan?
21:07:20 <sdague> is there a prioritized list of specs that should get hit
21:07:30 <sdague> there is such a large wall of them at the moment
21:07:35 <mikal> sdague: not at this point (I assume you mean for the review day)
21:07:42 <sdague> yeh
21:07:42 <dansmith> right, we do it that day, right?
21:07:47 <dansmith> that's part of the review we need to do I think
21:07:49 <angdraug> 24 June for spec triage day?
21:07:54 <sdague> sounds good
21:08:01 <mikal> Well, the day is also quite long
21:08:07 <mikal> i.e. its the night before you guys for me
21:08:18 <mikal> So early people could have a go at prioritizing as part of reviews
21:08:22 <mikal> We can track that in an etherpad
21:08:49 <mikal> But I can pre-create that etherpad so people can try doing that now if they want
21:08:58 <russellb> the NFV sub-team would love for us to prioritize the specs tracked here:  https://wiki.openstack.org/w/index.php?title=Teams/NFV
21:08:58 <russellb> :)
21:09:06 <mikal> #action mikal to create etherpad for spec review day where people can try and pre-prioritize
21:09:16 <mikal> russellb: heh, I'm going to make you talk about nfv in subteams
21:09:24 <russellb> if you want to review stuff that at least some group this is important
21:09:30 <russellb> thinks*
21:09:31 <mikal> I do think prioritization has to include reasons
21:09:43 <mikal> Not "cause my thing!"
21:09:59 <mikal> Ok, it sounds like we can move on from here
21:10:21 <mikal> #topic Bugs
21:10:26 <mikal> So, we still have a lot of bugs
21:10:35 <mikal> jogo has some interesting ideas about an initial automated cleanup
21:10:39 <mikal> jogo: want to talk about that?
21:10:48 <jogo> mikal: yeah
21:10:53 <jogo> so this isn't automated cleanup per se
21:11:02 <jogo> so we have been getting better at doing the initial bug triage
21:11:11 <jogo> but we are still really bad at following up with existing bugs
21:11:18 <jogo> https://etherpad.openstack.org/p/eEYO2Fdsuv
21:11:41 <jogo> so based on a previous meeting I took a look at what infra uses (thanks pleia2) and added a few things to it
21:11:49 <jogo> http://paste.openstack.org/show/84532
21:12:04 <jogo> ^ is a link to the first 300 or so bugs (sorted by priority)
21:12:15 <jogo> generated with https://github.com/jogo/openstack-infra-scripts
21:12:28 <mikal> So the general idea is to unassign idle bugs, make status match reality, etc. Yes?
21:12:39 <jogo> with that its fairly easy to follow up on bug statuses and fix them
21:12:41 <jogo> mikal: correct
21:12:42 <mikal> i.e. in progress with abandoned patch != in progress
21:12:49 <jogo> mikal: bingo
21:12:57 <mriedem> yeah the first on that list all patches are merged but it's marked as 'confirmed'?
21:12:58 <mikal> Cool
21:13:01 <jogo> mikal: and confirmed ith merged patch may be fixed as well
21:13:26 <jogo> mriedem: I just fixed that one a few minutes ago in fact
21:13:32 <mikal> So, if some people want to volunteer to have a grind through some of those that would be appreciated
21:13:39 <jogo> mikal: yeah
21:13:48 <jogo> I was hoping the existing bug team can use this
21:13:53 <jogo> tjones: ^
21:13:55 <mikal> Noting that stackalytics now tracks bug closes as contributions, which I am hoping will help too
21:14:00 <tjones> yeah thanks jogo
21:14:26 <mikal> I think we should also be reminding people that when they close a bug they should do a quick search for duplicates, or very similar bugs
21:14:29 <jogo> so paste cut off my list but I have los for about 1k bugs
21:14:38 <mikal> I've started just picking keywords and searching as I work on a bug
21:14:40 <jogo> I have a hunch we can close a few hundred of those easily
21:14:45 <tjones> ooooooooooooooo
21:14:46 <mikal> And its surprising how often we have very similar bugs
21:15:37 <mikal> I think this is also a pretty obvious topic for the mid cycle meetup... May be we should carve out some time to try and grid through fixing states etc
21:15:44 <mikal> We'll wait and see how bad things are at that point I suppose
21:15:59 <mikal> #info jogo has a script which helps find bugs in inconsistent states
21:16:02 <jogo> ++ to doing that at mid cycle, but we don't have to wait until then to start working
21:16:12 <mikal> #link https://etherpad.openstack.org/p/eEYO2Fdsuv
21:16:13 <jogo> tjones: lets sync after the meeting
21:16:15 <tjones> jogo: lets sync
21:16:17 <tjones> lol
21:16:24 <tjones> i was just saying that
21:16:27 <mikal> Yes, I very much would like to see some of this done before the mid cycle
21:16:34 <mikal> Mid cycle is a very expensive way of working on bug state
21:16:37 <mikal> But we'll do it if we have to
21:16:53 <mikal> If people feel that bribes would help, then I'd be interested in suggestions
21:16:59 <mikal> I could buy mars bars for people or something
21:17:06 * mikal flails at incentives
21:17:22 <mikal> tjones: any interesting bugs for us this week?
21:18:02 <angdraug> re bribes: find a way prioritize review inbox by committer's karma in LP?
21:18:11 <tjones> yes  2 citical bugs that are not assigned
21:18:16 <tjones> i think 1 just got fixed
21:18:20 <tjones> https://bugs.launchpad.net/nova/+bug/1275500
21:18:25 <uvirtbot> Launchpad bug 1275500 in nova "Cannot reboot instance: Network filter not found: Could not find filter" [Critical,Confirmed]
21:18:48 <tjones> https://bugs.launchpad.net/nova/+bug/1257626
21:18:50 <uvirtbot> Launchpad bug 1257626 in nova "Timeout while waiting on RPC response - topic: "network", RPC method: "allocate_for_instance" info: "<unknown>"" [Critical,Invalid]
21:18:52 <xarses> +1 on bug karma == more reviews
21:19:01 <tjones> both affecting gate
21:19:20 <jogo> tjones:  1257626 re-open didn't appear to be valid
21:19:50 <mikal> I also think that https://bugs.launchpad.net/nova/+bug/1313477 looks interesting
21:19:51 <uvirtbot> Launchpad bug 1313477 in nova "libvirt driver hang with genisoimage when boot new instance" [High,Confirmed]
21:19:56 <mikal> (Possible eventlet bug)
21:20:14 <mikal> And https://bugs.launchpad.net/nova/+bug/1316621
21:20:16 <uvirtbot> Launchpad bug 1316621 in nova "ebtables calls can race with libvirt" [Medium,Confirmed]
21:20:22 <mikal> (Race condition with ebtables and libvirt)
21:20:39 <mikal> Those two are less urgent, but look interesting
21:20:49 <sdague> jogo: 1257626 - it's probably the general screen race, I've got a retry loop to see if that helps
21:21:05 <jogo> sdague: ahh that makes sense
21:21:15 <mriedem> yeah was gonna say that sounded like the grenade one that is failing 25% of the time
21:21:17 <tjones> also we've been trying to triage the untriaged bugs in our  meeting.  it's really slow going especially since the subject matter experts may not be around
21:21:41 <sdague> jogo: oh, wait. for large-ops, it shouldn't be using screen.
21:21:46 <mikal> tjones: is it worth reminding people in nova IRC at the start of that meeting that its on?
21:21:50 <mikal> tjones: or are you already doing that?
21:21:52 <tjones> the ares with the mostr untriaged bugs are novaclient, network, testing (surprse), and compute
21:22:10 <tjones> I do that
21:22:16 <mikal> OK cool
21:22:34 <tjones> oh and api
21:22:44 <mikal> So, we should help tjones more, and fix lots of bugs. Kthxbye.
21:22:50 <tjones> lol
21:23:00 <mriedem> those tags are super broad, except novaclient
21:23:08 <mriedem> testing is basically anything that fails a compute test in tempest
21:23:13 <mriedem> of which there are many
21:23:24 <mikal> So, we should probably move on unless there's anything else we can achieve with bugs right now
21:23:25 <mriedem> network could be nova-network or neutronapi
21:23:37 <mriedem> arosen is about the only person that fixes neturonapi bugs
21:23:46 <tjones> yes - ideas for helping make this bettter?
21:24:10 <mriedem> not really, more specific tags for people to ignore :)
21:24:18 <mikal> Heh
21:24:20 <tjones> lol
21:24:29 <mriedem> move on
21:24:42 <mikal> tjones: perhaps emailing out lists of untriaged bugs?
21:24:50 <tjones> sure
21:25:09 <tjones> here is the link by tag https://wiki.openstack.org/wiki/Nova/BugTriage
21:25:11 <russellb> including a short list of untriaged ones
21:25:14 <russellb> link bait gets me
21:25:26 <russellb> like, if i could just click one to triage, and at least have contributed that one
21:25:48 <tjones> that has a link to untraged bugs per area
21:26:20 <tjones> i'll send out something to the ML
21:28:58 <mriedem> next topic?
21:29:36 <mikal> Sorry
21:29:38 <mikal> DSL dropped
21:29:49 <mikal> #topic Gate status
21:29:59 <mikal> So, my understanding is we can now approve things like crazy again
21:30:05 <mriedem> already have been
21:30:08 <mikal> sdague: is that a fair summary of the state of play?
21:30:08 <sdague> mikal: yes sir
21:30:16 <jogo> mikal: ++
21:30:21 <jogo> lets break some records https://github.com/openstack/openstack/graphs/commit-activity
21:30:22 <mikal> Yeah, I guess I'm more after "do you still need help?"
21:30:33 <sdague> you have 2.5 hrs to try to land another 30 patches to make it another > 100 merge day
21:30:35 <mriedem> fyi that people will probably be rechecking for httpretty failures https://bugs.launchpad.net/openstack-ci/+bug/1332266
21:30:36 <uvirtbot> Launchpad bug 1332266 in openstack-ci "httpretty 0.8.1 fails to install, causing job failure" [Undecided,Confirmed]
21:30:38 <mikal> It would be nice to be fixing things so we don't end up wedged again
21:30:58 <sdague> mriedem: only novaclient, right?
21:31:06 <mriedem> sdague: was more than novaclient in logstash
21:31:13 <sdague> well, the clients in general
21:31:28 <sdague> that's where it mostly was being pulled in
21:31:30 <mikal> Ok, but if people see that failure they can just recheck with that bug number, so its not the end of the world
21:31:31 <mriedem> as for gate status, i still have suspicions about ec2 tests and boto connection pools causing issues with nova-network
21:31:49 <mriedem> the one ssh timeout bug in scenario tests
21:31:49 <mikal> We have a little more logging in nova-network now, but I think we need more
21:31:54 <mikal> linux_net specifically could do with more
21:32:21 <mikal> I'll try and take a look at that in the next few days
21:32:26 <mikal> Unless someone beats me to it
21:32:34 <mikal> Nothing else for gate right now, right?
21:32:35 <mriedem> https://bugs.launchpad.net/tempest/+bug/1298472
21:32:37 <uvirtbot> Launchpad bug 1298472 in tempest "SSHTimeout in tempest scenario tests using nova-network" [Critical,Fix committed]
21:32:38 <mriedem> that's the ssh one
21:32:45 <mriedem> *one of them
21:33:06 <mriedem> no other gate stuff
21:33:09 <mikal> Ok, let's move on
21:33:16 <mikal> #topic Subteam reports
21:33:23 <mikal> Containers people... Got anything to say?
21:33:46 <russellb> sounds like there has been really nice nova-docker progress this cycle
21:33:49 <russellb> on features
21:33:55 <mikal> Cool
21:33:58 <mikal> ewindisch: you around?
21:34:02 * russellb not a containers person, just hearing updates
21:34:13 <mikal> It would be interesting to know what their plans are for merging back
21:34:22 <mikal> i.e. which milestone
21:34:38 <mikal> But I think we've missed out on containers people today
21:34:56 <mikal> Ironic people... How goes your nova driver?
21:35:01 <mikal> devananda: ^--
21:35:31 <devananda> hi!
21:35:37 <mikal> How goes your driver?
21:35:46 <mikal> I know you'd like to trick us into more spec reviews?
21:35:50 <devananda> stability is good. testing is good. thanks to the folks who have reviewed the spec!
21:36:06 <devananda> mikal: i haven't proposed the driver code yet to nova, since the spec hasn't been approved
21:36:18 <mikal> The gate job ended up not being removed, right?
21:36:21 <devananda> we're continuing to improve it in our tree until then
21:36:29 <devananda> the gate job was never removed -- just made non-voting briefly
21:36:32 <devananda> and we'vce proposed to revert that
21:36:42 <devananda> it was coupled to oslo-test which put ironic in the integrated gate
21:36:44 <mikal> So its more reliable now?
21:36:56 <devananda> it was reliable, outside of network issues
21:37:00 <devananda> and yes, thsoe have been addressed too now
21:37:02 <mikal> Ahhh, ok
21:37:14 <devananda> (the failures were in downlading UCA PPA's)
21:37:14 <mikal> How is progress going on getting it reporting like a third party CI in nova reviews?
21:37:25 <devananda> that has stalled in infra
21:37:26 <devananda> let me find the patch
21:37:32 <devananda> (sorry, jugglign two meetings at once )
21:37:38 <mikal> Oh, sorry
21:37:58 <devananda> https://review.openstack.org/97411
21:38:44 <mikal> I can ask jhesketh to chase that with clarkb today
21:38:49 <sdague> there apparently seems to have been some disconnect in what everyone thought was agreed there. I think it would be good to get mikal, devananda, jeblair into an irc room again to sort out the final bits of confusion
21:39:04 <mikal> Ok, I'd be happy to do that
21:39:17 <devananda> ++
21:39:29 <mikal> Can someone propose a time and place in email?
21:39:41 <mikal> Anything else for ironic before we roll on?
21:39:59 <devananda> mikal: aside from please review the specs -- no :)
21:40:05 <mikal> So noted
21:40:12 <devananda> thanks!
21:40:15 <mikal> Note our spec review day next week, that's your time to iterate quickly
21:40:29 <mikal> NFV team... russellb, how goes it?
21:40:32 <devananda> mikal: sorry. which day?
21:40:37 <russellb> o/
21:40:39 <mikal> devananda: Wednesday next week
21:40:39 <russellb> #link https://wiki.openstack.org/wiki/Teams/NFV
21:40:46 <russellb> so this isn't nova specific, but highly related to nova
21:40:53 <jeblair> i don't think i have an objection to that patch
21:40:58 <devananda> ugh. i'll be on a plane // onsite ...
21:40:59 <russellb> there's a couple things here, 1) what is NFV? and 2) what does that mean for us (OpenStack) ?
21:41:19 <mikal> russellb: is there a list of features needed from nova forming somewhere?
21:41:20 <russellb> NFV in short, is a standardization effort in the telco industry on using a cloud platform and VMs to replace hardware network applicances
21:41:23 <russellb> to be more agile
21:41:28 <russellb> mikal: yep, will get to that in a sec
21:41:35 <mikal> Appliances like routers?
21:41:37 <russellb> yes
21:41:42 <jeblair> sdague, devananda, mikal: ^
21:41:43 <russellb> #link https://wiki.openstack.org/wiki/Teams/NFV#What_is_NFV.3F
21:41:50 <russellb> if nothing else, read our stuff on "What is NFV"
21:41:52 <russellb> just 2 paragraphs
21:42:03 <mikal> #info People should read the NFV wiki page
21:42:19 <russellb> so, the NFV people want to standardize on OPenStack as the platform
21:42:20 <russellb> which is cool.
21:42:23 <russellb> and a HUGE opportunity
21:42:29 <mikal> Are there any proposed specs ready for review now, or are people still frantically typing?
21:42:30 <russellb> because the industry we're talking about is _really_ bug
21:42:36 <mikal> Big I hope
21:42:40 <russellb> big yes
21:42:51 <russellb> so we want to help make sure OpenStack supports their use cases
21:42:56 <russellb> and THAT is where the openstack NFV team comes in
21:43:00 <mikal> Do they have a realistic timeline?
21:43:12 <russellb> the wiki page includes what NFV is, use cases, and a list of development efforts in support of NFV use cases
21:43:14 <mikal> I assume its going to take us a while to get all this done?
21:43:18 <russellb> dev efforts: https://wiki.openstack.org/wiki/Teams/NFV#Development_Efforts
21:43:20 <russellb> #link https://wiki.openstack.org/wiki/Teams/NFV#Development_Efforts
21:43:22 <russellb> yes, it'll be a while
21:43:28 <russellb> but there's several doable for juno, for sure
21:43:32 <russellb> lots of specs on that list ready for review
21:43:33 <mikal> Excellent
21:43:36 <russellb> some with implementations in progress
21:43:47 <mikal> I think the "what is NFV" thing is a pretty helpful contribution by itself to be honest
21:43:55 <russellb> so basically, anything on that page is being requested by REALLY big potential openstack users
21:44:06 <mikal> But it sounds like its relatively on track
21:44:10 <russellb> yes the #1 goal of that page is to be able to point openstack devs to it
21:44:20 <russellb> to get quick context on all this
21:44:24 <russellb> that's one of the key deliverables of the team
21:44:30 <russellb> context around NFV, and tracking the work
21:44:35 <mikal> Awesome. Anything else we should know about NFV before we move on?
21:44:43 <russellb> nope!
21:44:48 <mikal> Yay!
21:45:02 <mikal> Scheduler peoples... How goes your scheduler refactor?
21:45:35 <n0ano> still ongoing, not much to report yet
21:45:41 <n0ano> but we think we know what we are doing
21:45:43 <mikal> Ok
21:45:51 <mikal> The BP said it was ready for review IIRC
21:45:54 <mikal> Is that correct?
21:45:57 <mikal> Or is there more coding to be done?
21:46:12 <n0ano> There is one that should be ready now, yes
21:46:24 <mikal> Ok, cool
21:46:25 <n0ano> there will be more work but there'll be another BP
21:46:37 <mikal> Sounds like its in progress and we should get to reviews soonish
21:46:45 <mikal> Anything else from scheduler peeps?
21:46:55 <n0ano> just a sec and I can give the links to review
21:47:21 <n0ano> they are:  https://review.openstack.org/#/c/82778 and https://review.openstack.org/#/c/97232/
21:47:26 <mikal> Cool
21:47:35 <mikal> So... What subteams did I forget?
21:47:39 <tjones> vmwareapi
21:47:50 <mikal> And do we like calling them out like this, or should we just pile on like we used to?
21:47:58 <tjones> i like calling it out
21:48:09 <mikal> I like it too, but I'm often wrong
21:48:14 <tjones> :-D
21:48:25 <mikal> Ok, vmwareapi. Sorry for forgetting such a lovely subteam. Report!
21:48:37 <tjones> no prob.  and i'll be quick as usual
21:48:46 <tjones> phase 2 refactor is ready for review https://etherpad.openstack.org/p/vmware-subteam-juno
21:49:01 <mikal> And phase 3 is still a work in progress, right?
21:49:23 <tjones> the top lists the patches in order.  reviews much appreciated!   phase 3 is being worked in parallel - it will be posted very soon
21:49:37 <mikal> Cool
21:49:39 <mikal> Anything else?
21:49:43 <tjones> nope that's it
21:49:47 <mikal> Cool
21:49:54 <mikal> #topic Open Discussion
21:50:00 <angdraug> o/
21:50:00 <mikal> We have 10 minutes for open discussion
21:50:03 <mikal> Spend it wisely
21:50:10 <mspreitz> nova networking
21:50:14 <mikal> Go
21:50:32 <mspreitz> https://bugs.launchpad.net/nova/+bug/1327406
21:50:34 <uvirtbot> Launchpad bug 1327406 in nova "The One And Only network is variously visible" [Undecided,In progress]
21:50:47 <russellb> i'll make a few more notes about nova + NFV ... the requests are largely around getting most performance possible out of VMs, so all generally useful stuff as well, but critical for some telco uses
21:50:52 <mspreitz> It looks like nova flat networking does not allow a non-administrative user to enumerate networks
21:51:13 <mspreitz> ... which looks pretty wrong to me
21:51:27 <mspreitz> and, of course, the doc sucks
21:51:30 <russellb> that's the kind of stuff most doable for juno, so SR-IOV networking, NUMA, large pages, dedicated CPUs ...
21:52:07 <mspreitz> I am wondering why gate doesn't object to current breakage.  And what people think the right fix is.
21:52:14 <mspreitz> And, what were they thinking anyway?
21:52:22 <mikal> mspreitz: vishy has been doing a bunch of work on nova-network recently, it would be a good idea to draw this bug to his attention
21:52:46 <mikal> He might have more context about the historical reasons (or lack thereof)
21:52:51 <mspreitz> that's a different vish than I already have subscribed?
21:53:03 <mikal> No, that's him
21:53:08 <russellb> no, that's not him
21:53:09 <mikal> But a ping on IRC might be more effective
21:53:13 <russellb> wrong launchpad vish
21:53:14 <mikal> Oh, ok
21:53:16 <mikal> Sigh
21:53:19 <alex_xu> for nova api, just wanting more core review on v2.1 on v3 and nova api policy - we still block on those. After those got approved, it will be a lot of patches for them, so hope we can doing on it early.
21:53:30 <mikal> But I am sure he gets lots of bug email
21:53:30 <mspreitz> OK, I'll try to alert the right vish
21:53:34 <mikal> So, I'd ping him in IRC
21:53:51 <mikal> angdraug: you had something as well?
21:53:53 <angdraug> rbd backend
21:53:55 <mspreitz> In IRC he is "vishy" ?
21:53:58 <angdraug> I have a patch series to address a number of problems with rbd driver, in review since May 1 (one patch since September 2013 really)
21:54:01 <angdraug> https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:master+topic:bug/1226351,n,z
21:54:01 <mikal> mspreitz: yes
21:54:05 <mspreitz> thanks
21:54:09 <angdraug> blueprint rbd-clone-image-handler, spec: https://review.openstack.org/91486
21:54:17 <angdraug> the first commit in the series ups RPC API, so I have to keep rebasing when other API affecting changes are merged ahead of it (4 times so far)
21:54:25 <angdraug> it didn't have -1 since June 11, a week ago (was addressed on June 12, still a week ago)
21:54:26 <mikal> The spec is approved?
21:54:36 <angdraug> no, still in review
21:54:43 <russellb> angdraug: can you ping pbrady (or pixelbeat on irc sometimes) ?  i was talking to him today about getting more involved with ceph+nova, so he may be able to help review
21:54:44 <angdraug> first commit is a bugfix, the spec related commits depend on it
21:54:46 <mikal> So that wont be helping
21:54:51 <yjiang5> russellb: I think the integration testing for these feature is something interesting.
21:54:56 <angdraug> I will, thanks
21:55:00 <russellb> yjiang5: yes
21:55:14 <mikal> pixelbeat would be a great person to get involved
21:55:45 <dgenin> I have a patch that depends on Barbican, which is now in incubation. The Barbican wrapper spec has been approved https://review.openstack.org/#/c/94918/
21:55:55 <angdraug> I would really appreciate if this could be given a priority over other API changes long enough to get merged
21:56:12 <angdraug> any chance of that?
21:56:36 <mikal> What's the review number for the API change?
21:56:39 <mikal> That's the bugfix one right?
21:56:43 <yjiang5> russellb: We should push tempest case to upstream, but also keep them easily be tested by 3rd parties (considering so many vendor interest on it)  since gate has no hardware testing.
21:56:49 <angdraug> 91722
21:56:52 <angdraug> yes
21:57:11 <russellb> yjiang5: *nod* ... we'll have to rely heavily on *VERY* good unit testing for the gate for now
21:57:14 <angdraug> the bp commits are pretty well isolated, not a lot of conflicts on rebase
21:57:18 <russellb> and vendor testing of hw environments
21:57:34 <mikal> angdraug: I will take a look at that review today
21:57:43 <mikal> If other people could take a look too that would be great
21:57:52 <mriedem> angdraug: when is rbd/ceph 3rd party CI going to be a thing? :)
21:57:54 <mikal> angdraug: we don't really have a process for compelling people to review something though
21:58:00 <angdraug> thanks. re testing, fuel team is working on running CI with master branches, we're only running stable/* for now
21:58:06 <mikal> I would like to see third party CI on this though
21:58:10 <mriedem> ++
21:58:18 <russellb> mikal: for rbd?
21:58:20 <angdraug> mriedem: it's still probably a month away at list
21:58:23 <angdraug> at least even
21:58:26 <mikal> russellb: yes
21:58:31 <mriedem> rbd/ceph 3rd party CI was discussed when things were pulled from FFE in icehouse
21:58:34 <mikal> russellb: well, kind of for all of these things
21:58:37 <angdraug> when we can have fuel ci for this, it will cover rbd
21:58:39 <mikal> russellb: lvm, rbd, etc etc
21:58:40 <russellb> mikal: yeah, i'll go chase that a bit here
21:58:49 <mikal> russellb: that would be awesome
21:59:40 <yjiang5> mikal: do you know how many person register for the meetup till now?
22:00:08 <russellb> time up!
22:00:09 <dansmith> did we have a registration thing?
22:00:13 <mriedem> eventbrite
22:00:14 <sdague> so, interestingly, we're going to flip on trusty images probably tonight
22:00:15 <tjones> do you guys have the link handy?  I didn't register
22:00:15 <mriedem> linked from wiki
22:00:27 <sdague> which means ceph would be theoretically testable in our ci
22:00:36 <mikal> So yeah, out of time unfortunately
22:00:39 <n0ano> tjones, start here https://wiki.openstack.org/wiki/Sprints/BeavertonJunoSprint
22:00:39 <mikal> We have 15 for the meetup IIRC
22:00:44 <mikal> The rego link is on the wiki page
22:00:56 <tjones> htanks n0ano
22:00:57 <mikal> Thanks everyone for your time
22:00:59 <mikal> #endmeeting