13:59:28 <johnthetubaguy> #startmeeting nova
13:59:29 <openstack> Meeting started Thu Aug  7 13:59:28 2014 UTC and is due to finish in 60 minutes.  The chair is johnthetubaguy. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:59:30 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:59:32 <openstack> The meeting name has been set to 'nova'
13:59:46 <johnthetubaguy> OK, 30 seconds early apparently
13:59:57 <johnthetubaguy> who is around for today's meeting?
13:59:59 * n0ano must wake up
14:00:01 <n0ano> o/
14:00:16 <johnthetubaguy> we are going to try and go with a slightly different agenda for today's meeting
14:00:23 <johnthetubaguy> #link https://wiki.openstack.org/wiki/Meetings/Nova#Agenda_for_next_meeting
14:01:19 <bauzas> \o
14:01:27 <johnthetubaguy> OK.. a few more people joining now
14:01:40 <johnthetubaguy> #topic Juno-3 status
14:01:55 <dansmith> o/
14:02:08 <beagles> hi
14:02:11 <alex_xu> hi
14:02:19 <johnthetubaguy> so we have Feature Proposal freeze fast approaching on August 21st and Feature Freeze on September 4th
14:02:31 <johnthetubaguy> … but first spec exceptions
14:02:42 <johnthetubaguy> we have like four pending specs still
14:02:55 <johnthetubaguy> but really all spec exceptions have expired
14:03:03 <johnthetubaguy> so whats people thoughts about these specs?
14:03:25 <dansmith> I vote for not approving any more spec exceptions :)
14:03:29 <bauzas> johnthetubaguy: the spec exception period was conflicting with nova mid-cycle meetup
14:03:31 <johnthetubaguy> first API, I think mikal was planning a meeting to sort that, I haven't hurd anything though, dansmith any news?
14:03:50 <dansmith> johnthetubaguy: he sent a mail last night, nothing scheduled yet
14:04:03 <johnthetubaguy> ah, OK, I should read my email better
14:04:10 <n0ano> well, the scheduler DB isolation, https://wiki.openstack.org/wiki/Meetings/Nova#Agenda_for_next_meeting, has one +2, only needs another +2 and we're working on it, I think it should be accepted
14:04:25 <johnthetubaguy> dansmith: how is the ironic discussions going, I don't see an updated deprecation sepc
14:04:31 <n0ano> wrong link - https://review.openstack.org/#/c/85399/
14:04:39 <johnthetubaguy> devananda: any news on the https://review.openstack.org/#/c/95025/13/specs/juno/deprecate-baremetal-driver.rst,cm
14:04:45 <dansmith> johnthetubaguy: I talked with devananda yesterday, he's going to revise that soon
14:04:53 <johnthetubaguy> OK...
14:05:11 <johnthetubaguy> dansmith: are you cool with the list on the agenda? I think thats what we agreed at the midcycle
14:05:23 <bauzas> n0ano: still wrong link : Isolate-Sched-DB is https://review.openstack.org/89893
14:05:35 <johnthetubaguy> API maybe, keystone was already merged, isolate-db, deprecate-baremetal
14:05:56 <dansmith> yeah
14:05:59 <pkoniszewski> o/
14:05:59 * n0ano I repeat - must wake up
14:06:08 <dansmith> cinderv2 merged last night, by the way
14:06:11 <johnthetubaguy> dansmith: cool, thanks
14:06:19 <dansmith> don't see that on this list, but I think we agreed that too, no?
14:06:23 <dansmith> or maybe that was already in the list
14:06:36 <johnthetubaguy> dansmith: yeah, good point, I looked an unmerged ones about 15mins ago
14:06:48 <johnthetubaguy> dansmith: it was on the other list at least
14:06:59 <johnthetubaguy> dansmith: but yeah, agreed no more other than the above list
14:07:00 <dansmith> cool, well was happy to see that go :)
14:07:11 <mriedem> i'm sure thingee was too
14:07:11 <johnthetubaguy> yeah
14:07:28 <johnthetubaguy> OK… so I figure we should try and agree some review priorities
14:07:37 <johnthetubaguy> I tried to make a list of the top few blueprints to review:
14:07:44 <johnthetubaguy> #link https://etherpad.openstack.org/p/nova-juno-3-review-list
14:08:07 <johnthetubaguy> now, first things, dansmith: what are you thinking about objects and juno?
14:08:23 <johnthetubaguy> do we just draw a line under it, and mark them all as NeedsCodeReview for juno now?
14:08:46 <dansmith> what do you mean draw a line under it?
14:08:57 <johnthetubaguy> sorry, totally unclear...
14:09:04 <dansmith> the objects patches move pretty quickly, so maybe just "good progress" or something?
14:09:06 <johnthetubaguy> are we ready to say, we have all the patches up for juno now?
14:09:14 <dansmith> oh, no
14:09:28 <johnthetubaguy> ah, OK, thats good new really, wasn't sure
14:09:36 <johnthetubaguy> yeah, maybe good progress is best
14:09:41 <dansmith> they move quickly, so I'm constantly throwing more up and getting them reviewed
14:09:47 <dansmith> plan to keep doing that until FF
14:10:01 <johnthetubaguy> dansmith: sweet, makes sense
14:10:04 <dansmith> cool
14:10:16 <johnthetubaguy> dansmith: so reviewing those is at the top of the list, its imporant
14:10:43 <dansmith> woot :)
14:10:54 <johnthetubaguy> OK, so we have a list now, there are four slots left, any suggestions on what needs to go in there (looking at medium priority stuff that has code up for review)
14:11:04 <johnthetubaguy> #link https://launchpad.net/nova/+milestone/juno-3
14:11:21 <russellb> i think to make this successful, people need to be tagged as reviewers
14:11:43 <johnthetubaguy> russellb: so this probably comes on to another idea for ttx
14:11:57 <russellb> i'm worried that just having a list doesn't do much
14:12:03 <johnthetubaguy> should we try to get people to sign up in pairs for all the days between now and FF?
14:12:40 <johnthetubaguy> russellb: the hope is to focus all the reviews on the same subset of super important blueprints, but I get what you mean
14:12:48 <mriedem> when is FF again?
14:12:48 <russellb> right, i get that
14:12:54 <dansmith> russellb: at the meetup, people asked for a top ten prioritization like this
14:12:59 <dansmith> basically "what should I be reviewing"
14:12:59 <toabctl> FF=feature freeze, I guess
14:13:05 <mspreitz> What about https://bugs.launchpad.net/nova/+bug/1327406 ? It is a pretty small and simple thing, with a patch already having some approval
14:13:06 <johnthetubaguy> #info Feature Proposal Freeze August 21st, September 4th Juno-3, FF and SF
14:13:07 <uvirtbot> Launchpad bug 1327406 in nova "The One And Only network is variously visible" [Undecided,In progress]
14:13:19 <russellb> so how about saying "here is a list a subset of the group thinks is important, would anyone like to sign up to reivew these to completion?"
14:13:21 <PhilD> https://blueprints.launchpad.net/nova/+spec/user-defined-shutdown for a slot ?
14:13:24 <johnthetubaguy> focusing on juno-3 blueprints just now
14:13:32 <mriedem> FF is 9/4 https://wiki.openstack.org/wiki/Juno_Release_Schedule
14:13:33 <mriedem> fyi
14:13:39 <russellb> avoid things getting missed, or duplicated efforts
14:13:42 <johnthetubaguy> medium priority stuff first ideally
14:13:54 <johnthetubaguy> PhilD: its not all up for review yet though? still might get cut before FF
14:14:16 <johnthetubaguy> PhilD: want to focus review time on stuff we can complete first, there loads been up for review for a few months now
14:14:17 <mriedem> mspreitz: we're talking about juno blueprint reviews, not bugs...
14:14:25 <PhilD> The computer manager layer is all up for review
14:14:47 <PhilD> As discussed that would be worth landing on its own
14:14:52 <johnthetubaguy> russellb: back to your point, I like that idea
14:15:06 <bauzas> johnthetubaguy: https://blueprints.launchpad.net/nova/+spec/isolate-scheduler-db is not triaged :)
14:15:29 <johnthetubaguy> PhilD: Thats different then, maybe mark that is NeedsCodeReview, and drop the other stuff, and propose a reduction in the spec, then we raise the priority of it, maybe, just maybe
14:15:31 <dansmith> johnthetubaguy: I think just having the prioritized list is helpful, FWIW
14:16:16 <johnthetubaguy> so getting people signed up to reviews, are people wanting to sign up for specific days, or is that just impractical?
14:16:35 <russellb> i think it's impractical
14:16:41 <dansmith> yeah
14:16:43 <johnthetubaguy> dansmith: maybe the signup is just additional, better to have something rather than nothing though, at least thats my feeling
14:16:55 <dansmith> johnthetubaguy: sure, doesn't hurt of course
14:16:56 <johnthetubaguy> russellb: dansmith: that was my thinking, I have no free days
14:16:57 <russellb> i don't think that's how reviews should work, the same people should continue to follow up on the same thing
14:17:28 <russellb> for the big stuff
14:17:37 <russellb> you don't pass it around day to day
14:18:07 <johnthetubaguy> russellb: yeah, thats true, the per day thing only really works for the "little" bugs I guess
14:18:14 <johnthetubaguy> anyways, lets discount that for now
14:19:22 <johnthetubaguy> OK...
14:19:39 <johnthetubaguy> so I vote we have a nova-drivers meeting to look at filling out this list: https://etherpad.openstack.org/p/nova-juno-3-review-list
14:19:47 <johnthetubaguy> does that make sense?
14:19:54 <dansmith> sure,
14:20:16 <dansmith> I think we discussed doing that anyway, and I think we can continue to revise the ordering as things get more or less likely to be ready
14:20:27 <johnthetubaguy> (we will make the time public, its just don't want to waste the time of the bigger group)
14:20:45 <johnthetubaguy> yeah, right now the list is a bit short, but the other stuff all seemed lower priority at this point
14:20:55 <johnthetubaguy> OK…
14:21:08 <johnthetubaguy> any more on Juno-3 status, mostly blueprint status?
14:21:41 <johnthetubaguy> #topic Bugs
14:21:49 <johnthetubaguy> #link http://54.201.139.117/nova-bugs.html
14:21:58 <johnthetubaguy> Ok, no unassigned critical bugs
14:22:23 <johnthetubaguy> any other bugs people want to raise
14:22:27 * ttx lurks
14:22:29 <johnthetubaguy> not seen a list from tjones
14:22:39 <dansmith> she's been on vacation I think
14:22:58 <johnthetubaguy> dansmith: ah, OK, not heard anything mikal wanted to raise either
14:23:05 <johnthetubaguy> so I guess we skip that for now
14:23:06 <dansmith> I think the meetup led to a decision to close some old bugs, right?
14:23:06 <mspreitz> https://bugs.launchpad.net/nova/+bug/1327406
14:23:08 <uvirtbot> Launchpad bug 1327406 in nova "The One And Only network is variously visible" [Undecided,In progress]
14:23:15 <dansmith> that would make looking at the list a lot easier
14:23:25 <johnthetubaguy> dansmith: right, very good point
14:23:34 <johnthetubaguy> who was owned that task, can you remember
14:23:48 <dansmith> I figured tjones, but I can try to catch up with her when she pops up and see
14:24:13 <johnthetubaguy> #action tjones: need to close out some old bugs so we can read the bug list, need to find out who is doing that
14:24:19 <johnthetubaguy> dansmith: yeah, I guess
14:24:26 <johnthetubaguy> #topic Gate status
14:24:43 <johnthetubaguy> mriedem: hows we doing these days?
14:24:51 <mriedem> johnthetubaguy: quiet
14:24:57 <mriedem> mspreitz: your patch needs a unit test
14:25:03 <johnthetubaguy> I guess thats good
14:25:14 <mriedem> quiet is good
14:25:23 <johnthetubaguy> #topic Open Discussion
14:25:26 <mspreitz> I'll work on the unit test.  How about some prioritization of the bug?
14:25:38 <mriedem> mspreitz: there are like 1000 bugs
14:25:43 <johnthetubaguy> mspreitz: feel free to join the group and help with bug triage
14:26:09 <mriedem> mspreitz: the only bugs that generally get high priority are the ones breaking the gate
14:26:09 <johnthetubaguy> mspreitz: there is a wiki on that, and a meeting run my tjones if you want to talk about that with the sub team
14:26:28 <johnthetubaguy> mspreitz: agreed its an issue though
14:26:49 <johnthetubaguy> OK, so we are skipping the sub-team updates to help concentrage on juno-3 status more
14:26:51 <mspreitz> wiki ref pls?
14:27:02 <johnthetubaguy> but if there is anything urgent then you can cover that here?
14:27:08 <bauzas> about opens, was just wondering if there would be any design session planned for presenting elastic-recheck and how people could help ?
14:27:17 <johnthetubaguy> #link https://etherpad.openstack.org/p/juno-nova-mid-cycle-meetup
14:27:32 <johnthetubaguy> if you want to know what happened at the mid-cycle it was fun, notes are above ^
14:27:36 <johnthetubaguy> mspreitz: looking
14:27:41 <mriedem> mspreitz: https://wiki.openstack.org/wiki/Nova/BugTriage
14:27:42 <bauzas> most of the time, I'm unable to find out the correct Kibana query for checking if the bug is already known or not
14:27:53 <mriedem> google \o/
14:28:06 <johnthetubaguy> mspreitz: https://wiki.openstack.org/wiki/Meetings/NovaBugScrub
14:28:14 <russellb> i think a recap of key topics on the mailing list would be helpful, easier to parse than the notes, and also to allow discussion
14:28:17 <mriedem> which is linked from the above
14:28:29 <russellb> ^ re: meetup
14:28:29 <mriedem> russellb: +2
14:28:33 <johnthetubaguy> russellb: thats a very good idea
14:28:35 <mspreitz> mriedem: johnthetubaguy: thanks
14:28:37 <mriedem> asked for that w/ the containers guys too in the ML
14:28:48 <mriedem> b/c they were busy bees but no notes in ML
14:28:50 <bauzas> mriedem: dammit, was not so used to find good docs :)
14:28:53 <dansmith> yeah, definitely need documentation from the container folks :)
14:29:12 <johnthetubaguy> #action mikal to find someone to create a summary of midcycle meetup
14:29:22 <johnthetubaguy> OK, so I have mikal an action item for that...
14:29:26 <mriedem> bauzas: see the e-r readme for notes on queries
14:29:28 <mriedem> and writing them
14:29:35 <johnthetubaguy> if you want to help out with that, please email mikal
14:29:37 <n0ano> dansmith, I think they worked mainly on defining their API, expect spec soon
14:29:49 <mriedem> bauzas: also look for a juno summit session from sdague on e-r
14:29:51 <mriedem> for a high-level
14:30:05 <dansmith> n0ano: I want them to document what they presented to us there, for the rest of the group :)
14:30:12 <mriedem> right
14:30:14 <n0ano> dansmith, +1
14:30:15 <johnthetubaguy> dansmith: +1
14:30:22 <mriedem> there are people that didn't make the meetup that are interested in the containers/nova stuff
14:30:29 <dansmith> also to help avoid letting them change their minds later :P
14:30:36 <dansmith> without due scorn
14:30:42 <mriedem> and for people that didn't pay great attention that were there.... :(
14:30:56 <johnthetubaguy> russellb: I think mikal has been in a conference since the midcycle, I will sync up with him about getting out a summary, not had chance myself
14:31:17 <mriedem> as for open discussion, the core team should probably weigh in here https://review.openstack.org/#/c/110754/
14:31:24 <johnthetubaguy> dansmith: should we maybe add our thoughts into the etherpad about what we remember?
14:31:37 <dansmith> johnthetubaguy: about what, containers?
14:31:39 <mriedem> johnthetubaguy: use the ML please...
14:31:56 <mriedem> johnthetubaguy: maybe just me, but i lose things in etherpads b/c i lose etherpads
14:32:06 <mriedem> i can always search for the thread in thunderbird
14:32:07 <johnthetubaguy> mriedem: agreed, just thinking to refine the etherpad, so we can send something fairly complete to the ML
14:32:12 <mriedem> sure
14:32:15 <dansmith> yeah, I think just poking them to send a mail to the list would be ideal
14:32:18 <johnthetubaguy> dansmith: yeah, I should get in contact with those folks
14:32:33 <mriedem> fwiw i did send a thing to the containers thread already asking for that
14:32:36 <dansmith> I have some notes, but they had... PPT!
14:32:43 <dansmith> mriedem: yeah, saw that
14:32:44 <johnthetubaguy> mriedem: sweet
14:32:58 <johnthetubaguy> dansmith: I hear rumers of a draft spec as well
14:33:08 <johnthetubaguy> it seems we are all done then?
14:33:12 <mriedem> adrian_otto: ^?
14:33:12 <johnthetubaguy> any more for any more?
14:33:16 <mriedem> johnthetubaguy: https://review.openstack.org/#/c/110754/
14:33:22 <mriedem> just fyi for the core team
14:33:38 <mriedem> well anyone really
14:33:42 <mriedem> since it's policy related
14:34:05 <russellb> i think that needs to go to the ML
14:34:11 <russellb> let's not use gerrit as a debate forum
14:34:19 <johnthetubaguy> #info we should discuss the libvirt cap here: https://review.openstack.org/#/c/110754/
14:34:25 <mriedem> sure, it probably just tacks on to the existing thread
14:34:34 <johnthetubaguy> yeah ML is usually better
14:34:40 <mriedem> honestly i'm tired of talking about it
14:34:44 <mriedem> and have become complacent
14:34:57 <mriedem> wrong word there...
14:35:02 <mriedem> indifferent
14:35:13 <johnthetubaguy> mriedem: lets keep tracking it, so indecision doesn't just keep the patch in the tree
14:35:24 <mriedem> sure
14:35:30 <mriedem> i'll post it to the ML for everyone's FYI
14:35:34 * russellb thinks the patch is fine (obviously since he was one of the +2s)
14:36:09 <johnthetubaguy> do we want to chat about this here right now? I kinda feel like the ML is better for that though
14:36:14 <russellb> ML++
14:36:15 <johnthetubaguy> anyways, any other things?
14:36:27 <russellb> sdague isn't here, and danpb is on PTO
14:36:34 <russellb> 2 key parties to that particular revert proposal
14:36:48 <johnthetubaguy> russellb: +1 we need to wait for those folks, very good point
14:37:12 <adrian_otto> johnthetubaguy: Sorry for my delayed response. The draft specs for the containers service are expected next week. I am out on ETO this week, on minimum duty.
14:37:30 <johnthetubaguy> #info please feedback on the agenda format, its a WIP, more ideas welcome to johnthetubaguy and/or mikal
14:37:47 <johnthetubaguy> so its holiday season, this much is clear
14:37:52 <johnthetubaguy> I am out next week myself
14:37:56 <johnthetubaguy> I guess we are done now
14:38:03 <johnthetubaguy> thanks all
14:38:21 <johnthetubaguy> lets keep evolving the agenda so we keep this useful, ideas very welcome
14:38:27 <johnthetubaguy> #endmeeting