21:04:15 <dansmith> #startmeeting nova
21:04:17 <openstack> Meeting started Thu Sep 25 21:04:15 2014 UTC and is due to finish in 60 minutes.  The chair is dansmith. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:04:18 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:04:20 <openstack> The meeting name has been set to 'nova'
21:04:21 <dansmith> #chair mriedem
21:04:22 <openstack> Current chairs: dansmith mriedem
21:04:28 <mriedem> #link https://wiki.openstack.org/wiki/Meetings/Nova#Agenda_for_next_meeting
21:04:30 <mriedem> does that work?
21:04:33 <dansmith> I'm on a cell connection, so I can't run it
21:04:35 <dansmith> mriedem: yep, go
21:04:45 <mriedem> ok, juno rc1
21:04:51 <leifz> o/
21:04:53 <mriedem> sdague just dumped 3 bugs on the list, those are in the agenda now
21:04:56 <mriedem> oh yeah who's here?
21:05:02 <melwitt> o/
21:05:07 <alaski> o/
21:05:09 <dansmith> o/
21:05:10 <n0ano> o/
21:05:15 <edleafe> o/
21:05:38 <mriedem> cool so juno rc1 is supposed to be today
21:05:45 <mriedem> this is the rc1 bug list https://launchpad.net/nova/+milestone/juno-rc1
21:05:48 <mriedem> #link https://launchpad.net/nova/+milestone/juno-rc1
21:06:15 <jogo> o/
21:06:18 <mriedem> 9 open, 6 of those in progress
21:06:44 <mriedem> sounds like we might have a patch for something similar to https://bugs.launchpad.net/nova/+bug/1373962
21:06:45 <uvirtbot> Launchpad bug 1373962 in nova "LVM backed VM fails to launch" [High,Confirmed]
21:06:55 <mriedem> so if someone can dig that up (ML?) it'd be good
21:07:15 <mriedem> another confirmed is https://bugs.launchpad.net/neutron/+bug/1357476
21:07:19 <uvirtbot> Launchpad bug 1357476 in nova "Timeout waiting for vif plugging callback for instance" [Critical,Confirmed]
21:07:25 <mriedem> dansmith: you improved logging for that,
21:07:28 <mriedem> but not sure if anything has changed
21:07:32 <mriedem> or if we've noticed
21:07:43 <dansmith> ah, yeah, was waiting to get a post-patch hit on that
21:07:45 <mriedem> mikal noted we should untarget from rc1 if it's not being worked, i'd second that
21:08:02 <dansmith> we should try to see if it's still getting hit before we do I think
21:08:10 <mriedem> ok
21:08:12 <dansmith> at least so we know if it is a thing we're capable of looking at
21:08:19 <mriedem> do we have a query?
21:08:19 <dansmith> I'm out tomorrow, otherwise I'd do that tomorrow
21:08:21 * mriedem looks
21:08:24 <dansmith> we must
21:08:37 <mriedem> running it
21:08:47 <dansmith> #link http://lists.openstack.org/pipermail/openstack-dev/2014-September/046741.html
21:08:56 <dansmith> that's the ML post about the LVM issue with config drive
21:08:57 <mriedem> #action see if https://bugs.launchpad.net/neutron/+bug/1357476 is still a problem
21:08:59 <uvirtbot> Launchpad bug 1357476 in nova "Timeout waiting for vif plugging callback for instance" [Critical,Confirmed]
21:09:08 <mriedem> 0 hits in 7 days
21:09:28 <dansmith> heh, well, can't be that big of a deal then
21:09:32 <dansmith> I say untarget
21:09:35 <mriedem> ok i'll untarget
21:09:48 <dansmith> so, on the LVM thing
21:10:07 <dansmith> looks like maybe mikal thought that the only consequence was not being able to have an LVM-formatted configdrive
21:10:19 <mriedem> is this flwang's patch for rbd then?
21:10:22 <dansmith> but I think the bug is about using LVM breaking configdrive incidentally, right?
21:10:38 <dansmith> I don't think so, that's for evacuate and unrelated AFAICT
21:10:41 <mriedem> ok
21:11:35 <mriedem> it's not popping out to me if there is a related patch up for that issue from the ML
21:11:38 <mriedem> anyway, moving on
21:12:05 <mriedem> this is the other rc1 bug https://bugs.launchpad.net/nova/+bug/1323658
21:12:07 <uvirtbot> Launchpad bug 1323658 in nova "Nova resize/restart results in guest ending up in inconsistent state with Neutron" [Critical,Confirmed]
21:12:10 <dansmith> yeah, don't see it
21:12:27 <mriedem> arosen isn't here
21:12:35 <dansmith> so, on that
21:12:44 <dansmith> I worked with him for a few days to try to get to the bottom of it
21:12:55 <dansmith> he actually thinks that it's a sequencing thing in the tempest test,
21:13:02 <dansmith> and not something that actually matters in the real world
21:13:12 <mriedem> ok, still top gate bug
21:13:17 <mriedem> but tempest...
21:13:22 <dansmith> yeah, but not critical for the release as a result
21:13:27 <dansmith> based on what I heard last
21:13:33 <dansmith> so, painful, but not something we need to hold up for
21:13:48 <mriedem> ok, i'll untarget rc1
21:14:28 <mriedem> ok so that leaves the lvm thing for rc1
21:14:36 <mriedem> anything else on rc1?
21:14:40 <dansmith> When mikal pops up,
21:14:50 <dansmith> we should make sure he looks at the LVM thing, since we think he might've broke it
21:15:16 <dansmith> then he can decide if it can wait for rc2 or if it's worth delaying rc1
21:15:27 <mriedem> sure, we have mikal's revert linked into the bug
21:15:48 <mriedem> what's the tag for a new topic? topic?
21:15:59 <dansmith> I think
21:16:04 <mriedem> #topic bugs
21:16:14 <dansmith> like a pro
21:16:19 <mriedem> \o/
21:16:34 <mriedem> i added 3 bugs here https://wiki.openstack.org/wiki/Meetings/Nova#Weekly_Nova_team_meeting
21:16:52 <mriedem> one is the lvm config drive rc1 bug
21:17:07 <mriedem> one is https://bugs.launchpad.net/nova/+bug/1371677 which is our happy periodic task / resize timeout bug
21:17:09 <uvirtbot> Launchpad bug 1371677 in nova "Race in resource tracker causes 500 response on deleting during verify_resize state " [Critical,Fix committed]
21:17:24 <mriedem> since e-r is backed up to hell we don't know if dansmith's latest pach for that has resolved it
21:17:30 <dansmith> still like five hours away from e-r showing us anything
21:17:54 <mriedem> we suspect we still need some logic in the libvirt driver to check if the volume exists before calling (blocking) blockdev to get the volume size, because danpb said that'll hang if the volume is gone
21:17:57 <mriedem> which is causing the timeout
21:18:07 <dansmith> well,
21:18:09 <mriedem> i didn't get a chance to work on that today
21:18:13 <dansmith> but we'll be doing that without the lock,
21:18:22 <dansmith> so it will only delay the periodic, but not really a probem right?
21:18:32 <mriedem> i'd have to double check
21:18:39 <dansmith> that's my understanding, FWIW
21:18:42 <jogo> Its also odd that we have an RPC CALL (versus cast) in nova-delete in this case
21:18:55 <mriedem> jogo: cyeoh said there were some notes in the code on why that is
21:18:59 <mriedem> i didn't look last night though
21:19:05 <dansmith> yeah, there is some reson
21:19:08 <jogo> mriedem: yeah but I think we can do better
21:19:08 <dansmith> I forget why
21:19:15 <mriedem> cyeoh said some other race
21:19:24 <jogo> dansmith: it has to check the source of the migrate
21:19:30 <jogo> before moving on or something
21:19:37 <mriedem> dansmith: ok, so you moved the lock past this now:
21:19:37 <mriedem> resources = self.driver.get_available_resource(self.nodename)
21:19:39 <jogo> but maybe long term we can move this logic to the conductor so it can be async
21:19:44 <dansmith> mriedem: right
21:19:45 <mriedem> that's what would be eventually hitting the blockdev call
21:19:45 <mriedem> ok
21:19:48 <jogo> from API
21:20:07 <mriedem> alright, so thinking dansmith's fix is good
21:20:13 <mriedem> we'll find out when e-r flushes
21:20:31 <mriedem> the 3rd bug that sdague had listed was https://bugs.launchpad.net/keystone/+bug/1188189
21:20:33 <uvirtbot> Launchpad bug 1188189 in cinder "Some server-side 'SSL' communication fails to check certificates (use of HTTPSConnection)" [High,In progress]
21:20:44 <mriedem> that's an ssl issue, which is really like 5 bugs in nova apparently
21:20:51 <mriedem> sounds like there are separate bugs opened for each
21:21:02 <mriedem> so if people want something to work on, pick those up
21:21:27 <mriedem> #link https://bugs.launchpad.net/keystone/+bug/1188189/comments/54
21:21:31 <mriedem> those are the separate bugs
21:21:55 <mriedem> anything else on bugs? i guess checkout the 'in progress' rc1 bugs for code reviews
21:22:11 <mriedem> since we can't tag rc1 until those are closed out probably
21:22:26 <mriedem> moving on
21:22:32 <mriedem> #topic gate status
21:22:45 <mriedem> #link http://status.openstack.org/elastic-recheck/
21:22:49 <mriedem> as noted e-r is backed up
21:22:53 <mriedem> so we don't know the true state of the gate right now
21:23:19 <mriedem> i think we've got fixes out for the top nova bugs in there right now though
21:23:32 <mriedem> hell, the wsgi test was deleted :)
21:23:37 <dansmith> heh
21:23:44 <mriedem> jogo: anything on gate?
21:23:54 <mriedem> categorization rate is high http://status.openstack.org/elastic-recheck/data/uncategorized.html
21:23:59 <mriedem> but that will also change when e-r flushes
21:24:21 <jogo> mriedem: http://jogo.github.io/gate/  is looking decent
21:24:24 <mriedem> and looks like https://review.openstack.org/#/c/122291/ was approved, that was a gate issue
21:24:52 <mriedem> moving on
21:24:53 <jogo> mriedem: that page uses graphite so its up to date
21:25:02 <mriedem> ok
21:25:10 <mriedem> yeah things seem to be moving at least
21:25:34 <mriedem> #topic open discussion
21:25:48 <mriedem> agenda says summit topics
21:25:52 <mriedem> #link https://etherpad.openstack.org/p/kilo-nova-summit-topics
21:26:02 <mriedem> like most etherpads it's a mess
21:26:04 <mriedem> :)
21:26:25 <mriedem> anyone have anything on summit topics?
21:26:58 <mriedem> regarding kilo and the bp/spec process,
21:27:19 <mriedem> we approved jogo's https://review.openstack.org/#/c/116699/ and https://review.openstack.org/#/c/112733/ will probably be approved when johnthetubaguy wakes up
21:27:33 <mriedem> still need to work out some of the runway stuff https://review.openstack.org/#/c/115410/
21:28:00 <mriedem> any other topics? sub-teams?
21:28:10 <dansmith> please no.
21:28:16 <mriedem> end early?
21:28:19 <dansmith> +1
21:28:23 <jogo> +1
21:28:23 <tjones> :-)
21:28:28 <mriedem> #endmeeting