21:00:51 <mriedem> #startmeeting nova
21:00:52 <openstack> Meeting started Thu Dec 18 21:00:51 2014 UTC and is due to finish in 60 minutes. The chair is mriedem. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:53 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:56 <openstack> The meeting name has been set to 'nova'
21:00:56 <melwitt> o/
21:00:58 <beagles> o/
21:00:59 <dansmith> o/
21:00:59 <edleafe> o/
21:01:02 <gilliard> o/
21:01:02 <mriedem> raise em up
21:01:03 <alaski> o/
21:01:04 <n0ano> o/
21:01:04 <alex_xu> o/
21:01:14 <mriedem> agenda: https://wiki.openstack.org/wiki/Meetings/Nova#Agenda_for_next_meeting
21:01:18 <edleafe> :w
21:01:23 <edleafe> arrgghhh
21:01:28 <mriedem> #topic kilo-specs
21:01:43 <mriedem> well today is the day for k-1 deadline on spec approvals
21:01:52 <clif_h> o/
21:01:54 <mriedem> i believe ttx is cutting k-1 today sometime
21:02:01 <mriedem> Non-priority Feature Freeze is kilo-2 (February 5th)
21:02:25 <mriedem> anything that didn't make the approval deadline (today) has to get an exception, and that process is TBD until people get back from vacation
21:02:48 <mriedem> sounds like there will be a meeting the first week of january to iron those detials out, and then i'm assuming ML for the process
21:02:50 <n0ano> mriedem, so we don't even know the process for another 2 weeks
21:02:50 <jogo> o/
21:03:03 <dims__> o/
21:03:12 <dansmith> n0ano: right
21:03:18 <jcook> o/
21:03:32 <JoshNang> o/
21:03:33 <mriedem> n0ano: well, i'd think there is some exception request on the ML, priority will be important, and probably people signed up to review them
21:03:35 <mriedem> but i'm guessing
21:03:49 <n0ano> it just leaves us in limbo for a long time
21:04:12 <mriedem> well, there are things people can do in the interim
21:04:21 <mriedem> like help review the k1 approved specs,
21:04:30 <mriedem> get code in shape for anything proposed as a priority exception for k2, etc
21:04:47 <mriedem> review this https://review.openstack.org/#/c/135700/ :)
21:05:00 * dansmith slips mriedem a $20
21:05:03 <mriedem> re-approve blueprint fast-track - anything needing re-approval
21:05:04 <mriedem> ?
21:05:16 <mriedem> i honestly haven't checked
21:05:36 <dansmith> re-approval is just for things early in the cycle,
21:05:39 <mriedem> i had this in open discussion but the agenda talks about spec free bp's, there was one here https://blueprints.launchpad.net/nova/+spec/network-template-routes-injection
21:05:41 <dansmith> so we can probably start asking about this I think
21:05:47 <jogo> right, I think we can take that off the agenda now
21:05:49 <bauzas> \o
21:05:52 <mriedem> jogo: ok
21:06:03 <mriedem> regarding https://blueprints.launchpad.net/nova/+spec/network-template-routes-injection - i don't think it needs a spec given the guidelines
21:06:14 <jogo> mriedem: I thought there was already a spec for that
21:06:17 <mriedem> i can't pretend to understand it really, not really my area, but it's up there
21:06:24 <mriedem> jogo: no, it was reported as a 'nova should do this' bug
21:06:31 <mriedem> and a patch, which i said open a bp
21:06:45 <dansmith> this is for nova-network right?
21:06:50 <jogo> https://review.openstack.org/85673
21:06:51 <mriedem> dansmith: yeah, i added vishy to the review
21:07:05 <jogo> ohh nova-network ahh
21:07:15 <mriedem> https://review.openstack.org/#/c/115409/
21:07:38 <mriedem> anyway, moving on from that - take a peek if you care, i don't think spec is required
21:07:52 <bauzas> can we just restate that priority reviews can be set there https://etherpad.openstack.org/p/kilo-nova-priorities-tracking ?
21:08:00 <mriedem> just about to do that
21:08:03 <mriedem> #topic priorities
21:08:05 <mriedem> #link https://etherpad.openstack.org/p/kilo-nova-priorities
21:08:06 <jogo> mriedem: agreed sounds like a good candidate for no spec
21:08:10 <mriedem> #link https://etherpad.openstack.org/p/kilo-nova-priorities-tracking
21:08:34 <mriedem> top three are still cells, objects and scheduler
21:08:50 <jogo> mriedem dansmith: should I approve https://blueprints.launchpad.net/nova/+spec/network-template-routes-injection ?
21:08:54 <mriedem> i don't know if there is much to report here? alaski dansmith jaypipes ^ ?
21:08:58 <mriedem> jogo: up to you
21:09:04 * dansmith doesn't care much
21:09:18 * jogo approves
21:09:20 <mriedem> alaski has cells specs and devref stuff up for review, so we could get some eyes on them
21:09:23 <bauzas> I can proxy jaypipes's voice
21:09:24 <dansmith> mriedem: the objects status has pretty much been the same for weeks, but I'll do some updates there
21:09:25 <mriedem> did the cells specs get approved yet?
21:09:30 <n0ano> in re: scheduler - most important thing is review for https://review.openstack.org/#/c/127609/
21:09:31 <dansmith> mriedem: some
21:09:31 <mriedem> i don't think they did
21:09:35 <alaski> two cells specs are approved
21:09:45 <mriedem> dansmith: alaski: ok, i'm assuming anything that didn't would be exception fodder anyway
21:09:51 <alaski> two others are up for review
21:09:59 * alaski needs to add it to the etherpad
21:10:07 <mriedem> #action need people to review https://review.openstack.org/#/c/127609/ for the scheduler bp priority
21:10:18 <alaski> mriedem: I think we need to discuss when everyone is back from the holidays
21:10:18 <mriedem> #action alaski to update priorities etherpad for cells specs
21:10:30 <mriedem> alaski: yeah - i'm just drunk with power here
21:10:40 <bauzas> mriedem: as I said, most important reviews for the scheudler are in the etherpad
21:10:53 <mriedem> bauzas: n0ano: ok, thanks
21:10:55 <bauzas> https://review.openstack.org/#/c/127609/ will need an exception
21:11:10 <dansmith> re: the flavor blob one, I don't think there is any way to get serious review on it before the break, so I presume we'll just hold the -2 on that one until January
21:11:11 <bauzas> if we consider k1 as the spec freeze
21:11:43 <mriedem> dansmith: yeah i don't think so either, i guess you could address what i pointed out today and then it will sit for a bit
21:11:50 <dansmith> yep, will
21:12:19 <mriedem> i'm technically out for the rest of the year but with the inlaws staying with us next week i'm sure i'll be online poking around
21:12:28 <mriedem> moving on
21:12:31 <mriedem> #topic gate
21:12:36 <mriedem> the gate is good http://status.openstack.org/elastic-recheck/gate.html
21:12:46 <mriedem> 90% classification of bugs
21:12:50 <mriedem> which is as high as i can remember
21:12:50 <jogo> \o/
21:13:10 <mriedem> if it craps over the break i guess put out the jogo signal :)
21:13:23 <mriedem> #topic bugs
21:13:27 <dansmith> I have a bug thing
21:13:28 <mriedem> there was nothing on the agenda about bugs
21:13:29 <mriedem> ok
21:13:31 <dansmith> https://bugs.launchpad.net/nova/+bug/1402813
21:13:34 <uvirtbot> Launchpad bug 1402813 in nova "https://review.openstack.org/#/c/91722 breaks icehouse->juno live migration" [Undecided,New]
21:13:35 <dansmith> apparently, in juno,
21:13:42 <dansmith> we intentionally broke live migrations across icehouse->juno
21:13:52 <dansmith> which breaks the way a lot of people upgrade without dropping workloads
21:14:10 <dansmith> I think this needs to be classified highly, and we need to fix master and backport to juno
21:14:12 <dansmith> thoughts?
21:14:14 <mriedem> is that only for people using shared storage?
21:14:17 <dansmith> no
21:14:23 <dansmith> it should be only for shared storage on RBD,
21:14:29 <dansmith> but it was just broken across the board
21:14:31 <mriedem> wow
21:14:31 <dansmith> for no reason
21:14:34 <dansmith> I know.
21:14:41 <mriedem> i remember that patch, and there was some hate
21:14:52 <dansmith> it didn't do this in the early versions
21:15:06 <dansmith> but the one that merged calls it out in the commit message clearly
21:15:08 <dansmith> so anyway,
21:15:20 <dansmith> I just wanted to see if others felt it was a critical issue like I do
21:15:29 <mriedem> i marked it critical
21:15:36 <dansmith> and I'll work on either helping the author make the change, or just do it (when I get back)
21:15:38 <dansmith> okay
21:15:45 <mriedem> i think for the people i've been talking to about upgrades to kilo, they are going to be doing cold migrates anyway b/c of distro upgrades
21:15:54 <dansmith> well,
21:16:00 <mriedem> but that's not everyone
21:16:00 <jogo> wow the upgrade impact discussed the issue
21:16:11 <dansmith> we do live migrates to allow people to do distro upgrades without dropping workloads
21:16:21 <jogo> ++ to critical
21:16:22 <dansmith> like, live migrate from RHEL6 to RHEL7, icehouse to juno
21:16:24 <dansmith> works well
21:16:31 <dansmith> except when we intentionally break it :(
21:16:43 <alaski> yeah, +1 to critical. this is a pretty big break
21:16:50 <mriedem> dansmith: yeah, we're talking 6.5 to 7 for juno/kilo here
21:16:55 <dansmith> right
21:17:05 <mriedem> so cern will hit this too...
21:17:11 <mriedem> b/c they are upgrading distros
21:17:14 <dansmith> I think lots of people are going to hit it
21:17:17 <mriedem> yeah
21:17:18 <mriedem> ok
21:17:21 <mriedem> marked as critical and for k2
21:17:21 <dansmith> probably right after the break when they sit down to do upgrades :)
21:17:30 <dansmith> cool, thanks
21:17:45 <mriedem> #action fix https://bugs.launchpad.net/nova/+bug/1402813 if you want happy users
21:17:46 <uvirtbot> Launchpad bug 1402813 in nova "https://review.openstack.org/#/c/91722 breaks icehouse->juno live migration" [Undecided,New]
21:17:59 <mriedem> any other critical bugs?
21:18:12 <mriedem> dansmith: maybe make ndipanov fix it :)
21:18:18 <dansmith> heh
21:18:21 <dansmith> he has enough to do
21:18:25 <mriedem> blargh
21:18:37 <mriedem> #topic stuck-reviews
21:18:46 <mriedem> i think this pacemaker one is old
21:18:48 <mriedem> no link
21:19:04 <mriedem> beagles has https://review.openstack.org/#/q/status:open+project:openstack/nova-specs+branch:master+topic:bp/nova-neutron-refactor,n,z on here for the neutron v2 api refactor
21:19:15 <mriedem> there are 3 specs there, which missed the deadline obviously
21:19:32 <bauzas> mriedem: about Pacemaker, you mean https://review.openstack.org/#/c/139991/ ?
21:19:47 <mriedem> i think we can stagger those in kilo still and are technial debt priority, so at least one or two might get exceptions if done right
21:19:53 <dansmith> since this is in support of neutron usability, and non-damaging to the mainline while developing, I think an exception for this work to start/continue is cool, but we can talk about that in Jan
21:19:55 <mriedem> bauzas: looks right
21:20:04 <mriedem> dansmith: agreed
21:20:16 <clif_h> can I bring up a review I'd just like to get core eyes on? https://review.openstack.org/#/c/141188/ this is to improve efficiency with the ironic driver using the ironic client
21:20:17 <mriedem> looks like https://review.openstack.org/#/c/139991/ isn't stuck...
21:20:31 <jogo> mriedem: that is dead on arrival IMHO
21:20:35 <bauzas> mriedem: agreed
21:20:38 <mriedem> clif_h: that doesn't look 'stuck' to me
21:20:42 <bauzas> mriedem: it seems there is a consensus
21:20:55 <clif_h> mriedem: sorry, is there a better time to bring this up?
21:21:05 <tonyb> clif_h: open discussion
21:21:06 <mriedem> clif_h: at the end i guess
21:21:08 <mriedem> right
21:21:14 <clif_h> alright, I will, thanks
21:21:30 <mriedem> another was host health monitoring: https://review.openstack.org/#/c/137768/
21:21:41 <mriedem> doesn't look stuck,
21:21:46 <mriedem> and doesn't look like a priority for kilo
21:21:58 <mriedem> is this another spec about auto-evacuate/migrate or sometihng?
21:22:22 <alaski> not quite, but along those lines
21:22:25 <mriedem> yup, auto-evacuate
21:22:30 <mriedem> hw failure on your intel box :)
21:22:42 <baoli_> we have a few SR-IOV related specs for cores' attention. Wonder if they still have a chance
21:22:56 <alaski> mriedem: I don't think it's stuck, there's been discussion on it recently
21:22:57 <mriedem> baoli_: let's leave that for open discussion
21:23:01 <mriedem> alaski: agreed
21:23:06 <bauzas> mriedem: https://review.openstack.org/#/c/137768/ isn't stuck too
21:23:09 <baoli_> mriedem, sure
21:23:24 <mriedem> moving on to https://review.openstack.org/#/c/136487/
21:23:28 <mriedem> remove server group members
21:23:37 <bauzas> maybe it would be good to reexplain what a stuck review means...
21:23:42 <mriedem> dansmith is -1 b/c he wants remove/add done together,
21:23:50 <dansmith> hell yes I do
21:23:51 <mriedem> i was hoping that johnthetubaguy would review https://review.openstack.org/#/c/136487/ and throw his input in
21:24:15 * johnthetubaguy noticed he is mentioned, looks at review
21:24:16 <mriedem> it was discussed at the summit so was hoping that others involved in that discussion could chim in
21:24:21 <mriedem> *chime in
21:24:28 <mriedem> personally i don't have a dog in that fight so don't care either way
21:24:37 <dansmith> mriedem: have you looked at the add spec yet?
21:24:39 <mriedem> i haven't reviewed the add spec either
21:24:40 <mriedem> nope
21:24:41 <jmulsow> I previously had add/remove together, but as discussed at summit split these into two specs to stage remove in for kilo and add later.
21:24:56 <mriedem> dansmith: did you look at the add spec?
21:24:58 <mriedem> assumes yes
21:24:59 <dansmith> mriedem: yes
21:25:04 <dansmith> I've been avoiding commenting
21:25:04 <mriedem> problems?
21:25:16 <dansmith> it adds a ton of new DB traffic to try to avoid the hard problems
21:25:17 * mriedem assumes jmulsow has thick skin
21:25:46 <dansmith> I'm not sure it covers all the bases, although it covers a bunch, but the cost for it is high, IMHO
21:25:52 <mriedem> ok, so the concern is we do remove w/o add and if we can't decide on a design for add, we're stuck w/o it
21:25:58 <tonyb> BTW My driver (mikal) says "hi"
21:26:04 <alaski> not having read the specs yet, I agree with add/remove being in the same spec.
21:26:12 <dansmith> and then we're stuck with weird can-remove-but-not-add API semantis
21:26:15 <dansmith> er, semantics
21:26:25 <dansmith> right now it's symmetric and easy:
21:26:26 <mriedem> and it's not weird to not be able to remove at all?
21:26:32 <dansmith> you get into a group on birth and leave on death, period.
21:26:37 <jogo> honestly we have enough other stuff going on I this doesn't seem worth dealing with now
21:26:54 <jogo> dansmith: like a hard core gang?
21:26:55 <mriedem> jogo: feel free to weigh in on the spec then, you were at the summit session too
21:26:56 <dansmith> jogo: a number of folks hate server_groups as it is, so yeah, that
21:27:00 <mriedem> jogo: ha
21:27:02 <dansmith> jogo: lol
21:27:09 <mriedem> don't the HP guys like server groups?
21:27:17 * jogo pulls out the -2 hammer
21:27:19 <mriedem> PhilD and such?
21:27:24 <dansmith> I dunno
21:27:25 <jmulsow> To me it seems less confusing to have just remove than it is to have to figure out you need to delete the VM to get it out of the group
21:27:37 * gilliard not sure can check with PhilD tomorrow.
21:27:44 <n0ano> mriedem, that's my understanding, yes PhilD likes server groups
21:27:46 <mriedem> gilliard: thanks, i added him too just in case
21:27:57 <mriedem> PhilD must be busy externally lately...
21:28:07 <mriedem> anyway, we can move on - anyone interested or has input, please get it in the review
21:28:27 <jmulsow> Comments in the add review would be apreciated, too, so they can be addressed
21:28:35 <mriedem> jmulsow: link?
21:28:56 <jmulsow> https://review.openstack.org/#/c/139272/
21:28:59 <mriedem> #topic open discussion
21:29:01 * jogo -2ed
21:29:02 <mriedem> there was one item
21:29:03 <mriedem> Libvirt meetings. https://wiki.openstack.org/wiki/Meetings/Libvirt - Do they happen any more? Someone else was in that meeting room at the time mentioned there, and no minutes for months.
21:29:13 <mriedem> i don't know if danpb is doing those still
21:29:20 <gilliard> I went along and it was just a bunch of people talking about lbaas
21:29:25 <mriedem> gilliard: ha
21:29:29 <dansmith> I don't think there was this last time at least
21:29:29 <mriedem> almost the same
21:29:40 <mriedem> ok, i guess that's a better ML question
21:29:41 <dansmith> I saw people asking about it
21:29:53 <mriedem> #action post the libvirt meeting question to the ML
21:30:00 <gilliard> I'll do that
21:30:04 <mriedem> gilliard: thanks
21:30:08 <mriedem> ok, other open discussion?
21:30:22 <dansmith> no meetings until January?
21:30:28 <jogo> ++
21:30:34 <mriedem> tonyb: can you ask mikal ^?
21:30:38 <mriedem> i won't be attending
21:30:41 <tonyb> I am
21:30:54 <baoli_> mriedem: can we discuss the sr-iov specs now?
21:30:57 <clif_h> I'd like to get core eyes on this review if possible: https://review.openstack.org/#/c/141188/ this is to improve efficiency with the ironic driver using the ironic client
21:31:27 <tonyb> start again for the first thursday (2nd)?
21:31:35 <mriedem> tonyb: sounds good
21:31:46 <gilliard> That is an odd week, right?
21:31:53 <mriedem> clif_h: ok, it's not that old though, be patient :) and it's a wishlist bug
21:31:58 <dansmith> the second is friday
21:32:04 <alaski> Thursday is the 1st
21:32:06 <dansmith> so it will be the eight
21:32:07 <dansmith> h
21:32:09 <tonyb> gilliard: Yeah I guess so, unless we start at 0
21:32:13 <dims__> i have the nuke-xml reviews lined up
21:32:24 <dims__> and the ext3->ext4 as well
21:32:25 <mriedem> 1/1 won't happen for a meeting i don't think, at least in the US
21:32:33 <mriedem> baoli_: go ahead
21:32:36 <jogo> dims__: sweet
21:32:37 <bauzas> 8th Jan meeting is at 1400UTC
21:32:44 <clif_h> mriedem: sorry :) Is there any expected timeframe to get reviews reviewed?
21:32:46 <bauzas> just to be clear
21:32:50 <mriedem> baoli_: if they are for NFV, i don't think that's on the priority list though..
21:32:56 <tonyb> okay start then
21:33:01 <mriedem> clif_h: no, we just have a lot
21:33:07 <mriedem> clif_h: feel free to help review some others
21:33:24 <JayF> mriedem: the bug clif_h is working on is a wishlist bug in the tracker; but is impacting any Ironic installation of size (1 call to identity and 1 call to Ironic for every Ironic instance)
21:33:42 <JayF> So there's a strong desire in Ironic to get those fixes in.
21:33:57 <mriedem> sure, i'm not telling people to *not* review it
21:33:58 <baoli_> mriedem: we discussed these items during the summit
21:33:59 <mriedem> i'm just saying
21:34:04 <mriedem> baoli_: links?
21:34:15 <JoshNang> i've got the network json spec i'd love to get in before the deadline, needs 1 more +2, previously had +2 from dansmith and johnthetubaguy, and hasn't changed significantly since then. i've got the nova code proposed already, and we've got configdrive support ready. https://review.openstack.org/#/c/85673/
21:34:37 <mriedem> dansmith: johnthetubaguy: ^?
21:34:44 <baoli_> https://blueprints.launchpad.net/nova/+spec/sriov-live-migration https://blueprints.launchpad.net/neutron/+spec/api-specify-vnic-type https://blueprints.launchpad.net/nova/+spec/sriov-interface-attach-detach
21:34:45 * dansmith blinks
21:34:46 <mriedem> might be easy pickins before an exception requirement
21:34:59 <JoshNang> hopefully :)
21:35:15 <tsekiyama> Cinder iSCSI multipath & failover specs ( https://review.openstack.org/#/c/134299/ and https://review.openstack.org/#/c/137468/ ) was -1'ed just because of waiting for cinder-spec approval. Now cinder-specs are approved, so I'd like cores to recheck these.
21:35:16 <baoli_> one more: https://blueprints.launchpad.net/nova/+spec/sriov-sched-with-stateless-offloads
21:35:23 <jogo> mriedem: how are we doing with the kilo-1 goals we set at the summit?
21:35:34 <mriedem> jogo: we had goals
21:35:34 <mriedem> ?
21:35:35 <dansmith> JoshNang: I was proxying a +2 back on there, I think my last vote was -1 :)
21:35:49 <dims__> jogo: mriedem: :)
21:35:54 <mriedem> jogo: like CI for NFV?
21:36:01 <jogo> baoli_: is there CI for SRI-OV yet?
21:36:01 <johnthetubaguy> JoshNang: I can take a look, I do like the idea
21:36:03 <JoshNang> dansmith: ah, right you are
21:36:07 * jogo digs up the link
21:36:07 <mriedem> baoli_: is there CI running somewhere in the world for NFV yet?
21:36:07 <JoshNang> johnthetubaguy: thanks!
21:36:18 <dansmith> so, I can say some words on that
21:36:20 <dansmith> NFV CI
21:36:34 <dansmith> there are still a bunch of things that will require real hardware, of course,
21:36:36 <baoli_> mriedem: as far as I know, folks are working on them
21:36:40 <mriedem> baoli_: so that's like what 4 bps/specs there, and i don't think NFV is a project priority for kilo, the scheduler stuff trumps that as i recall
21:36:46 <JayF> johnthetubaguy: dansmith: FWIW we're running a downstreamed version of that JSON spec/code downstream, and also have code waiting for cloud-init to support that JSON format, so really we're just waiting on the spec to get done :(
21:36:50 <dansmith> but I think we have nailed down some very real ways to test NUMA on existing CI systems without much trouble
21:36:53 <mriedem> baoli_: they were also supposed to be working on them in juno
21:36:56 <jmulsow> Wanting to make sure we have reached a consensus for add/remove server group members. Does everyone agree that going forward in proposing these for the L release, these two specs need to be merged back together?
21:37:19 <mriedem> jmulsow: that's the way i'd lean
21:37:35 <n0ano> mriedem, NFV was never a priority for Nova, it might be for Neutron
21:37:52 <mriedem> dansmith: ok, i have no idea how related that is as a dependency for the 4 bp's that baoli_ linked above
21:37:58 <jogo> ahhhttps://etherpad.openstack.org/p/kilo-nova-milestone-targets
21:38:02 <jogo> #link https://etherpad.openstack.org/p/kilo-nova-milestone-targets
21:38:12 <mriedem> baoli_: is there a way to prioritize / stagger these specs?
21:38:23 <dansmith> mriedem: it's not at all, but you brought up NFV CI and numa was one of the things we identified as untested stuff that needed testing, and was previously hung on requiring hardware
21:38:39 <baoli_> mriedem, well, these specs are worked on by various folks.
21:39:07 <jogo> without CI for SRIOV I don't like the idea of adding more features to it
21:39:11 <baoli_> But we need cores' attention so that we can move forward
21:39:35 <mriedem> baoli_: yeah, core attention is on many things, and nfv isn't a priority for kilo given the list
21:39:38 <dansmith> jogo: we also found a couple critical issues with it right after we released juno
21:39:43 <mriedem> baoli_: and there are many bp's
21:39:46 <jogo> dansmith: exactly
21:39:50 <alex_xu> metion a bug about network https://review.openstack.org/116578 , it break network after migration, even l2 pop doesn't work afte migration. l2 pop is importart feature for neutron also. The fix alread there for sometime
21:40:05 <jogo> so based on https://etherpad.openstack.org/p/kilo-nova-milestone-targets
21:40:09 <mriedem> baoli_: i think from the nfv session we were hoping for more CI before more bp's, since it was the other way around in juno
21:40:11 <jogo> we are waayyy off
21:40:25 <mriedem> jogo: we've hit some of the k1 things
21:40:41 <tonyb> who was helping the CI happen?
21:40:44 <jogo> mriedem: want to go down the list
21:40:46 <mriedem> tonyb: good questoin
21:40:53 <mriedem> alex_xu: yeah, this just needs another +2 https://review.openstack.org/#/c/116578/
21:40:53 <dansmith> ian from HP
21:41:02 <tonyb> Ian from cisco said he had hw
21:41:03 <mriedem> jogo: did you ever talk to ian wells
21:41:12 <dansmith> oh, thought he was HP
21:41:13 <mriedem> lots of people said they had lots of stuff
21:41:15 <bauzas> jogo: this prioriryt milestone list maybe deserves an update
21:41:29 <baoli_> mriedem, the current CI is testing API only. But more stuff is being added
21:41:36 <bauzas> jogo: because for example some blueprints are not fully merged, but some patches in the series laned
21:41:37 <alex_xu> mriedem, yes, thanks for your +2, hope can merge, i think it really break some basic function
21:41:40 <bauzas> *landed
21:42:11 <JoshNang> johnthetubaguy: thanks for the review :)
21:42:11 <jogo> mriedem: no not sure what happened to him, I thought I said they have to initiate
21:42:30 <mriedem> baoli_: so unless others disagree, i think it might be helpful to take something to the nova mailing list and recap where we are with NFV, what specs are up and which are the most important (candidates for exceptions) and what is going on with the state of that CI
21:42:42 <jogo> mriedem: ++
21:42:58 <yjiang5> mriedem: jogo, I know our team member working on PCI CI.
21:43:01 <jogo> mriedem: can w e go down the list of 8 or so kilo 1 targets
21:43:06 <tonyb> mriedem: ++ from me
21:43:10 <mriedem> jogo: yeah, sec
21:43:14 <tonyb> mriedem: no idea about mikal
21:43:24 <baoli_> mriedem, ok, sounds good.
21:43:31 <mriedem> ok, going down the k1 milestone targets list
21:43:35 <mriedem> 1. cells
21:43:35 <jogo> cells
21:43:43 <jogo> you go for it
21:43:45 <mriedem> alaski is working through the testing gaps, there is an etherpad
21:43:52 <alaski> testing: down to around 40 failures from 153 to start
21:43:54 <mriedem> actually the wiki
21:43:57 <mriedem> #link https://wiki.openstack.org/wiki/Nova-Cells-v2
21:43:57 <alaski> so.. progress
21:43:59 <dansmith> I think we're doing or have done exactly what the k1 bit says
21:44:07 <bauzas> +1
21:44:08 <jogo> awesome, progress is good
21:44:09 <mriedem> yeah, 2 specs are merged, 2 are in flight
21:44:17 <dansmith> getting scheduler requirements, specs in progress some merged, testing is going
21:44:17 <mriedem> there are well attended weekly meetings
21:44:20 <jogo> we are off to a good start :)
21:44:23 <mriedem> yup
21:44:29 <mriedem> 2. glance client library
21:44:31 <mriedem> i have no idea on that
21:44:33 <alaski> yes, things are going well re: cells
21:44:34 <mriedem> flaper87: ^?
21:44:35 <dansmith> I think we merged something on that
21:44:39 <dansmith> the spec
21:44:45 <jogo> dansmith: yeah we dod
21:44:49 <jogo> did
21:44:50 <dansmith> so that's good
21:44:55 <johnthetubaguy> yeah, +1, saw that go in
21:45:12 <johnthetubaguy> was mean to be implemented, but its a step forward
21:45:18 <jogo> so maybe a bit behind but making strong progress on that as well
21:45:19 <mriedem> http://specs.openstack.org/openstack/nova-specs/specs/kilo/approved/remove-glanceclient-wrapper.html ?
21:45:27 <bauzas> that one
21:45:29 <mriedem> ok
21:45:42 <mriedem> 3. neutron - grenade testing with neutron is non-voting
21:45:50 <mriedem> mestery: mtreinish: ^?
21:45:50 <dansmith> I haven't heard anything about this
21:45:58 <jogo> mestery: ^
21:45:59 <mriedem> jogo: know anything about that?
21:46:03 <mriedem> guess not :)
21:46:06 <jogo> oh hmm
21:46:12 <jogo> I did see something let me check
21:46:14 <mriedem> #action mriedem to the ML on neutron grenade testing
21:46:24 <sdague> mriedem: there has been no progress on a sideways job yet that I've seen
21:46:26 <mestery> Yes, this is due to the services split, we're close.
21:46:28 <mestery> armax: ^^^
21:46:38 <sdague> mestery: neutron -> neutron is voting
21:46:43 <mestery> sdague: Ah
21:46:51 <mriedem> ok, so people are working it i assume?
21:46:52 <armax> sdague, mestery: that’s my understanding too
21:46:57 <mriedem> but $dependencies
21:46:59 <sdague> there is no nova -> neutron effort as far as I know
21:47:05 <mestery> sdague: Ah, ok, that makes sense.
21:47:09 <jogo> https://review.openstack.org/#/c/142741/
21:47:12 <jogo> its voting and working
21:47:16 <armax> sdague: you mean the sideways job?
21:47:22 <dansmith> sdague: is this supposed to be testing n-net to neutron?
21:47:31 <sdague> jogo: that's neutron => neutron
21:47:39 <jogo> right
21:47:40 <mriedem> i didn't think it was the same goal as nova-net to neutron migrations
21:47:53 <mriedem> i thought it was just neutron > neutron that wasn't working
21:47:54 <sdague> mriedem: oh, is this just neutron?
21:47:55 <jogo> not clear on what we meant by grenade testing with neutron as a goal for k1
21:48:00 <sdague> neutron is working
21:48:00 <mriedem> sdague: i thought so
21:48:11 <mriedem> neutron > neutron pre summit wasn't working in grenade
21:48:15 <mriedem> if it's working now, huzzah
21:48:20 <sdague> yeh, I'm not clear why neutron grenade would be a nova item :)
21:48:29 <sdague> sorry to add to confusion there
21:48:29 <mriedem> idk
21:48:30 <jogo> sdague: we are babysitting them
21:48:35 <mriedem> oooooo
21:48:37 <mestery> lol
21:48:42 <dansmith> yeah, there are sideways items in later milestones
21:48:48 <sdague> ok, yeh, that's been working for at least a week
21:48:51 <mriedem> moving on, 12 min left
21:48:56 * mestery is confused
21:49:00 <mriedem> funtional testing - sdague has that started
21:49:06 <mriedem> api samples tests are in functional
21:49:10 <mriedem> sdague: next steps on that?
21:49:16 <dansmith> fixture refactoring
21:49:21 <mriedem> links?
21:49:24 <jogo> we have the functional test tree, which was the gaol
21:49:33 <mriedem> oh those are k2, nvm
21:49:34 <dansmith> and we have some folks that are supposed to start work on some functional tests for numa to go into the functional tree
21:49:35 <mriedem> yeah
21:49:40 <mriedem> ok
21:49:41 <mriedem> moving on
21:49:52 <mriedem> there is a big sublist here for scheduler
21:49:56 <mriedem> test refactor - done right?
21:49:56 <bauzas> yeah
21:49:59 <jogo> mriedem: lets double back to that one
21:50:06 <bauzas> mriedem: in progress
21:50:09 <sdague> https://review.openstack.org/#/c/134532/ - or a month, as the case may be
21:50:14 <jogo> since that may take a while
21:50:29 <mriedem> not much time left, or items, so pushing through
21:50:35 <bauzas> mriedem: progress can be track using https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:master+topic:bp/make-resource-tracker-use-objects,n,z
21:50:37 <mriedem> nova objects for hardware.py?
21:50:44 <bauzas> mriedem: on the way too
21:50:49 <mriedem> cpu pinning?
21:50:51 <mriedem> i think that's done
21:50:55 <n0ano> mriedem, it is
21:50:58 * bauzas passes
21:50:58 <mriedem> huge pages
21:51:06 <bauzas> I think it's done
21:51:09 <n0ano> mriedem, needs one more +2
21:51:09 <dansmith> thatr's up I think
21:51:16 <mriedem> n0ano: link?
21:51:18 <bauzas> n0ano: you sure ?
21:51:25 <bauzas> we can ask sahid tomorrow
21:51:33 <n0ano> https://review.openstack.org/#/c/129608/
21:51:35 <dansmith> I think there is still plenty to merge for that, no?
21:51:48 <mriedem> https://review.openstack.org/#/q/status:merged+project:openstack/nova-specs+branch:master+topic:virt-driver-large-pages-kilo,n,z
21:51:53 <mriedem> oh that's the spec
21:51:54 <mriedem> nvm
21:52:05 <dansmith> maybe not
21:52:06 <jogo> dansmith: that was my impression too
21:52:16 <mriedem> ok so huge pages sounds like it's behind
21:52:34 <bauzas> ndipanov is off now but we can ask sahid tomorrow
21:52:44 <mriedem> ok, "detach service from compute node"
21:52:54 <bauzas> in progress, the main patches landed
21:53:00 <mriedem> ok
21:53:07 <bauzas> now, that's for compatiblity purposes
21:53:09 <mriedem> get_available_resources from virt layer
21:53:18 <bauzas> um
21:53:35 <bauzas> it was merged to anohter spec IIRC
21:53:42 <bauzas> n0ano: help ?
21:53:48 <mriedem> moving on
21:53:54 <bauzas> sure
21:54:01 <mriedem> we skipped moving the hypervisor support matrix into the devref
21:54:04 <mriedem> dansmith: ^?
21:54:07 <mriedem> or was that mikal?
21:54:08 <n0ano> not sure, all the specs (except jaypipes ) from our list have been accepted
21:54:09 <dansmith> that was mikal
21:54:14 <jogo> I thought I saw dapb patch up on that
21:54:14 <dansmith> I dunno if he did it or not, I haven't seen it
21:54:17 <gilliard> I thought danpb had a patch
21:54:18 <dansmith> not critical though
21:54:22 <mriedem> tonyb: punch mikal about hypervisor support matrix in devref
21:54:22 <bauzas> agreed
21:54:28 <mriedem> ok
21:54:35 <dansmith> mriedem: whilst driving?
21:54:35 <jogo> https://review.openstack.org/136380
21:54:51 <mriedem> dansmith: why not, it's australia, what could happen?
21:55:01 <dansmith> well, we could lose tonyb
21:55:03 <dansmith> mikal, meh
21:55:06 <gilliard> and a kangaroo
21:55:08 <mriedem> and a wallaby
21:55:08 <dims__> haha
21:55:09 <mriedem> ha
21:55:19 <mriedem> moving on
21:55:22 <tonyb> mikal is a terrible person
21:55:24 <mriedem> nova-net > neutron migration
21:55:26 <mriedem> mestery: ^ ?
21:55:31 <tonyb> he thought it had landed
21:55:53 <tonyb> we're walking from car -> cafe
21:55:53 <mestery> mriedem: I have an email out to the nuetorn dev working on that (obondarev)
21:55:59 <mestery> I was under the impression a spec was filed in nova, I found out today there was none :(
21:56:11 <mestery> I am trying to fix that
21:56:14 <mriedem> mestery: ah, our etherpad makes it sounds like a spec in neutron
21:56:14 <dansmith> hmm
21:56:24 <mestery> lol
21:56:28 <mestery> mriedem: I thought nova! :)
21:56:33 <dansmith> well,
21:56:34 <mriedem> i don't remember
21:56:37 <dansmith> I thought there were nova bits
21:56:41 <dansmith> and that those would be in our specs
21:56:43 <jogo> mestery: I don't see it in nova
21:56:46 <jogo> nova-specs
21:56:50 <dansmith> I'm a little concerned,
21:56:57 <dansmith> because this is supposed to be a big deal this cycle
21:57:02 <mestery> jogo: Yes, I found out it's not there, I reached out to obandarev, he's in Russia
21:57:23 <mestery> dansmith: It is, and I'm sorry if it's fallen through the cracks, that's on me, and I'm doing my best to recover it now.
21:57:30 <jogo> ahh, mestery can you send something to the ML about the progress of this
21:57:32 <mriedem> ok, so i guess we shoot for an exception
21:57:35 <mriedem> yeah pleease
21:57:36 <n0ano> since it's n-net -> neutron does that mean all the specs are in neutron?
21:57:42 <jogo> as this is kinda a big deal
21:57:43 <mestery> jogo: There was a thread on this last week
21:57:45 <mriedem> n0ano: don't think so
21:57:45 <mestery> We'll circle back
21:57:47 <jogo> (likst like mikal)
21:57:50 <jogo> mestery: oh? link
21:57:56 * mestery goes to look
21:57:59 <bauzas> n0ano: nope, it was not what was discussed in the summit IIRC
21:58:08 <mriedem> i saw some threads in nova about neutron vif drivers and plugins and stuff
21:58:12 <mriedem> i don't remember migration talk
21:58:21 <n0ano> then yes, sounds like something fell through the cracks
21:58:29 * bauzas checking the summit etherpad
21:58:37 <mestery> #link http://lists.openstack.org/pipermail/openstack-dev/2014-December/052771.html
21:58:39 <mestery> jogo: ^^^
21:58:45 <mestery> Not much, but I'll get to the bottom of this.
21:58:47 <bauzas> https://etherpad.openstack.org/p/kilo-nova-nova-network-to-neutron
21:59:02 <jogo> mestery: thanks
21:59:06 <mriedem> and this http://lists.openstack.org/pipermail/openstack-dev/2014-November/050406.html
21:59:14 <jogo> 1 minute and 1 more to go
21:59:20 <mriedem> gdi
21:59:26 <mriedem> microversions?
21:59:35 <mriedem> land first as proof it works
21:59:36 <mriedem> anyone know?
21:59:38 <mriedem> alex_xu: ^?
21:59:50 <dansmith> I thought it was landing imminently
21:59:50 <gilliard> I think they're almost all merged
21:59:51 <sdague> the infrastructure patches are still landing, I think about 1/2 are in
21:59:57 <tonyb> mriedem: I didn't think we were quite there yet
22:00:10 <mriedem> ok, i haven't been on those, but ok
22:00:11 <n0ano> bauzas, look at the milestones sections of that etherpad - "Most of this is a neutron work"
22:00:24 <bauzas> n0ano: agreed
22:00:31 <mriedem> last item was midcycle - i think that's in the ML - register early or you might be stuck
22:00:33 <tonyb> mriedem: I'll find cyeoh and ask him.
22:00:37 <mriedem> tonyb: thanks
22:00:38 <mriedem> ending meeting
22:00:44 <mriedem> #openstack-nova for the rest
22:00:45 <mriedem> thanks
22:00:47 <mriedem> #endmeeting