14:00:16 <johnthetubaguy> #startmeeting nova
14:00:17 <openstack> Meeting started Thu Jan  8 14:00:16 2015 UTC and is due to finish in 60 minutes.  The chair is johnthetubaguy. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:18 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:20 <openstack> The meeting name has been set to 'nova'
14:00:27 <alaski> o/
14:00:32 <bauzas> \o
14:00:34 <alex_xu> o/
14:00:34 <heyongli-> hi
14:00:35 <n0ano> o/
14:00:37 <gilliard> Hi
14:00:37 <sdague> o/
14:00:47 <dansmith> o/
14:00:49 <edleafe> o/
14:00:51 <johnthetubaguy> #topic kilo specs
14:00:52 <abhishekk> o/
14:00:53 <baoli> Hi
14:00:57 <johnthetubaguy> Happy new year all
14:01:08 <abhishekk> Happy new year all
14:01:17 <johnthetubaguy> so, the spec freeze has happened
14:01:18 <dims__> o/
14:01:27 * bauzas just wising a new year for ibvious reasons
14:01:28 <johnthetubaguy> we need an exception process, holidays got in the way of that
14:01:37 <johnthetubaguy> so...
14:01:50 <johnthetubaguy> step 1: email ML to request exception
14:02:02 <abhishekk> johnthetubaguy: https://review.openstack.org/#/c/135387/ nova-spec for unshelve needs review
14:02:12 <johnthetubaguy> step 2: nova-drivers review spec, vote −2 if they don't think it needs doing
14:02:17 <johnthetubaguy> during kilo
14:02:40 <johnthetubaguy> step 3: if two people have +2ed it for kilo, it merges as normal
14:02:49 <bauzas> how many nova-drivers for an exception ?
14:02:54 <bauzas> eh
14:02:58 <johnthetubaguy> step 4: but there is a deadline, two weeks before kilo
14:03:06 <johnthetubaguy> bauzas: I think I sad two above
14:03:10 <johnthetubaguy> so...
14:03:15 <johnthetubaguy> does that sound sane?
14:03:17 <bauzas> johnthetubaguy: yeah cross-posted
14:03:18 <dims__> johnthetubaguy: kilo-2?
14:03:21 <n0ano> in re: step 1 - any special format to the subject line so it doesn't get lost in the noise?
14:03:32 <johnthetubaguy> dims__: yeah, sorry, two weeks before kilo-2
14:03:36 <dims__> :)
14:03:59 <bauzas> how long is during the exception to leave the spec merged ? one week ?
14:04:00 <johnthetubaguy> n0ano: I guess, something like "[nova] request spec freeze exception for XXXX"
14:04:22 <dims__> sounds sane to me!
14:04:26 <johnthetubaguy> bauzas: till the deadline, two weeks before kilo-2 (assuming thats not last week, goes to find date...)
14:04:38 <bauzas> ok and then you fence
14:04:44 <bauzas> then I'm +1
14:04:55 <jaypipes> o/ hio guys
14:04:56 <n0ano> other thing, is the only notice that the exception is granted the fact that two +2s happen or is there some kind of official notice
14:05:06 <johnthetubaguy> dansmith: alaski: didn't put any core review sponsors on this one, as leaving that for the feature freeze at end of kilo-2, that sound OK?
14:05:08 <bauzas> two weeks before K2 is Jan 24th IIUC
14:05:28 <bauzas> I mean 29th
14:05:40 <dansmith> johnthetubaguy: core sponsors on which?
14:05:40 <johnthetubaguy> #link https://wiki.openstack.org/wiki/Kilo_Release_Schedule
14:05:44 * dansmith is multi-meeting-tasking
14:06:10 <johnthetubaguy> dansmith: I am just letting nova-specs-core vote in gerrit on the spec exceptions
14:06:11 <bauzas> oops 22th then
14:06:35 <johnthetubaguy> dansmith: was going to ignore nova-core sponsors till feature freeze, where we need three again
14:06:36 <dansmith> johnthetubaguy: oh I see, I thought you were referencing a spec
14:06:59 <johnthetubaguy> dansmith: its just the spec at this point, but yeah, I am ignore nova-core votes on the code for now
14:07:05 <dansmith> johnthetubaguy: yes, agreed, drivers for this, and any driver -2 NAKs, otherwise usual two drivers required to merge?
14:07:09 <alaski> johnthetubaguy: I'm fine with leaving the sponsorship off
14:07:13 <dansmith> basically, standard gerrit rules
14:07:16 <johnthetubaguy> #action johnthetubaguy to write up the plan and email the dev list
14:07:25 <johnthetubaguy> dansmith: yeah, cool, seemed silly to do anything else
14:07:38 <johnthetubaguy> OK, so thats the exception process
14:07:39 <dansmith> so is the goal to get every spec either -2'd or merged?
14:07:47 <johnthetubaguy> dansmith: I think so
14:07:51 <jaypipes> it should be, yes
14:08:05 <dansmith> okie
14:08:16 <johnthetubaguy> I plan to try and go through them all, and do the "big" −2 pass, skipping ones that I want to have an exception on
14:08:25 <johnthetubaguy> hopefully this afternoon
14:08:26 <dims__> johnthetubaguy: reviews need to be ready when the request for exception is sent?
14:08:40 <dansmith> if something isn't ready now,
14:08:43 <dansmith> it should be -2d anyway
14:08:50 <dims__> right
14:08:54 <edleafe> dansmith: +1
14:08:56 <dansmith> specs that get exceptions should be ones that are really close, already maybe voted on once, etc I think
14:09:05 <dims__> +1 dansmith
14:09:12 <johnthetubaguy> yeah, thats fair, stuff where you are likely to get the code up soon
14:09:15 <jaypipes> dansmith: any chance you could ask danpb to hop on #openstack-nova for the next couple days, since he's on nova-drivers?
14:09:30 <johnthetubaguy> I don't want to check that, or require that, more recommend that
14:09:43 <dansmith> jaypipes: I can ask
14:09:48 <jaypipes> thx
14:10:15 <johnthetubaguy> anyways, any more questions on that, I will mail out a summary of the plan today
14:10:30 <jaypipes> not from me, thanks john
14:10:33 <edleafe> sounds good
14:10:45 <johnthetubaguy> next sub topic, kilo-2 marks nova feature freeze
14:11:08 <johnthetubaguy> so there was a plan that you need a feature freeze exception, or be on the priority list, to merge code in kilo-3
14:11:19 <johnthetubaguy> I am guessing folks are still cool with that idea?
14:11:40 <johnthetubaguy> #info kilo-2 will be feature freeze for things not on the priorities list
14:11:52 <n0ano> johnthetubaguy, does that apply to bug fixes?
14:11:52 <dansmith> sounds good to me
14:12:11 <johnthetubaguy> n0ano: well bugs are on the priority list, I guess
14:12:18 <johnthetubaguy> cools
14:12:28 <johnthetubaguy> #topic Kilo priorities
14:12:29 <n0ano> and not a feature - silly me, never mind
14:12:46 <johnthetubaguy> hands up for any updates or questions?
14:13:16 <johnthetubaguy> any specs for priority things people want to raise here
14:13:23 <jaypipes> johnthetubaguy: https://review.openstack.org/#/c/127609/
14:13:46 <johnthetubaguy> jaypipes: I vote we give that an exception, once we are happy with it
14:14:00 <anteaya> the only question is if the nova net to neutron migration needs a nova spec, which wwe don't know yet
14:14:04 <johnthetubaguy> but will let the drivers vote in gerrit, as per the process
14:14:06 <jaypipes> johnthetubaguy: needs your and danpb's input.
14:14:24 <johnthetubaguy> jaypipes: ack
14:14:47 <n0ano> also, https://review.openstack.org/13844 could use some attention
14:15:01 <n0ano> s/13844/138444
14:15:31 <bauzas> n0ano: I think this spec also needs to ask for an exception
14:15:47 <johnthetubaguy> bauzas: seems reasonable to me
14:16:06 <johnthetubaguy> anyways, those are two good ones I will help try get in
14:16:13 <bauzas> cool
14:16:13 <edleafe> bauzas: Already writing the exception request... :)
14:16:14 <baoli> johnthetubaguy: we have a few sriov-related specs, http://lists.openstack.org/pipermail/openstack-dev/2015-January/053917.html.
14:16:56 <johnthetubaguy> baoli: thats not on the priority list at this point, but feel free to make the case on the ML
14:17:11 <johnthetubaguy> #topic Gate Status
14:17:13 <heyongli-> and to pci, intel setting up a CI, want to comments nova repo, so pci/sriov related featues could get tested at lest.
14:17:20 <baoli> johnthetubaguy, will do after your email is out.
14:17:45 <heyongli-> johnthetubaguy,
14:17:46 <heyongli-> https://wiki.openstack.org/wiki/ThirdPartySystems/Intel-PCI-CI
14:17:46 <heyongli-> here is the CI infomation
14:17:53 <johnthetubaguy> baoli: heyongli-: I would expect specs to be rejected until the CI is working, but we can talk about that later on
14:17:53 <heyongli-> a sample logs:
14:17:54 <heyongli-> http://192.55.68.190/143614/6/
14:18:02 <johnthetubaguy> so gate status
14:18:09 <johnthetubaguy> any news from people?
14:18:19 <heyongli-> johnthetubaguy, sure, let talk the CI late
14:18:46 <johnthetubaguy> #topic Bugs
14:18:52 <johnthetubaguy> anything on bugs from people
14:18:54 <sdague> johnthetubaguy: the big current issue is the warnings problem on juno unit tests
14:19:08 <dansmith> I have a bug thing
14:19:13 <sdague> from a gate perspective, I'm actually trying to figure out the right fix for that one
14:19:23 <johnthetubaguy> dansmith: fire away
14:19:26 <dansmith> https://review.openstack.org/#/c/145292/
14:19:36 <dansmith> ^ that is a fix for the live migration RPC stuff,
14:19:44 <dansmith> which basically turns the error into a very verbose warning,
14:19:56 <dansmith> based on a best guess if the migration is shared-block,
14:20:01 <dansmith> assuming so if it doesn't know
14:20:17 <johnthetubaguy> hmm, OK
14:20:18 <dansmith> doing anything more sophisticated is really (really) tricky at this point
14:20:35 <dansmith> so I just want to encourage thought and review on that
14:20:37 <johnthetubaguy> dansmith: making the best of a bad situation makes sense I guess
14:20:45 <dansmith> once you bump past the icehouse RPC version, the warning goes away
14:20:49 <dansmith> and we can drop it later
14:20:59 <johnthetubaguy> makes sense
14:21:22 <johnthetubaguy> any more on bugs?
14:21:30 <dims__> i have one - ext4 as ephemeral disk - has a long history and worked on by many folks before
14:21:32 <dims__> https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:master+topic:bug/1266262,n,z
14:21:44 <dims__> could use input!
14:21:51 * mriedem slinks in late
14:21:59 <johnthetubaguy> dims__: is that a feature or is that just me?
14:22:13 <dims__> mriedem: and jogo pointed me to this
14:22:17 <johnthetubaguy> mriedem: we are on bugs, but we can stretch that to gate bugs, if there is anything to be raised
14:22:31 <mriedem> johnthetubaguy: nothing for nova i don't think, neutron has been blowing up this week
14:22:36 <dims__> johnthetubaguy: it's being treated a bug with multiple reviews abandoned
14:22:37 <mriedem> some ssh no route to host failure
14:23:01 <mriedem> http://status.openstack.org/elastic-recheck/gate.html
14:23:15 <johnthetubaguy> dims__: its always the debate about whats supported in what distros, I think
14:23:40 <sdague> johnthetubaguy: honestly, the ext4 default is something that we should have switched to a long time ago. We're forcing it over in the gate on test runs for a long time because ext3 there slows things down a bunch
14:23:42 <dansmith> johnthetubaguy: yeah, doesn't seem like a bug to me at all
14:23:44 <dims__> yep, i have a bunch of pointers to previous work in the commit message
14:24:27 <dims__> dansmith: i'd agree
14:24:29 <mriedem> from what i remember it was ok to switch to ext4 in juno
14:24:45 <mriedem> as the default since we advertised it in icehouse
14:25:42 <dims__> we can continue conversation on the 2 reviews, don't want to hold up
14:25:54 <johnthetubaguy> dims__: want about adding a blueprint we can just approve without a spec?
14:26:00 <johnthetubaguy> dims__: just for tracking really
14:26:06 <dims__> johnthetubaguy: works for me
14:26:18 <sdague> +1
14:26:29 <johnthetubaguy> lets move on
14:26:30 <mriedem> you could also send a heads up to the operators list, since PhilD was the one that raised the issue long ago after it was first changed
14:26:44 <dims__> mriedem: will do
14:27:09 <johnthetubaguy> dims__: probably worth reaching out to phil directly
14:27:11 <johnthetubaguy> anyways
14:27:20 <johnthetubaguy> #topic stuck reviews
14:27:26 <johnthetubaguy> I guess we did most of that
14:27:33 <johnthetubaguy> I vote we leave any more till the end...
14:27:42 <bauzas> agreed
14:27:43 <johnthetubaguy> #topic nova-net to neutron migration
14:27:48 <anteaya> hi
14:27:54 <anteaya> #link http://lists.openstack.org/pipermail/openstack-dev/2014-December/053355.html
14:27:56 <johnthetubaguy> anteaya: fire away
14:28:15 <anteaya> this email thread is trying to get some folks to congregate around a regular meeting time
14:28:33 <anteaya> folks are being identified and once a meeting is selected it will be posted to -dev
14:28:39 <johnthetubaguy> in terms of process, do you think you will know the specs you need before we reach the end of jan?
14:28:42 <anteaya> that is all I have this week
14:28:52 <anteaya> I ssure hope so
14:29:06 <anteaya> if not this effort is really in trouble for kilo
14:29:09 <johnthetubaguy> anteaya: next week we can just cover this under priorites
14:29:17 <johnthetubaguy> anteaya: its on our list there
14:29:22 <anteaya> great thanks
14:29:29 <johnthetubaguy> anteaya: but really appreciate you pushing on this :)
14:29:30 <anteaya> my first meeting so wastn't sure
14:29:34 <anteaya> thank you for the support
14:29:43 <johnthetubaguy> np
14:29:49 <johnthetubaguy> #topic Open Discussion
14:30:05 <johnthetubaguy> before we talk about early marks, anyone got anything they want to raise?
14:30:15 <alex_xu> o/, may I looking from some eyes on policy stuff, the base patch is ready, the contributors are waiting for those base patch merged, then they can begin to work on subsequent tasks https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:master+topic:bp/v3-api-policy,n,z thanks in advance!
14:30:22 <heyongli-> johnthetubaguy, anteaya we want start comment to nova repo for our CI
14:30:45 <abhishekk> johnthetubaguy: I have submitted a nova-spec for improving unshelve api performance
14:31:02 <mriedem> abhishekk: do you have code up for review?
14:31:17 * anteaya notes if anyone cares she is might lose internet anytime
14:31:18 <johnthetubaguy> abhishekk: it will need a spec exception, as described earlier, assuming you are almost ready with code there
14:31:38 <abhishekk> mriedem: I have code ready, testing it in my environment
14:31:50 <mriedem> abhishekk: you should probably get it posted then
14:31:56 <mriedem> even if only WIP
14:32:06 <johnthetubaguy> abhishekk: yep, sounds OK, please follow the spec freeze exception process
14:32:17 <johnthetubaguy> heyongli-: lets talk about the CI
14:33:01 <abhishekk> johnthetubaguy: thank you, I have sent a mail for freeze exception process
14:33:02 <heyongli-> johnthetubaguy, we will start comments recent day, now we had some basic pci test case runing already
14:33:10 <heyongli-> Test cases on github:
14:33:11 <heyongli-> https://github.com/intel-hw-ci/Intel-Openstack-Hardware-CI/tree/master/pci_testcases
14:33:30 <johnthetubaguy> heyongli-: are you running tempest?
14:33:35 <johnthetubaguy> I guess thats a no?
14:33:40 <heyongli-> johnthetubaguy, yes, for about one month
14:33:50 <abhishekk> mriedem: thank you, I will may be in the middle of next week (probably next thursday)
14:34:04 <heyongli-> not all tempest, just PCI related test case, help by tempest.
14:34:13 <johnthetubaguy> heyongli-: were did you say you were sending reports again?
14:34:39 <heyongli-> johnthetubaguy, i confused, what report?
14:34:58 <mriedem> do we have a post-merge queue/report site or anything? i know we talked about that at the summit.
14:35:07 <mriedem> like periodic jobs
14:35:16 <johnthetubaguy> heyongli-: the list of test results, how many pass vs fail, how well you keep up with all the patches, etc
14:35:32 <johnthetubaguy> mriedem: bit out of touch, not see one, but a good question...
14:35:48 <mriedem> sdague: are you aware of any post-merge jobs/results posted anywhere?
14:36:10 <heyongli-> johnthetubaguy, now, about 10 testcases now, will add more later,
14:36:32 <sdague> mriedem: they live in jenkins or can be emailed out
14:36:36 <sdague> there is no nice dashboard
14:36:45 <heyongli-> for now oure resources could catch up patch sets, if needed, we will add more machine for that.
14:36:59 <mriedem> sdague: is there any 3rd party jobs reporting to that?
14:37:03 <mriedem> *are there
14:37:32 <johnthetubaguy> heyongli-: OK, not sure I understand what you are asking about the CI, you are wanting to vote in jenkins?
14:37:53 <anteaya> johnthetubaguy: I told him he had to ask before he could comment on nova patches
14:38:00 <heyongli-> johnthetubaguy, no, not request to vote, just annouce, we going to start comments,
14:38:03 <anteaya> that may be what he is asking permission to do
14:38:08 <johnthetubaguy> right, got it
14:38:12 <steveg> johnthetubaguy, the intent ultimately would ideally be to vote on nova patches
14:38:16 <johnthetubaguy> heyongli-: I guess you have followed this: http://ci.openstack.org/third_party.html
14:38:19 <heyongli-> hope people can get attention.
14:38:21 <steveg> currently iirc the SR-IOV reporting is only on neutron
14:38:35 <heyongli-> johnthetubaguy, yeah, and anteaya help us to make it,
14:38:38 <steveg> which is the gap heyongli is aiming to close on the nova side
14:38:38 <johnthetubaguy> heyongli-: I think we would like to see it writing into gerrit, before it starts voting
14:38:46 <johnthetubaguy> and see it prove its-self
14:38:47 <sdague> mriedem: oh, 3rd party, no there is no place for that outside the system
14:39:14 <anteaya> heyongli-: so sounds to mee like you can comment now, congratulations
14:39:19 <johnthetubaguy> heyongli-: have you got a link to a wiki page on the CI system again?
14:39:31 <heyongli-> johnthetubaguy, sure, we we keep it runing and make stable ASAP, so it will worth to help push PCI feature and bugs.
14:39:44 <johnthetubaguy> anteaya: I am ok with commenting, yeah, not sure what others are thinking
14:40:06 <heyongli-> johnthetubaguy, https://wiki.openstack.org/wiki/ThirdPartySystems/Intel-PCI-CI
14:40:16 <anteaya> mriedem: there is an effort to get stackforge/radar into shape for a third party dashboard: http://git.openstack.org/cgit/stackforge/radar/
14:40:20 <mriedem> commenting on patches as a non-voting job is fine as long as it's not just noise right?
14:40:25 <heyongli-> testcases: https://github.com/intel-hw-ci/Intel-Openstack-Hardware-CI/tree/master/pci_testcases
14:40:27 <anteaya> mriedem: sweston is driving that
14:40:50 <mriedem> like the nova-docker job is busted so it always fails until nova-docker is fixed
14:41:08 <mriedem> cells used to be that way, so we moved it to the experimental queue
14:41:49 <heyongli-> johnthetubaguy, if you want some sample running log, there it is:http://192.55.68.190/137715/13/
14:41:49 <heyongli-> http://192.55.68.190/133269/14/
14:41:59 <johnthetubaguy> heyongli-: OK, we also need the list of tempest tests that are being skipped, etc, but we can talk more about that off line I think
14:42:16 <mriedem> skipped == most of them http://192.55.68.190/137715/13/testr_result.html.gz
14:42:17 <johnthetubaguy> heyongli: ah, I think I see the tempest tests there, cool
14:42:23 <heyongli-> johnthetubaguy, the resize is skipped, because it's had bug now.
14:43:05 <mriedem> heyongli: these tests don't live in tempest http://git.openstack.org/cgit/openstack/tempest/tree/tempest/api/compute/servers
14:43:12 <mriedem> are you contributing those upstream?
14:43:27 <johnthetubaguy> heyongli-: I don't fully understand why you don't just run the regular tempest tests, you can tell tempest what flavor to launch in its config?
14:43:30 <heyongli-> mriedem, i tried suggested by jogo, but reject.
14:43:59 <mriedem> heyongli: hmm, i'd think tempest could have them if there was a config flag to say whether or not pci is supported
14:43:59 <anteaya> heyongli-: can you share the link to the patch where that discussion took place?
14:44:03 <heyongli-> johnthetubaguy, regular trempest tests can not verify pci test cases now.
14:44:20 <mriedem> i'd think a qa-spec is in order at least for the discussoin
14:44:26 <heyongli-> anteaya, sure. a moment.
14:44:42 <johnthetubaguy> heyongli-: but just launching the VM is a good testing, testing you can ssh is great if it was a PCI passthrough NIC right?
14:44:46 <dansmith> do we need to keep all the nova folks on the line for this/
14:45:04 <johnthetubaguy> dansmith: you are right, I tried to say that early but was too chicken
14:45:06 <mriedem> we can move it to -qa
14:45:16 <johnthetubaguy> mriedem: thanks
14:45:30 <johnthetubaguy> OK, thats all folks I think, lets move the CI convo offline
14:45:32 <sdague> mriedem: there was a discussion, the pci tests require *so* much specific config that they are pretty far outside the test model for tempest
14:46:05 <heyongli-> johnthetubaguy, this is a specfic test cases, we make sure pci does assiged to vm for now, and for more advanced test like ping via nic and ping via sriov will come soon.
14:46:53 <johnthetubaguy> heyongli-: what I mean is tempest will do the NIC test for you right now, so you don't need any specific PCI tests
14:46:54 <mriedem> any other topics?
14:46:56 <johnthetubaguy> anyways, let move on
14:47:05 <johnthetubaguy> any more for any more?
14:47:07 <johnthetubaguy> no...
14:47:07 <heyongli-> johnthetubaguy, currently running test cases assign pci to vm, login and check them, do reboot,resume... to make sure basic function ok.
14:47:13 <mriedem> let's call it
14:47:16 <mriedem> and move to other channels
14:47:17 <johnthetubaguy> yep
14:47:17 <dansmith> +1
14:47:21 <johnthetubaguy> #endmeeting