14:01:53 <johnthetubaguy> #startmeeting nova
14:01:54 <openstack> Meeting started Thu Apr 16 14:01:53 2015 UTC and is due to finish in 60 minutes.  The chair is johnthetubaguy. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:55 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:57 <openstack> The meeting name has been set to 'nova'
14:02:01 <alaski> o/
14:02:06 <n0ano> o/
14:02:07 <claudiub> o/
14:02:07 <dansmith> o/
14:02:08 <edleafe> \o
14:02:08 * bauzas waves officiallyu
14:02:09 <abhishekk> o/
14:02:13 <bauzas> \o
14:02:24 <alex_xu> o/
14:02:25 <sdague> o/
14:02:38 <anteaya> o/
14:02:44 <johnthetubaguy> #topic kilo release status
14:02:51 <johnthetubaguy> hello all
14:02:55 <johnthetubaguy> so we have RC1 out the door
14:03:05 <johnthetubaguy> we have master open for liberty
14:03:13 <johnthetubaguy> but there are some bloopers we need to fix
14:03:19 <gilliard> o/
14:03:20 <johnthetubaguy> and RC2 is being triggered
14:03:31 <johnthetubaguy> but we need to look at what *really* needs to be in there
14:03:44 <johnthetubaguy> the current plan is to add *possible* candidates here:
14:03:50 <johnthetubaguy> https://bugs.launchpad.net/nova/+bugs?field.tag=kilo-rc-potential
14:04:04 <ndipanov> o/
14:04:09 <sahid> o/
14:04:14 <johnthetubaguy> I believe ttx is going to help review that list tomorrow, to see what we push into RC2
14:04:29 <johnthetubaguy> so if you have strong views, please do add comments to the bugs
14:04:37 <bauzas> johnthetubaguy: any idea *when* shipping RC2 ?
14:04:39 <sdague> johnthetubaguy: so about an hour ago I discovered this - https://bugs.launchpad.net/nova/+bug/1445021 - which seems like it might need to add to that list
14:04:40 <openstack> Launchpad bug 1445021 in OpenStack Compute (nova) "nova-compute does not start after upgrade from juno->kilo if there are boot from volume servers running" [Critical,New]
14:05:04 <dansmith> yeah
14:05:07 <dansmith> that one is bad
14:05:10 <johnthetubaguy> #info for really bad bugs you want into RC2 please tag with kilo-rc-potential https://bugs.launchpad.net/nova/+bugs?field.tag=kilo-rc-potential
14:05:26 <johnthetubaguy> +1 I added a tag
14:05:38 <johnthetubaguy> sdague: honestly, thats worth delating RC2 to get a fix in
14:05:51 <sdague> johnthetubaguy: yeh, if we can figure out what the fix is
14:06:02 <johnthetubaguy> sdague: good point
14:06:25 <johnthetubaguy> I mean we can wait until monday, I believe, but will have to check
14:07:00 <ndipanov> sdague, I think I know what the fix could be
14:07:04 <johnthetubaguy> bauzas: to answer your question, it happens sometime after today, when we are happy with the list of things we have
14:07:04 <bauzas> would it be possible to see with logstash when it happened ?
14:07:04 <ndipanov> let me propose something
14:07:09 <sdague> ndipanov: ok
14:07:15 <ndipanov> sdague, but let's talk after the meeting
14:07:21 <johnthetubaguy> cools, good stuff
14:07:22 <bauzas> johnthetubaguy: yeah my question was before sdague's point which is totally valuable
14:07:23 <sdague> bauzas: no, this is discovered in a new test
14:07:31 <bauzas> ah
14:08:02 <johnthetubaguy> so, any more things on kilo?
14:08:11 <ndipanov> so this code has been like that for a long time, and I am really surprised that it worked
14:08:22 <ndipanov> but let me comment on the bug - disregard me
14:08:31 <johnthetubaguy> … time for more tests, tests are good
14:08:38 <johnthetubaguy> anyways, lets move on
14:08:49 <johnthetubaguy> #topic liberty release status
14:08:56 <johnthetubaguy> so we are open for liberty
14:09:02 <johnthetubaguy> its time to upload nova-specs
14:09:07 <johnthetubaguy> its time to review them too
14:09:20 <bauzas> planning a review day ?
14:09:26 <johnthetubaguy> ping me if there is any process confusion, and I can try answer "what do I do next?"
14:09:27 <dansmith> I have a spec question
14:09:28 <bauzas> like last cycle ?
14:09:49 <johnthetubaguy> bauzas: possible, I am keen for one before the summit, if thats feasible
14:09:54 <bauzas> +1
14:09:56 <dansmith> I put this in open discussion but I'll ask it here: we need to move to using the oslo.versionedobjects library this cycle.. do we need a spec for that, or is it straightforward enough for just a bp?
14:10:12 <johnthetubaguy> thats a good question
14:10:20 <johnthetubaguy> I am OK with that been spec-less
14:10:20 <bauzas> dansmith: sounds like the code is nearly the same right ?
14:10:35 <sdague> dansmith: I think just a bp
14:10:39 <bauzas> dansmith: I briefly looked at it and found very few diffs
14:10:41 <dansmith> it's very close.. we have some changes we have to make, and more just transition code to make it seamless
14:10:44 <johnthetubaguy> we need to track it, so lets just have a bp
14:10:48 <dansmith> okay
14:10:51 <sdague> I'm not sure there is anything that really needs discussing
14:10:59 <johnthetubaguy> sdague: +1
14:11:00 <dansmith> cool
14:11:16 <johnthetubaguy> so on specs,
14:11:23 <johnthetubaguy> previously-approved: kilo
14:11:36 <johnthetubaguy> is a really handy git commit tag to fast approve from kilo -> liberty
14:11:58 <johnthetubaguy> so other things...
14:12:07 <johnthetubaguy> there is likely to be a change on how we use milestones
14:12:15 <johnthetubaguy> https://wiki.openstack.org/wiki/Release_Cycle_Management/Liberty_Tracking
14:12:22 <johnthetubaguy> working with ttx on what we do there
14:12:31 <bauzas> https://review.openstack.org/#/q/project:openstack/nova-specs+is:open+message:%22previously%22,n,z
14:12:38 <johnthetubaguy> basically, more likely just to use milestones to tell people when it happened
14:12:53 <dansmith> which is kinda what happens now :)
14:13:04 <dansmith> i.e. punt from milestone to milestone until it's done :)
14:13:09 <johnthetubaguy> dansmith: yeah, :)
14:13:20 <johnthetubaguy> its basically adminiting defeat
14:13:27 <dansmith> at least we're honest :)
14:13:32 <johnthetubaguy> yeah
14:13:35 <johnthetubaguy> feels better
14:13:43 <johnthetubaguy> and its much less faffing about
14:13:52 <johnthetubaguy> cools
14:14:00 <johnthetubaguy> #link https://etherpad.openstack.org/p/liberty-nova-summit-ideas
14:14:08 <johnthetubaguy> #link https://etherpad.openstack.org/p/liberty-nova-priorities
14:14:25 <johnthetubaguy> so its time to start getting suggestions for summit discussion put in the etherpads
14:14:39 <johnthetubaguy> there are places for cross-project ones too (see ML message)
14:14:52 <johnthetubaguy> more on that soon I suspect
14:15:18 <johnthetubaguy> I would love to see nova-specs for the features people want to discuss, to try avoid usless sessions that could just be a spec discussion
14:15:24 <johnthetubaguy> but thats all
14:15:28 <johnthetubaguy> any more on process?
14:15:47 <johnthetubaguy> #topic Bugs
14:16:03 <ndipanov> johnthetubaguy, I won't be at the summit this time - but I feel the last thing on the priorities list is kind of my area
14:16:07 <johnthetubaguy> how is the gate doing, nova wise?
14:16:31 <ndipanov> johnthetubaguy, any ideas how I can still get some feedback on that (ML?)
14:16:36 <sdague> johnthetubaguy: seems pretty solid
14:16:36 <johnthetubaguy> ndipanov: we will do a spec thingy again for priorities, so there should be space to comment without being at the design summit
14:16:37 <ndipanov> sorry to go back to the previous topic
14:17:00 <ndipanov> ok
14:17:11 <johnthetubaguy> ndipanov: can we punt that till open discussion, sorry moved on too quickly, but yes, ML is good too
14:17:18 <johnthetubaguy> anything more on bugs?
14:17:42 * mriedem joins late
14:17:54 <johnthetubaguy> mriedem: just in the bug section if you have anything
14:17:59 <mriedem> nada
14:18:04 <johnthetubaguy> #topic open discussion
14:18:15 <dansmith> oops
14:18:16 <johnthetubaguy> so I have a few notes on the agenda to go first...
14:18:20 <dansmith> I put my items under review requests
14:18:23 <dansmith> didn't mean to
14:18:24 * dansmith edits
14:18:36 * johnthetubaguy clicks refresh
14:18:44 <johnthetubaguy> so there are some review requests
14:18:44 <dansmith> done
14:18:50 <kashyap> mriedem: You might want to mention you've got the offending test from live snapshot bug passing w/ the experimental Fedora job :-)
14:18:52 <abhishekk> hi, Improve performance of unshelve api - https://review.openstack.org/135387
14:18:58 <johnthetubaguy> https://review.openstack.org/160658 https://review.openstack.org/170031 https://review.openstack.org/135387
14:19:05 <johnthetubaguy> those folks request reviews
14:19:12 <johnthetubaguy> not sure any are "stuck"
14:19:24 <dansmith> none of these are stuck, IMHO
14:19:30 <johnthetubaguy> right
14:19:48 <abhishekk> @all, since liberty is open for review, could you please give feedback on specs when you get time
14:20:12 <johnthetubaguy> abhishekk: please email mikal about removing his -2, if that doesn't happen quickly, but yes, we are reviewing the specs now
14:20:33 <johnthetubaguy> dansmith: your note about flavor stuff?
14:20:38 <dansmith> yeah, so,
14:20:40 <ndipanov> one juno bug I backported - since it's a tricky backport - wanted to get attention of people who are also on nova-stable-maint https://review.openstack.org/#/c/173226/
14:20:42 <abhishekk> johnthetubaguy: sure thing
14:20:45 <sdague> abhishekk: but realize that spec review bw is low until the release crtiical bugs get sorted
14:20:58 <dansmith> in kilo we moved flavor stuff from sysmeta to the instance extra blob
14:21:01 <ndipanov> tricky as in - had to backport a bunch of code to make it work
14:21:04 <abhishekk> sdauge: i understand
14:21:05 <dansmith> and we provided a command in nova-manage to push those migrations
14:21:09 <johnthetubaguy> sdague: thanks good point
14:21:28 <dansmith> the flavor compat code is complicated and we should drop it as soon as possible.. so what I want to poll for is: can we do that now?
14:21:39 <dansmith> and just say "to move from kilo to lemming you have to have done all those migrations first" ?
14:21:42 <dansmith> I vote "yes"
14:21:43 <johnthetubaguy> dansmith: is it simple to log a warning if you spot un-migrated flavors for a release after we drop the translation code?
14:21:50 <johnthetubaguy> or is that just silly
14:22:04 <ndipanov> I vote yes!
14:22:05 <dansmith> but I also feel like we probably need a way to either block the first lemming db migration on a check, or something
14:22:18 <johnthetubaguy> FWIW, I am +1 the vote yes
14:22:22 <johnthetubaguy> ah, yeah, I like that
14:22:34 <dansmith> johnthetubaguy: not really, if we drop the compat code and they haven't migrated, then we'll fail to be able to load flavor info for the instance
14:22:37 <dansmith> which is, like, bad
14:22:47 <dansmith> so, we could do two things:
14:22:52 <johnthetubaguy> put in a DB migration to check the nova-manage command has been run, and then remove the compat code, sounds good
14:22:57 <dansmith> 1. When the first lemming db migration hits, just augment it with an unrelated check
14:23:13 <dansmith> 2. Make the first migration an empty shell that just checks and fails, but otherwise does no actual migration
14:23:13 <sdague> yeh, that seems like 2 db migrations right?
14:23:26 <sdague> yeh, I like #2
14:23:29 <dansmith> johnthetubaguy: right, that's my 2
14:23:31 <dansmith> cool, me too
14:23:32 <sdague> a dummy check migration
14:23:38 <johnthetubaguy> yeah, I like that
14:23:42 <mriedem> sounds like the instance.uuid thing i had
14:23:43 <dansmith> excellent, I'll make it so
14:23:54 <sdague> dansmith: we get to do a db drop after that?
14:23:55 <mriedem> fails if you don't run the script
14:24:06 <dansmith> sdague: a db drop?
14:24:15 <johnthetubaguy> dansmith: we might want to make it a general patten and document "stuff we do just after we open liberty" like adding those dummy db migrations?
14:24:29 <bauzas> johnthetubaguy: sounds like part of relnotes ?
14:24:31 <dansmith> johnthetubaguy: yeah, agreed, I was just about to say: we should make this a pattern/precedent
14:24:33 <sdague> dansmith: oh, never mind, I was thinking we got to get rid of some tables / colums in the process as well
14:24:40 <johnthetubaguy> sdague: we didn't remember system_metadata right?
14:24:40 <dansmith> sdague: nope, this was all metadata
14:24:52 <johnthetubaguy> bauzas: I am thinking dev not users, but yes, that too
14:24:57 <sdague> doesn't this drop a flavor reference though?
14:25:00 <johnthetubaguy> cool, sounds good
14:25:04 <dansmith> sdague: no
14:25:09 <sdague> never, mind, I'll look later
14:25:21 <dansmith> ping me and we can discuss
14:25:23 <bauzas> johnthetubaguy: well, devs would face the db migration failure, so that's fine I guess :)
14:25:35 <bauzas> since when, devs are looking at devref ?
14:25:51 <johnthetubaguy> bauzas: I was thinking more general, just having a note of stuff to do at the start and end of each release
14:25:55 <johnthetubaguy> just a tick box
14:25:58 <johnthetubaguy> anyways...
14:25:59 <bauzas> ih
14:26:00 <bauzas> oh
14:26:07 <dansmith> johnthetubaguy: the next thing on the agenda was my question about the spec for o.vo, so we can skip that now
14:26:22 <johnthetubaguy> dansmith: ah, yes, cool
14:26:29 <johnthetubaguy> so nova-stable-maint
14:26:33 <johnthetubaguy> who raised that one?
14:26:43 <ndipanov> me
14:26:44 * dansmith bets mriedem
14:26:46 <dansmith> oh
14:26:50 <mriedem> me
14:26:59 <ndipanov> probably him
14:26:59 <ndipanov> then
14:27:02 <mriedem> nova-stable-maint needs fixing i think
14:27:13 <mriedem> it's mostly non-cores and people that aren't actively involved in nova
14:27:24 <mriedem> so i get pretty frustrated about trying to get backports reviews for stable in nova
14:27:29 <johnthetubaguy> mriedem: yes, very good point
14:27:30 <mriedem> i don't like begging for reviews
14:27:38 <mriedem> but when the gate has problems it has to happen
14:27:42 <johnthetubaguy> we did talk about this before, and decided against just adding all of nova-core
14:27:55 <mriedem> i'm particularly interested in stable for two reasons,
14:27:56 <dansmith> yeah, stable takes a little more care
14:27:56 <mriedem> 1. gate
14:27:59 <dansmith> because there are other rules
14:28:05 <johnthetubaguy> mriedem: do we need to get more folks to offer help, and remove the inactive folks?
14:28:05 <mriedem> 2. i'm involved in stable maint internally for nova
14:28:13 <dansmith> I think step one is adding mriedem to this list
14:28:16 <mriedem> i'm offering to help here
14:28:18 <mriedem> if that's not obvious
14:28:19 <dansmith> but I think there are rules about that
14:28:26 <sdague> right, put mriedem in the +2 list for sure
14:28:27 <dansmith> i.e. I don't know if I'm allowed to do it
14:28:43 <johnthetubaguy> yes, +1 to miedem being added
14:28:47 <dansmith> when I was added,
14:28:49 <sdague> basically I think the point is that people that want to help and are nova core, should be added
14:28:53 <dansmith> I had a little intro from the stable people
14:28:59 <johnthetubaguy> is this a PTL thing or stable core thing?
14:29:07 <dansmith> any of us can add him,
14:29:08 <sdague> I'm not sure that all of nova core add is a great idea
14:29:11 <dansmith> but I thought it was a stable core thing
14:29:19 <mriedem> it should be a stable core decision
14:29:26 <mriedem> since the review rules are different
14:29:29 <dansmith> yeah
14:29:32 <johnthetubaguy> so I can ping ttx when we sort out RC2 I guess
14:29:52 <dansmith> I will talk to adam_g and apevec today to see if we can quick-add mriedem
14:30:00 <sdague> yeh, I think, honestly, it would just be good to get someone to write down the policy hoops to add folks
14:30:01 <dansmith> surely we can drop people on our own though, right?
14:30:04 <johnthetubaguy> sdague: I think you can add him as well?
14:30:04 <mriedem> ok, and i think we need to prune the list
14:30:10 <dansmith> sdague: it might be written down
14:30:21 <sdague> dansmith: I am unconvinced that it is, it's been a bit fluid
14:30:31 <dansmith> sdague: well, I thought I saw it at one point
14:30:38 <mriedem> https://wiki.openstack.org/wiki/StableBranch#Stable_branch_policy
14:30:40 <dansmith> but it's entirely possible that it's out of date too
14:30:44 <mriedem> there should be things linking from that wiki
14:30:52 <mriedem> https://wiki.openstack.org/wiki/StableBranch#Team_organization
14:31:00 <johnthetubaguy> https://wiki.openstack.org/wiki/StableBranch#Project-specific_teams
14:31:02 <johnthetubaguy> yeah
14:31:02 <dansmith> https://wiki.openstack.org/wiki/StableBranch#Joining_the_Team
14:31:06 <johnthetubaguy> lol
14:31:19 <mriedem> "Those groups are managed by stable-maint-core, names are added after the suggestion of the Stable Branch CPL."
14:31:32 <johnthetubaguy> CPL?
14:31:34 <sdague> CPL ?
14:31:42 <bauzas> Cross Project Liaison
14:31:45 <bauzas> I guess
14:31:51 <johnthetubaguy> who is that?
14:31:55 <dansmith> mriedem: what pruning would you do to the list?
14:32:04 <sdague> nova is supposed to nominate folks for that
14:32:06 <dansmith> there are non-cores on there already, which makes it weird
14:32:09 <johnthetubaguy> I guess we just use the review count for now
14:32:25 <johnthetubaguy> as a start
14:32:25 <mriedem> dansmith: naming names?
14:32:32 <sdague> dansmith: yeh, honestly, I'd drop
14:32:39 <johnthetubaguy> vishy?
14:32:41 <sdague> Russell Bryant	rbryant@redhat.com
14:32:41 <sdague> Vish Ishaya	vishvananda@gmail.com
14:32:41 <sdague> garyk	gkotton@vmware.com
14:32:41 <sdague> p-draigbrady	P@draigBrady.com
14:32:43 <mriedem> https://review.openstack.org/#/admin/groups/540,members
14:32:50 <mriedem> i'd drop vishy, russellb and pixelb probably
14:33:07 <mriedem> garyk and claudiub probably do the most reviews on nova stable
14:33:09 <sdague> I'm not sure why claudio is there either
14:33:14 <sdague> ok
14:33:18 <dansmith> it's weird that those two are on there
14:33:22 <sdague> yeh, agreed
14:33:27 <mriedem> claudiub: was cross project stable before the project split
14:33:33 <mriedem> so was garyk
14:33:35 <mriedem> so they are legacy
14:33:38 <dansmith> right
14:33:45 <sdague> mriedem: well, they can come back in via stable-maint-core
14:33:51 <dansmith> but seems weird for them to be in the -nova list if they should be on -core
14:33:52 <sdague> if that's the right place
14:33:52 <dansmith> yeah, that
14:34:10 <mriedem> yeah idk who decided on that list
14:34:15 <mriedem> after the big split
14:34:22 <dansmith> so, I will hunt down apevec or adam_g today, and I can ask them about drops whilst about adding mriedem
14:34:27 <sdague> yay for legacy with no audit trail
14:34:36 <mriedem> there is probably a trail in the ML
14:34:51 <mriedem> i don't care enough :)
14:35:19 <mriedem> anyway, sounds like we have an action
14:35:24 <dansmith> aye
14:35:35 <mriedem> #action dansmith to talk to adam_g and apevec about nova stable maint core
14:35:38 <johnthetubaguy> OK, sounds like we know who we need to talk to to get an answer
14:35:51 <johnthetubaguy> mriedem: dansmith: thanks for raising this
14:35:56 <bauzas> mriedem: not sure it works, you're not chair
14:36:12 <mriedem> meh
14:36:15 <dansmith> bauzas: sshh let him think he did something
14:36:16 <johnthetubaguy> irc://localhost:9011/#action dansmith to talk to adam_g and apevec about nova stable maint core
14:36:22 <johnthetubaguy> arg...
14:36:23 <dansmith> heh
14:36:28 <mriedem> copy/paste fail
14:36:32 <johnthetubaguy> #action dansmith to talk to adam_g and apevec about nova stable maint core
14:36:36 <johnthetubaguy> yeah, lol
14:36:40 <bauzas> :
14:36:41 <bauzas> :)
14:36:50 <dansmith> guess we know what port to attack johnthetubaguy's laptop at summit
14:36:55 <johnthetubaguy> :)
14:37:12 <dansmith> are we done?
14:37:17 <johnthetubaguy> I think almost
14:37:23 <johnthetubaguy> one more crazy idea
14:37:33 <johnthetubaguy> so stable list seems to get a bit stale
14:38:02 <johnthetubaguy> would giving them the task of driving the post Feature freeze bug fixing be totally crazy, like we never close master for features?
14:38:12 <johnthetubaguy> that could mean way too many backports, of course
14:38:26 <johnthetubaguy> but might give stable more "practice" and keep the group active…
14:38:55 <ndipanov> johnthetubaguy, but criteria is different for pending release and stable for sure
14:38:58 <dansmith> I'm not sure I understand, but maybe that sounds like a process-affecting summit talk?
14:39:02 <johnthetubaguy> yeah
14:39:12 <johnthetubaguy> I think we are done
14:39:23 <sdague> yeh, there is a whole issue about when handoff happens, but ttx needs to be in the middle of that
14:39:29 <dansmith> yeah
14:39:31 <johnthetubaguy> sdague: yeah, agreed
14:39:43 <johnthetubaguy> he has good intuition on this stuff
14:40:02 <johnthetubaguy> anyways, happy bug fixing and tagging
14:40:06 <johnthetubaguy> thanks all
14:40:10 <johnthetubaguy> #endmeeting