14:00:31 <johnthetubaguy> #startmeeting nova
14:00:36 <openstack> Meeting started Thu May 14 14:00:31 2015 UTC and is due to finish in 60 minutes.  The chair is johnthetubaguy. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:37 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:39 <openstack> The meeting name has been set to 'nova'
14:00:45 <jaypipes> o/
14:00:53 <dansmith> o/
14:00:56 <n0ano> o/
14:00:59 <johnthetubaguy> good <insert time of day> to you all
14:01:02 <alaski> o/
14:01:04 <jlvillal> o/
14:01:16 <sdague> o/
14:01:17 <PaulMurray> o/
14:01:22 <johnthetubaguy> #topic liberty release status
14:01:27 <gilliard> Hello
14:01:39 <johnthetubaguy> so we are pushing forward with the spec reviews
14:01:47 <johnthetubaguy> hoping to break the back of those before the summit
14:02:00 <johnthetubaguy> so those with real issues merging can get a slot during the unconference
14:02:19 <johnthetubaguy> anyways, we have a bp to talk about
14:02:22 <johnthetubaguy> #link https://blueprints.launchpad.net/nova/+spec/memory-bw
14:02:34 <alex_xu> o/
14:02:40 <johnthetubaguy> its adding an extra metric to the existing metric system
14:03:02 <johnthetubaguy> it doesn't feel like it needs a spec, in the same way as a scheduler weigher / filter
14:03:12 <johnthetubaguy> …but do we want more of this kind of thing in tree?
14:03:14 <johnthetubaguy> thoughts?
14:03:20 <dansmith> is this a static value?
14:03:32 * jaypipes looks...
14:03:36 <johnthetubaguy> dansmith: I get the idea they poll for it
14:03:39 <dansmith> this is utilization I guess
14:03:41 <johnthetubaguy> yeah
14:04:05 <dansmith> is it point in time or averaged?
14:04:13 <dansmith> if it's the former, it's completely useless to us, no?
14:04:51 <n0ano> if the HW provides the info the filter can return either point in time or average so I hope the BP is usgin avg
14:05:07 <sudipto> dansmith, Hi, it's averaged
14:05:10 <dansmith> okay
14:05:12 * mriedem joins late
14:05:34 <johnthetubaguy> sounds like any more details are best reviewed in code? are we OK with the concept?
14:05:38 <jaypipes> sudipto: this would be adding another value to the compute_node['stats'] thing, yes?
14:05:43 * beagles joins late
14:05:50 <jaypipes> sudipto: within the RT...
14:05:54 <dansmith> johnthetubaguy: well, are the units in percent or bps or what?
14:06:03 <dansmith> johnthetubaguy: would want to make sure that this is generic enough
14:06:08 <sudipto> jaypipes, no, this is not tracked by RT...
14:06:23 <n0ano> sudipto, really, why is that?
14:06:23 <sudipto> jaypipes, in the metrics column like the cpu one (as a monitor)
14:06:33 <jaypipes> sudipto: ? in the spec it says: "Extend the resource tracker framework to implement a optional	65
14:06:33 <jaypipes> monitor for Memory B/W utilization, much in line with the CPU monitor."
14:07:02 <johnthetubaguy> so question, are there enough questions that we move this to a spec review?
14:07:05 <dansmith> johnthetubaguy: I think maybe a spec would be good :)
14:07:11 <alaski> +1
14:07:14 <jaypipes> johnthetubaguy: yes.
14:07:16 <n0ano> +1
14:07:22 <jaypipes> johnthetubaguy: especially since there's already a spec :)
14:07:26 <dansmith> yeah
14:07:34 <jaypipes> #link https://review.openstack.org/#/c/180983/2/specs/liberty/approved/mem-bw.rst
14:07:45 <sudipto> jaypipes, sorry my bad, guess i need to correct it, initially i thought it could be done via RT, but it sounded like it's best fit just as a monitor
14:07:46 <johnthetubaguy> cools
14:07:57 <johnthetubaguy> lets take this debate to the spec review
14:08:02 <jaypipes> thx
14:08:26 <johnthetubaguy> #info https://blueprints.launchpad.net/nova/+spec/memory-bw will go to a spec review, too much to talk about for the meeting
14:08:42 <johnthetubaguy> #topic Liberty Design Summit
14:09:09 <johnthetubaguy> #info Midcycle is: Tuesday 21st July till Thursday 23rd July in Rochester, MN (at IBM)
14:09:16 <johnthetubaguy> so the first thing is kinda unrelated
14:09:24 <johnthetubaguy> I think the midcylce is official now
14:09:42 <johnthetubaguy> the schedule for the design summit has now been "soft" frozen
14:09:45 <johnthetubaguy> #link http://libertydesignsummit.sched.org/type/design+summit/Nova
14:10:15 <johnthetubaguy> if there are issues with whats written for your session, let me know and I can try get last moment changes
14:10:21 <johnthetubaguy> but it would be good to avoid those
14:10:28 <johnthetubaguy> #link https://wiki.openstack.org/wiki/Design_Summit/Liberty/Etherpads#Nova
14:10:39 <johnthetubaguy> I created an etherpad with a rough agenda for every session
14:10:57 <johnthetubaguy> … that took way too long, so the ones at the end were quite slap dash
14:11:09 <jaypipes> lol
14:11:12 <johnthetubaguy> but anyways, hopefully that helps, and I think we have leaders confirmed for most sessions now
14:11:35 <johnthetubaguy> any questions on the summit?
14:12:05 <mriedem> http://libertydesignsummit.sched.org/event/e57451a7a7d69f9e2626fa92862b119e#.VVStNvlVhBc
14:12:05 <mriedem> ha
14:12:08 <mriedem> 40 minutes?
14:12:18 <mriedem> 3 terribad topics
14:12:22 <johnthetubaguy> mriedem: I think they all it time boxing
14:12:23 <mriedem> for the price of 1
14:12:39 * mriedem shuts up
14:12:42 <johnthetubaguy> :)
14:12:49 <dansmith> yeah, that's going to be awesome
14:13:04 <sdague> "it's a trap!"
14:13:12 <johnthetubaguy> yeah, if someone has a concrete plan for the resource tracker to present, that would be cool…
14:13:14 * mriedem takes note to tell jogo to be bad cop in that session
14:13:49 <johnthetubaguy> cool, so hopefully see lots of you there
14:14:01 <johnthetubaguy> #topic Czar and CPL Refresh
14:14:11 <johnthetubaguy> so this is a repeat from last week
14:14:25 <johnthetubaguy> mostly to say, feel free to catch up with me if you want to help out with things
14:14:34 <johnthetubaguy> a few folks have reached out, and thank you for that!
14:14:48 * jaypipes notes that Robert Graham Clark's profile pic has him with some sort of M-16 rifle...
14:14:56 <johnthetubaguy> #link https://wiki.openstack.org/wiki/Nova/BugTriage
14:15:10 <johnthetubaguy> there are also bug tag owners if you fancy something around stability ^
14:15:29 <johnthetubaguy> #link https://wiki.openstack.org/wiki/Nova#People
14:15:47 <johnthetubaguy> anyways advert break over…
14:15:52 <johnthetubaguy> #topic Bugs
14:16:05 <johnthetubaguy> #link https://bugs.launchpad.net/nova/+bug/1450291
14:16:05 <openstack> Launchpad bug 1450291 in OpenStack Compute (nova) "nova-manage db sync not committing to database" [High,Incomplete]
14:16:15 <johnthetubaguy> oh, that was me who added that
14:16:19 <sdague> so... I kind of feel like on the bug front, until we get a burndown dashboard that includes "by tag" it's hard to motivate. Burn down dashboards are nice from sense of accomplishment though.
14:16:30 <johnthetubaguy> I guess we fixed that
14:16:42 <johnthetubaguy> sdague: thats a good idea
14:17:00 <johnthetubaguy> #help we could do with per bug tag burn down charts
14:17:08 <jlvillal> From an Ironic related perspective.  mrda and I have setup this.  https://wiki.openstack.org/wiki/Nova-Ironic  and  https://wiki.openstack.org/wiki/Nova-Ironic-Bugs
14:17:18 <mriedem> dansmith: cherry pick for https://review.openstack.org/#/c/182787/ ?
14:18:24 <mriedem> jlvillal: so someone has to manually update that daily?
14:18:30 <dansmith> johnthetubaguy: that bug is mis-titled
14:18:46 <johnthetubaguy> jlvillal: one request, can you maybe recommend what is ready for review on here? https://etherpad.openstack.org/p/liberty-nova-priorities-tracking
14:18:54 <jlvillal> mriedem, We were going to do weekly bug scrubs.  mrda and I.  Open to better suggestions
14:19:04 <jlvillal> johnthetubaguy, Will do
14:19:42 <johnthetubaguy> jlvillal: it sounds like you are a bug tag owner, could you update yourselves here please? https://wiki.openstack.org/wiki/Nova/BugTriage
14:19:43 <mriedem> whatever happened to tjones' page?
14:19:56 <mriedem> is that in infra now?
14:19:56 <sdague> dims has a version of it up somewhere I think
14:20:01 <jlvillal> johnthetubaguy, Will do
14:20:03 <johnthetubaguy> mriedem: I couldn't find the link actually, does anyone have that?
14:20:15 <mriedem> sdague: is it useful? i'd have to think that's better than a wiki
14:20:32 <johnthetubaguy> #action johnthetubaguy to talk to dims about getting the bug web page link back up and running
14:20:33 <sdague> so, non of these tools really did the by-tag pivot
14:20:43 <sdague> so it's just the whole pile
14:20:50 <johnthetubaguy> sdague: right, I like the idea of looking at the smaller pile, that makes sense
14:20:55 <sdague> the whole pile is usually too big to tackle
14:21:20 <mriedem> we could add a tag filter to tjones' page though probably, right?
14:21:25 <mriedem> if the LP API provides tag filtering
14:21:48 <johnthetubaguy> dansmith: can we update the title, did we work out what it was?
14:22:13 <dansmith> johnthetubaguy: it's definitely wrong either way because we know it's committing the changes
14:22:22 <mriedem> johnthetubaguy: something about sqlite
14:22:23 <dansmith> johnthetubaguy: and we know it's just a warning, and we know it's oslo and config related :)
14:22:25 <johnthetubaguy> dansmith: agreed
14:22:26 <sdague> mriedem: there are a lot of iffs there
14:22:56 <sdague> mriedem: anyway, can take it offline
14:23:03 <dansmith> and we know it seems to only be with ubuntu package-based upgrades ;)
14:23:15 <johnthetubaguy> https://bugs.launchpad.net/nova/+bug/1450291
14:23:15 <openstack> Launchpad bug 1450291 in OpenStack Compute (nova) "nova-manage db sync seems like its pointing at the wrong database for some people" [High,Incomplete]
14:23:19 <johnthetubaguy> so I changed it
14:23:32 <johnthetubaguy> yeah, any other bugs people want to raise
14:23:42 <johnthetubaguy> sdague: did we sort out that python-novaclient patch?
14:23:58 <mriedem> it's here https://review.openstack.org/#/c/182966/
14:24:19 <sdague> so there is current debate on where the config file should exist for people to find it
14:24:24 <sdague> which is the -1s
14:25:15 <sdague> so *shrug*
14:25:41 <johnthetubaguy> sdague: add it to a top level function test config folder maybe?
14:25:46 <johnthetubaguy> anyways, more debate on the review
14:25:49 <johnthetubaguy> lets keep moving
14:26:03 <sdague> johnthetubaguy: yeh, that's what jaypipes wants, I would argue that if you can't run a tox command without doing a thing
14:26:09 <sdague> that thing should be in the top folder
14:26:15 <cfriesen> ls
14:26:20 <jaypipes> like I said, I'm not strong-willed about it...
14:26:33 <sdague> jaypipes: you are -1, that's some will :)
14:26:33 <johnthetubaguy> sdague: gotcha, I am certainly used to running tox at the top
14:26:52 <johnthetubaguy> #topic Review stats
14:26:52 <jaypipes> sdague: it's OK to disagree and still be friends :)
14:27:07 <dansmith> jaypipes: I disagree
14:27:11 <johnthetubaguy> I vote I drop this topic when there are no items, I forgot to do that
14:27:18 <jaypipes> I knew dansmith would say that.
14:27:21 * dansmith stopped reading at "it's okay to disagree"
14:27:23 <johnthetubaguy> #topic Open discussion
14:28:06 <johnthetubaguy> so we agreed to not dis-agreed about agreeing right?
14:28:21 <johnthetubaguy> OK, so I don't have anything sensible on the agenda
14:28:31 <johnthetubaguy> we had a good ML debate on images in specs
14:28:43 <johnthetubaguy> I think we agreed to try non-ascii art things that are not bitmaps
14:28:54 <johnthetubaguy> where that makes sense
14:29:10 <johnthetubaguy> any comments? or other topics from folks?
14:29:30 <johnthetubaguy> … oh, clearly we are skipping next weeks meeting
14:29:52 <johnthetubaguy> do we want the next meeting at this time, to keep the pattern the same, so May 28th 2015 1400 UTC
14:29:54 <johnthetubaguy> ?
14:30:08 <mriedem> yes
14:30:13 <johnthetubaguy> #info next meeting May 28th 2015 1400 UTC
14:30:17 <mriedem> some of us use calendar reminders
14:30:19 <sdague> keep the pattern, otherwise, things get confusing
14:30:21 <cfriesen> agreed
14:30:22 <sdague> mriedem: ++
14:30:30 <dansmith> yes
14:30:38 <johnthetubaguy> mriedem: exactly my thinking
14:31:08 <johnthetubaguy> cool, save journey for all those folks who have a journey to the summit
14:31:18 <johnthetubaguy> s/safe/save/
14:31:20 <johnthetubaguy> oops
14:31:33 <johnthetubaguy> thanks all
14:31:39 <johnthetubaguy> #endmeeting