14:00:12 <johnthetubaguy> #startmeeting nova
14:00:13 <openstack> Meeting started Thu Jul  9 14:00:12 2015 UTC and is due to finish in 60 minutes.  The chair is johnthetubaguy. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:14 <andreykurilin> hi!
14:00:16 <openstack> The meeting name has been set to 'nova'
14:00:24 <alaski> o/
14:00:25 <dansmith> o/
14:00:25 <jaypipes> .........o/
14:00:25 <sahid> o/
14:00:26 <bauzas> \o
14:00:27 <abhishekk> o/
14:00:28 <n0ano> o/
14:00:31 <johnthetubaguy> #topic Release Status
14:00:33 <alex_xu> o/
14:00:43 <mriedem> o/
14:00:43 <johnthetubaguy> #info tomorrow is: July 10: non-priority feature review bash day
14:00:56 <johnthetubaguy> #link http://lists.openstack.org/pipermail/openstack-dev/2015-July/068815.html
14:01:08 <edleafe> o/
14:01:15 <johnthetubaguy> so this is a new one I dreamt up a when I started writing out the date list
14:01:27 <johnthetubaguy> is everyone cool with the plan for tomorrow's review day?
14:01:39 <bauzas> wondering if we could provide a dashboard
14:01:45 <johnthetubaguy> try get some of the low priority blueprints that are all up for review sorted
14:01:58 <johnthetubaguy> so I made a list in the usual review etherpad
14:02:06 <johnthetubaguy> #link https://etherpad.openstack.org/p/liberty-nova-priorities-tracking
14:02:09 <jaypipes> johnthetubaguy: sure.
14:02:43 <johnthetubaguy> bauzas: a dashboard would be nice, I haven't had chance beyond the above list
14:03:02 <johnthetubaguy> there are some funky stats here: http://reviews.johnthetubaguy.com
14:03:10 <bauzas> johnthetubaguy: I made one for the NFV work group, maybe we can just change the list for that one ?
14:03:36 <johnthetubaguy> bauzas: if you have the time, that would be cool
14:03:39 <johnthetubaguy> so the next thing
14:03:47 <johnthetubaguy> #info Next deadline: July 16: non-priority feature proposal freeze
14:04:01 <claudiub> o/
14:04:02 <bauzas> johnthetubaguy: will ping you offline
14:04:14 <johnthetubaguy> thats the, please put your blueprint into the NeedsCodeReview state, else I unapproved your non-priority blueprint thing
14:04:35 <johnthetubaguy> well, probably more importantly, get your code up for review date
14:05:01 <johnthetubaguy> I can send a horrific bloodbath on the friday, but it is really helping to get the priority stuff the attention it needs
14:05:13 <johnthetubaguy> OK, so blueprint exceptions
14:05:28 <johnthetubaguy> basically, the deadline has passed, an the extention has past
14:05:44 <johnthetubaguy> #info priority specs can still merge for now
14:06:03 <johnthetubaguy> #info we can merge bug fix specs, but lets bring them up in the nova-meeting to discuss
14:06:14 <johnthetubaguy> so we had a spec added to the agenda
14:06:21 <johnthetubaguy> Review for Improve performance of unshelve api, https://review.openstack.org/135387
14:06:30 <johnthetubaguy> I know alaski has done some great reviews on that one
14:06:38 <johnthetubaguy> alaski: is that anywhere close to a merge?
14:06:52 <abhishekk> johnthetubaguy: I have impelemented andrew's comments
14:07:01 <alaski> johnthetubaguy: I need to go through it again
14:07:14 <dansmith> looks like mriedem has questions
14:07:19 <alaski> it looks much cleaner than last time at least
14:07:24 <abhishekk> alaski: yes please
14:07:27 <neiljerram> johnthetubaguy: For tomorrow, are you talking about code reviews?  (As opposed to specs?)
14:07:39 <johnthetubaguy> this was a spec, it got on the agenda
14:07:50 <abhishekk> dansmith: I will answer it asap
14:07:52 <johnthetubaguy> so we may have to move this to the backlog
14:08:05 <johnthetubaguy> it feels way too late at this point, sadly
14:08:16 <johnthetubaguy> but lets catch up offline about all that
14:08:26 <johnthetubaguy> #topic Bugs
14:08:36 <johnthetubaguy> any bug things people want to raise?
14:08:37 <abhishekk> johnthetubaguy: I am ready with everything
14:08:40 <johnthetubaguy> stable branch stuff, etc
14:08:53 <bauzas> no criticals AFAIK
14:09:07 <johnthetubaguy> I see one critial bug: https://bugs.launchpad.net/nova/+bug/1469865
14:09:07 <openstack> Launchpad bug 1469865 in OpenStack Compute (nova) "oslo.versionedobjects breaks nova/cinder tests" [Critical,In progress] - Assigned to Victor Stinner (victor-stinner)
14:09:08 <bauzas> neither nova nor the client
14:09:16 <mriedem> johnthetubaguy: that's old
14:09:35 <johnthetubaguy> mriedem: should we just remove nova from the impact list?
14:09:42 <mriedem> i'll peek at it
14:09:49 <johnthetubaguy> mriedem: sweet, thank you
14:09:53 <bauzas> I thought it was merged for Nova ?
14:09:53 <dansmith> yes, remove it
14:10:02 <bauzas> hence my point about non criticals
14:10:11 <mriedem> it was reverted from ovo
14:10:12 <mriedem> removed nova
14:10:31 <bauzas> coolness
14:10:44 <johnthetubaguy> cool, sounds like that all the bug stuff for this week?
14:11:05 <johnthetubaguy> #topic Regular Reminders
14:11:08 <johnthetubaguy> #link https://etherpad.openstack.org/p/liberty-nova-priorities-tracking
14:11:20 <johnthetubaguy> so this is not working as well as I was hoping
14:11:37 <johnthetubaguy> the idea was we get more review attention on the stuff the subteams say are the most important
14:11:44 <johnthetubaguy> now we don't have a way to track this
14:11:53 <johnthetubaguy> but folks don't seem to be feeling much difference right now
14:12:05 <johnthetubaguy> but lets keeps trying, while we don't have tags in gerrit
14:12:30 <johnthetubaguy> #info please do try review things on the priority tracking etherpad
14:12:44 <johnthetubaguy> I suspect the list has got so long no one gets to the bottom any more
14:12:50 <johnthetubaguy> anyways, ideas welcome
14:13:14 <johnthetubaguy> will review progress at the midcylce on summit actions, lets try follow through on our promises here:
14:13:17 <johnthetubaguy> #link https://etherpad.openstack.org/p/YVR-nova-liberty-summit-action-items
14:13:29 <edleafe> johnthetubaguy: how about deleting completed items? They seem to be noise
14:13:41 <edleafe> move 'em to the bottom if we need them for tracking
14:13:46 <mriedem> s/delete/move to archive section or something/
14:13:49 <mriedem> yeah, move to bottom
14:13:58 <johnthetubaguy> edleafe: mriedem: sounds like a plan
14:14:06 <mriedem> where is kanban.openstack.org?!
14:14:09 <johnthetubaguy> I have a feeling we were thinking of just deleting
14:14:27 <johnthetubaguy> mriedem: quite, phabricator is being tested I am told
14:14:40 <johnthetubaguy> I don't think I got the spelling correct, but its like that
14:14:43 <johnthetubaguy> anyways
14:14:51 <johnthetubaguy> no stuck reviews today, so...
14:14:57 <johnthetubaguy> #topic Open Discussion
14:15:03 <johnthetubaguy> we have lots of items on the agenda
14:15:09 <johnthetubaguy> so lets chew through those first please
14:15:26 <johnthetubaguy> naturally half of them I wrote, sorry about tht
14:15:33 <johnthetubaguy> #info Please share midcyle ideas: https://etherpad.openstack.org/p/liberty-nova-midcycle
14:15:41 <johnthetubaguy> so its almost midcylce time
14:15:50 <johnthetubaguy> mriedem: do we know the final number of registered folks now?
14:15:58 <mriedem> johnthetubaguy: i haven't checked my email yet
14:16:01 <johnthetubaguy> please do add ideas above
14:16:10 <johnthetubaguy> mriedem: no worries
14:16:19 <mriedem> mikal is TBD
14:16:52 <johnthetubaguy> so the next few things are cross project things folks might be interested in
14:17:18 <johnthetubaguy> there is a request id thing for python-novaclient being discussed here: https://review.openstack.org/#/c/156508/16/specs/return-request-id.rst,cm
14:17:32 <johnthetubaguy> eventlet things are being written up here: https://review.openstack.org/#/c/154642/2/specs/eventlet-best-practices.rst,cm
14:17:44 <johnthetubaguy> API WG stuff is here: http://lists.openstack.org/pipermail/openstack-dev/2015-July/068682.html
14:18:06 <johnthetubaguy> we had an email from mlavalle to help with cells support and neutron
14:18:16 <johnthetubaguy> I think we have some neutron folks at the midcycle
14:18:28 <johnthetubaguy> alaski: have these folks reached out to your about cells already?
14:18:48 <alaski> mlavalle has, he attended the cells meeting yesterday
14:18:56 <johnthetubaguy> awesome-ness
14:19:22 <johnthetubaguy> so I think this is one mriedem added:
14:19:24 <johnthetubaguy> metadata service API change for adding instance.project_id - needs a spec? https://review.openstack.org/#/c/197185/
14:19:34 <mriedem> yeah, it's a simple change,
14:19:40 <mriedem> we said it needs a bp but not sure about a spec
14:19:46 <johnthetubaguy> so the metadata service is a public rest API, I think
14:19:50 <mriedem> it's the metadata service api which has a versoin in it, and that change updates the version
14:19:51 <johnthetubaguy> and we said those need specs
14:20:02 <johnthetubaguy> but yeah, it seems a simple change
14:20:16 <mriedem> the interesting thing will be the versions have always been based on release dates
14:20:19 <johnthetubaguy> #link https://blueprints.launchpad.net/nova/+spec/instance-id-in-metadata
14:20:29 <mriedem> unlike microversions that are just a number at the time of merge
14:20:35 <johnthetubaguy> mriedem: yeah, its a little nasty combined with releasing every commit
14:20:56 <johnthetubaguy> I think its always been very close to the ec2 style API
14:21:03 <johnthetubaguy> its probably something that needs some love
14:21:16 <mriedem> the date could just be whatever the change is
14:21:19 <johnthetubaguy> but it seems wrong to block someone following the existing pattern
14:21:21 <mriedem> it doesn't need to be a variable called LIBERTY
14:21:29 <mriedem> it could be a var that describes the change for that version
14:21:46 <mriedem> but we're saying spec?
14:21:50 <johnthetubaguy> mriedem: true, it just each version is generated with you generate config drive, so that might get a bit much
14:22:04 <johnthetubaguy> not sure, I think a quick spec would be following policy
14:22:08 <johnthetubaguy> but it seems a simple change
14:22:21 <johnthetubaguy> anyone got a strong vote one way or the other?
14:22:21 <mriedem> does a spec put this in limbo?
14:22:28 <mriedem> or does it get an exception?
14:22:42 <mriedem> note that i don't have a horse in this race, just wondering about process
14:22:55 <sahid> don't think we need spec we can talk about that on the code reviews as we will do with the spec
14:22:56 <johnthetubaguy> so in theory, we could call it a bug, so it gets an exception
14:23:04 <garyk> mriedem: i would hope that things like this which are importnat could get an exception
14:23:13 <mriedem> it's not really a bug though
14:23:20 <mriedem> i'm definitely in favor of a bp
14:23:22 <garyk> agree, its a feature
14:23:33 <johnthetubaguy> OK, so anyone against just approved the blueprint
14:23:42 <sahid> +1
14:23:46 <mriedem> +1 to approve
14:23:48 <johnthetubaguy> I am trying to remember about project vs tenant and where our API sits with that
14:24:35 <edleafe> yeah, +1
14:24:37 <johnthetubaguy> Ok, so thats an approve then I guess
14:25:05 <johnthetubaguy> so a heads up about things I promised to do after the summit
14:25:09 <alex_xu> as I remember we use project
14:25:20 <johnthetubaguy> we have the start of a wiki page on mentoring: https://wiki.openstack.org/wiki/Nova/Mentoring
14:25:23 <bauzas> yep, 'project'
14:25:45 <johnthetubaguy> we also have some more details on why our current process is the way it is: https://wiki.openstack.org/wiki/Nova/Liberty_Release_Schedule
14:25:53 <johnthetubaguy> so I plan to move them to devref
14:26:02 <johnthetubaguy> but wanted to get some rough work done on them in the wiki first
14:26:07 <johnthetubaguy> so we see what shape they look
14:26:13 <johnthetubaguy> anyways, feedback very welcome
14:26:40 <johnthetubaguy> so I caught up with thingee yesterday, and he pointed out we have some bugs cinder folks are worried about
14:26:56 <johnthetubaguy> the have added the volumes bug tag, that I think ndipanov owns
14:27:03 <johnthetubaguy> #link https://bugs.launchpad.net/nova/+bugs?field.tag=volumes+
14:27:08 <johnthetubaguy> #link https://etherpad.openstack.org/p/CinderNovaAPI
14:27:10 <mriedem> see https://review.openstack.org/#/c/197713/
14:27:18 <mriedem> and https://review.openstack.org/#/c/197721/
14:27:26 <garyk> https://review.openstack.org/#/c/186742/ is criticial when it comes to cinder
14:27:28 <mriedem> those are related to encrypted volumes for some cinder backends we don't test in the gate like FC
14:27:40 <johnthetubaguy> yeah, we might need to tweak the priority
14:27:53 <mriedem> heh, yeah, https://bugs.launchpad.net/nova/+bug/1460044
14:27:53 <openstack> Launchpad bug 1460044 in OpenStack Compute (nova) "Data loss can occur if cinder attach fails" [Undecided,In progress] - Assigned to Vipin Balachandran (vbala)
14:28:03 <mriedem> if it's critical, the importance should probably be set in the bug report
14:28:09 <johnthetubaguy> yeah +1
14:28:27 <johnthetubaguy> so anyway, please help get these triaged in that bug tag
14:28:57 <johnthetubaguy> cools
14:29:06 <johnthetubaguy> so we are at the end of the agenda
14:29:11 <mriedem> i have a thing
14:29:15 <johnthetubaguy> anyone got anything they want to talk about?
14:29:16 <sahid> yes then me too
14:29:19 <johnthetubaguy> mriedem: fire away
14:29:27 <mriedem> garyk: i think we probably need a specless bp for this https://review.openstack.org/#/c/165060/
14:29:47 <garyk> mriedem: sure, i can add one
14:29:49 <mriedem> it's a feature, i don't think requires a spec though, but a bp would be good for tracking in launchpad against the liberty series
14:29:49 <johnthetubaguy> ah, yes, +1
14:29:50 <mriedem> ok, thanks
14:29:59 <johnthetubaguy> it looks that way for sure
14:30:11 <johnthetubaguy> garyk: let me known when thats created, and I can approve it
14:30:14 <dansmith> and release notes
14:30:20 <mriedem> dansmith: yeah, that too
14:30:20 <garyk> johnthetubaguy: ok, sure, will do
14:30:25 <mriedem> and jaypipes charts at the end of the release :)
14:30:28 <johnthetubaguy> feels like UpgradeImact is required
14:30:36 <johnthetubaguy> that way it gets in the release notes
14:30:47 <ankit> I have a review request for bug https://review.openstack.org/#/c/194063/
14:30:48 <dansmith> johnthetubaguy: it's backwards compatible, so no actual upgrade impact I think
14:30:56 <johnthetubaguy> ah, fair enough
14:31:04 <ankit> mriedem: can you please take a look at it
14:31:20 <johnthetubaguy> so sahid, you put your hand up I think?
14:31:24 <sahid> yep
14:31:32 <sahid> it's about a spec from danpb
14:31:41 <sahid> the spec got +2 from mikal
14:31:48 <sahid> then some nit so i have re psuhed it
14:31:52 <sahid> then you +éed it
14:31:54 <sahid> https://review.openstack.org/#/c/139688/
14:31:57 <sahid> 2ed
14:32:21 <sahid> the code is ready for review so i wandoering if we can +W it
14:32:40 <sahid> https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:master+topic:bp/libvirt-real-time,n,z
14:32:41 <bauzas> and danpb is on vacation till next week
14:33:01 <bauzas> but he was basically +1 with ^
14:33:25 <johnthetubaguy> so this one has been waiting a long time, so its tempting to let it in
14:33:32 <johnthetubaguy> although its not got long to get merged at this point
14:33:33 <sahid> johnthetubaguy: i guess yes :)
14:33:59 <johnthetubaguy> if a nova driver is able to +2 and +W that, then so be it
14:34:15 * mriedem grumbles about pointless deadlines
14:34:22 <johnthetubaguy> tomorrow I will try go through and -1 everything thats not on the back log
14:34:35 <andreykurilin> johnthetubaguy, about priority patches: rally team uses "gerrit stars" from ptl and release manager(some other person) to mark critical patches. such patches can be displayed via gerrit dashboard - http://goo.gl/YuCJfl (section "Critical for next release"). Maybe we can do the same for nova?
14:34:53 <johnthetubaguy> mriedem: I tried to describe the intent for this one here: https://wiki.openstack.org/wiki/Nova/Liberty_Release_Schedule#Why_is_there_a_non-priority_Feature_Freeze_in_Nova.3F
14:35:02 <sahid> johnthetubaguy: ok cool thank you
14:35:15 <mriedem> johnthetubaguy: my point is, https://review.openstack.org/#/c/139688/ isn't a priority, it missed the cutoff, and we have lots of other approved stuff out there needing review
14:35:36 <sahid> mriedem: the spec got 2 +2
14:35:37 <mriedem> giving everything an exception sort of defeats the purpose
14:35:50 <johnthetubaguy> andreykurilin: we could, currently we use this thing for that purpose: https://etherpad.openstack.org/p/liberty-nova-priorities-tracking
14:35:52 <johnthetubaguy> mriedem: true
14:36:04 <mriedem> sahid: and?
14:36:10 <sahid> it's just dealing with time to review
14:36:38 <mriedem> so is everyone else
14:36:45 <johnthetubaguy> sahid: it got restored very late, thats the key reason its late
14:36:48 <mriedem> check out hte list of non-priority stuff in the etherpad for tomorrow
14:36:54 <mriedem> it's huge
14:37:09 <johnthetubaguy> mriedem: +1
14:37:12 <mriedem> NFV != priority
14:37:31 <mriedem> now maybe if this were related to nfv + containers i'd make an exception :)
14:37:37 <johnthetubaguy> that certainly was the consensus at the summit
14:37:45 <bauzas> mriedem: while I tend to agree with you, it was just bad to see this spec left off because of a basic rebase :/
14:37:48 <dansmith> libvirt realtime DOCKER
14:37:58 <garyk> so nfv is no longer the new black...
14:38:11 <johnthetubaguy> so it feels like no one is sponsoring an exception here
14:38:15 <johnthetubaguy> so it doesn't get one
14:38:33 <johnthetubaguy> it was up for review quite late (22nd June)
14:38:33 <bauzas> mriedem: sahid was maybe too nice to provide a rebase due to some nitpicks, but then it left the change out
14:39:00 <johnthetubaguy> I get the feeling we are done?
14:39:09 <mriedem> it was restored on 6/22
14:39:11 <mriedem> that's pretty damn late
14:39:16 <mriedem> anyway, we can move it to -nova
14:39:19 <bauzas> agreed
14:39:31 <johnthetubaguy> yeah, lets not keep everyone
14:40:11 <garyk> yalla bye
14:40:30 <johnthetubaguy> #action johnthetubaguy is going to -1 everything that not in the spec backlog so its clear the freeze has ended (it ended on Monday, for sure sure)
14:40:46 <johnthetubaguy> anyways, I need to go do that big -1 run
14:41:05 <johnthetubaguy> thanks all
14:41:09 <edleafe> thanks
14:41:10 <johnthetubaguy> #endmeeting