21:01:02 <mriedem> #startmeeting nova
21:01:03 <openstack> Meeting started Thu Sep 24 21:01:02 2015 UTC and is due to finish in 60 minutes.  The chair is mriedem. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:01:04 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:01:06 <ctrath> o/
21:01:07 <openstack> The meeting name has been set to 'nova'
21:01:13 <bauzas> \o
21:01:17 <rlrossit> o/
21:01:23 <alaski> o/
21:01:28 <mriedem> i'm not pinging lazy people that don't have calendar reminders
21:01:28 <tonyb> man you're alte by 2mins and mriedem is runnign the thing ;P
21:01:33 <melwitt> o/
21:01:40 <dansmith> o/
21:01:41 <scottda> hi
21:01:42 * mriedem brings up agenda
21:01:57 <mriedem> https://wiki.openstack.org/wiki/Meetings/Nova
21:01:59 <dansmith> tonyb: two minutes times the number of people waiting is a lot of minutes
21:02:02 <bauzas> tonyb: sssht, you could unfortunately become a chair
21:02:08 <mriedem> #topic release status
21:02:13 <mriedem> rc1 is out
21:02:19 <tonyb> dansmith: I know I was having technical difficulties
21:02:36 <mriedem> there will be an rc2 for translations and anything critical that missed rc1
21:02:41 <jaypipes> afternoon all
21:02:48 <dansmith> tonyb: :)
21:02:54 <mriedem> for anything that should be considered for rc2, add the liberty-rc-potential tag
21:02:58 <mriedem> and scrub these https://bugs.launchpad.net/nova/+bugs?field.tag=liberty-rc-potential
21:03:08 <mriedem> oh snap. 2/3 are fix committed
21:03:15 <mriedem> so let's remove the potential tag someone plesae on those
21:03:15 <tonyb> mriedem: what's the process for remving that tag?
21:03:22 <mriedem> tonyb: if it's fixed, remove the potential tag
21:03:34 <mriedem> that's what i've been doing anyway
21:03:35 <tonyb> mriedem: what if it's just not rc2 material?
21:03:47 <bauzas> mriedem: bug 1493680 is merged in Mitaka, we need to backport it to RC2
21:03:48 <openstack> bug 1493680 in OpenStack Compute (nova) "HostState.metrics is no longer a dict" [High,Fix committed] https://launchpad.net/bugs/1493680 - Assigned to Sylvain Bauza (sylvain-bauza)
21:03:59 <mriedem> tonyb: then liberty-backport-potential
21:04:03 <bauzas> mriedem: hence the fix committed stuff
21:04:14 <tonyb> mriedem: okay thanks.
21:04:21 <mriedem> bauzas: we can't backport to a tag
21:04:28 <mriedem> and i don't see a stable/liberty branch yet
21:04:33 <tonyb> mriedem: just don't want to irritate people that thought it was rc'ish :/
21:04:36 <mriedem> hmm
21:04:45 <tonyb> mriedem: it was there last night
21:04:48 <mriedem> well, i thought we'd have a stable/liberty branch for backports
21:04:50 <mriedem> oh
21:05:00 <rlrossit> mriedem: there is a stable/libery
21:05:03 <mriedem> not seeing it in github
21:05:05 <rlrossit> s/libery/liberty
21:05:06 <bauzas> mriedem: well I think it was done by the release team
21:05:15 <rlrossit> https://github.com/openstack/nova/tree/stable/liberty
21:05:21 <bauzas> mriedem: given ttx's email
21:05:27 <mriedem> https://github.com/openstack/nova/tree/stable/liberty/nova
21:05:28 <mriedem> yeah, ok
21:05:43 <bauzas> mriedem: so yeah, I was about to propose 1493680 for stable/liberty (to be clear)
21:05:48 <mriedem> so liberty-rc-potential for rc2 should be backported to stable/liberty, i believe
21:05:52 <mriedem> do it
21:06:02 <Johnthetubaguy-w> Yeah release team created it based after that open Mitaka commit
21:06:11 <mriedem> oh well look who it is
21:06:32 <Johnthetubaguy-w> How'd you
21:06:39 <mriedem> #action liberty-rc-potential tagged bugs fixed on master should be backported to stable/liberty
21:06:43 <Johnthetubaguy-w> Doh autocorrect
21:06:55 <bauzas> mriedem: okay, the question is still there, how can we tag bugs for being backported to stable/liberty as RC2 candidates ?
21:07:16 <mriedem> bauzas: i think liberty-rc-potential
21:07:16 <bauzas> mriedem: okay thanks, you answered that question :)
21:07:26 <tonyb> bauzas: set the milestone?
21:07:26 <mriedem> until merged in stable/liberty
21:07:35 <mriedem> i don't see an rc2 milestone
21:07:46 <bauzas> tonyb: there are no lib milestones
21:07:53 <bauzas> heh, jinxed again by mriedem
21:08:04 <Johnthetubaguy-w> We could target to rc2 milestone I guess, yeah I can get that created
21:08:31 <bauzas> that would be awesome
21:08:55 <Johnthetubaguy-w> Give me an action for the morning
21:09:13 <mriedem> #action Johnthetubaguy to create an rc2 milestone
21:09:20 <mriedem> moving on?
21:09:28 <bauzas> +1
21:09:34 <Johnthetubaguy-w> Sure
21:09:39 <mriedem> usual reminder for sub-teams to put their bugs on the etherpad https://etherpad.openstack.org/p/liberty-nova-priorities-tracking
21:09:55 <mriedem> also, we need to start updating the liberty release notes https://wiki.openstack.org/wiki/ReleaseNotes/Liberty#OpenStack_Compute_.28Nova.29
21:10:09 <Johnthetubaguy-w> Oops, I should create a new etherpad now
21:10:11 <mriedem> which includes anything tagged as UpgradeImpact during liberty
21:10:30 <mriedem> there are also quite a few things probably tagged with DocImpact that are really meant for release note updates
21:10:41 <Johnthetubaguy-w> Yeah
21:10:42 <mriedem> we can query gerrit for that stuff though, i could do that tomorrow
21:10:55 <mriedem> #action mriedem to get the list of docimpact/upgradeimpact commits for release notes
21:11:00 <Johnthetubaguy-w> That would be awesome, thank you
21:11:16 <mriedem> we should get better about just doing those once the changes land
21:11:25 <mriedem> so we don't have to remind ourselves of the last 6 months
21:11:31 <Johnthetubaguy-w> +1
21:11:48 <mriedem> # mitaka release process and specs
21:11:50 <mriedem> oops
21:11:54 <mriedem> #topic mitaka release process and specs
21:12:14 <mriedem> i guess there is an etherpad started here https://etherpad.openstack.org/p/mitaka-nova-spec-review-tracking
21:12:16 <Johnthetubaguy-w> Oh, quick thing, need Liberty blueprint summary, I may so that
21:12:39 <Johnthetubaguy-w> Yeah, idea is to spot important stuff
21:12:47 <Johnthetubaguy-w> And get that soon
21:13:05 <mriedem> you mean for this mitaka etherpad?
21:13:06 <Johnthetubaguy-w> And stop stuff that needs summit, etc
21:13:15 <Johnthetubaguy-w> Oops, find stuff
21:13:32 <Johnthetubaguy-w> Yeah, sorry, for that etherpad
21:13:46 <mriedem> ok
21:13:52 <mriedem> so i haven't really started reviewing specs
21:13:59 <mriedem> but yeah people can get started on those
21:14:08 <mriedem> and remember to do the previously-approved thing
21:14:18 <Johnthetubaguy-w> Basically submit specs now, let's try merge before the summit where we can
21:14:31 <dansmith> I've done a bunch today
21:14:47 <mriedem> i thought i noticed a bunch of -1...
21:14:59 <dansmith> heh
21:15:06 <Johnthetubaguy-w> Cool, I hit a few yesterday
21:15:09 <mriedem> also, ping cores to remove -2 once the bits are place for mitaka, e.g. bp's and specs are approved
21:15:23 <mriedem> moving on?
21:15:29 <mriedem> #topic bugs
21:15:40 <Johnthetubaguy-w> We need spec less bp process, but yeah, later for that
21:15:41 <mriedem> i think the gate status is okish?
21:15:55 <mriedem> i haven't really paid attention in the last couple of days, but no news is good news
21:15:58 <tonyb> mriedem: do you want to talk about: https://bugs.launchpad.net/cinder/+bug/1415087?
21:16:00 <openstack> Launchpad bug 1415087 in OpenStack Compute (nova) "[OSSA 2015-011] Format-guessing and file disclosure in image convert (CVE-2015-1850, CVE-2015-1851)" [High,Triaged] - Assigned to Tony Breeds (o-tony)
21:16:01 <Johnthetubaguy-w> We broke ironic earlera did we merge that?
21:16:16 <bauzas> Johnthetubaguy-w: yup
21:16:36 <mriedem> ok, so tonyb has this security bug
21:16:46 <bauzas> Johnthetubaguy-w: bug 1499271 is fix committed
21:16:49 <openstack> bug 1499271 in OpenStack Compute (nova) "MetricsWeigher can return a NoneType exception" [Critical,Fix committed] https://launchpad.net/bugs/1499271 - Assigned to Sylvain Bauza (sylvain-bauza)
21:16:49 <mriedem> sounds like tonyb and kashyap have identified the problems in nova for the bug
21:17:00 <mriedem> tonyb: you're working a patch?
21:17:21 <tonyb> mriedem: Yeah verifying that it fixes anythign other than a theoretical issues is the hard part
21:17:36 <mriedem> yeah...
21:17:44 <tonyb> mriedem: Yeah, I'll punt on the Juno stuff until I have something out
21:17:59 <mriedem> oh you mean your stable juno crusade?
21:18:05 <mriedem> yeah i'd consider that low priority :)
21:18:20 <tonyb> mriedem: Yeah that thing. the tangled-web-of-onions
21:18:50 <mriedem> as for stable branches, kilo is going into a freeze for the next stable kilo release
21:19:06 <mriedem> stable/juno is, ...probably doesn't matter
21:19:13 <mriedem> maybe busted, maybe not
21:19:17 <Johnthetubaguy-w> freeze, is that for strings?
21:19:31 <mriedem> Johnthetubaguy-w: no
21:19:31 <tonyb> Johnthetubaguy-w: all commits I think
21:19:35 <mriedem> right
21:19:39 <mriedem> stable isn't translated
21:19:46 <mriedem> the stable release lead just -2s everything
21:19:59 <Johnthetubaguy-w> Yeah, I think they were talking about starting, but gotcha
21:20:03 <mriedem> until there is the tagged release and then drops the -2
21:20:09 <Johnthetubaguy-w> Ah, ok
21:20:17 <mriedem> ok, anything else on bugs?
21:20:34 <mriedem> #topic design summit sessions
21:20:35 <tonyb> can I add new strings?
21:20:45 <mriedem> tonyb: on master you can b/c it's mitaka
21:21:01 <tonyb> mriedem: okay.
21:21:03 <mriedem> people frequently backport changes to stable that have i18n changes
21:21:15 <mriedem> which is why string freeze is kind of funny imo
21:21:19 <mriedem> but let's not get into it
21:21:41 <mriedem> design summit sessions should be proposed here http://goo.gl/forms/D2Qk8XGhZ6
21:21:49 <mriedem> or by emailing tonyb if your govt blocks google
21:21:50 <Johnthetubaguy-w> Yeah, techincally hard freeze right now
21:22:11 <mriedem> tonyb's home address is in the ML i think
21:22:24 <tonyb> mriedem: Yeah and there's an etherpad
21:22:28 * Johnthetubaguy-w giggles
21:22:34 <mriedem> tonyb: link to the etherpad?
21:22:34 <tonyb> mriedem: so at least the process is clear :)
21:22:38 <mriedem> it's in the ML i guess
21:22:40 <tonyb> mriedem: tryign to find it
21:22:54 <Johnthetubaguy-w> Yeah, it's on that thread
21:23:00 <mriedem> ok, moving on
21:23:03 <mriedem> #topic stuck reviews
21:23:10 <mriedem> i have one in here https://review.openstack.org/#/c/173204/
21:23:11 <tonyb> #link https://etherpad.openstack.org/p/mitaka-nova-summit-suggestions
21:23:30 <mriedem> https://review.openstack.org/#/c/173204/ proposes to not set the 'default' security group for neutron by default
21:23:39 <mriedem> because it breaks certain configs of neutron
21:23:49 <mriedem> if port_security_enabled=False on the network provider
21:24:00 <mriedem> i put it on the stuck list since it's technically a nova api kind of change
21:24:21 <mriedem> but i feel like there are reasons to justify it, inline in that reivew
21:24:26 <mriedem> anyway, could use other opinions on that one
21:24:34 <Johnthetubaguy-w> Yeah, it's a tricky one, but it feels correct
21:24:54 <mriedem> i have'nt looked in a week but i think we basically were making the wrong assumptions from the beginning,
21:24:58 <mriedem> which is why we could justify we shouldn't do it
21:25:06 <mriedem> and because neutron adds the default secgroup if port_security_enabled=True
21:25:10 <mriedem> so nova doesn't/shouldn't need to
21:25:23 <Johnthetubaguy-w> yeah, sounds like they have done that for a few years
21:25:32 <mriedem> and ops people just hack around it
21:25:34 <Johnthetubaguy-w> Which is handy
21:26:08 <mriedem> other stuck reviews?
21:26:11 <jaypipes> mriedem: ooh, kudos for digging up a bug that refers to Quantum.
21:26:29 <mriedem> you're welcome
21:26:48 <mriedem> not hearing more stuck reviews
21:26:52 <mriedem> #topic open discussion
21:26:58 <mrkz> I have 2 questions regarding blueprints + specs for mitaka, to my understanding this blueprint needs a spec https://blueprints.launchpad.net/nova/+spec/boot-from-uefi  so I would like to push a draft so subscribers /devs can early comment in that one
21:27:03 <mrkz> so 1st question: template says to stop in "proposed change" section (http://git.openstack.org/cgit/openstack/nova-specs/tree/specs/mitaka-template.rst#n111) , but do I need to wipe-out all missing text below that or just leave it like that? (my current answ is just edit needed bit and leave everything as is)
21:27:14 <mrkz> and 2nd question: would the review be pushed under the same folder all other mitaka specs are (specs/mitaka/approved)?
21:27:22 <mriedem> yes to 2nd
21:27:44 <mrkz> s/bit/bits/
21:28:08 <mriedem> on 1st question i'd probably wipe out the rest below that, but it doesn't really matter probably
21:28:13 <mriedem> as long as it's clear that the rest is template stuff
21:28:41 <mriedem> other open discussion?
21:28:43 <mrkz> mriedem: gotcha, thanks a lot! :)
21:28:55 <mriedem> cinder people have anything?
21:28:56 <vilobhmm11> I have open spec which needs some diccussion
21:28:59 <mriedem> i saw some sneek in
21:29:09 <vilobhmm11> sent an email on ML http://lists.openstack.org/pipermail/openstack-dev/2015-September/075267.html
21:29:09 <mriedem> s/sneek/sneak/
21:29:10 <bauzas> mriedem: sssshhhht
21:29:28 * bauzas jk
21:29:37 <vilobhmm11> spec : https://review.openstack.org/#/c/222423/ detailed options : https://etherpad.openstack.org/p/servicegroup-refactoring ML http://lists.openstack.org/pipermail/openstack-dev/2015-September/075267.html
21:30:01 <vilobhmm11> please not this spec was accepted for Liberty and there are few concerns raised on the same when proposed again for Mitaka
21:30:23 <vilobhmm11> jaypipes, Johnthetubaguy-w : ^^
21:30:24 <mriedem> vilobhmm11: for someone that doesn't have the background on all of that in his head, what can we do in the nova meeting, or are you just raising awareness?
21:30:49 <mriedem> i'm pretty sure dansmith wanted to keep talking about it... :P
21:30:53 <Johnthetubaguy-w> Yeah, I think it's an easier starting point, the new direction sounds good
21:31:18 <Johnthetubaguy-w> Let's just review the updated spec I guess
21:31:27 <bauzas> well, we can discuss that on the spec
21:31:31 <dansmith> vilobhmm11: you didn't update the spec did you?
21:31:36 <dansmith> I thought you wanted agreement before updating the spec
21:31:48 <Johnthetubaguy-w> Ah, good question
21:31:57 <dansmith> my feeling is: update the spec and lets discuss
21:31:58 <vilobhmm11> dansmith : as we dicsussed the other day on IRC haev created an etherpad https://etherpad.openstack.org/p/servicegroup-refactoring  with all possible options
21:32:11 <vilobhmm11> thought its easier to colaborate on etherpad with multiple people involved
21:32:13 <dansmith> vilobhmm11: right, but everyone in that discussion was in favor of a change
21:32:18 <dansmith> and like I said,
21:32:26 <dansmith> the spec is where we need to document consensus
21:32:38 <bauzas> +1 to dansmith
21:32:40 <Johnthetubaguy-w> +1
21:32:51 <vilobhmm11> ok will submit one
21:32:56 <dansmith> thanks
21:33:00 <Johnthetubaguy-w> Cool
21:33:23 <jaypipes> vilobhmm11: will try to review those tomorrow on my flight back home.
21:33:48 <mriedem> more open discussion?
21:33:56 <mriedem> or leave early so i can piss off more ops poeple?
21:33:59 <mriedem> *people even
21:34:07 <dansmith> +1
21:34:20 <mriedem> ok, that's it
21:34:21 <mriedem> thanks
21:34:23 <mriedem> #endmeeting