21:02:37 <mriedem> #startmeeting nova
21:02:38 <openstack> Meeting started Thu Mar  3 21:02:37 2016 UTC and is due to finish in 60 minutes.  The chair is mriedem. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:02:39 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:02:42 <openstack> The meeting name has been set to 'nova'
21:02:45 <mriedem> dansmith: never!
21:02:48 <tonyb> buit I have an open discussion item!
21:02:52 <rlrossit_> o/
21:02:55 <alaski> o/
21:02:56 <mriedem> #link agenda https://wiki.openstack.org/wiki/Meetings/Nova
21:02:57 <doffm> o\
21:02:58 <edleafe-> o/
21:02:59 <tonyb> mriedem: +1
21:03:06 <ctrath> o/
21:03:07 <bauzas> \o
21:03:09 <scottda> hi
21:03:11 * dansmith makes a rude noise to announce his presence
21:03:14 <markusz> o/
21:03:19 <cdent> o/
21:03:21 <mriedem> real mature
21:03:24 <dansmith> heh
21:03:29 <mriedem> #topic release status
21:03:31 <mriedem> Mar 1-3, Mitaka-3 and feature freeze, Final release for client libraries, Soft String Freeze, etc.
21:03:35 <tonyb> dansmith: so talking then?
21:03:39 <mriedem> http://docs.openstack.org/releases/schedules/mitaka.html
21:03:44 <mriedem> #link release schedule http://docs.openstack.org/releases/schedules/mitaka.html
21:03:50 <dansmith> tonyb: ouch
21:03:52 <bauzas> so, m3 landed
21:03:54 <mriedem> johnthetubaguy was -2ing things today
21:03:57 <mriedem> ok
21:04:24 <mriedem> Looking out for release critical bugs, potential release blocker
21:04:32 <mriedem> #link release blocker bugs https://bugs.launchpad.net/nova/+bugs?field.tag=mitaka-rc-potential
21:04:41 <mriedem> i think we have a few already
21:05:04 <mriedem> #link review focus list https://etherpad.openstack.org/p/mitaka-nova-priorities-tracking
21:05:05 <tonyb> and add mitaka-backport-potential
21:05:09 <mriedem> note new section "Mitaka-RC blockers" has a gerrit query for mitaka blocker patches
21:05:13 <bauzas> https://etherpad.openstack.org/p/mitaka-nova-priorities-tracking has some RC blockers already
21:05:17 <bauzas> snap
21:05:24 <mriedem> step off bro!
21:05:31 <bauzas> meh
21:05:34 <mriedem> yeah, i haven't seen that yet
21:05:35 * bauzas yawms
21:05:46 <mriedem> i was doing bug triage today though and there is at least one api regression it looks like
21:06:07 <mriedem> any questions on the release?
21:06:14 <markusz> tonyb: mitaka-rc-potential
21:06:26 <tonyb> markusz: that too.
21:06:29 <mriedem> markusz: yeah, that first
21:06:36 <mriedem> anything that doesn't make the rc becomes backport potential
21:06:43 <mriedem> #topic bugs
21:06:45 <markusz> yeah, makes sense
21:06:55 <mriedem> #link gate status http://status.openstack.org/elastic-recheck/index.html
21:06:56 <jaypipes> grr my Nova meeting calendar events are reversed still :(
21:06:57 <tonyb> markusz: I was thinking of bugs that we see now that aren't good for the RC stage but we want to land in mitaka once it's stable/mitaka
21:07:14 <tonyb> jaypipes: use the one true ical :D
21:07:18 <mriedem> so, gate status
21:07:25 <mriedem> we made the ceph job non-voting earlier in the week
21:07:30 <tonyb> jaypipes: http://eavesdrop.openstack.org/calendars/octavia-meeting.ics
21:07:39 <mriedem> there was an updated librados package on 2/24 which made the failure rate on the ceph job jump to 25%
21:07:40 <tonyb> s/octiava/nova :(
21:07:54 <mriedem> can we school jay on how to use a calendar after the meeting pleasE?
21:08:06 <mriedem> anywho
21:08:17 <mriedem> jbernard is working on getting the ceph plugin job into the QA program
21:08:20 * jaypipes sulks and scuttles himself away to the dunce chair.
21:08:28 <mriedem> since that uses upstream packages for trusty from ceph.org
21:08:41 <mriedem> b/c apparently trusty 14.04 LTS is using an EOL branch for ceph packages
21:08:44 <mriedem> which is, not great
21:08:55 <dansmith> not just that,
21:08:56 <mriedem> b/c we can't get fixes backported,
21:09:01 <dansmith> but EOL architecture apparentl;y
21:09:16 <mriedem> jamespage and co are working on patching that librados package in 14.04
21:09:32 <mriedem> so once that's done we can make the ceph job voting again, or make the plugin job voting, whichever comes first
21:09:41 <mriedem> that's the only gate news i have
21:09:55 <mriedem> #link 3rd party ci status http://ci-watch.tintri.com/project?project=nova&time=7+days
21:10:05 <mriedem> i think hyper-v is back online now that live migration is fixed for them
21:10:08 <mriedem> claudiub|2: ^ right?
21:10:22 <mriedem> i don't know of any other news there
21:10:42 <mriedem> there are a couple of critical bugs in the agenda
21:10:48 <mriedem> but those should just be marked as rc potential
21:10:50 <claudiub|2> yep
21:10:55 <claudiub|2> thanks for the reviews.
21:11:07 <mriedem> and they are, just checked
21:11:30 <mriedem> we have a general reminder about bug skimming duty
21:11:44 <mriedem> there were ~35 new bugs this morning when i started looking, i think that's down to around 20 now
21:11:52 <mriedem> *21
21:12:00 <mriedem> most are invalid/garbage so it's not to ohard
21:12:02 <mriedem> *too hard
21:12:20 <bauzas> thanks for this
21:12:23 <mriedem> #link stable branch status https://etherpad.openstack.org/p/stable-tracker
21:12:32 <mriedem> nova is clearish
21:12:32 <auggy> thanks mriedem!
21:12:44 <mriedem> the only big news on stable for nova is that we have kilo unblocked now that lifeless relesaed fixtures 1.2.1
21:12:50 <mriedem> thanks to tonyb for pushing on that
21:12:59 <tonyb> mriedem: well you made it happen
21:13:14 <mriedem> *we* made it happen :)
21:13:17 <tonyb> :)
21:13:19 <mriedem> cue sappy music
21:13:27 <markusz> take a room
21:13:31 <auggy> there's no ewe in we?
21:13:33 <mriedem> re: liberty
21:13:35 <mriedem> https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:stable/liberty,n,z
21:13:38 <mriedem> #link liberty reviews https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:stable/liberty,n,z
21:13:51 <mriedem> i've not done a great job on pushing for a liberty release, maybe next week
21:14:02 <mriedem> but we could use help on reviewing anything open for liberty, there isn't much
21:14:09 <mriedem> and then hopefully cut a release soon
21:14:25 <mriedem> last thing on stable,
21:14:46 <mriedem> if you're doing bug triage or reviewing a change for a bug fix and see that the bug was opened awhile back, or reported against what is now a stable branch,
21:14:54 <mriedem> please mark it as *-backport-potential
21:14:58 <mriedem> or nominate for the stable release
21:15:19 <mriedem> the neutron team has been skimming merged changes each friday to see backport candidates, and i don't really feel like doing that,
21:15:30 <mriedem> but it means we have to be better about identifying and taggings bugs when they are fixed or triaged
21:15:33 <markusz> mriedem: ok, understood
21:15:37 <mriedem> it helps the stable team see what can be backported
21:15:37 <auggy> markusz: should we maybe add a note about that to the bug docs?
21:15:44 <mriedem> auggy: yeah, that would be helpful
21:15:46 <auggy> i can take that as an action item
21:15:47 <mriedem> since we have a template
21:15:59 <mriedem> #action auggy to update the nova bug template with a note about backport potential tagging
21:16:03 <mriedem> thanks
21:16:13 <mriedem> anything else for bugs?
21:16:31 <mriedem> skipping stuck reviews since there is nothing on the agenda
21:16:39 <mriedem> #topic open discussion
21:16:48 <mriedem> 1. Would like to help with the l18n team, we need a CPL: https://wiki.openstack.org/wiki/CrossProjectLiaisons#I18n
21:16:57 <mriedem> #link https://wiki.openstack.org/wiki/CrossProjectLiaisons#I18n
21:17:05 <mriedem> #help i18n team needs a nova liaison
21:17:19 <tonyb> What does that really mean for novw?
21:17:30 <mriedem> good question
21:17:45 <mriedem> i guess it's detailed in https://wiki.openstack.org/wiki/CrossProjectLiaisons#I18n
21:18:17 <mriedem> basically, let the i18n team know when our string freeze is
21:18:21 <mriedem> review translation updates
21:18:22 <mriedem> etc
21:18:28 <mriedem> it says it should be a core but i don't think that's necessary
21:18:36 <tonyb> okay, the core reviewer things is a bit limiting
21:18:54 <mriedem> i don't think that's necessary
21:18:58 <mriedem> we don't require cores for other CPL things
21:19:07 <bauzas> I don't see the need for a core
21:19:12 <mriedem> there is a ML thread on that, you could reply in kind
21:19:23 <mriedem> 'geez i would but i'm not a core so sorry!'
21:19:36 <mriedem> moving on
21:19:37 <mriedem> 2. (thomasem): Quick update on Libvirt/LXC gate effort
21:19:40 <bauzas> the only need would be for the zanata patches, but the CPL could just ping the cores
21:20:05 <mriedem> thomasem isn't around
21:20:24 <mriedem> he's been pung
21:20:30 * mriedem waits
21:20:32 <auggy> panged?
21:20:35 <mriedem> gross
21:20:36 <mriedem> pung
21:20:38 <mriedem> panged is dirty
21:20:39 <thomasem> hey
21:20:39 <dims> lol
21:20:45 <mriedem> thomasem: go
21:21:12 <thomasem> Essentially, I'm back on it. Filed a bug here: https://bugs.launchpad.net/nova/+bug/1552740
21:21:14 <openstack> Launchpad bug 1552740 in OpenStack Compute (nova) "Nova hard reboot fails to mount logical volume (LVM + libvirt-lxc)" [Medium,Confirmed] - Assigned to Thomas Maddox (thomas-maddox)
21:21:14 <thomasem> for one of the problems
21:21:41 <thomasem> I was pulled on to some other things recently, so didn't get back to looking at the libvirt lxc gate issues again until this week. So, more progress to come.
21:21:42 <mriedem> thomasem: i saw you noted that ubuntu kernel bug in there
21:21:50 <mriedem> thomasem: is it less of a problem with a newer kernl?
21:21:56 <thomasem> Able to recreate some of these issues in devstack, though it's still kind of hacky.
21:22:34 <thomasem> mriedem: yeah, I haven't seen it on another kernel. I was going to start testing with some newer kernels next
21:22:45 <thomasem> To see if it's a kernel problem, libvirt problem, etc.
21:22:56 <mriedem> thomasem: ok
21:23:08 <mriedem> could also try a fedora job....but that might have problems of it's own
21:23:14 <mriedem> but it would be much newer libvirt
21:23:27 <thomasem> Yeah, Dimitry is helping me out with testing on CoreOS, may try Fedora next.
21:23:31 <thomasem> Sorry, CentOS
21:23:34 <thomasem> not CoreOS
21:23:37 <thomasem> Got containers on the mind.
21:23:43 <mriedem> heh
21:23:49 <tonyb> which libvirt version?
21:23:51 <mriedem> ok, well thanks for pusuing this
21:23:53 <thomasem> Anyway, more to come. Just wanted y'all to know I'm still looking @ it.
21:23:55 <mriedem> *pursuing
21:24:13 <thomasem> And that I _do_ very much care about fixing it. Just taking a long time since it's a bit more complicated.
21:24:24 <mriedem> yes, it sounds like it certainly does suck
21:24:27 <thomasem> And so on... prod isues, like the one I'm in the middle of right now. :)
21:24:27 <mriedem> so thanks for taking that bullet
21:24:37 <thomasem> You bet!
21:24:48 <mriedem> last item
21:24:49 <mriedem> 3. (tonyb) Testing bleeding-edge libvirt in the gate status and call for help
21:25:16 <tonyb> So markusz and I have a devstack plugin that will install the UCA version of libviert and qemu
21:25:20 <mriedem> didn't markusz agree to help at the mid cycle?
21:25:33 <tonyb> in order to add that to the gate it needs to be on git.o.o
21:25:53 <tonyb> what I need to know is shoudl this start of as a nove "deliverable"
21:25:56 <markusz> yep, I can work on that tomorrow (finally)
21:26:09 <mriedem> maybe you two should get a room
21:26:10 <tonyb> and can I get a potential core team
21:26:19 <tonyb> markusz: and I is a little sparse
21:26:31 <mriedem> this has to be in the compute program?
21:26:41 <tonyb> mriedem: no
21:26:46 <tonyb> it can go anywhere
21:27:10 <bauzas> it doesn't need to be an official project, right?
21:27:11 <tonyb> QA would be my first choice but I wanted to discuss it here to come up with a plan that will work
21:27:17 <bauzas> I mean, not in the projects.yaml
21:27:22 <tonyb> bauzas: It seems it does :/
21:27:33 <mriedem> so, the ceph plugin is a thing
21:27:35 <mriedem> that we use in the gate
21:27:40 <mriedem> i'd try to follow what they did
21:27:41 <mriedem> or need to do
21:27:45 <bauzas> just adding the project to openstack doesn't mean you need to have it in the big tent
21:27:46 <tonyb> bauzas: Ahh no but it does need to be in project-config/*
21:28:07 <bauzas> tonyb: you can have a project in project-config and not in the big tent, you knoxwx
21:28:12 <mriedem> there was talk an hour or so ago in -infra about the ceph plugin being part of the QA program
21:28:33 <tonyb> mriedem: Ah okay I'll read the scroolback
21:28:36 <mriedem> i honestly don't know what's needed,
21:28:44 <mriedem> but it sounds like we should at least talk to mtreinish
21:28:48 <tonyb> bauzas: sure but it needs a core team so I'm here askign for help :)
21:28:58 <tonyb> mriedem: okay I'll ping him
21:29:01 <mriedem> it's a separate repo right?
21:29:04 <bauzas> so, that's pretty old but http://docs.openstack.org/infra/system-config/stackforge.html
21:29:06 <tonyb> mriedem: yeah
21:29:17 <tonyb> bauzas: yeah that's out of date :(
21:29:21 <bauzas> ^ that is how to add a new project not really in the big tent
21:29:21 <mriedem> oh, i think sdague brought something up about that in the infra channel about the ceph plugin
21:29:29 <mriedem> basically devstack core team has core on the ceph plugin
21:29:37 <mriedem> and it would be in the QA program
21:29:56 <bauzas> tonyb: you can create your own team and still not be in projects.yaml
21:30:00 <mriedem> tonyb: so, let's talk to sdague and mtreinish
21:30:04 <dims> tonyb mriedem : all enable_plugin(s) i see in project-config seem to be on our git - http://codesearch.openstack.org/?q=enable_plugin&i=nope&files=&repos=project-config
21:30:06 <bauzas> no really need to ask for it IMHO
21:30:15 <tonyb> mriedem: I was hoping sdague woudl be here ;P
21:30:16 <mriedem> tonyb: i'm sure danpb would probably be on board as a core for this
21:30:28 <mriedem> sdague dropped a smoke bomb and vanished about an hour ago
21:30:35 <bauzas> tonyb: see for example the blazar project as a (defunct) example
21:30:50 <mriedem> yeah, i'm not sure why we couldn't have a devstack plugin in tree either
21:30:54 <mriedem> a bunch of projects do that
21:31:05 <tonyb> mriedem: markusz thought of that
21:31:07 <dims> mriedem : because you are limited to just one plugin
21:31:17 <tonyb> mriedem: the plugin is generic enough to be of use to neutron
21:31:18 <dims> you can't have more than one
21:31:26 <tonyb> to adding it to nova seems like a bad idea
21:31:30 <dims> yep
21:31:31 <mriedem> huh, weird
21:32:04 <tonyb> I think markusz and I have a plan
21:32:15 <markusz> dun dun duuuuun
21:32:16 <mriedem> well, idk, you could always start in tree, get it working and then split it out for others to use
21:32:24 <bauzas> tonyb: honestly, I just think that you should just create your project and add CI jobs without really thinking about which service to be within
21:32:31 <tonyb> bauzas: right
21:32:36 <tonyb> bauzas: that's what I'm doing
21:32:57 <tonyb> bauzas: I was just trying to find a coer team >2
21:33:18 <bauzas> tonyb: heh, that's another concern :)
21:33:29 <tonyb> bauzas: I just [hrased the opening statement badly
21:33:30 <mriedem> i can't be core on a devstack repo, so kind of a non-starter
21:33:31 <bauzas> tonyb: I was thinking you were asking how to create a new projectr
21:33:34 <dims> tonyb : start with you, when someone shows up with a patch, add them in :)
21:33:51 <mriedem> get the devstack core team to grandfather it in
21:33:55 <Vek> heh :)
21:33:58 <mriedem> anyway, we should sort this out after the meeting
21:34:05 <bauzas> yeha
21:34:09 <mriedem> and it's kind of moot w/o sdague
21:34:16 <mriedem> so,
21:34:26 <mriedem> #action tonyb to talk to sdague about a libvirt devstack plugin thing + core team
21:34:35 <mriedem> sound good?
21:34:44 <tonyb> +1
21:34:56 <mriedem> cool
21:35:01 <mriedem> ok, any other open discussion items?
21:35:29 <mriedem> alright, let's end it
21:35:31 <mriedem> thanks everyone
21:35:33 <mriedem> #endmeeting