21:00:51 <mriedem> #startmeeting nova
21:00:51 <openstack> Meeting started Thu Apr 14 21:00:51 2016 UTC and is due to finish in 60 minutes.  The chair is mriedem. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:52 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:55 <openstack> The meeting name has been set to 'nova'
21:00:59 <jroll> hai
21:00:59 <tonyb> o/
21:01:01 <dansmith> o/
21:01:03 <diana_clarke> o/
21:01:03 <melwitt> o/
21:01:05 <knikolla> o/
21:01:08 <sdague> o/
21:01:09 <bauzas> \o
21:01:09 <sarafraj> o/
21:01:09 <edleafe> \o
21:01:16 <mriedem> #link agenda https://wiki.openstack.org/wiki/Meetings/Nova#Agenda_for_next_meeting
21:01:18 <scottda> hi
21:01:22 <rdopiera> o/
21:01:24 <auggy> \o/
21:01:47 <mriedem> #topic bugs
21:01:49 <DuncanT> Lo
21:02:02 <mriedem> gate status looks ok
21:02:20 <mriedem> i don't really have any status on third party ci, not sure if the mellanox ci is fixed yet
21:02:26 <mriedem> lennyb: ^ any idea?
21:02:30 <mriedem> it was hitting merge conflicts
21:02:40 <alaski> o/
21:02:47 <dansmith> I don't see it commenting even lately
21:02:48 <mriedem> i pinged tjones this morning about vmware ci not running on some changes after multiple rechecks
21:03:02 <dansmith> 2 days since the last report from mellanox that I see
21:03:41 <mriedem> i haven't checked that ci watch page in awhile
21:04:24 <mriedem> on a related note for CI
21:04:28 <mriedem> #info There is a proposal to make the ceph plugin job voting and gating (again, kind of): https://review.openstack.org/#/c/306009/
21:04:28 <patchbot> mriedem: patch 306009 - openstack-infra/project-config - Make the ceph devstack-plugin-based job gating on ...
21:04:41 <dansmith> I love that proposal
21:04:59 <cburgess> late but here
21:05:11 <mriedem> i guess i never heard what kind of fallout there is from not having the mirroring done?
21:05:13 <mriedem> dansmith: do you know?
21:05:28 <dansmith> mriedem: just us controlling our own destiny if the ceph site goes down
21:05:31 <dansmith> which is a good plan for sure
21:05:33 <dansmith> but...
21:05:40 <sdague> it's not just if the site goes down
21:06:03 <sdague> connectivity from our providers across the wider internet goes squishy quite often
21:06:10 <dansmith> well, heh
21:06:10 <dansmith> okay
21:06:20 <dansmith> " if the ceph site appears down"
21:06:33 <mriedem> but that hasn't been a problem since red hat has been monitoring has it?
21:06:39 <mriedem> which has been ~1 month now?
21:06:44 <dansmith> nope, more than a month
21:06:47 <dansmith> but it could happen any time
21:06:56 <dansmith> so a month is probably not really a useful metric
21:07:01 <dansmith> we know the internet is not perfect
21:07:06 <mriedem> it's not?
21:07:15 <dansmith> yeah, sorry to burst your bubble
21:07:42 <sdague> anyway, it's probably worth the risk
21:07:52 <sdague> we can always make it NV if there are big issues
21:08:00 <sdague> +2ed it right now
21:08:07 <mriedem> is pabelanger going to work on the AFS mirror stuff?
21:08:23 <dansmith> mriedem: yeah, he is in the next few days it seems
21:08:29 <mriedem> ok, cool
21:08:35 <dansmith> I'm pro going forward without the mirror so the pressure is on though
21:08:40 <dansmith> because I htink it's a safe bet
21:08:48 <sdague> https://review.openstack.org/#/c/293155/ seems to be rebased
21:08:48 <patchbot> sdague: patch 293155 - openstack-infra/system-config - Apt mirror for ceph hammer release
21:08:52 <mriedem> just like the panthers in the super bowl
21:08:53 <mriedem> what could go wrong
21:09:06 <mriedem> related to the ceph job
21:09:07 <mriedem> #help Need someone to convert gate-tempest-dsvm-full-ceph-src-glance_store to using the devstack plugin so we can make that job voting for glance_store and os-brick.
21:09:18 <mriedem> ^ for newcomers
21:09:31 <mriedem> should be some trivial copy/paste/tweak in project-config
21:09:37 <dansmith> I think melwitt said she was bored earlier today
21:09:46 <mriedem> orly, i still have those charts to work on...
21:09:59 <mriedem> auggy: anything on bugs?
21:10:01 <melwitt> hah
21:10:21 <auggy> mriedem: i don't have much to report, i think people have been doing a great job helping out with the skimming and triage
21:10:21 <bauzas> nothing really huge I saw recently
21:11:03 <mriedem> #link untriaged nova bugs https://bugs.launchpad.net/nova/+bugs?search=Search&field.status=New&orderby=-datecreated&start=0
21:11:14 <mriedem> yeah, it's pretty simple, i just triaged this https://bugs.launchpad.net/nova/+bug/1570241
21:11:15 <openstack> Launchpad bug 1570241 in OpenStack Compute (nova) "ERROR (ClientException): Unexpected API Error during type the command: nova virtual-interface-list" [Undecided,Invalid]
21:11:20 <mriedem> by triage i mean marked it invalid
21:11:38 <mriedem> #topic reminders
21:11:45 <mriedem> #info Launchpad bug spring cleaning day Monday 4/18: http://lists.openstack.org/pipermail/openstack-dev/2016-April/091456.html
21:11:57 <tonyb> mriedem: we coud probably write a script to do that kind of "triage"
21:12:18 <mriedem> tonyb: meh
21:12:19 <auggy> one thing i do try to keep in mind, if an error message could be more helpful, that could be the focus of the bug
21:12:20 <bauzas> sssssht, don't awake the beast
21:12:24 <bauzas> tonyb:  ^
21:12:32 <auggy> or if we see several where people were following documentation instructions, that could be a doc bug
21:12:41 <mriedem> tonyb: or one of the 377 people in the nova channel could look at a new bug reported once per day
21:12:49 <auggy> the same documentation instructions rather, resulting in a config error
21:13:11 <tonyb> mriedem: true dat I shoudl do that thing
21:13:21 <mriedem> auggy: yeah, that reminds me of the neutron connection error bug where the person didn't have credentials setup properly for nova talking to neutron
21:13:30 <mriedem> auggy: and we talked about wrapping that so it's not a 500 in the nova api
21:13:45 <bauzas> well
21:13:48 <auggy> mriedem: yeah, the bug had already been closed as invalid so i wasn't sure if i should reopen it with that new info or file a new bug
21:13:53 <bauzas> sometimes it's documented
21:14:03 <bauzas> it's just that people don't really look at those
21:14:18 <mriedem> auggy: we should probably have a bug for that regardless, i hit a similar thing last week with listing instances and neutron server was down
21:14:20 <mriedem> we get a 500
21:14:31 <auggy> mriedem: kk i'll go ahead and file it and reference that invalid bug
21:14:42 <auggy> i still have notes from the conversation we had about steps towards fixing it
21:14:47 <mriedem> ok, thanks
21:14:58 * mriedem golf claps for auggy
21:15:00 <auggy> i believe you had volunteered rlossit so i guess i can just assign it to him?? ;P
21:15:11 <mriedem> eh, maybe
21:15:13 <mriedem> #link Newton review focus list: https://etherpad.openstack.org/p/newton-nova-priorities-tracking
21:15:26 * auggy kids
21:15:33 <mriedem> ^ mostly a reminder to keep that fresh
21:15:41 <mriedem> as things tend to build up that are already merged
21:16:25 <mriedem> #link Draft Newton release schedule is up: http://releases.openstack.org/newton/schedule.html
21:16:33 <mriedem> #link Open re-proposed specs: https://review.openstack.org/#/q/project:openstack/nova-specs+status:open+previously-approved
21:17:04 <mriedem> of those 4, 3 are going to be discussed at the summit
21:17:21 <mriedem> would be good if we were happier with the glance v2 spec before the summit
21:17:25 <mriedem> i need to go through the recent updates
21:17:46 <mriedem> the volume multiattach spec is probably not ready yet given the nova/cinder meeting we had yesterday
21:17:59 <mriedem> starting to see some progress on the design there at least
21:18:21 <mriedem> We already have 44 approved blueprints: https://blueprints.launchpad.net/nova/newton - 4 are completed, 6 have not started
21:18:30 <mriedem> #link https://blueprints.launchpad.net/nova/newton
21:19:26 <mriedem> the ones that dont have code up yet,
21:19:29 <mriedem> i'm starting to worry about
21:19:36 <mriedem> because they didn't have code up last week either
21:19:57 <mriedem> #help https://wiki.openstack.org/wiki/Nova/BugTriage#Weekly_bug_skimming_duty Volunteers for 1 week of bug skimming duty?
21:20:36 <mriedem> looks like we actually have one person for this week
21:20:37 <mriedem> cihand
21:20:59 <mriedem> #topic stable branch status
21:21:04 <mriedem> #link Stable branch status: https://etherpad.openstack.org/p/stable-tracker
21:21:19 <mriedem> so far so good for nova
21:21:24 <mriedem> we released liberty 12.0.3 today
21:21:54 <mriedem> #topic stuck reviews
21:22:06 <mriedem> there was nothing in the agenda, does anyone have anything they want to bring up here?
21:22:35 <mriedem> #topic instance users
21:22:44 <mriedem> The Cross Project workshops: Instance Users session needs Nova representation. Nova plays a part in the problem and needs to be part of the solution. Can some representatives from Nova please attend so that we can find a supportable solution that everyone will be happy with? Thanks - kfox1111
21:22:53 <mriedem> #link https://www.openstack.org/summit/austin-2016/summit-schedule/events/9485
21:23:18 <mriedem> is anyone planning to be in that session? i'm going to be in something else at the same time
21:23:22 <mriedem> hence asking for volunteers
21:23:38 <dansmith> I feel like the overwhelming feedback (and the last time we discussed this) was "do it outside of nova" so I will probably choose to attend something else during that slot
21:23:45 <mriedem> part of me is thinking about volunteering johnthetubaguy since he's (1) on vacation and (2) has replied to the spec before
21:24:33 <mriedem> alright, moving on...if you plan on being there, please let me or kfox1111 know
21:24:40 <auggy> i can attend and take notes but i can't really speak for nova
21:24:56 <alaski> I probably need to be in the quota one at the same time
21:25:09 <mriedem> alaski: yeah, there was that too
21:25:20 <bauzas> I would honestly prefer the quota discussion...
21:25:24 <tonyb> I'll be there but as with auggy can't really speak for nova
21:25:47 <mriedem> auggy: tonyb: ok
21:26:09 <mriedem> #topic open discussion
21:26:12 <mriedem> #link Austin Design Summit sessions: https://www.openstack.org/summit/austin-2016/summit-schedule/global-search?t=Nova%3A+
21:26:30 <bauzas> I have a point
21:26:31 <mriedem> #action mriedem still needs to create some etherpads for the nova design summit sessions
21:26:40 <mriedem> bauzas: hold up
21:26:50 <mriedem> any questions on the design summit sessions?
21:27:00 <bauzas> yup
21:27:05 <mriedem> oh, about this :)
21:27:08 <mriedem> go ahead then
21:27:38 <bauzas> I saw that feature classif session was on Thurs (AFAIR) but I was thinking about discussing about feature classif also in the performance VMs session
21:27:45 <bauzas> which is on Wed
21:28:09 <bauzas> so, wondering if it was okay for us
21:28:22 <bauzas> I don't really want to swap the sessions
21:28:26 <dansmith> I'd like to focus on verification stuff during the one on thursday
21:28:35 <mriedem> we wanted feature classification after the API sessions
21:28:40 <dansmith> which I can see spending most of the time on anyway
21:28:40 <mriedem> because of it's relation to API discoverabliilty
21:28:51 <bauzas> okay, let's leave that way
21:28:52 <mriedem> wow, more i's and l's please
21:29:21 <mriedem> yeah there were 3 other xp sessions on thursday afternoon which are strict on scheduling since they are with other projects
21:29:57 <mriedem> anything else on the summit?
21:30:11 <mriedem> #link Newton midcycle planning: http://lists.openstack.org/pipermail/openstack-dev/2016-April/092014.html
21:30:18 <mtreinish> mriedem: https://www.openstack.org/summit/austin-2016/summit-schedule/events/9081?goback=1 overlaps with the qa track
21:31:03 <tonyb> mtreinish: you're not the PTL anymore so you can choose ;P
21:31:46 <mriedem> i can see if anything could be shuffled after the meeting
21:31:51 <mriedem> but it's tight
21:32:10 <mtreinish> mriedem: swap it with unconference #2 right after it and the conflict goes away :)
21:32:29 <mriedem> mtreinish: i won't be in that one
21:32:33 <mriedem> the thurs 1:30
21:32:48 <mriedem> anyway, can look later
21:33:14 <mriedem> #action mriedem to see if anything can be moved around so QA can be at the feature classification session
21:33:31 <mriedem> for the midcycle
21:33:32 <mriedem> It's sounding like 7/19-7/21 at the Intel campus in Beaverton, OR is what we'll be doing, but it's not confirmed yet.
21:34:08 <mriedem> i never heard back about vmware
21:34:24 <tonyb> mriedem: did they address mikal's query?
21:34:25 <sdague> PDX is good
21:34:30 <dansmith> that's cool with me.. I don't remember issues at intel
21:34:33 <mriedem> does anyone have any major issues with that date and location? besides the chaperoned bathroom runs?
21:34:34 <dansmith> I distinctly remember peeing alone
21:34:45 <tonyb> mriedem: do we have feedback from horizon on how ther last mid-cycle wemt?
21:34:51 <bauzas> mriedem: I commented something
21:35:02 <bauzas> mriedem: about the flight prices
21:35:05 <sdague> Intel's network is pretty port locked down, but I thought it ended up fine
21:35:17 <tonyb> sdague: ssh out?
21:35:24 <david-lyle> IRC won't go through on the guest net, ssh works fine
21:35:29 <dansmith> I vpn out of everything anyway, so I didn't notice
21:35:37 <sdague> oh, maybe that was it, IRC
21:35:39 <mriedem> bauzas: ah, so flights from europe are considerably cheaper in R-15 rather than R-11?
21:35:51 <mtreinish> david-lyle: does ssh have to go over port 22?
21:35:53 <bauzas> I was only checking on my own
21:35:55 * tonyb does email/irc/git over ssh anyway so cool
21:36:00 <bauzas> so that could be only me
21:36:05 <david-lyle> mtreinish: I believe so
21:36:06 <bauzas> just raising a flaf
21:36:08 <bauzas> flag
21:36:38 <mriedem> i really have no idea how many other people from europe are planning on making the midcycle
21:36:45 <bauzas> but anyway, I don't want to stop things
21:36:49 <mriedem> or asia for that matter
21:37:00 <bauzas> just expressing that point as worth it
21:37:07 * tonyb will be there
21:37:17 <mriedem> bauzas: yeah, thanks for looking it up
21:37:35 <mriedem> personally i like the R-11 date for when it falls in the schedule
21:37:50 <bauzas> i agree
21:38:14 <bauzas> R-11 showed that it's a good time for sprinting against our left prios
21:38:14 <mriedem> any other stuff about the midcycle?
21:38:44 <david-lyle> Intel is trying to make sure we have an appropriate room available, WIP
21:38:51 <auggy> i'm also local PDX so if we do go with the Intel option here, I'm happy to help out with any local organization stuff
21:39:16 <david-lyle> but a date helps
21:39:28 <dansmith> david-lyle: we were already told we're good
21:39:37 <mriedem> david-lyle: for either date, yeah
21:40:03 <david-lyle> dansmith, mriedem ok, I missed that
21:40:17 <sdague> I think R-11 is a better point in our schedule to do it
21:40:47 <mriedem> yeah, so i'll follow up with them next week
21:40:57 <mriedem> #action follow up with Intel on the midcycle date
21:41:12 <jlvillal> o/
21:41:15 <mriedem> last item in the agenda is should we have the nova meeting next week?
21:41:40 <mriedem> i don't expect to make any ground breaking decisions 4 days before the summit
21:41:40 <sdague> it's the early one right? I think it's fine for sorting any last minute summit item
21:41:53 <mriedem> it is the early one for US people yeah
21:42:03 <edleafe> yeah, a quick meeting would be good
21:42:04 <mriedem> i don't mind holding it and it just ends fast if nothing to talk about
21:42:07 <mriedem> ok
21:42:08 <sdague> yep
21:42:16 <mriedem> i'll find some stuff to fill it out for dansmith
21:42:25 <mriedem> anyone else have anything for open discussion?
21:42:31 <tonyb> 1 thing
21:42:49 <tonyb> do we know which (if any cores) will *not* be in Austin?
21:43:07 <mriedem> i know of at least 2 that one be
21:43:14 <mriedem> *won't be
21:43:26 <mriedem> tonyb: why?
21:43:48 <tonyb> mriedem: just thinking about in-person discussions
21:44:01 <mriedem> ok...
21:44:02 <tonyb> mriedem: theres stuff I'll do more prep work for if they're goign to happen
21:44:24 <mriedem> well danpb won't be there which is why i asked him to write up the os-vif status in the ML
21:44:39 <mriedem> tdurakov won't be there so i asked him to write up the status on the live migration testing
21:44:58 <mriedem> tonyb: anyway, if you have specific stuff, hit me up in -nova
21:45:09 <tonyb> okay thanks
21:45:17 <mriedem> alright, anything else?
21:45:24 <mriedem> no?!
21:45:24 <mriedem> ok
21:45:26 <mriedem> thanks
21:45:28 <mriedem> #endmeeting