14:00:19 <mriedem> #startmeeting nova
14:00:20 <openstack> Meeting started Thu Jul 14 14:00:19 2016 UTC and is due to finish in 60 minutes.  The chair is mriedem. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:21 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:23 <openstack> The meeting name has been set to 'nova'
14:00:28 <takashin> o/
14:00:29 <markus_z> o/
14:00:32 <alaski> o/
14:00:43 <auggy> o/
14:00:59 <edleafe> \o
14:01:11 <cdent> /o/
14:01:18 <mriedem> will wait another minute or so
14:02:00 <woodster_> o/
14:02:04 <johnthetubaguy> o/
14:02:05 <mnestratov|2> o/
14:02:16 <rlrossit> o/
14:02:16 <mriedem> alright let's get started
14:02:24 <mriedem> #link agenda https://wiki.openstack.org/wiki/Meetings/Nova#Agenda_for_next_meeting
14:02:25 <andrearosa> o/
14:02:31 <mriedem> #topic release news
14:02:42 <mriedem> #link Newton release schedule: https://wiki.openstack.org/wiki/Nova/Newton_Release_Schedule
14:02:44 <mriedem> today is n-2
14:02:49 <mriedem> #info The n-2 milestone has been tagged: https://review.openstack.org/#/c/341932/
14:03:20 <mriedem> we're also past the non-priority FFE deadline, so anything not approved as of this morning i'm going to -2 and defer to ocata
14:03:34 <mriedem> questions about the release?
14:03:55 <mriedem> i'm also going to checkout a release for novaclient as we've merged some new microversion support there
14:04:04 <mriedem> #topic bugs
14:04:13 <mriedem> #link check queue gate status http://status.openstack.org/elastic-recheck/index.html
14:04:24 <mriedem> so last week the postgres job was at 75% failure rate
14:04:27 <mriedem> we made it non-voting on friday
14:04:39 <mriedem> we found the breaking change early in the week and reverted it,
14:04:45 <mriedem> so the pg job is back to normal and voting again
14:05:04 <mriedem> everything else is relatively quiet
14:05:25 <mriedem> 3rd party CI status, I don't have any news
14:05:35 <mriedem> are there any critical bugs that anyone wants to bring up?
14:05:52 <markus_z> nope, haven't heard of anything
14:06:04 <mriedem> we have 34 new bugs https://goo.gl/JsMuWb
14:06:11 <johnthetubaguy> being doing a bit of bug triage, not tripped over any yet
14:06:21 <johnthetubaguy> yeah, been chewing through some of those
14:06:25 <mriedem> yeah i triaged a few yesterday
14:06:34 <johnthetubaguy> but was doing a bit of step 2 and 3 to start with
14:06:37 <mriedem> there are some NUMA and vmware related ones which i'm not able to triage
14:06:39 <mriedem> so need subteams on those
14:07:08 <johnthetubaguy> yeah, I wish that tagging worked better that it is at the moment
14:07:55 <mriedem> markus_z: don't you have a dashboard with the tags or subteams?
14:07:57 <markus_z> the tagging itself, or the triaging of tagged items=
14:08:00 <mriedem> and the number of open bugs per each?
14:08:16 * PaulMurray says hi
14:08:18 <mriedem> i think the tagging is fine, it's getting triage from subteams on tagged things
14:08:36 <johnthetubaguy> yeah, that later bit isn't really happening like it used to
14:08:41 <markus_z> mriedem: http://45.55.105.55:3000/dashboard/db/openstack-bugs has a view on tagged "new" bugs
14:08:54 <mriedem> johnthetubaguy: it ever worked? :P
14:09:29 <mriedem> ok let's move on,
14:09:36 <mriedem> but a reminder for help needed as usual with bug triage
14:09:49 <mriedem> #topic reminders
14:09:53 <mriedem> #info: no meeting on July 21st due to the midcycle
14:09:55 <johnthetubaguy> mriedem: for like a week, we were golden, about a year or two ago
14:10:07 <markus_z> a bug related item would also be http://lists.openstack.org/pipermail/openstack-dev/2016-July/099096.html
14:10:08 * johnthetubaguy is happy he can now make the midcycle :)
14:10:08 <mriedem> johnthetubaguy: i think that's after sdague had his kid and went crazy on the backlog :)
14:10:25 <johnthetubaguy> mriedem: heh, yeah, that seriously helped
14:10:32 <mriedem> #info: The meetup is happening at the Holiday Inn Express in Hillsboro: http://lists.openstack.org/pipermail/openstack-dev/2016-July/099139.html
14:11:03 <mriedem> i'm hoping for the best as far as seating and wifi,
14:11:05 <mriedem> but we'll see
14:11:20 <mriedem> #link Newton review focus list: https://etherpad.openstack.org/p/newton-nova-priorities-tracking
14:11:30 <johnthetubaguy> should we ask dansmith to bring garden chairs?
14:11:40 <mriedem> you mean lawn chairs?
14:11:50 <johnthetubaguy> yeah, auto translate fail there
14:11:54 <mriedem> i don't think extra chairs are the issue
14:12:03 <mriedem> literally square footage is my concern
14:12:08 <johnthetubaguy> ah, gotcha
14:12:39 <mriedem> so now that we're past non-priority FFEs, we can prioritize the actual priorities!
14:12:52 <mriedem> #help https://wiki.openstack.org/wiki/Nova/BugTriage#Weekly_bug_skimming_duty Volunteers for 1 week of bug skimming duty?
14:13:00 <mriedem> ^ is open for next week
14:13:23 <mriedem> #topic stable branch status
14:13:46 <mriedem> i think the gates are clean at least for nova on stable
14:13:47 <mriedem> https://etherpad.openstack.org/p/stable-tracker
14:13:54 <mriedem> stable/mitaka: https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:stable/mitaka,n,z
14:13:59 <mriedem> stable/liberty: https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:stable/liberty,n,z
14:14:11 <mriedem> now that we cut n-2 we'll probably look at doing at least a mitaka point release
14:14:30 <mriedem> there is a lot out there that i haven't gone through yet though
14:14:59 <mriedem> markus_z: you were asking about why i asked for that one port_security_enabled=False tempest test
14:15:11 <mriedem> it's because we don't have tempest coverage for that scenario, which is why i've blocked backporting the series here https://review.openstack.org/#/c/284095/
14:15:19 <mriedem> and we've regressed it a few times
14:15:49 <mriedem> sorry this is the mitaka link https://review.openstack.org/#/c/306470/
14:15:58 <johnthetubaguy> I have seen the unit tests that cover all that, we totally need tempest tests
14:15:59 <markus_z> mriedem: I'm not exactly sure about the expected result of the tempest tests
14:16:22 <mriedem> markus_z: not failing to create a server is a good start :)
14:16:29 <mriedem> since that was the original bug for several yesar
14:16:31 <mriedem> *years
14:16:32 <markus_z> I'd need in a little prose what the result should be
14:16:48 <markus_z> -in
14:16:52 <johnthetubaguy> is this just a setup thing, rather than a new tempest test?
14:17:09 <johnthetubaguy> or is that port security thing network specific?
14:17:15 <mriedem> it's network specific
14:17:20 <markus_z> My WIP tempest test is this: https://review.openstack.org/#/c/341098/
14:17:24 <markus_z> A few pointers would be nice
14:17:39 <mriedem> so you have to create a tenant network with port_security_enabled=False
14:17:54 <mriedem> and boot a server and make sure that a security group doesn't get applied
14:18:01 <mriedem> but before the fixes the create would actually fail
14:18:08 <mriedem> anyway - the recreate is also in the bug reports
14:18:08 <markus_z> nova instance sec group or neutron port sec group?
14:18:22 <mriedem> markus_z: neutron, but really either
14:18:32 <mriedem> anyway, the server create would fail if we have it wrong
14:18:40 <mriedem> we can talk about that later
14:18:49 <markus_z> ok, I'll read the change
14:19:14 <mriedem> #topic subteam highlights
14:19:22 <mriedem> there was no cells v2 meeting this week
14:19:33 <mriedem> reminder was to review cells v2 changes in the review priorities etherpad
14:19:37 <alaski> yes please
14:19:43 <mriedem> but there aren't any blocking issues -  is what i heard
14:19:54 <alaski> correct
14:20:13 <mriedem> edleafe: cdent: there was a scheduler meeting this week right? i think i even attended most of that.
14:20:24 <edleafe> some good progress on the qualitative spec side of things
14:20:24 <edleafe> alex_xu posted the design for ResourceProviderTags
14:20:24 <edleafe> http://lists.openstack.org/pipermail/openstack-dev/2016-July/099032.html
14:20:40 <edleafe> otherwise, just getting ready for the midcycle discussions
14:20:42 <edleafe> that's it
14:21:21 <mriedem> alaski: since you're in a room with jaypipes all day,
14:21:36 <mriedem> i seem to remember jay saying he was going to summarize <something> in the ML this week
14:21:45 <mriedem> related to scheduler/placement/resource providers/allocations
14:21:49 <mriedem> you might want to nudge him
14:21:54 <cdent> he's made some slides and some related information that he plans to push today
14:22:01 <mriedem> slides!
14:22:04 <mriedem> awesome
14:22:04 <cdent> he was basically stating it as "homework"
14:22:11 <johnthetubaguy> slides :S
14:22:11 <mriedem> it is homework
14:22:12 <alaski> heh
14:22:24 <alaski> mostly about resource providers and what's happening there
14:22:49 <cdent> short, medium and long term vision stuff along side "this is how it works"
14:22:57 <johnthetubaguy> its like he just submitted a presentation on that for the summit or something?
14:23:05 <cdent> he's already on his way to portland, so we can get dansmith to remind him
14:23:07 <mriedem> heh
14:23:24 <mriedem> just as long as all of that doesn't change next week...but it might
14:23:31 <mriedem> moving on
14:23:36 <mriedem> there was no live migration meeting this week
14:23:41 <PaulMurray> no
14:23:44 <PaulMurray> but
14:23:54 <PaulMurray> we're trying to parallelise the imgae
14:24:02 <PaulMurray> backend and stroage pools work a little
14:24:12 <PaulMurray> I'll have more next week
14:24:22 <mriedem> ok
14:24:29 <mriedem> alex_xu: are you around?
14:24:48 <mriedem> i'm not sure if there was an api meeting or not
14:24:52 <johnthetubaguy> there was
14:24:56 <johnthetubaguy> not lots to report
14:25:09 <johnthetubaguy> there was a discussion around the remaining policy bits
14:25:31 <johnthetubaguy> there is the bit we need to help deployers still, I think alaski has that started
14:25:41 <johnthetubaguy> api-ref made some progress
14:25:45 <johnthetubaguy> but needs reviews
14:25:48 <alaski> yes, I have some patches up
14:25:48 <johnthetubaguy> I think that was it
14:26:07 <mriedem> ok
14:26:19 <mriedem> alaski: i've been mostly MIA on the policy redo
14:26:33 <mriedem> a ML summary on what's done there and what still needs to happen would be nice
14:26:44 <mriedem> alaski: since i think you need some homework too :)
14:26:49 <johnthetubaguy> so this is the most exciting bit: https://github.com/openstack/nova/blob/master/etc/nova/policy.json
14:26:49 <alaski> heh. can do
14:26:55 <mriedem> i saw that
14:27:25 <mriedem> i will say, i kind of miss having a single place to look at policy in the tree
14:27:40 <mriedem> but if we get the 'effective' default policy in the docs like the config options
14:27:43 <mriedem> i'll be happy
14:27:58 <alaski> the sample file can be generated
14:28:08 <alaski> tox -egenpolicy
14:28:15 <johnthetubaguy> yeah, thats one of that patches
14:28:16 <mriedem> ok, we should figure out how to build that into the docs
14:28:17 <johnthetubaguy> that we need
14:28:18 <mriedem> like the config options
14:28:24 <johnthetubaguy> mriedem: +1
14:28:30 <mriedem> i think mtreinish might have done that one long ago
14:28:34 <johnthetubaguy> so it is all here now: https://github.com/openstack/nova/tree/master/nova/policies
14:29:09 <mriedem> ok that's easy
14:29:13 <alaski> I think there's a sphinx extension for configs. I need to check that out
14:29:20 <alaski> and adapt it for policy
14:29:28 <mriedem> #alaski to recap the api policy in code work in the ML
14:29:32 <mriedem> oops
14:29:34 <mriedem> ha
14:29:40 <mriedem> #action alaski to recap the api policy in code work in the ML
14:29:56 <mriedem> moving on
14:30:02 <mriedem> there wasn't an sriov/pci meeting this week,
14:30:14 <mriedem> but a reminder to go over the changes listed in http://lists.openstack.org/pipermail/openstack-dev/2016-July/099016.html
14:30:27 <mriedem> to get resize/migration working, which it sounds like mellanox ci has a multinode setup to test now
14:30:30 <mriedem> which is great
14:30:57 <mriedem> notifications
14:31:08 <mriedem> johnthetubaguy: gibi_: ^ was there a meeting this week?
14:31:23 <mriedem> i assume those don't need to be weekly meetings now that we're past non-priority FF
14:31:28 <johnthetubaguy> unsure, I didn't get to that
14:31:35 <johnthetubaguy> but yeah, the work has all stopped now I think
14:31:50 <mriedem> ok
14:31:53 <mriedem> #topic stuck reviews
14:31:58 <mriedem> there was nothing on the agenda
14:32:06 <mriedem> anyone waiting to pounce?
14:32:16 <mriedem> #topic open discussion
14:32:21 <mriedem> a couple things
14:32:28 <mriedem> #info Mascot/logo thing: http://lists.openstack.org/pipermail/openstack-dev/2016-July/099046.html
14:32:38 <mriedem> you've probably already seen that
14:32:38 <alaski> I suggest cattle
14:32:42 <alaski> or a panda
14:32:51 <mriedem> i suggested sinkhole
14:32:53 <PaulMurray> hord of lemmings
14:32:54 <mriedem> it doesn't have to be animals
14:32:56 <markus_z> I want a super-nova, hand-sized
14:33:03 <markus_z> a real one
14:33:04 <andrearosa> cowcat
14:33:11 <cdent> a cow, sitting on a dog, sitting on a panda
14:33:16 <edleafe> definitely a lemming
14:33:30 <mriedem> so,
14:33:33 <PaulMurray> cdent, cow on top - really!
14:33:43 <cdent> cattle -> pet -> panda
14:33:44 <PaulMurray> you wont see the dog
14:33:47 <mriedem> i'm not going to be proposing anything for that, since i'm not interested in mascots and stickers
14:34:13 <mriedem> but if anyone has strong feelings about this, besides lemmings on top of mole rats eating bald eagles, then feel free to respond to the ML
14:34:36 <alaski> I support the lack of a mascot
14:34:44 <mriedem> thanks
14:34:47 <mriedem> #info Proposal to cleanup quota classes: http://lists.openstack.org/pipermail/openstack-dev/2016-July/099218.html (for Ocata)
14:34:50 <auggy> we can say it's a black hole
14:34:53 <mriedem> this is just fyi ^
14:35:06 <mriedem> while doing some bug triage yesterday, i remembered that i hate quota classes
14:35:21 <mriedem> i've got a blueprint staged for ocata, will write a spec at some point
14:35:30 <mriedem> but i'd really like to neuter a lot of that functionality
14:35:38 <mriedem> and make the API less bad
14:35:47 <mriedem> maybe even deprecate the API for removal
14:36:02 <mriedem> #info Discussion on when we need microversion testing in Tempest: http://lists.openstack.org/pipermail/openstack-dev/2016-July/099238.html
14:36:16 <mriedem> ^ will be going over that next week too a bit
14:36:34 <mriedem> but we have a glut of nova microversion changes in tempest right now all colliding
14:36:51 <mriedem> and some actual bugs from not having 2.3 schema validation support in tempest
14:37:04 <mriedem> ok,
14:37:07 <mriedem> it's open
14:37:25 <mriedem> anyone have anything? else we'll wrap up.
14:37:42 <markus_z> more feedback would be nice: http://lists.openstack.org/pipermail/openstack-dev/2016-July/099096.html
14:37:56 <markus_z> That's an idea how to make a bit more progress on bug fix reviews.
14:38:06 <mriedem> i haven't read all of the responses, i'm not crazy about driven from review comments
14:38:22 <mriedem> i prefer #2 until we have #4
14:38:34 <mriedem> because #2 can be built into a dashboard
14:38:40 <johnthetubaguy> mriedem: I should reply to the thread, but Turnstile never get used AFAIK
14:38:44 <markus_z> yeah, the technical side has a lot of feedback
14:39:31 <johnthetubaguy> mriedem: yeah, +1 on the dashboard
14:39:56 <markus_z> don't need to discuss it here. tooling doesn't work if people are not willing to use it.
14:40:02 <mriedem> yup
14:40:10 <mriedem> let's move it to the ML, thanks for starting that markus_z
14:40:26 <mriedem> thanks everyone, ttyl
14:40:27 <mriedem> #endmeeting