21:00:49 <mriedem> #startmeeting nova
21:00:50 <openstack> Meeting started Thu Mar 16 21:00:49 2017 UTC and is due to finish in 60 minutes. The chair is mriedem. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:51 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:54 <openstack> The meeting name has been set to 'nova'
21:00:59 <edleafe> \o
21:01:01 <dansmith> o/
21:01:02 <dtp> o/
21:01:06 <melwitt> o/
21:01:15 <efried> o/
21:01:19 <lyarwood> o/
21:01:25 <efried> DST is stupid.
21:01:43 <bauzas> \o
21:01:56 * efried was really confused in the novaclient meeting an hour ago
21:02:04 <mriedem> efried: there is a novaclient meeting?
21:02:25 <efried> openstackclient, mebbe
21:02:36 <mriedem> yes
21:02:50 <mriedem> ok so let's get started
21:02:53 <mriedem> #link agenda https://wiki.openstack.org/wiki/Meetings/Nova#Agenda_for_next_meeting
21:03:01 <mriedem> #topic release news
21:03:06 <mriedem> #link Pike release schedule: https://wiki.openstack.org/wiki/Nova/Pike_Release_Schedule
21:03:11 <mriedem> #info Blueprints: 58 targeted, 30 approved
21:03:20 <mriedem> #info Open spec reviews: 116
21:03:24 <mriedem> ^ as of yesterday
21:03:59 <mriedem> #info Reminder that spec freeze is on the p-1 milestone which is April 13th
21:04:13 <mriedem> questions?
21:04:29 <mriedem> #topic Bugs (stuck/critical)
21:04:45 <mriedem> no critical bugs
21:04:52 <mriedem> #link https://launchpad.net/bugs/1671648 - Instances are not rescheduled after deploy fails
21:04:52 <openstack> Launchpad bug 1671648 in OpenStack Compute (nova) ocata "Instances are not rescheduled after deploy fails" [High,In progress] - Assigned to Matt Riedemann (mriedem)
21:05:01 <mriedem> that was a notable mention, the fix is in the gate for master,
21:05:05 <mriedem> i've begun backporting to ocata
21:05:11 <mriedem> "backport proceedings"
21:05:23 <mriedem> #link check queue gate status http://status.openstack.org/elastic-recheck/index.html
21:05:28 <mriedem> gate is same old
21:05:48 <mriedem> dansmith: ever hear if jbernard made progress on the ceph job?
21:05:58 <dansmith> mriedem: no, actually
21:06:04 <dansmith> I should ask him
21:06:07 <mriedem> are you waring your kicking boots?
21:06:11 <mriedem> *wearing
21:06:12 <melwitt> I checked for open reviews from him recently and didn't see anything
21:06:27 <mriedem> ok
21:06:37 <mriedem> #action follow up with jbernard about the ceph job
21:06:52 <mriedem> for 3rd party ci, there isn't much news,
21:06:58 <mriedem> except my thread on the ML about the vmware ci
21:07:02 <mriedem> or lack thereof
21:07:26 <mriedem> doesn't appear we have any vmware people in the meeting
21:07:29 <mriedem> which isn't surprising
21:07:47 <mriedem> moving on
21:07:51 <mriedem> #topic reminders
21:07:58 <mriedem> #link Pike Review Priorities etherpad: https://etherpad.openstack.org/p/pike-nova-priorities-tracking
21:08:10 <mriedem> let's keep that up to date
21:08:13 <mriedem> #link Forum planning: https://wiki.openstack.org/wiki/Forum/Boston2017
21:08:19 <mriedem> #info EOD April 2: deadline for Forum topic submission
21:08:33 <mriedem> i haven't even looked at the topics yet
21:08:48 <mriedem> i've requested an onboarding room slot for nova
21:08:54 <mriedem> i have at least one person interested in running that
21:09:08 <mriedem> name rhymes with hague
21:09:20 <mriedem> #link https://etherpad.openstack.org/p/BOS-Nova-brainstorming Forum discussion planning for nova (add your name if you are going)
21:09:39 <mriedem> if you didn't see my ML thread, please put your name at the bottom of ^ if you think you'll be at the summit
21:10:02 <mriedem> dansmith: i see you didn't get the message :)
21:10:03 <dansmith> I also put a call out in the MIL one for cells,
21:10:20 <dansmith> looking for people from the ops summit to specifically bring outcomes and questions to forum
21:10:29 <mriedem> oh the ops meetup
21:10:30 <mriedem> yeah
21:10:53 <mriedem> i should track that etherpad down, no idea if they even talked about cells v2
21:11:06 <dansmith> yeah they had one, just got filled out in the last couple days,
21:11:08 <bauzas> they did
21:11:14 <bauzas> I have a source :p
21:11:17 <dansmith> mostly just looking for feedback on who is interested or paying attention
21:11:24 <mriedem> besides dpt
21:11:26 <mriedem> *dtp
21:11:31 <dtp> O_o
21:11:32 <mriedem> ok
21:11:35 <mriedem> #topic Stable branch status: https://etherpad.openstack.org/p/stable-tracker
21:11:43 <mriedem> stable/ocata: https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:stable/ocata,n,z
21:11:51 <mriedem> #info Ocata 15.0.1 is released.
21:11:57 <bauzas> so the main issue they encountered is they tried to understand our features without really having lots of people knowing it
21:12:07 <bauzas> (that's my source who told that)
21:12:30 <mriedem> bauzas: so let me get this straight,
21:12:36 <mriedem> they are all up in our kool aid,
21:12:39 <mriedem> without even knowing the flavor?
21:12:46 <bauzas> LOL
21:12:56 <mriedem> moving on
21:13:01 <mriedem> stable/newton: https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:stable/newton,n,z
21:13:24 <mriedem> and mitaka is basically eol
21:13:30 <lyarwood> mriedem: any plans for the final stable/mitaka release?
21:13:38 <mriedem> lyarwood: that happens when the actual eol happens
21:13:51 <lyarwood> mriedem: ah nice
21:13:53 <mriedem> which is 2017-04-10
21:14:05 <mriedem> so let's hope for now whammies
21:14:07 <mriedem> *no
21:14:17 <mriedem> #topic subteam highlights
21:14:20 <mriedem> dansmith: cellsv2
21:14:25 <dansmith> ohai
21:14:44 <dansmith> we mostly just talked about the current efforts, my patch series to get multiple cells working,
21:14:48 * edleafe gets scheduler notes prepared
21:14:49 <dansmith> as well as melwitt's for quota
21:15:13 <dansmith> and talked about some of the regression bugs that have come up and mostly been squashed recently
21:15:23 <dansmith> I believe that is all
21:15:27 <mriedem> i also saw you made changes to the counting quotas stuff last night to make it smaller patches
21:15:35 <dansmith> oh, yeah
21:15:35 <mriedem> but i haven't looked
21:15:46 <dansmith> well, I took a thing that was working and made it not work, but in smaller pieces
21:15:52 <dansmith> but I think it's the right way to go
21:15:59 <mriedem> heh, ok
21:16:10 <melwitt> haha, that's a funny way to put it
21:16:15 <mriedem> melwitt will piece it back together i'm sure
21:16:26 <mriedem> ok, edleafe - scheduler
21:16:36 <edleafe> Traits series looks close - just a few issues left
21:16:36 <edleafe> Ironic Inventory patch discussed - has since merged (yay!)
21:16:36 <edleafe> Starting to work on functional test coverage for placement - looking for input there
21:16:39 <edleafe> Discussed the general thoughts on separating placement into its own repo. Generally in favor of sooner than later, with Queens being the working target to tackle this.
21:16:42 <edleafe> EOM
21:17:17 <mriedem> ok
21:17:36 <mriedem> i don't think there was a live migration meeting this week since tdurakov was sick
21:17:45 <mriedem> so onto api
21:17:54 <mriedem> alex_xu left some notes:
21:17:56 <mriedem> The spec for policy docs merged https://review.openstack.org/#/c/433010/
21:18:08 <mriedem> The spec for removing scope check need wider feedback https://review.openstack.org/#/c/433037/
21:18:19 <mriedem> Discuss the spec show scheduler_hints in the response https://review.openstack.org/#/c/440580/, found two problems:
21:18:23 <mriedem> There is no quota/limit in the request of scheduler_hints, this should be fixed as a bug
21:18:30 <mriedem> Need more strong use-case for this proposal
21:18:40 <mriedem> and finally,
21:18:41 <mriedem> A PoC come up for removing the stevedore from the nova API to reach the final goal of no extension https://review.openstack.org/445864, people think this is specless BP and can be done in Pike.
21:19:14 <dansmith> woot
21:19:18 <mriedem> we could just rename and reuse https://blueprints.launchpad.net/nova/+spec/api-no-more-extensions-ocata under that
21:19:58 <mriedem> no sriov/pci people around
21:20:07 <mriedem> notification updates
21:20:09 <mriedem> 1. BDM in InstancePayload proposal is discussed both on the meeting and on the ML. Implementation is ongoing.
21:20:17 <mriedem> 2. Searchlight team will provide the list of notifications need to be transformed to the versioned format to be able to switch to consuming versioned notifications in Searchlight.
21:20:38 <mriedem> i guess once we get that list from searchlight, we have our priority list for versioned notifications,
21:20:39 <mriedem> which would be nice
21:20:52 <mriedem> efried: powervm, go
21:20:57 <efried> Yeaux
21:20:59 <efried> https://review.openstack.org/438119 (bottom-most change set) refreshed per mriedem review. Changes nontrivial, so it's going to take me a while to rebase the rest on top. Meanwhile, encourage others to review this 'un.
21:21:16 <efried> That's about all I have.
21:21:30 <mriedem> ok so i can look at the first change again now?
21:21:33 <efried> Yes please.
21:21:36 <mriedem> you took out the swear words?
21:21:37 <mriedem> ok
21:21:40 <efried> Hah
21:21:44 <efried> No, those are still there.
21:21:51 <efried> Including "Swamp Thing".
21:22:06 <mriedem> mmm adrien barbeau
21:22:16 <mriedem> ok nova/cinder: still working on same things as last week (bdm.attachment_id, support for cinder v3, and the John's spec for the new cinder APIs)
21:22:29 <mriedem> i've got +2s on lyarwood's attachment_id changes to the bdm model
21:22:46 <mriedem> jgriffith is working on making nova know which microversion is available in cinder
21:22:54 <mriedem> and we still need more reviews on johnthetubaguy's spec
21:23:04 <efried> link?
21:23:18 <mriedem> #link cinder v3 attach spec https://review.openstack.org/#/c/373203/
21:23:44 <mriedem> i haven't gone through it again myself since the ptg, so need to sit down and do that sometime, but mdbooth and lyarwood have been picking it over
21:23:53 * efried will do his usual thing, pointing out typos without actually understanding content.
21:23:57 <mriedem> but at some point, we'll just need to get off that pot
21:24:01 <mriedem> or shit, i don't know which
21:24:23 <mriedem> #topic stuck reviews
21:24:31 <mriedem> nothing on the agenda, anyone have anything here?
21:24:35 <mriedem> stuck != no attention
21:24:51 <mriedem> moving on
21:24:54 <mriedem> #topic open discussion
21:25:09 <mriedem> logan isn't here to discuss https://blueprints.launchpad.net/nova/+spec/lvm-thin-pool
21:25:26 <mriedem> i feel like i told them to talk to cfriesen and/or cburgess about that one
21:25:34 <cburgess> Do what now?
21:25:39 <mriedem> i feel like i've heard opsy types talking about already having that support out of tree
21:26:02 <mriedem> cburgess: ^ the lvm thin pool bp
21:26:09 <cburgess> Oh that... yeah cfriesen and I discussed that at the PTG. I don't have out of tree code but I think he said he did or knew someone who did.
21:26:17 <cburgess> Its a good idea. We need it.
21:26:23 <mriedem> cfriesen has all of the out of tree code
21:26:36 <mriedem> which is why he shows up asking "is this supposed to happen?"
21:26:50 <mriedem> ok i see -1s on the actual code patch
21:27:01 <lyarwood> asking for a spec iirc
21:27:10 <cburgess> mriedem Did you want me to review it and provide feedback?
21:27:12 <mriedem> ok, i see mdbooth, lyarwood and cfriesen on review
21:27:15 <mriedem> cburgess: sure
21:27:24 <cburgess> mriedem Added to my list.
21:27:45 <mriedem> from what i'm reading at the end, logan is ops and busy, but agrees a spec would be good
21:27:50 <mriedem> so i'll wait for that
21:28:25 <mriedem> #action mriedem to leave a note in https://blueprints.launchpad.net/nova/+spec/lvm-thin-pool about needing a spec
21:28:34 <mriedem> edleafe: https://blueprints.launchpad.net/nova/+spec/remove-openstack-api-directory
21:28:39 <mriedem> that was discussed a bit last week,
21:28:48 <mriedem> edleafe: can i delegate that to the api subteam to decide?
21:29:03 <mriedem> and you follow up with it in their weekly meeting?
21:29:13 <edleafe> sure thing
21:29:13 <mriedem> or just talk to sdague and alex_xu
21:29:15 <mriedem> thanks
21:29:33 <mriedem> last but sort of least, dtp: https://blueprints.launchpad.net/nova/+spec/conf-network-metadata-always-static-ip
21:30:10 <mriedem> dtp: did you want to say anything about that one?
21:30:24 <dtp> For your consideration, this is a config option to have nova write static network config even when DHCP is enabled, for the purpose of fallback, and initial PXE boot for ironic.
21:30:47 <mriedem> jroll: could you take a look at ^ ?
21:30:55 <mriedem> this one is over my head
21:31:08 <mriedem> or dansmith et al
21:31:23 <dansmith> jroll gets a dedicated shout, but I am lumped in with "et al" eh?
21:31:25 <mriedem> the change itself is relatively small
21:31:29 <mriedem> dansmith: yes
21:31:32 <dansmith> :(
21:31:46 <mriedem> jroll is still considered a guest
21:33:14 <mriedem> ok so i guess we'll just talk about that later
21:33:20 <mriedem> anyone else have anything they wanted to discuss?
21:33:23 <dansmith> I'll look
21:33:28 <mriedem> cool
21:33:33 <dansmith> I mean, me and everyone else will look
21:33:34 <mriedem> i'm assuming johnthetubaguy has input too
21:33:47 <mriedem> hell, he'll probably sign up to own it
21:33:58 <mriedem> ok, that's it, thanks everyone
21:34:00 <mriedem> #endmeeting