14:00:33 <mriedem> #startmeeting nova
14:00:34 <openstack> Meeting started Thu Aug 10 14:00:33 2017 UTC and is due to finish in 60 minutes.  The chair is mriedem. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:35 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:38 <openstack> The meeting name has been set to 'nova'
14:00:41 <cdent> o-
14:00:47 <efried> \o
14:00:59 <takashin> o/
14:01:05 <edmondsw> o/
14:01:28 <gibi> o/
14:01:31 <edleafe> \o
14:02:08 <mriedem> alright,
14:02:08 <bauzas> \o
14:02:14 <mriedem> #link agenda https://wiki.openstack.org/wiki/Meetings/Nova
14:02:24 <mriedem> #topic release news
14:02:31 <mriedem> #link Pike release schedule: https://wiki.openstack.org/wiki/Nova/Pike_Release_Schedule
14:02:36 <mriedem> #info August 10 (today) is Pike RC1
14:02:52 <mriedem> there is one change i'm tracking before we cut rc1
14:02:56 <mriedem> #link tracking https://review.openstack.org/#/c/491012/ for rc1
14:03:23 <bauzas> on it
14:03:28 <mriedem> check queue is at 6 hours
14:03:50 <mriedem> there are some other changes i'm watching too and rechecking, but that's the main one
14:04:01 <mriedem> i can put those all at the top of the etherpad after the meeting
14:04:13 <mriedem> #action to summarize which changes we're watching for rc1 in the etherpad at the top
14:04:29 <mriedem> #info Blueprints: 50 targeted, 50 approved, 49 completed (+3 from last week)
14:04:42 <mriedem> the only one not marked completed yet is the doc migration one,
14:04:52 <mriedem> but i think we can probably mark that complete at any point since most stuff has moved over
14:04:57 <mriedem> sdague: or did you have a definite end state?
14:05:48 <mriedem> ok sdague and bauzas are still busy i guess
14:05:57 <mriedem> #link Pike RC1 TODO etherpad: https://etherpad.openstack.org/p/nova-pike-release-candidate-todo
14:06:13 <mriedem> anyone have anything they want to mention for the release?
14:06:36 <sdague> yes, the manual imports
14:07:11 <sdague> we really want to do those before the pike branch, otherwise we just don't have them in pike
14:07:22 <mriedem> sdague: so all of https://review.openstack.org/#/q/topic:bp/doc-migration+status:open+project:openstack/nova ?
14:07:25 <mriedem> today?
14:07:51 <mriedem> they won't be in the pike branch, but the docs will be generated and published to latest from master which is what i think most people are looking at
14:08:09 <sdague> except they all cross link
14:08:19 <sdague> so, minimally you want to get to here - https://review.openstack.org/#/c/491853
14:08:28 * bauzas notes
14:08:41 <sdague> people get sent to the install guide per release
14:08:46 <sdague> but this is one docs tree now
14:08:58 <sdague> so every link from the pike install guide will be to pike versions of all the rest of it
14:09:01 <mriedem> ok i'll star that one then
14:09:19 <mriedem> #link https://review.openstack.org/#/c/491853 is end goal for docs migration in pike
14:09:20 <sdague> which, is it's own sort of issue called out here https://review.openstack.org/#/c/492124
14:09:51 <sdague> and probably deserves a dedicated carve out at PTG to figure out the dust settling of all of this
14:10:40 <sdague> anyway, we can move on
14:10:46 <mriedem> alright
14:10:53 <mriedem> #topic bugs
14:11:02 <mriedem> nothing marked critical
14:11:18 <mriedem> 0 untriaged right now
14:11:23 <mriedem> there was one for live migration from the xen team last night
14:11:29 <mriedem> but now i don't see it - must have been triaged,
14:11:34 <mriedem> but it looked related to cells v2
14:11:39 <mriedem> sdague: did you happen to see ^ ?
14:11:42 <mriedem> or did a bot take care of that?
14:11:47 <bauzas> it's confirmed yeah
14:11:57 <bauzas> https://bugs.launchpad.net/nova/+bug/1709594
14:11:58 <openstack> Launchpad bug 1709594 in OpenStack Compute (nova) "live-migration without '--block-migrate" failed with "No sql_connection parameter is established"" [High,Confirmed]
14:12:01 <sdague> mriedem: I confirmed it and put it under xenserver cellsv2
14:13:08 <mriedem> hmm, ok, i'm just wondering if it's a pike-rc-potential
14:13:17 <mriedem> since i don't know what would be different about this for xenserver
14:13:34 <sdague> yeh, I don't know
14:14:06 <mriedem> ok i'm going to tag it pike-rc-potential so we can investigate it for a possible rc2
14:14:10 <bauzas> oh, just saw someone forgot to put back the new state for https://bugs.launchpad.net/nova/+bug/1709236
14:14:11 <openstack> Launchpad bug 1709236 in OpenStack Compute (nova) "Live migration failed in openstack on xenserver" [Undecided,Incomplete]
14:14:13 <bauzas> after replying
14:14:29 * bauzas likes BZ for that
14:14:42 <bauzas> by default it assumes you close your needinfo tag
14:15:23 <bauzas> tl;dr: looks v2.34 regressed xen live-migration
14:15:55 <mriedem> ok that was newton
14:15:56 <mriedem> ...
14:16:13 <sdague> yeh, if this goes back to newton as an issue, it's not an rc blocking bug
14:16:33 <mriedem> right
14:16:39 <bauzas> oh nevermind then
14:16:52 <bauzas> I'll continue digging
14:17:13 <mriedem> ok marked it confirmed,
14:17:16 <mriedem> and added ocata and newton to it
14:17:43 <mriedem> #info pike-rc-potential bugs: https://bugs.launchpad.net/nova/+bugs?field.tag=pike-rc-potential
14:18:00 <mriedem> so we've got fixes in flight for 2 of those
14:18:14 <mriedem> the ironic one from ed, i'd really like dansmith to be happy with that, but he's on vacation
14:18:26 <mriedem> and that live migration one can be an rc2 candidate
14:19:05 <mriedem> edleafe: dansmith asked about an ironic ci test that uses resource classes to test your healing change - i know dtantsur has a patch for that, but has there been a clean run?
14:19:20 <mriedem> plus talk yesterday of disallowing people from changing a resource class on a node
14:19:24 <bauzas> mriedem: plus https://review.openstack.org/#/c/491012/ right?
14:19:37 <mriedem> bauzas: yes i expect that to be approved this morning
14:19:43 <mriedem> or your french night
14:19:48 <edleafe> mriedem: I know that dtantsur is still working on that patch
14:20:15 <edleafe> mriedem: I can add something on top of that one
14:20:31 <mriedem> ok could talk about the ironic one later
14:20:38 <mriedem> i haven't really been following it
14:21:01 <edleafe> mriedem: heh, the patch is about where it was over a week ago when the ironic people told me that operators could change resource_class on a node
14:21:28 <bauzas> mriedem: yeah, on its way, just wanted to make sure we don't forget it :)
14:21:48 <mriedem> edleafe: ok i don't know if they are changing that as a bug fix in ironic or not
14:21:50 <mriedem> but anyway, moving on
14:22:01 <mriedem> gate status is ok-ish
14:22:14 <mriedem> there are slow nodes from citycloud-lon1 causing job timeouts and other weirdness
14:22:21 <mriedem> and the check queue is way backed up, as noted
14:22:25 <edleafe> mriedem: they are. Don't know if it's just a doc change or what
14:22:39 <mriedem> #topic reminders
14:22:45 <sdague> yeh, just plan for > 6 hrs to get check results back at this point
14:22:49 <mriedem> #link Consider signing up for the Queens PTG which is the week of September 11 in Denver, CO, USA: https://www.openstack.org/ptg
14:22:56 <mriedem> #link Pike PTG topics etherpad: https://etherpad.openstack.org/p/nova-ptg-queens
14:23:09 <mriedem> sdague: ^ there is a section in there about docs, maybe add whatever you'd like to see discussed at the ptg
14:23:18 <sdague> mriedem: will do
14:23:20 <mriedem> i need to add something about consistent home pages for the various projects
14:23:24 <mriedem> which i brought up in the ML
14:23:28 <mriedem> and seemed to have general agreement
14:25:07 <mriedem> #topic stable branch status
14:25:13 <mriedem> #link stable/ocata: https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:stable/ocata,n,z
14:25:18 <mriedem> #link stable/newton: https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:stable/newton,n,z
14:25:22 <mriedem> oodles of reviews on stable
14:25:42 <mriedem> yet another thing i've been meaning to flush through
14:25:52 <mriedem> will probably work on some of that today too
14:26:45 <mriedem> #topic subteam highlights
14:26:51 <mriedem> no cells v2 meeting this week
14:26:53 <mriedem> edleafe: scheduler stuff?
14:27:03 <edleafe> Not much to talk about, with all the hullabaloo going on with the claims patches
14:27:06 <edleafe> Clarified that shared resources will be not be a thing in Pike
14:27:08 <edleafe> Jay had to deal with a lot of (literal) shit during the meeting
14:27:09 <edleafe> EOM
14:27:11 <edleafe> Jay agreed to document the specifics of what happens (re: placement) in each of the move/resize operations
14:27:14 <edleafe> The meeting ended with much love for the ChanceScheduler
14:27:58 <mriedem> right ok those docs aren't up yet, but we have something as a stand in
14:28:13 <mriedem> this https://review.openstack.org/#/c/491900/
14:28:21 <mriedem> also, the caching scheduler and chance schedulers are now deprecated
14:28:40 <mriedem> #info chance and caching schedulers are now deprecated https://review.openstack.org/#/c/492210/
14:28:51 <edleafe> ...and not a tear was shed
14:28:59 <mriedem> oh and
14:29:05 <mriedem> #info ram and disk filters are no longer enabled by default https://review.openstack.org/#/c/491854/
14:29:35 <bauzas> edleafe: well wait for a bit about that :)
14:29:37 <mriedem> alex_xu: was there an api meeting this week?
14:29:54 <edleafe> Also I'm working with dtantsur to deprecate all things about the ironic scheduler filters and options
14:29:58 <cdent> there was not, the meetbot was down and nobody had anything to talk about so it was called off
14:30:12 <mriedem> ok, only api thing i know of is https://review.openstack.org/#/c/489926/
14:30:20 <mriedem> which is more docs for the new route mapping
14:30:47 <mriedem> holy cow https://review.openstack.org/#/c/489926/9/doc/source/_static/images/evolution-of-api.png,unified
14:31:06 <mriedem> we should have the classic ape -> man evolution graphic in there
14:31:32 <mriedem> https://thumbs.dreamstime.com/z/evolution-man-25266163.jpg
14:31:51 <sdague> yeh, that's a really nice patch
14:32:02 <sdague> good work gmann
14:32:18 <mriedem> there was no notification meeting this week
14:32:35 <mriedem> and the nova/cinder meeting hasn't happened yet
14:32:39 <mriedem> but will likely be short
14:32:47 <mriedem> #topic stuck reviews
14:32:55 <mriedem> nothing on the agenda
14:32:59 <mriedem> does anyone want to bring something up here?
14:33:22 <mriedem> #topic open discussion
14:33:28 <mriedem> ok only thing i wanted to mention
14:33:37 <mriedem> #info mriedem is on vacation next week (along with sdague, bauzas and  stephenfin), dansmith is in charge of release stuff in case we need an  RC2
14:33:57 <mriedem> i don't plan on bringing my laptop with me
14:34:17 <mriedem> anyone have anything else to discuss?
14:34:47 <mriedem> ok that's it then, thanks everyone
14:34:50 <bauzas> ++
14:34:52 <mriedem> #endmeeting