21:00:04 <mriedem> #startmeeting nova
21:00:05 <openstack> Meeting started Thu Aug 31 21:00:04 2017 UTC and is due to finish in 60 minutes.  The chair is mriedem. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:08 <openstack> The meeting name has been set to 'nova'
21:00:13 <dansmith> o/
21:00:14 <efried> o/
21:00:16 <melwitt> o/
21:00:22 <edleafe> \o
21:00:51 <cfriesen_> \o
21:00:52 <mriedem> alright then
21:00:55 <mriedem> #link meeting agenda https://wiki.openstack.org/wiki/Meetings/Nova#Agenda_for_next_meeting
21:01:03 <mriedem> #topic release news
21:01:13 <mriedem> well we know pike is released
21:01:16 <mriedem> good riddance
21:01:21 <dansmith> I'll say
21:01:23 <melwitt> heh
21:01:25 <mriedem> #link Queens release schedule: https://wiki.openstack.org/wiki/Nova/Queens_Release_Schedule
21:01:29 <mriedem> i have to fill in ^
21:01:36 <mriedem> #info Re-propose specs for Queens
21:01:37 <cfriesen_> resource tracking is going to haunt us
21:02:03 <mriedem> i love resource tracking but it doesn't love me
21:02:13 <mriedem> ok that's about it for release news
21:02:21 <mriedem> #topic bugs
21:02:30 <mriedem> nothing marked critical
21:02:34 <mriedem> #info 4 new untriaged bugs (up 1 from last week)
21:03:09 <mriedem> gate status is ok
21:03:15 <mriedem> 3rd party ci status is, ok?
21:03:46 <mriedem> #topic reminders
21:03:52 <mriedem> #link Consider signing up for the Queens PTG which is the week of September 11 in Denver, CO, USA: https://www.openstack.org/ptg
21:04:06 <mriedem> #link Pike PTG topics etherpad: https://etherpad.openstack.org/p/nova-ptg-queens
21:04:20 <mriedem> i will hopefully get more serious about organizing that etherpad next week
21:04:31 <mriedem> right now it's PLACEMENT...CELLS...EVERYTHING ELSE
21:04:49 <mriedem> #info Be a star and consider the Pike project update interview at the PTG: http://lists.openstack.org/pipermail/openstack-dev/2017-August/121369.html
21:04:53 <melwitt> yeah. are we gonna have designated times for syncing with cinder and neutron teams?
21:05:01 <mriedem> thursday morning is nova/cinder love time
21:05:05 <dansmith> yeah, 9th green at 9
21:05:06 <dansmith> for both
21:05:11 <mriedem> don't know about neutron
21:05:16 <mriedem> kevinbenton hasn't been returning my calls
21:05:18 <mriedem> or texts
21:05:21 <mriedem> or letters
21:05:27 <kevinbenton> mriedem: you called?
21:05:27 <melwitt> haha
21:05:42 <mriedem> oh NOW you decide to respond
21:05:58 <kevinbenton> mriedem: you don't even hang out in the #openstack-neutron channel :)
21:06:03 <mriedem> sure as shit i do
21:06:19 <mriedem> anyway, kevinbenton if you want to talk PTG stuff later we can
21:06:34 <kevinbenton> mriedem: i haven't finished a schedule for neutron PTG so i'm flexible for a cross session
21:06:40 <kevinbenton> mriedem: ack, let's chat in channel
21:06:47 <mriedem> #topic stable branch status
21:06:54 <mriedem> well, we drop one, we add one
21:06:58 <melwitt> another thing to consider with PTG scheduling is, whether we should try to break stuff up into some time chunks to make it easier for people to move between rooms
21:06:58 <mriedem> #link stable/pike: https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:stable/pike,n,z
21:07:17 <dansmith> melwitt: we did that last time right?
21:07:21 <dansmith> I assumed we would again
21:07:25 <mriedem> did we?
21:07:34 <dansmith> yeah, didn't we assign some times to things?
21:07:39 <melwitt> I don't think we did. some folks were disappointed with the lack of ability to move between rooms
21:07:41 <mriedem> yeah, morning/afternoon
21:07:47 <mriedem> but not granular like to the hour, like at the summit
21:07:54 <mriedem> some people == mel
21:08:06 <efried> There's that #openstack-ptg channel
21:08:06 <melwitt> haha, nooo
21:08:16 <efried> where we're sposed to announce when we're gonna move on to a topic.
21:08:22 <mriedem> yeah there is a bot thing now to notify when something is happening in a room
21:08:28 <dansmith> https://etherpad.openstack.org/p/nova-ptg-pike
21:08:34 <dansmith> we did for L287 and 288
21:08:55 <mriedem> yeah there are common rooms for cross-project things
21:08:55 <dansmith> there were meeting times for some of the cross-project ones, that's probably what I'm thinking about though
21:08:58 <dansmith> like the api wg one
21:09:00 <mriedem> that you can schedule a block of time
21:09:11 <mriedem> the horizontal topic things are also mostly monday/tuesday
21:09:16 <mriedem> leaving wed-friday for nova-specific stuff
21:09:17 <clarkb> efried: it has a "now" topic and a "next" topic
21:09:18 <mriedem> in our cave
21:09:21 <melwitt> I never move so it's not about me. I just heard some people felt stuck in the room so as not to miss the topic they wanted
21:09:40 <mriedem> yeah, i hope the bot helps with that,
21:09:53 <dansmith> we scheduled the neutron and keystone syncs
21:09:54 <mriedem> plus, if you're there, and you want to be pinged when we start talking about something, put your nick in the etherpad next to said topic
21:10:05 <dansmith> anyway
21:10:06 <bauzas> holy ship
21:10:09 <dansmith> +1 to slots
21:10:10 * bauzas waves super late
21:10:28 <mriedem> #action mriedem to appease melwitt and only melwitt with slotifying the ptg topics down to the nanosecond
21:10:37 <melwitt> lol
21:10:55 <mriedem> melwitt: i will totally be happy to trade doing that for you doing the project update
21:11:01 <mriedem> with the red hat marketing team
21:11:20 <mriedem> so as for stable stuff,
21:11:22 <melwitt> I'll take a look at that, maybe I could do it
21:11:25 <mriedem> stable/pike is active
21:11:42 <mriedem> and we have some known bugs coming out of pike FF/RC1/RC2 for edge cases with placement stuff
21:12:01 <mriedem> which will all get backported
21:12:16 <mriedem> we've had recent releases for ocata and newton, so those are pretty stable atm
21:12:26 <mriedem> no pun intended
21:12:34 <mriedem> #topic subteam highlights
21:12:38 <mriedem> dansmith: cells v2?
21:12:50 <bauzas> mriedem: planning a stable version soon-ish ?
21:13:07 <bauzas> given all the backports
21:13:08 <mriedem> not until several more bugs are fixed and backported
21:13:19 <bauzas> okay, fine by me
21:13:25 <bauzas> will prioritize that then
21:13:42 <mriedem> did we lose dansmith?
21:13:49 <dansmith> sorry
21:13:53 <dansmith> we talked about ptg topics
21:13:59 <dansmith> details are in the ptg etherpad
21:14:08 <dansmith> only one minorish bug since rc2
21:14:11 <dansmith> winning.
21:14:13 <dansmith> that's all
21:14:24 <mriedem> edleafe: scheduler?
21:14:28 <edleafe> Most of the meeting was spent discussing the options for returning data from the scheduler once we support alternates for each instance, along with the allocations for each choice.
21:14:32 <edleafe> We agreed not to use a cache for the allocations, and to use an object to manage the data returned from select_destinations()
21:14:35 <edleafe> There is already a much more limited Destination object in the RequestSpec, so that may be adapted to add this new information.
21:14:38 <edleafe> Lots of pre-requisite work, such as BP/specs for returning alternates and allocations still needs to be done first.
21:14:41 <edleafe> Fin.
21:15:09 <mriedem> ok
21:15:12 <mriedem> api meeting, i wasn't there
21:15:23 <mriedem> not sure anyone here was there either given timezone
21:15:52 <mriedem> notifications,
21:15:54 <mriedem> there was a meeting
21:16:00 <mriedem> The subteem meeting and weekly status mail has been restarted
21:16:09 * mriedem speaks for gibi
21:16:12 <mriedem> I started a ML thread and an etherpad to collect who is using nova  notifications and I'm trying to get feedback and possible new  contributors. #link http://lists.openstack.org/pipermail/openstack-dev/2017-August/121651.html
21:16:42 <mriedem> and finally cinder,
21:16:50 <mriedem> meeting was today. there was a new cinderclient release that has some stuff we need
21:17:00 <mriedem> patches in nova are going to be rebased
21:17:08 <mriedem> and ildikov is re-proposing the specs
21:17:20 <mriedem> #topic stuck reviews
21:17:23 <mriedem> nothing on the gaenda
21:17:24 <mriedem> *agenda
21:17:34 <mriedem> #topic open discussion
21:17:42 <mriedem> nothing on the agenda so i'll open it up
21:18:26 <mriedem> ok well i guess that's it
21:18:30 <mriedem> thanks everyone
21:18:33 <mriedem> #endmeeting