21:00:24 <mriedem> #startmeeting nova
21:00:25 <openstack> Meeting started Thu Sep 28 21:00:24 2017 UTC and is due to finish in 60 minutes.  The chair is mriedem. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:26 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:29 <melwitt> o/
21:00:29 <openstack> The meeting name has been set to 'nova'
21:00:30 <takashin> o/
21:00:31 <tssurya> o/
21:00:31 <efried> \o
21:00:39 <edleafe> \o
21:01:07 <dansmith> o/
21:01:34 <mriedem> alright let's get started
21:01:41 <mriedem> #link agenda https://wiki.openstack.org/wiki/Meetings/Nova#Agenda_for_next_meeting
21:01:49 <mriedem> #topic release news
21:01:55 <mriedem> #link Queens release schedule: https://wiki.openstack.org/wiki/Nova/Queens_Release_Schedule
21:02:15 <mriedem> #info Re-propose and review specs for Queens
21:02:22 <mriedem> #info Oct 19: q-1 milestone, nova spec freeze (3 weeks away)
21:02:33 <mriedem> #info Blueprints: 41 targeted, 12 approved, 1 complete
21:02:48 <mriedem> i know i personally haven't done a good job of reviewing specs right now
21:03:03 <mriedem> any questions about the release?
21:03:17 <mriedem> #topic bugs
21:03:27 <mriedem> nothing listed as critical
21:03:43 <mriedem> #info 9 new untriaged bugs (up 1 from last week)
21:04:22 <mriedem> a few of the ones opened in the last day look like easy triage
21:04:28 <mriedem> if someone wants to dig into those
21:04:35 * tonyb will take a look
21:04:59 <tssurya> I can chip in too
21:05:00 <mriedem> gate status
21:05:07 <mriedem> well, zuul is being changed to v3
21:05:10 <mriedem> so there is really no ci today
21:05:20 <mriedem> http://status.openstack.org/zuul/
21:05:48 <mriedem> i did happen to notice that our live migration grenade multinode job has been broken since 8/16 or so
21:05:51 <mriedem> i have a patch up to fix that
21:06:04 <mriedem> that's about it for ci
21:06:06 <mriedem> #topic reminders
21:06:11 <mriedem> #help We need to propose Forum topics by 9/29 (tomorrow): https://etherpad.openstack.org/p/SYD-nova-brainstorming
21:06:22 <mriedem> more on ^ in open discussion...
21:06:32 <mriedem> #topic stable branch status
21:06:37 <mriedem> #link stable/pike: https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:stable/pike,n,z
21:06:43 <mriedem> #info Pike 16.0.1 released
21:06:49 <mriedem> #link Etherpad for bugs tracked for Pike backports: https://etherpad.openstack.org/p/nova-pike-bug-fix-backports
21:07:04 <mriedem> i started to have a hard time keeping track of all of the regressions in pike that needed fixing,
21:07:07 <mriedem> so i started that etherpad
21:07:20 <mriedem> think of it like pike rc10
21:07:26 <tonyb> LOL
21:07:32 <mriedem> #link stable/ocata: https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:stable/ocata,n,z
21:07:34 <tonyb> link?  It'll help with reviews
21:07:47 <mriedem> link is above
21:07:52 <mriedem> #link stable/newton: https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:stable/newton,n,z
21:07:58 <mriedem> newton is eol pretty soon right?
21:08:03 <tonyb> Yeah
21:08:08 <jaypipes> o/
21:08:11 <mriedem> 2017-10-11
21:08:32 <tonyb> On that this is the last week for library releases so if there's anythign in novaclient or (os-vif) we shoudl do that thing
21:08:50 <mriedem> os-vif didn't exist in newton
21:08:52 <mriedem> so i think we're ok there
21:09:05 <tonyb> sure I was too lazy to check hence the ? ;P
21:09:06 <mriedem> https://review.openstack.org/#/q/status:open+project:openstack/python-novaclient+branch:stable/newton
21:09:24 <mriedem> ok i guess i have to review that one
21:09:30 <mriedem> and then do a novaclient release yeah?
21:09:50 <mriedem> yes ok
21:09:51 <tonyb> Yeah
21:09:51 <mriedem> moving on
21:10:03 <tonyb> only 2 changes but worth it
21:10:05 <mriedem> #action mriedem to do a novaclient newton release for the last time
21:10:26 <mriedem> #topic subteam highlights
21:10:30 <mriedem> dansmith: cellsv2
21:10:37 <dansmith> we had a meeting
21:10:40 <dansmith> I whined
21:10:59 <dansmith> we're close to cutting over to the new instance list stuff
21:11:20 <dansmith> um, I forget if there was anything else important as I'm pretty focused on that
21:11:23 <dansmith> I think not so much
21:11:32 <mriedem> don't think so
21:11:45 <mriedem> edleafe: scheduler highlights?
21:11:53 <edleafe> Long meeting this week.
21:11:53 <edleafe> Settled on naming for the Selection object - went with accuracy over existing names
21:11:56 <edleafe> The traits specs are close
21:11:59 <edleafe> Nested RPs are once again moving forward
21:12:01 <edleafe> Otherwise discussed a whole lot of specs and reviews that are currently being worked on
21:12:04 <edleafe> Fin
21:12:20 <mriedem> ok i dont think we have anyone around that was at the api meeting
21:12:31 <mriedem> notification stuff
21:12:39 <mriedem> i'm standing in for gibi
21:12:40 <mriedem> #help The BDM notification performance fix series needs review: https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:master+topic:bug/1718226
21:12:46 <mriedem> #info We propose to remove "notify_on_api_faults": http://lists.openstack.org/pipermail/openstack-dev/2017-September/122658.html
21:12:53 <mriedem> penick said he's ok with ^
21:13:02 <mriedem> even though he's using it in his archaic juno env
21:13:19 <mriedem> he's probably ok with it since he's never going to upgrade that env
21:13:22 <mriedem> but i digress
21:13:29 <mriedem> #help gibi is looking for a home to host the versioned notifications burndown graph service
21:13:36 <mriedem> gibi is investigating ways to simplify the duplication in the notification sample files
21:13:51 <mriedem> ok cinder
21:14:09 <cdent> Is gibi just in need a web server somewhere, I got one of those that’s he’s welcome to
21:14:13 <mriedem> the cinder team is working on some specs for multiattach data modeling stuff for shared storage backends
21:14:20 <mriedem> cdent: i think so,
21:14:24 <cdent> I’ll ping him tomorrow
21:14:25 <mriedem> sdague also said he might have something
21:15:05 <mriedem> and in the nova/cinder meeting we talked about policy rules for multiattach, and agreed to just keep it simple for now - you can either do multiattach volumes in cinder or not,
21:15:12 <mriedem> so ops can disable it if they don't want it on at all to start
21:15:23 <mriedem> the r/o vs r/w policy stuff is more complicated,
21:15:29 <mriedem> probably going to talk about some of that at the summit
21:16:09 <mriedem> stvnoyes has to make some updates to the live migration patch,
21:16:10 <mriedem> but it's close
21:16:23 <mriedem> that's it
21:16:32 <mriedem> #topic stuck reviews
21:16:37 <mriedem> nothing on the agenda
21:16:45 <mriedem> does anyone have something to bring up that's stuck?
21:17:03 <mriedem> #topic open discussion
21:17:08 <mriedem> ok i've got 2 things
21:17:17 <mriedem> 1. Should we have a spec review sprint next week?
21:17:29 <mriedem> i think probably yes
21:17:41 <mriedem> dansmith: jaypipes: ^?
21:17:52 <jaypipes> ++
21:17:54 <dansmith> as you wish
21:18:04 <jaypipes> mriedem: can even do one tomorrow if you'd like.
21:18:23 <jaypipes> mriedem: while waiting for tests to run on n-r-p, I've spent most of my time reading specs this week...
21:18:26 <mriedem> hmm, that doesn't give me sufficient time to mentally and emotionally prepare
21:18:41 <jaypipes> mriedem: :) monday also works.
21:18:48 <mriedem> i'll send something to the ML
21:19:00 <jaypipes> coo
21:19:24 <mriedem> ok the other thing
21:19:27 <mriedem> 2. Need to discuss forum topic proposals: https://etherpad.openstack.org/p/SYD-nova-brainstorming
21:19:40 <mriedem> so we have some stuff in ther
21:19:42 <mriedem> *there
21:19:51 <mriedem> it's come time to cull the list lest i just start proposing stuff
21:20:01 <mriedem> mikal wanted to do something on privsep i think
21:21:10 <tonyb> Yeah but he's sick so not here
21:21:11 <mriedem> sounds like one catch-all would be new stuff in pike
21:21:25 <mriedem> which is multi-cell plus limitations, claims in the scheduler, and quotas
21:21:44 <dansmith> that's a lot for one session
21:21:45 <mriedem> we will have a project update talk, but this would be more informal
21:22:09 <mriedem> could be 2 sessions? or we break into cells/quota for one and placement for another
21:22:15 <mriedem> i think ^ is what we did in boston
21:22:35 <tonyb> Yeah there's a lot to cover in 45mins
21:22:57 <mriedem> if people are ok with 2 sessions for those, i can propose those
21:23:11 <mriedem> those can also mix in stuff we're doing for them in queens
21:23:29 <dansmith> sounds fine
21:23:51 <mriedem> another one i thought about was a general, queens dev items and current status
21:24:16 <mriedem> which is essentially highlights of things being worked on in queens, which could be a place to ask questions
21:24:33 <mriedem> like the vgpu stuff came to mind
21:24:39 <mriedem> since we start to start small there
21:24:43 <mriedem> *we said
21:25:19 <mriedem> oh yeah - the ironic upgrade thing....that would be a good fodder too but i don't know where that goes
21:26:00 <cdent> maybe a generic topics in  vm/bm session
21:26:12 <mriedem> is there going to be a vm/bm session?
21:26:23 <mriedem> i don't know if johnthetubaguy is going to be at the summit
21:26:53 <mriedem> this is what's currently proposed btw http://forumtopics.openstack.org/
21:27:13 <cdent> I’m predictig lots of proposals at the last minute
21:27:26 <mriedem> stephenfin has some stuff in here about hardware and docs work, which i'm fine with leaving to him if he wants to propose those
21:27:55 <mriedem> so,
21:28:31 <mriedem> maybe i'll just roll up what i plan on proposing, which right now is basically cells v2 pike/queens, placement pike/queens, and maybe upgrade? (melwitt's), and then if others want to propose stuff they can
21:29:24 <mriedem> ok. well, ok then.
21:29:34 <mriedem> anything else for open discussion?
21:30:04 <mriedem> alright, that's the end of the meeting then, thanks everyone
21:30:07 <mriedem> #endmeeting