14:00:14 <mriedem> #startmeeting nova
14:00:14 <openstack> Meeting started Thu Oct  5 14:00:14 2017 UTC and is due to finish in 60 minutes.  The chair is mriedem. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:18 <openstack> The meeting name has been set to 'nova'
14:00:27 <mriedem> howdy
14:00:32 <dansmith> ohai
14:00:38 <edleafe> \o
14:00:40 <takashin> o/
14:01:19 <mriedem> #link agenda https://wiki.openstack.org/wiki/Meetings/Nova#Agenda_for_next_meeting
14:01:27 <mriedem> guess we'll get started
14:01:35 <mriedem> #link Queens release schedule: https://wiki.openstack.org/wiki/Nova/Queens_Release_Schedule
14:01:37 <mriedem> oops
14:01:39 <mriedem> #undo
14:01:39 <openstack> Removing item from minutes: #link https://wiki.openstack.org/wiki/Nova/Queens_Release_Schedule
14:01:45 <mriedem> #topic release news
14:01:50 <mriedem> #link Queens release schedule: https://wiki.openstack.org/wiki/Nova/Queens_Release_Schedule
14:01:55 <mriedem> #info Oct 19: q-1 milestone, nova spec freeze (2 weeks away)
14:02:08 <mriedem> taking a minute to think about progress,
14:02:16 <mriedem> the efficient instance list main change is merged
14:02:23 <mriedem> so that's a major accomplishment
14:02:35 <dansmith> \o/
14:02:48 <mriedem> dansmith: jaypipes: edleafe: the alternate hosts stuff...thinking possible by q1?
14:02:52 <gmann> o/
14:03:01 <andreas_s_> o/
14:03:03 <edleafe> mriedem: very possible
14:03:09 <dansmith> mriedem: it's not all proposed yet, so hard to say, but not impossible
14:03:10 <jaypipes> mriedem: 2018 Q1, def.
14:03:16 <mriedem> ha
14:03:16 <jaypipes> mriedem: :)
14:03:22 <jaypipes> mriedem: yes, definitely queens-1
14:03:28 <jaypipes> mriedem: we're making good progress on it.
14:03:44 <mriedem> alright, if the scheduler stuff could get done yet this week and conductor next, then yeah it's in good shape for q1
14:03:56 <mriedem> and the migration uuid stuff is moving along
14:04:18 <mriedem> we'll probably have traits done by q1 too once alex is back
14:04:20 <mriedem> but moving on
14:04:29 <mriedem> #info Blueprints: 50 targeted, 23 approved, 1 complete
14:04:35 <mriedem> #link forum topics are being reviewed: http://forumtopics.openstack.org/
14:04:42 <mriedem> so far there isn't a lot of feedback on the proposed topics
14:04:52 <mriedem> i don't know when they are supposed to all be reviewed offhand
14:04:59 <mriedem> hopefully soon
14:05:03 * gibi arriving late
14:05:07 <mriedem> anything for release news?
14:05:27 <mriedem> ok moving on
14:05:30 <mriedem> #topic bugs
14:05:39 <mriedem> nothing listed as critical
14:05:45 <mriedem> #info 9 new untriaged bugs (up 3 from last week)
14:06:02 <mriedem> gate status is sort of stable, after the zuulv3 rollback
14:06:23 <mriedem> i'm still seeing random cellsv1 job failures, and there is a volume snapshot test in tempest that's randomly failing and doesn't have a fingerprint on it
14:06:38 <mriedem> no news on 3rd party ci
14:06:46 <mriedem> #topic reminders
14:06:59 <mriedem> only reminder i have is review and promptly reply to feedback on specs
14:07:16 <mriedem> #topic stable branch status
14:07:20 <mriedem> #link stable/pike: https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:stable/pike,n,z
14:07:25 <mriedem> #link Etherpad for bugs tracked for Pike backports: https://etherpad.openstack.org/p/nova-pike-bug-fix-backports
14:07:38 * bauzas waves late
14:07:41 <mriedem> last i looked, most everything in ^ is proposed to stable/pike and/or approved on master
14:07:54 <mriedem> so once we flush through some of the stable/pike backports i'm going to do another release
14:08:04 <mriedem> since there are some pretty severe fixes that need to get released
14:08:15 <mriedem> #link stable/ocata: https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:stable/ocata,n,z
14:08:22 <mriedem> #link stable/newton: https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:stable/newton,n,z
14:08:33 <mriedem> i proposed the final novaclient release earlier in the week
14:08:36 <mriedem> for newton i mean
14:08:43 <mriedem> #info Newton EOL postponed 1 week due to the zuulv3 issues http://lists.openstack.org/pipermail/openstack-dev/2017-October/123088.html
14:09:06 <mriedem> so the new proposed newton-eol is oct 18
14:09:25 <mriedem> so let's spend some time going through https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:stable/newton,n,z
14:09:38 <mriedem> #topic subteam highlights
14:09:46 <mriedem> dansmith: cells v2 highlights
14:09:55 <dansmith> we had a meeting,
14:10:07 <dansmith> where we didn't discuss much given the events of the last week
14:10:27 <dansmith> but we did get instance list merged, and I haven't heard of any fallout from that yet, which is good
14:10:45 <dansmith> we pointed out that the consoles set is still up and needing review
14:10:58 <dansmith> and only one usability bug reported recently that we could remember
14:11:06 <dansmith> I think that's all
14:11:15 <mriedem> ok
14:11:20 <mriedem> edleafe: scheduler highlights
14:11:27 <edleafe> Jay's nested resource provider spec merged; progress being made on the code for it
14:11:30 <edleafe> Same with the alternate host stuff
14:11:32 <edleafe> EOM
14:11:34 <edleafe> Jay has also started the work to remove the ORM stuff from placement
14:11:37 <edleafe> Chris's spec for limiting GET /rps just needs another +2
14:11:39 <edleafe> In general, moving forward at a good clip.
14:12:41 <mriedem> ok
14:12:45 <efried> What's the status of the GET /allocation_candidates syntax with numbered resources & traits?
14:12:56 <efried> jaypipes ^
14:13:31 <efried> Cause I noticed specs, including traits-in-flavors, getting pretty close to approval, but they're going to be impacted by that.
14:13:57 <efried> Like, those specs should at least be looked at with that in mind.
14:14:31 <jaypipes> efried: have not had time to do it. would definitely appreciate your help if you can hack it.
14:14:49 <efried> jaypipes Okay, I'll try to throw some words together.
14:14:57 <jaypipes> efried: ty sir
14:15:04 <efried> #action efried to start drafting numbered-resources-and-traits spec
14:15:28 <mriedem> ready to move on?
14:15:30 <efried> y
14:15:37 <mriedem> ok api
14:15:41 <mriedem> alex_xu isn't around
14:15:43 <jaypipes> edleafe: there's also johnthetubaguy's ironic traits spec, which is also close
14:15:47 <mriedem> gmann: was there an api meeting this week?
14:15:48 <gmann> mriedem: i can update
14:15:54 <gmann> yea we had but short one
14:15:57 <gmann> 2 item we discussed
14:15:58 <edleafe> jaypipes: right-o
14:16:02 <jaypipes> #link https://review.openstack.org/507052
14:16:13 <gmann> 1. extensions policies removal spec #link https://review.openstack.org/#/c/508101/
14:16:13 <mriedem> Extensions Policies removal list feedback  - https://review.openstack.org/#/c/508101/
14:16:22 <gmann> looking for feedback on this
14:16:53 <gmann> next item is abort cold migration from takashin
14:16:56 <gmann> #link https://review.openstack.org/#/c/334732
14:17:12 <gmann> we need consensus on return code.
14:17:33 <mriedem> what is the issue?
14:17:33 <cdent> gmann: I still need to read your response on that, haven’t had a chance to digest it yet
14:17:37 <gmann> current spec propose 400 in many case which can be 409. i agree with cdent on most of them
14:18:03 <gmann> mriedem: its 400 vs 409. many of them are state conflict and 409 make sense there
14:18:22 <gmann> actually it going 400 -> 409 -> 400 many times during review :)
14:18:26 <mriedem> is it consistent with the return codes for canceling an in-progress live migration?
14:18:48 <mriedem> or is there debate that the live migration abort return code is wrong too?
14:18:53 <gmann> live migration return 400 in one of the case which i feel(cdent too) should be 409
14:19:42 <gmann> yea, there are multiple cases like task state, migration state , migration type etc
14:19:43 <edmondsw> 400 is supposed to mean the client requested something it shouldn't have, and should not repeat the request
14:20:30 * bauzas disappears for 25+ mins
14:20:32 <gmann> edmondsw: yea which can be first case L100 in spec
14:21:09 <mriedem> ok so we don't need to debate this in the meeting, it can happen in the spec
14:21:16 <gmann> yea
14:21:16 <edmondsw> gmann yep, sounds right
14:21:23 <gmann> that's all from api side.
14:21:25 <mriedem> i would just like to be consistent between the live and cold migration stuff
14:21:40 <takashin> okay
14:21:43 <mriedem> so either conform, or change the live migration ones at the same time
14:21:55 <edmondsw> gmann I'll drop some comments in the extensions policies spec today... just started looking
14:22:10 <gmann> mriedem: takashin it is proposing to change the live migration also L111
14:22:10 <mriedem> ok moving on
14:22:19 <gmann> edmondsw: thansks.
14:22:26 <mriedem> gibi: notifications
14:22:30 <gibi> No meeting this week
14:22:30 <gibi> I have only two bug fixes to highlight:
14:22:30 <gibi> #link https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:master+topic:bug/1718226
14:22:34 <gibi> #link https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:master+topic:bug/1699115
14:22:37 <gibi> That is all
14:22:49 <mriedem> so brief
14:23:04 <mriedem> so #1 is the bdm perf improvement stuff, easy reviews, +2 from me on the series
14:23:12 <gibi> yes
14:23:23 <mriedem> #2 is removing the dead api.faul notification stuff, broken since kilo?
14:23:26 <mriedem> but also +2 from me
14:23:27 <gibi> mriedem: yes
14:23:29 <edmondsw> I think I saw some open notifications fixes in the stable newton/ocata links above as well needing reviews
14:23:45 <gibi> edmondsw: I will go look at those, thanks
14:23:46 <mriedem> yes, unrelated, but yes
14:23:53 <mriedem> just backports
14:23:57 <edmondsw> yep
14:24:05 <mriedem> gibi: for the stuff that wasn't whitelisted b/c of lack of proper testing
14:24:23 <gibi> mriedem: OK
14:24:28 <mriedem> alright moving on
14:24:30 <mriedem> cinder stuff
14:24:36 <mriedem> #link The new style attachment live migration patch needs a final +2 https://review.openstack.org/#/c/463987/
14:24:43 <mriedem> john has been pinged
14:24:56 <mriedem> starting next week, ildikov will begin escalation procedures on him
14:25:23 <ildikov> mriedem: +1
14:25:30 * johnthetubaguy hides
14:25:31 <mriedem> and jgriffith is working a cinder spec for modeling shared connections for volumes
14:25:50 <mriedem> learn more in the nova/cinder xp meeting in 2.5 hours!
14:25:59 <mriedem> #topic stuck reviews
14:26:12 <mriedem> nothing on the agenda - i guess the abort cold migrate spec is stuck for now
14:26:23 <mriedem> #topic open discussion
14:26:35 <mriedem> hshiina: specless BP request: https://blueprints.launchpad.net/nova/+spec/ironic-volume-connector-ip
14:26:49 <mriedem> This is the remaining work of ironic booting from volume support in Pike: https://blueprints.launchpad.net/nova/+spec/ironic-boot-from-volume
14:27:23 <andreas_s_> I have another short topic  for discussion after that
14:27:51 <mriedem> so i'm ok with that as a specless blueprint
14:28:11 <mriedem> it's a single non-api change
14:28:14 <mriedem> https://review.openstack.org/#/c/468353/
14:28:32 <hshiina> mriedem, thanks
14:28:54 <mriedem> there are some new virt driver methods https://review.openstack.org/#/c/468353/12/nova/virt/driver.py
14:28:59 <mriedem> which only ironic would implement, of course
14:29:22 <mriedem> but otherwise this doesn't look too bad
14:30:01 <mriedem> mikal might be interested
14:30:04 <mriedem> but moving on
14:30:08 <mriedem> andreas_s_: z ci
14:30:10 <mriedem> go!
14:30:23 <andreas_s_> It's about getting the kvm s390x (zkvm) third party ci back reporting.
14:30:26 <andreas_s_> I posted a Mail on the ML: http://lists.openstack.org/pipermail/openstack-dev/2017-October/123100.html
14:31:03 <andreas_s_> so it's only about reporting (+1/-1), NOT voting
14:31:16 <mriedem> ok that's fine with me
14:31:18 <efried> To be clear, voting but not gating
14:31:48 <andreas_s_> yeah, not sure about terminology here ;)
14:31:51 <efried> (or so I thought I saw someone else clarify in a separate ML thread)
14:32:17 <mriedem> just means you can't block a change from merging
14:32:18 <efried> (I guess it's displayed as "non-voting"
14:32:24 <efried> )
14:32:31 <mriedem> ok i'll add it to the nova-ci group
14:32:41 <andreas_s_> great, thanks!
14:32:43 <mriedem> andreas_s_: thanks for the details in the ML thread, and persisting
14:32:59 <mriedem> ok anything else?
14:33:00 <andreas_s_> yw
14:33:03 <mriedem> for anyone
14:33:30 <efried> Getting allocations into spawn?
14:33:41 <mriedem> ?
14:33:43 <efried> Maybe save that for the next scheduler meeting...
14:34:04 <edleafe> efried: add it to the agenda
14:34:04 <efried> Brief discussion around here: http://eavesdrop.openstack.org/irclogs/%23openstack-nova/%23openstack-nova.2017-10-04.log.html#t2017-10-04T13:51:25
14:34:08 <mriedem> if it's yet another 45 minute placement thing with jaypipes, yes save it for the scheduler meeting or nova channel
14:34:20 <efried> heh
14:34:48 <mriedem> alright if nothing else, that's the meeting, thanks everyone
14:34:53 <mriedem> #endmeeting