21:00:20 <melwitt> #startmeeting nova
21:00:21 <openstack> Meeting started Thu Mar 29 21:00:20 2018 UTC and is due to finish in 60 minutes.  The chair is melwitt. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:22 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:25 <openstack> The meeting name has been set to 'nova'
21:00:30 <tssurya> o/
21:00:34 <edleafe> \o
21:00:37 <takashin> o/
21:00:46 <efried> ö/
21:01:57 <mriedem> o/
21:02:32 <melwitt> sorry about that everyone
21:02:42 <melwitt> my irc client was messed up
21:02:51 <melwitt> #topic Release News
21:02:58 <melwitt> #link Rocky release schedule: https://wiki.openstack.org/wiki/Nova/Rocky_Release_Schedule
21:03:14 <melwitt> next milestone is r-1 Apr 19
21:03:36 <melwitt> and remember we have moved spec freeze out to r-2 Jun 7 because of runways
21:03:51 <melwitt> anyone have anything else for release news?
21:04:12 <melwitt> #topic Bugs (stuck/critical)
21:04:26 <melwitt> no critical bugs
21:04:36 <melwitt> #link 36 new untriaged bugs (down 4 since the last meeting): https://bugs.launchpad.net/nova/+bugs?search=Search&field.status=New
21:04:56 <melwitt> thanks to all who have been helping with bug triage
21:05:09 <melwitt> and the usual reminders:
21:05:13 <melwitt> #link bug triage how-to: https://wiki.openstack.org/wiki/Nova/BugTriage#Tags
21:05:19 <melwitt> #link untagged untriaged bugs: https://bugs.launchpad.net/nova/+bugs?field.tag=-*&field.status%3Alist=NEW
21:05:37 <melwitt> 9 untriaged untagged bugs, so again we've been good about applying tags
21:05:45 <melwitt> #help tag untagged untriaged bugs with appropriate tags to categorize them
21:05:54 <melwitt> #help consider signing up as a bug tag owner and help determine the validity and severity of bugs with your tag
21:06:16 <melwitt> #link check queue gate status http://status.openstack.org/elastic-recheck/index.html
21:06:39 <melwitt> gate status has been pretty good lately it seems
21:06:44 <mriedem> there is a race
21:06:50 <mriedem> https://review.openstack.org/#/c/557722/
21:07:31 <melwitt> ah, okay let's review that then
21:07:42 <melwitt> I'll take a look after this
21:07:53 <melwitt> #link 3rd party CI status http://ci-watch.tintri.com/project?project=nova&time=7+days
21:08:43 <melwitt> we had a thread about vmware CI recently on the dev ML, that's the main one we've noticed being very sporadic for awhile now
21:09:07 <melwitt> we're going to be working with the vmware subteam to get that more consistent
21:09:25 <melwitt> anything else on bugs or gate stuff?
21:09:54 <melwitt> #topic Reminders
21:10:03 <melwitt> #link Rocky Review Priorities https://etherpad.openstack.org/p/rocky-nova-priorities-tracking
21:10:24 <melwitt> priorities etherpad, still useful for surfacing various interesting subteam patches and bug fixes, IMO
21:10:50 <melwitt> so be sure to look there to find things to review
21:10:53 <melwitt> #info Review runways are live, check out the instructions and add your blueprint to the queue if it's ready-for-review https://etherpad.openstack.org/p/nova-runways-rocky
21:11:39 <melwitt> I sent a mail to the dev ML about runways, we've got blueprints in runways now and so far, so good. please be sure to make blueprints in runways your review priority
21:11:56 <melwitt> I'm seeing a lot of review activity on the runway blueprints already
21:12:04 <melwitt> #info Spec freeze is moved out to r-2, June 7
21:12:11 <melwitt> as mentioned earlier
21:12:20 <melwitt> anything else for reminders?
21:12:46 <melwitt> #topic Stable branch status
21:12:55 <melwitt> #link stable/queens: https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:stable/queens,n,z
21:13:10 <melwitt> no open reviews? wow
21:13:21 <efried> soon
21:13:28 <melwitt> good job reviewing stable patches everyone
21:13:28 <mriedem> https://review.openstack.org/#/c/557704/
21:13:36 <mriedem> 17.0.2 release request
21:14:10 <melwitt> okay, cool. will ack that
21:14:13 <efried> mriedem: do we want to wait for https://review.openstack.org/#/c/557508/ backport?
21:14:27 <efried> (I don't know how that works, with the waiting or not)
21:14:43 <mriedem> efried: if it gets approved soonish
21:15:13 <efried> k, I already bugged melwitt for a second review
21:15:21 <melwitt> I can review that one, then we can roll it into the release. anything else people were thinking for stable/queens?
21:15:53 <melwitt> #link stable/pike: https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:stable/pike,n,z
21:16:06 <melwitt> a fair number of backports there
21:16:33 <melwitt> I do want to do a pike release soon for https://bugs.launchpad.net/nova/+bug/1746509
21:16:34 <openstack> Launchpad bug 1746509 in OpenStack Compute (nova) pike "TypeError: Can't upgrade a READER transaction to a WRITER mid-transaction" [High,Fix committed] - Assigned to melanie witt (melwitt)
21:16:56 <mriedem> i can flush out the pike stuff after the meeting
21:16:59 <melwitt> people upgrading from ocata -> pike will break on that when they try to list instances
21:17:02 <mriedem> the stuff that's not mine
21:17:10 <efried> bah, list instances, who does that?
21:17:19 <melwitt> nobody, you're right
21:17:28 <melwitt> cool, thanks mriedem
21:17:41 <melwitt> #link stable/ocata: https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:stable/ocata,n,z
21:17:53 <melwitt> moar backports
21:18:14 <melwitt> I've got one stuck there that I'm still debugging func test failures on
21:18:34 <melwitt> I can feel that no more EOL is going to be "challenging" in that regard
21:19:36 <melwitt> I do want to get https://review.openstack.org/538310 reviewed and released for ocata when possible, regression on boot from volume + config drive for virtio-scsi
21:19:54 <mriedem> i can -1 that right now
21:20:03 <mriedem> oh wait, that's not a backport
21:20:20 <mriedem> i guess you're co-author on that now, but not listed?
21:20:53 <melwitt> I can't recall if there are other ocata things. I guess there is the DB reader/writer transaction issue that we didn't have a good answer for because of how callers of target_cell in ocata don't expect a new yielded RequestContext
21:21:16 <mriedem> maybe you uh, don't want to go over all of the ocata potential things right now... :)
21:21:24 <melwitt> I worked on the unit tests a bit, so I wasn't sure how much of a contribution it was for co-author. but yeah, wasn't gonna vote on it
21:21:56 <melwitt> right. just wanted to point out there are issues on stable/ocata that are pretty bad IMHO
21:22:06 <melwitt> okay, anything else on stable branches?
21:22:29 <melwitt> #topic Subteam Highlights
21:22:51 <melwitt> dansmith: cells v2
21:23:16 <mriedem> we didn't have a meeting, we talked about what amounted to https://review.openstack.org/#/c/557506/
21:23:20 <mriedem> which will go back to ocat
21:23:22 <mriedem> *ocata
21:23:26 <mriedem> once i can resolve this test race
21:23:45 <melwitt> ah, right
21:23:48 <mriedem> cells db fixture strikes me again
21:24:23 <mriedem> tssurya's disabled cells series is nearly all done
21:24:30 <melwitt> I'll take a look. I know too much about the CellDatabases fixture
21:24:36 <mriedem> and dan's placement req stuff is nearly all approved now too
21:24:41 <melwitt> awesome
21:25:19 <melwitt> okay, let's go to the next subteam, edleafe, scheduler?
21:25:26 <edleafe> Started the meeting off with a lively discussion about NUMA, and how to best represent the various ways it could be configured.
21:25:29 <edleafe> Agreed that the virt driver is responsible for representing NUMA-ness to placement, and that ops will have config knobs to control how NUMA is to be used.
21:25:32 <edleafe> We then ignored mriedem
21:25:34 <edleafe> gibi tried to sneak in a reference to his upcoming honeymoon, but we congratulated him nonetheless.
21:25:37 <edleafe> We stopped ignoring mriedem and agreed to review his long-ignored patch on the ironic flavor migration check in nova-status (https://review.openstack.org/#/c/527541)
21:25:40 <edleafe> That's all.
21:26:02 <melwitt> heh
21:26:16 <melwitt> I just reviewed that, coincidentally
21:26:43 <melwitt> okay, gibi left notes that there was no notifications subteam meeting this week
21:27:02 <efried> He's out for two weeks; is someone running notif meetings in his absence?
21:27:09 <melwitt> and he's away for the next two weeks, so the next notifications subteam meeting and summary mail are expected the week of Apr 16
21:27:18 <efried> :)
21:27:21 <melwitt> looks like they're getting a meeting break
21:27:30 <mriedem> it's just me and gibi
21:27:34 <mriedem> so i think i can manage
21:27:37 <melwitt> haha, okay
21:27:45 <melwitt> anything else for subteams?
21:27:48 * efried sings "Dancing with myself"
21:28:10 <melwitt> #topic Stuck Reviews
21:28:17 <melwitt> there's one item on the agenda
21:28:27 <melwitt> https://review.openstack.org/#/c/532407/ - Support volume-backed server rebuild spec; stuck figuring out what to do about the original root volume (create new one and swap out the old? delete the old or leave it? re-image the volume, in cinder? in nova?)
21:28:33 <melwitt> #link http://lists.openstack.org/pipermail/openstack-operators/2018-March/014952.html
21:28:35 <mriedem> i think that's mostly unstuck now, i put a stake in the ground during the spec review sprint
21:28:50 <mriedem> #link http://lists.openstack.org/pipermail/openstack-dev/2018-March/128870.html
21:28:51 <melwitt> okay, nice
21:28:53 <mriedem> ^ is the new hostness
21:28:55 <mriedem> *hotness
21:29:14 <melwitt> ah, yup, read that earlier today
21:29:48 <melwitt> cool, so the plan is a new re-image API from the cinder team and then we handle the rest on the nova side, if I got that right
21:30:01 <mriedem> yeah
21:30:08 <melwitt> sounds good
21:30:22 <melwitt> anyone else have anything for stuck reviews?
21:30:29 <mriedem> and by cinder team,
21:30:37 <mriedem> i assume the contributors that want the nova thing will do the cinder thing
21:31:04 <melwitt> ah, yeah. fair enough
21:31:22 <melwitt> #topic Open discussion
21:31:27 <efried> S release is called Stein.  Some may insist it be pronounced the German way, [shtīn] (rhymes with 'whine')
21:31:35 <efried> Me, I can't fathom what legal issues we were expecting with "solar", a ridiculously ordinary dictionary word.  I think it was just the drinkers on the board exerting their influence.
21:31:48 <melwitt> haha
21:31:58 <edleafe> Maybe too close to 'Solaris'?
21:32:04 <melwitt> I'm guessing there's some companies out there called Solar
21:32:18 <efried> I assert, who cares?  solar is just a word.
21:32:22 <efried> but whatever.
21:32:24 <melwitt> yeah, I hear you
21:32:31 <efried> Also:
21:32:32 <efried> We should add a "Runways status" section to the agenda for this meeting.
21:32:33 <edleafe> efried: so is 'apple'
21:32:47 <melwitt> efried: ah, good idea. I shall add that to the mix from now on
21:32:56 <efried> edleafe: Good example.  If we held our summit in New York and wanted to name the release apple, we freakin should be able to.
21:33:16 <melwitt> #action melwitt add "runways status" section to the nova meeting agenda
21:33:20 <edleafe> yeah, that's not how lawyers work
21:33:52 <melwitt> there aren't any items on the 'open discussion' section of the agenda
21:33:53 * efried raises eyebrow to the premise "lawyers work"
21:34:03 <melwitt> does anyone else have anything for open discussion?
21:34:55 <melwitt> oh, I guess I can mention I'm gonna be out tomorrow for $spring_holiday as I expect others might be too
21:35:11 <melwitt> some people might be out monday for the same
21:35:17 <edleafe> some of us don't get off
21:35:25 <edleafe> <grumble, grumble>
21:35:30 <melwitt> no $spring_holiday? *gasp*
21:35:46 <mriedem> can we say 'get off' more please
21:36:06 <efried> mriedem: is stuff like that why you don't work for IBM anymore?
21:36:11 <efried> We can't even *think* stuff like that.
21:36:13 <mriedem> let's say, sure
21:36:34 <melwitt> alright, sounds like we're done here
21:36:37 <melwitt> thanks everybody
21:36:42 <melwitt> #endmeeting