#openstack-meeting: nova

Meeting started by melwitt at 14:00:42 UTC (full logs).

Meeting summary

  1. Release News (melwitt, 14:01:20)
    1. Rocky release schedule: https://wiki.openstack.org/wiki/Nova/Rocky_Release_Schedule (melwitt, 14:01:26)
    2. https://etherpad.openstack.org/p/nova-rocky-blueprint-status (melwitt, 14:01:44)
    3. Rocky review runways: https://etherpad.openstack.org/p/nova-runways-rocky (melwitt, 14:02:27)
    4. runway #1: Use neutrons new port binding API https://blueprints.launchpad.net/nova/+spec/neutron-new-port-binding-api (mriedem) [END DATE: 2018-07-26] https://review.openstack.org/434870 (melwitt, 14:02:34)
    5. runway #2: NUMA-aware vSwitches https://blueprints.launchpad.net/nova/+spec/numa-aware-vswitches (stephenfin) [END DATE: 2018-07-26] https://review.openstack.org/#/c/564440 (melwitt, 14:02:41)
    6. runway #3: Multiple Fixed-IPs support in network information https://blueprints.launchpad.net/nova/+spec/multiple-fixed-ips-network-information (mgagne) [END DATE: 2018-07-26] https://review.openstack.org/580742 (melwitt, 14:02:47)

  2. Bugs (stuck/critical) (melwitt, 14:23:36)
    1. 49 new untriaged bugs (down 1 since the last meeting): https://bugs.launchpad.net/nova/+bugs?search=Search&field.status=New (melwitt, 14:23:55)
    2. 5 untagged untriaged bugs (up 1 since the last meeting): https://bugs.launchpad.net/nova/+bugs?field.tag=-*&field.status%3Alist=NEW (melwitt, 14:24:13)
    3. bug triage how-to: https://wiki.openstack.org/wiki/Nova/BugTriage#Tags (melwitt, 14:24:14)
    4. HELP: need help with bug triage (melwitt, 14:24:15)
    5. ACTION: melwitt to create RC1 bug status tracking etherpad (melwitt, 14:26:07)
    6. check queue gate status http://status.openstack.org/elastic-recheck/index.html (melwitt, 14:26:30)
    7. http://status.openstack.org/elastic-recheck/ (mriedem, 14:27:18)
    8. https://ethercalc.openstack.org/dorupfz6s9qt (gmann, 14:29:07)
    9. intermittent failing nova test in tempest http://status.openstack.org/elastic-recheck/index.html#1775947 (melwitt, 14:29:13)
    10. slow tests randomly timing out jobs http://status.openstack.org/elastic-recheck/index.html#1783405 (melwitt, 14:29:28)
    11. 3rd party CI status http://ci-watch.tintri.com/project?project=nova&time=7+days (melwitt, 14:30:26)

  3. Reminders (melwitt, 14:36:14)
    1. Rocky Subteam Patches n Bugs: https://etherpad.openstack.org/p/rocky-nova-priorities-tracking (melwitt, 14:36:20)
    2. Stein PTG planning: https://etherpad.openstack.org/p/nova-ptg-stein (melwitt, 14:36:24)

  4. Stable branch status (melwitt, 14:37:42)
    1. stable/queens: https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:stable/queens,n,z (melwitt, 14:37:47)
    2. stable/pike: https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:stable/pike,n,z (melwitt, 14:38:02)
    3. stable/ocata: https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:stable/ocata,n,z (melwitt, 14:38:07)

  5. Subteam Highlights (melwitt, 14:40:59)
    1. https://review.openstack.org/#/c/566813/ (mriedem, 14:42:11)
    2. scheduler subteam minutes http://eavesdrop.openstack.org/meetings/nova_scheduler/2018/nova_scheduler.2018-07-23-14.00.html (melwitt, 14:43:01)
    3. Currently the reshaper series starts with the microversion patch https://review.openstack.org/#/c/576927/ (efried, 14:43:10)
    4. IndexError when clearing a provider's inventories: https://bugs.launchpad.net/nova/+bug/1783130 (efried, 14:43:11)
    5. fix for bug 1783130 https://review.openstack.org/#/c/585033/ (efried, 14:43:11)
    6. consumer generation handling (gibi): https://review.openstack.org/#/c/583667/ (efried, 14:43:13)
    7. os-resource-classes proposal from Jay: https://github.com/jaypipes/os-resource-classes (efried, 14:45:46)
    8. os-resource-classes proposal from Chris: https://github.com/cdent/os-resource-classes (efried, 14:45:51)
    9. notification subteam status http://lists.openstack.org/pipermail/openstack-dev/2018-July/132410.html (melwitt, 14:47:05)
    10. Latest API updates http://lists.openstack.org/pipermail/openstack-dev/2018-July/132461.html (melwitt, 14:47:49)

  6. Stuck Reviews (melwitt, 14:48:13)
  7. Open discussion (melwitt, 14:48:53)


Meeting ended at 14:49:44 UTC (full logs).

Action items

  1. melwitt to create RC1 bug status tracking etherpad


Action items, by person

  1. melwitt
    1. melwitt to create RC1 bug status tracking etherpad


People present (lines said)

  1. melwitt (96)
  2. mriedem (56)
  3. efried (32)
  4. dansmith (24)
  5. gmann (10)
  6. cdent (9)
  7. openstack (5)
  8. gibi (4)
  9. LuK1337153 (3)
  10. mnaser (2)
  11. takashin_ (1)
  12. bauzas (1)
  13. edleafe (1)


Generated by MeetBot 0.1.4.