21:00:30 <melwitt> #startmeeting nova
21:00:31 <openstack> Meeting started Thu Aug  2 21:00:30 2018 UTC and is due to finish in 60 minutes.  The chair is melwitt. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:32 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:35 <openstack> The meeting name has been set to 'nova'
21:00:44 <efried> ō/
21:00:46 <mriedem> o/
21:00:47 <takashin> o/
21:00:50 <melwitt> I think this will be a short meeting
21:01:02 <melwitt> let's start
21:01:05 <melwitt> #topic Release News
21:01:21 <melwitt> #link Rocky release schedule: https://wiki.openstack.org/wiki/Nova/Rocky_Release_Schedule
21:01:31 <melwitt> (the bot didn't appear to change the topic)
21:01:32 <edleafe> \o
21:01:43 <melwitt> rc1 is next week Aug 9
21:01:50 <melwitt> #link https://etherpad.openstack.org/p/nova-rocky-blueprint-status
21:02:05 <melwitt> #link https://etherpad.openstack.org/p/nova-rocky-release-candidate-todo
21:02:26 <melwitt> we're tracking rc1 bug candidates here ^
21:02:39 <melwitt> the currently tagged bugs have had their patches merge already
21:03:01 <melwitt> if you have bugs that you think are important for rc1, add them to the etherpad
21:03:14 <mriedem> is anyone working on the release note stuff?
21:03:33 <mriedem> https://wiki.openstack.org/wiki/Nova/ReleaseChecklist
21:03:55 <mriedem> i talked with dan about bumping any rpc api versions and didn't seem justification for doing so
21:03:57 <melwitt> the reno prelude?
21:03:59 <mriedem> yes
21:04:25 <mriedem> the reno prelude has been pretty copy/paste the last few releases,
21:04:38 <mriedem> format wise, and then tweak for highlights,
21:04:49 <mriedem> similar but with more detail to the things that are in the release hightlights in the releases repo
21:05:05 <melwitt> okay. I don't know of anyone working on it yet. is anyone interested in doing that?
21:05:13 <melwitt> if no one is interested, I will do it
21:05:27 <mriedem> https://github.com/openstack/nova/blob/master/releasenotes/notes/queens_prelude-4bdf895167f979b2.yaml
21:05:29 <mriedem> e.g. ^
21:05:43 <melwitt> #link https://wiki.openstack.org/wiki/Nova/ReleaseChecklist
21:05:52 <melwitt> okay, that's helpful
21:06:32 <mriedem> probably want to talk to dansmith about "Ideally add the RPC version alias just before opening the next release"
21:07:13 <melwitt> #action melwitt to check with dansmith about RPC version alias for RC1
21:07:56 <melwitt> #action melwitt to propose draft or reno prelude next monday
21:08:12 <melwitt> okay, anything else for release news?
21:08:53 <melwitt> #topic Bugs (stuck/critical)
21:09:09 <melwitt> no critical bugs in the link
21:09:14 <melwitt> #link 56 new untriaged bugs (up 7 since the last meeting): https://bugs.launchpad.net/nova/+bugs?search=Search&field.status=New
21:09:23 <melwitt> untriaged bug count is climbing
21:09:43 <melwitt> I triaged a couple of things yesterday, will continue to do more
21:10:07 <melwitt> we really want to make sure there's nothing new in there that we need to target for RC1
21:10:14 <melwitt> #link 8 untagged untriaged bugs (up 3 since the last meeting): https://bugs.launchpad.net/nova/+bugs?field.tag=-*&field.status%3Alist=NEW
21:10:21 <melwitt> #link bug triage how-to: https://wiki.openstack.org/wiki/Nova/BugTriage#Tags
21:10:26 <melwitt> #help need help with bug triage
21:10:31 <melwitt> Gate status
21:10:35 <melwitt> #link check queue gate status http://status.openstack.org/elastic-recheck/index.html
21:10:43 <melwitt> lots of timeouts and other fails
21:10:51 <melwitt> anecdotally I've noticed
21:10:55 <mriedem> i can't tell if it's better than last week,
21:11:01 <mriedem> or i just haven't watched or cared as much
21:11:20 <melwitt> I think it's better but still not happy town
21:11:29 <melwitt> 3rd party CI
21:11:34 <melwitt> #link 3rd party CI status http://ci-watch.tintri.com/project?project=nova&time=7+days
21:11:53 <melwitt> I've seen some failures in third party CIs but haven't followed up with any yet
21:12:11 <melwitt> anything else for bugs or gate status or third party CI?
21:12:34 <melwitt> #topic Reminders
21:12:39 <melwitt> #link Rocky Subteam Patches n Bugs: https://etherpad.openstack.org/p/rocky-nova-priorities-tracking
21:12:46 <melwitt> #link Stein PTG planning: https://etherpad.openstack.org/p/nova-ptg-stein
21:13:10 <melwitt> stein ptg planning, add your topics and comments. please add your nick to your topics and comments so we know who to talk to
21:13:29 <melwitt> I added a link to an empty rocky retro etherpad on there ^
21:13:30 <melwitt> which is
21:13:32 <melwitt> #link Rocky retrospective for the PTG: https://etherpad.openstack.org/p/nova-rocky-retrospective
21:13:39 <melwitt> I'll send an email to the dev ML about it
21:13:53 <melwitt> but it's there, we'll start adding things to it
21:14:03 <melwitt> anyone else have any reminders?
21:14:30 <melwitt> #topic Stable branch status
21:14:34 <melwitt> #link stable/queens: https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:stable/queens,n,z
21:14:39 <melwitt> #link stable/pike: https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:stable/pike,n,z
21:14:45 <melwitt> #link stable/ocata: https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:stable/ocata,n,z
21:14:57 <melwitt> lots of backports have merged, thanks to all the stable reviewers who've been working on that
21:15:37 <melwitt> we had planned to propose releases for stable branches this week. is that ready to do at this point? anything else we want to wait for before releases?
21:15:46 <melwitt> else = specific bug fixes
21:16:16 <mriedem> yeah
21:16:21 <mriedem> the stats thing probably
21:16:40 <melwitt> ah, yup. I'll keep an eye on that
21:16:43 <mriedem> https://review.openstack.org/#/q/topic:bug/1784705+(status:open+OR+status:merged)
21:16:51 <mriedem> not critical to wait,
21:16:57 <mriedem> since it's been regressed since ocata...
21:17:08 <melwitt> understood
21:17:20 <efried> Be nice to get it out there sooner rather than later so we can make sure the fix doesn't regress worse...
21:17:39 <efried> since it wasn't exactly trivial
21:18:09 <melwitt> pike backport failed functional, both py27 and py35 so that's concerning
21:19:08 <melwitt> ocata passed though, you'd think if it failed pike it would fail both. hm. anyway, that's the only snag I'm seeing there
21:19:18 <melwitt> if those failures are legit
21:19:43 <melwitt> anything else for stable branch status?
21:20:04 <melwitt> #topic Subteam Highlights
21:20:13 <melwitt> cells v2, we skipped holding a meeting this week
21:20:20 <melwitt> we have two bugs to highlight
21:20:35 <melwitt> #link https://bugs.launchpad.net/nova/+bug/1784074
21:20:35 <openstack> Launchpad bug 1784074 in OpenStack Compute (nova) "Instances end up with no cell assigned in instance_mappings" [Medium,In progress] - Assigned to Matt Riedemann (mriedem)
21:20:42 <melwitt> #link https://bugs.launchpad.net/nova/+bug/1784093
21:20:42 <openstack> Launchpad bug 1784093 in OpenStack Compute (nova) "Build requests can be orphaned without instance mappings" [Medium,In progress] - Assigned to Mohammed Naser (mnaser)
21:21:06 <melwitt> those fixes are in the WIP stage
21:21:24 <melwitt> anything else to call out mriedem that I'm forgetting for cells this week?
21:21:57 <melwitt> okay, we'll move on
21:22:01 <melwitt> scheduler, efried?
21:22:04 <efried> #link Scheduler subteam minutes http://eavesdrop.openstack.org/meetings/nova_scheduler/2018/nova_scheduler.2018-07-30-13.59.html
21:22:04 <efried> The main discussion point was around having
21:22:04 <efried> #link yanked the partial support for sharing DISK_GB in libvirt https://review.openstack.org/#/c/586614/
21:22:04 <efried> due to the associated
21:22:05 <efried> #link bug about what needs to be fixed before we can reinstate sharing DISK_GB https://bugs.launchpad.net/nova/+bug/1784020
21:22:05 <openstack> Launchpad bug 1784020 in OpenStack Compute (nova) "Shared storage providers are not supported and will break things if used" [High,Triaged]
21:22:10 <efried> This came as a shock to some, and there was some brainstorming about whether/how it could be fixed in Rocky. Answer: the non-migration parts probably could be fixed via reshaper, if that were able to get in, which it probably won't, but we'll get it reviewed and ready anyway. That series has since been completed and is undergoing review.
21:22:10 <efried> #link reshaper series bottom https://review.openstack.org/#/c/576927/
21:22:10 <efried> We discussed the migration aspects some; and overall agreed it probably makes sense to write an uber-spec that addresses sharing providers as a whole, from which component-level specs could be branched which talk about the actual work items involved. As yet, no volunteers to write that.
21:22:10 <efried> END
21:22:36 <efried> agh, I tried to split it in two to avoid getting spambotted, but got spambotted anyway. What's the last thing you saw?
21:22:55 <melwitt> I got the END message
21:23:00 <efried> okay, cool.
21:23:03 <efried> Then
21:23:04 <efried> END
21:23:09 <melwitt> heh
21:23:12 <melwitt> thanks for the summary
21:23:24 <melwitt> gibi left a note on the agenda for notifications subteam
21:23:30 <melwitt> "We had a really short meeting this week but there was nothing to report."
21:23:43 <melwitt> and gmann for API subteam says "no office hour this week, nothing special to report from API side."
21:23:52 <melwitt> that's it for subteams
21:23:58 <melwitt> #topic Stuck Reviews
21:24:18 <melwitt> no items on the agenda. anyone in the room have anything for stuck reviews?
21:24:38 <melwitt> #topic Open discussion
21:24:55 <melwitt> anyone have anything they'd like to discuss?
21:25:22 <melwitt> okay, I guess that's all folks
21:25:23 <melwitt> thanks
21:25:27 <melwitt> #endmeeting