14:00:12 <gibi> #startmeeting nova
14:00:13 <openstack> Meeting started Thu Dec 13 14:00:12 2018 UTC and is due to finish in 60 minutes.  The chair is gibi. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:16 <cdent> o/
14:00:17 <openstack> The meeting name has been set to 'nova'
14:00:20 <edleafe> \o
14:00:23 <gmann> o/
14:00:45 <mriedem> o/
14:00:50 <gibi> Hello everyone, I will be your host today
14:01:31 <gibi> lets get started
14:01:34 <takashin> o/
14:01:37 <gibi> #topic Release News
14:01:42 <gibi> #link Stein release schedule: https://wiki.openstack.org/wiki/Nova/Stein_Release_Schedule
14:01:52 <gibi> #link Stein runway etherpad: https://etherpad.openstack.org/p/nova-runways-stein
14:01:58 <gibi> #link runway #1: https://blueprints.launchpad.net/nova/+spec/local-disk-serial-numbers (mdbooth) [END 2018-12-14] https://review.openstack.org/#/q/topic:bp/local-disk-serial-numbers+(status:open+OR+status:merged)
14:02:02 <gibi> #link runway #2: https://blueprints.launchpad.net/nova/+spec/live-migration-force-after-timeout (yikun) [END 2018-12-19] https://review.openstack.org/#/q/topic:bp/live-migration-force-after-timeout+(status:open+OR+status:merged)
14:02:06 <gibi> #link runway #3: https://blueprints.launchpad.net/nova/+spec/bandwidth-resource-provider (gibi) (current patch series below supports server create, delete and re-schedule cases) [END 2018-12-24] starts here https://review.openstack.org/#/c/567268
14:02:23 <gibi> anythin about the release schedul or the runway items?
14:02:37 <gibi> I'm +2 on https://blueprints.launchpad.net/nova/+spec/live-migration-force-after-timeout
14:03:33 <gibi> moving forward
14:03:34 <mriedem> i need to come back on it
14:03:50 <gibi> #topic Bugs
14:03:58 <gibi> no critical bugs \o/
14:04:07 <gibi> #link 58 new untriaged bugs (up 4 since the last meeting): https://bugs.launchpad.net/nova/+bugs?search=Search&field.status=New
14:04:12 <gibi> #link 10 untagged untriaged bugs (up 1 since the last meeting): https://bugs.launchpad.net/nova/+bugs?field.tag=-*&field.status%3Alist=NEW
14:04:16 <gibi> #link bug triage how-to: https://wiki.openstack.org/wiki/Nova/BugTriage#Tags
14:04:24 <gibi> #help need help with bug triage
14:04:49 <gibi> anything bug related?
14:06:05 <gibi> #topic Gate status
14:06:16 <gibi> #link check queue gate status http://status.openstack.org/elastic-recheck/index.html
14:06:22 <gibi> #link 3rd party CI status http://ciwatch.mmedvede.net/project?project=nova&time=7+days
14:06:35 <mriedem> the gate is unwell
14:06:37 <mriedem> #link http://lists.openstack.org/pipermail/openstack-discuss/2018-December/000867.html
14:07:51 <gibi> mriedem: anything where immediate attention would help?
14:08:03 <mriedem> i haven't really collected my thoughts yet today...
14:08:14 <gibi> mriedem: OK, thanks for the link
14:08:16 <mriedem> need to see where we're at since yesterday
14:08:36 <gmann> mriedem: have not got chance to check multiattach  cinder bug. i am seeing some connectivity issue on tempest-slow on stable branch
14:08:43 <gmann> #link https://review.openstack.org/#/q/topic:tempest-multinode-slow-stable+(status:open+OR+status:merged)
14:09:07 <gmann> rocky is fine but queens, pike are consistent failure
14:09:22 <gmann> i have not debugged those yet
14:10:34 <gibi> anything else gate or 3rd party CI related?
14:11:09 <gibi> #topic Reminders
14:11:13 <gibi> #link Stein Subteam Patches n Bugs: https://etherpad.openstack.org/p/stein-nova-subteam-tracking
14:11:19 <gibi> #link Spec freeze/non-priority blueprint freeze is s-2 January 10, 2019
14:11:50 <gibi> any other reminders?
14:12:38 <gibi> #topic Stable branch status
14:12:44 <gibi> #link stable/rocky: https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:stable/rocky,n,z
14:12:52 <gibi> #link stable/queens: https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:stable/queens,n,z
14:12:56 <gibi> #link stable/pike: https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:stable/pike,n,z
14:13:20 <mriedem> frickler needs a release for some bug fixes,
14:13:32 <mriedem> i think melwitt was thinking about doing one soon anyway, or maybe closer to s-2
14:13:42 <mriedem> but we could get one out before everyone leaves at the end of the month
14:13:59 <mriedem> so i'll try to push through what's reviewable today and then we can think about queuing up a release for early next week
14:14:11 <gibi> thanks mriedem
14:14:29 <gibi> anything else stable related?
14:15:10 <gibi> #topic Subteam Highlights
14:15:18 <gibi> Scheduler (cdent)
14:15:29 * cdent is caught off guard
14:15:50 <cdent> we met, I talked about all the things that are pending, and then we unmet
14:15:50 <gibi> did I remember correclty that you was the chair on Monday?
14:15:54 <cdent> yes
14:16:04 <edleafe> It was brief
14:16:11 <cdent> there was nothing sticky
14:16:30 <gibi> for me the biggest thing is that this is on the gate now https://review.openstack.org/#/c/617941/
14:16:43 <gibi> using extracted placement in nova functional test
14:16:46 <cdent> aye
14:17:17 <gibi> API (gmann)
14:17:18 <gibi> No updates this week. Office hour did not happen.
14:17:28 <gibi> #topic Stuck Reviews
14:17:31 <gmann> yeah, not much to share this week on API side
14:17:38 <gibi> gmann: thanks
14:17:45 <gibi> nothing on the agenda for stuck reviews
14:18:04 <gibi> #topic Open discussion
14:18:08 <gibi> FYI melwitt out 2018-12-20 through 2019-01-01. Will be back on Jan 2.
14:18:26 <mriedem> dan is out next week
14:18:28 <mriedem> fyi
14:18:44 <mriedem> i'm out the week of xmas fwiw
14:18:49 <mriedem> speaking of everyone being out,
14:19:00 <mriedem> spec freeze is jan 10,
14:19:13 <mriedem> and i'd like to lobby for some reviews on my cross-cell resize spec, which is a doozy https://review.openstack.org/#/c/616037/
14:19:39 <mriedem> so far only dan has looked at it but given the complicated nature of this (i have a poc already too), i'll need lots more eyes on this if there is hope to get it done in stein
14:20:11 <mriedem> otherwise i expect i'll just be in a spec freeze exception situation where we approve the spec, implementation details fuzzed over, and then sort it out in code review
14:20:25 <mriedem> i'm out the week of jan 10 too btw :)
14:20:29 <gibi> I try to look at it before xmass
14:20:37 <mriedem> thanks,
14:20:46 <mriedem> i think johnthetubaguy would be very valuable here being an old cells operator
14:20:55 <mriedem> so he understands the use case
14:21:14 <mriedem> but i think he's programming satellites in the australian desert or something
14:22:01 <gibi> OK there is one more thing on the agenda
14:22:03 <gibi> Do we want to have nova meeting on 2018-12-27 14:00 UTC?
14:22:26 <gibi> the date is still xmassy for me but I can solve it if there is a need
14:22:29 <mriedem> lots of people will be out so i say skip it
14:22:31 <cdent> I have a question about deleting the rest of placement. The start of that is at https://review.openstack.org/618215 but it is incomplete and it feels like we need some kind of stepwise plan re code/docs/whatever else.
14:22:40 <cdent> (let's skip the meeting)
14:22:53 <gmann> +1 on skip on 27
14:22:54 <cdent> I'm not asking that we make a plan here and now, but asking about how we go about making the plan.
14:23:01 <gibi> #agreed skip the meeting on  2018-12-27 14:00 UTC
14:23:16 <mriedem> cdent: maybe get a couple people together to scratch out a plan and then dump that in the ML for wider input
14:23:43 <mriedem> i would need to look back at the extraction checklist
14:24:01 <cdent> any takers? I'd particularly like someone who doesn't care about placement much but just wants to be sure nova is "OK"
14:24:12 <mriedem> mnaser?
14:24:20 <mriedem> he cares that it all works after the extraction
14:24:32 <cdent> the physics of taking the code out is no big deal, but making the docs floooow and similar is more challenging
14:24:33 <cdent> good idea
14:24:36 <mriedem> but he's also likely very busy
14:24:41 * mnaser reads buffer
14:25:12 <mriedem> i think we probably at least need to see osa or tripleo extracted placement upgrade working before we can delete the code from nova
14:25:31 <mriedem> canonical also said they can't package extracted placement while it's still in nova right?
14:25:37 <mriedem> coreycb said that i think
14:25:56 <cdent> mriedem: yeah, agree, I'm just hoping that we can have patches prepared so there's not much latency. yes coreycb said that
14:26:15 <cdent> and it is because of that that I'd like to minimize latency
14:26:18 <mriedem> so coreycb and mnaser would be good non-nova/placement stakeholders
14:26:39 <mnaser> I can chime in to answer questions but I’d be in favour of not having our gates broken because of placement removal
14:26:51 <cdent> that's a given
14:27:02 <mriedem> the gate (devstack/grenade) is already using extracted placement
14:27:05 <mriedem> but OSA isn't
14:27:08 <mriedem> nor tripleo etc
14:27:26 <mnaser> The hitch we hit now is that placement doesn’t have tempest tests so we can’t validate it like the rest of our roles
14:27:33 <cdent> puppet is successful with greendfield placement, but not upgrades
14:27:34 <mriedem> kolla is still on newton i think...
14:28:07 <gmann> it has integrated-gate-py35 (tempest-full-py3 and grenade-py3)
14:28:08 <mriedem> mnaser: anything creating or moving a server would validate placement
14:28:23 <mriedem> i.e. couldn't you run tempest compute api tests?
14:28:38 <mriedem> we probably don't need to hash this out here in the meeting
14:29:11 <mnaser> mriedem: we can, but we were hoping the placement role jobs only deployed placement alone and tested it. But indeed. I’d be okay being a poc for this from deployer side going back to original topic
14:29:21 <gmann> it run currently right with py3 - https://review.openstack.org/#/c/624942/
14:30:01 <mriedem> mnaser: then you gotta use gabbi
14:30:12 <mriedem> we said in the ML a week or so ago that tempest wouldn't have placement-only tests
14:30:18 <mriedem> since it's redundant with functional tests within placement
14:30:19 <bauzas> oh shit, gosh dammit DST
14:30:24 * bauzas waves like super late
14:30:31 <mnaser> ack
14:30:35 <cdent> mnaser: this might be of interest https://review.openstack.org/#/c/613386/
14:30:37 <gibi> nothing more on the agenda so we can use the time here or move it to openstack-nova
14:30:50 <cdent> gibi: let's kill it
14:31:12 <gibi> OK, any other open discussion topic?
14:32:00 <gibi> thanks you all
14:32:03 <gibi> #endmeeting