21:00:02 <melwitt> #startmeeting nova
21:00:03 <openstack> Meeting started Thu Jan 17 21:00:02 2019 UTC and is due to finish in 60 minutes. The chair is melwitt. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:04 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:06 <openstack> The meeting name has been set to 'nova'
21:00:10 <melwitt> howdy everyone, welcome to the nova meeting
21:00:19 <mriedem> o/
21:00:19 <takashin> o/
21:00:20 <edleafe> \o
21:00:39 <melwitt> #topic Release News
21:00:47 <melwitt> #link Stein release schedule: https://wiki.openstack.org/wiki/Nova/Stein_Release_Schedule
21:01:08 <melwitt> last week was the s-2 milestone and spec freeze
21:01:18 <efried> o/
21:01:20 <melwitt> with the new release process, the release team is supposed to propose releases for libs that need it,
21:01:35 <melwitt> but I haven't seen any releases proposed for any of our libs, so I need to look into that
21:01:52 <melwitt> seems unlikely none need a release
21:02:04 <melwitt> #info s-3 feature freeze is March 7
21:02:19 <mriedem> on the lib release thing,
21:02:34 <mriedem> i think os-vif recently had a release which is breaking some ovn jobs intermittently
21:02:44 <mriedem> so might want to talk to sean-k-mooney about that
21:03:03 <mriedem> or maybe it's not released, but then the ovn jobs would have to be running os-vif from source...
21:03:17 <melwitt> #action melwitt check with sean-k-mooney on latest os-vif release breaking ovn jobs intermittently
21:03:25 <melwitt> thanks
21:03:45 <melwitt> #link Stein runway etherpad: https://etherpad.openstack.org/p/nova-runways-stein
21:03:56 <melwitt> #link runway #1: https://blueprints.launchpad.net/nova/+spec/conf-max-attach-volumes (melwitt) [END 2019-01-18] https://review.openstack.org/#/q/topic:bp/conf-max-attach-volumes+(status:open+OR+status:merged)
21:04:09 <melwitt> I need to address review feedback on ^
21:04:15 <melwitt> #link runway #2: https://blueprints.launchpad.net/nova/+spec/per-aggregate-scheduling-weight (yikun) [END 2019-01-28] https://review.openstack.org/#/c/628163/
21:04:22 <melwitt> #link runway #3: <empty>
21:05:19 <melwitt> I'm going to update the blueprint status tracking etherpad and send an update to the ML hopefully today
21:05:35 <melwitt> so we can get a better picture of where we are right now and what we need to do
21:06:00 <melwitt> I think that's all I have for release news. anyone have anything else for release news before we move on?
21:06:30 <melwitt> #topic Bugs (stuck/critical)
21:06:46 <melwitt> no critical bugs in the link
21:06:53 <melwitt> #link 64 new untriaged bugs (same since the last meeting): https://bugs.launchpad.net/nova/+bugs?search=Search&field.status=New
21:06:59 <melwitt> #link 15 untagged untriaged bugs (up 1 since the last meeting): https://bugs.launchpad.net/nova/+bugs?field.tag=-*&field.status%3Alist=NEW
21:07:25 <melwitt> as usual, we need to do more bug triage and get the new bug number down
21:07:33 <melwitt> #link bug triage how-to: https://wiki.openstack.org/wiki/Nova/BugTriage#Tags
21:07:38 <melwitt> #help need help with bug triage
21:07:46 <melwitt> Gate status
21:07:51 <melwitt> #link check queue gate status http://status.openstack.org/elastic-recheck/index.html
21:08:30 <melwitt> hm, this says overall categorization rate of 0%? http://status.openstack.org/elastic-recheck/data/integrated_gate.html
21:08:51 <melwitt> something is weird here
21:09:36 <mriedem> need to follow up with clarkb
21:09:38 <melwitt> ok, will have to ask infra folks
21:09:55 <melwitt> 3rd party CI
21:10:01 * cdent realizes the time
21:10:03 <melwitt> #link 3rd party CI status http://ciwatch.mmedvede.net/project?project=nova&time=7+days
21:10:03 <clarkb> aroo
21:10:16 <melwitt> hay clarkb
21:10:17 <clarkb> oh ya I noticed that too. I thought maybe we just werent failing much
21:10:28 <clarkb> (we have had a low number of gating changes but its odd)
21:10:38 <mriedem> we're actually failing a lot, but we can move to -infra
21:11:16 <melwitt> ok, 3rd party CI, looks like the vmware CI is working again, powervm out-of-tree has been failing 100%
21:11:43 <melwitt> xenserver CI 100% fail
21:12:10 <melwitt> ok, moving on
21:12:24 <melwitt> #topic Reminders
21:12:41 <efried> edmondsw: ---^ powervm CI, I noticed that too. FYI.
21:13:03 <melwitt> #link Stein Subteam Patches n Bugs: https://etherpad.openstack.org/p/stein-nova-subteam-tracking
21:13:07 <melwitt> nothing much going on in there ^
21:13:08 <edmondsw> efried yeah, I've got someone looking at it
21:13:20 <melwitt> thanks edmondsw
21:13:38 <melwitt> ok, moving on
21:13:40 <melwitt> #topic Stable branch status
21:13:54 <melwitt> #link stable/rocky: https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:stable/rocky,n,z
21:13:59 <melwitt> #link stable/queens: https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:stable/queens,n,z
21:14:05 <melwitt> #link stable/pike: https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:stable/pike,n,z
21:14:31 <melwitt> not too many rocky patches, but queens and pike have a lot to review
21:14:46 <melwitt> anything else for stable branches before we move on?
21:14:58 <melwitt> #topic Subteam Highlights
21:15:11 <melwitt> efried: want to give a scheduler update?
21:15:16 <efried> YES!
21:15:21 <melwitt> \o/
21:15:25 <efried> #link n-sch meeting minutes http://eavesdrop.openstack.org/meetings/nova_scheduler/2019/nova_scheduler.2019-01-14-14.01.html
21:15:36 <efried> Nailed down the time for the extraction checkpoint hangout, which has since happened.
21:15:36 <efried> #link ML discussion of placement extraction checkpoint meeting http://lists.openstack.org/pipermail/openstack-discuss/2019-January/#1712
21:15:43 <efried> Discussed reshaper patches. See ^ for a more complete summary of that discussion.
21:15:50 <efried> Discussed bandwidth series. Meeting tomorrow (Fri) at 1700 UTC.
21:15:58 <efried> #link series to reduce placement traffic and do other sensible cleanup in how the resource tracker / report client operates, starting at https://review.openstack.org/#/c/615677
21:15:58 <efried> This should now be ready for final reviews. cdent, jaypipes, mriedem on the hook. Others welcome to have a gander.
21:16:07 <efried> Requested CERN to pull down & test that ^ and
21:16:07 <efried> #link single pass instance info fetch in host manager https://review.openstack.org/#/c/623558/
21:16:13 <efried> END
21:16:18 <melwitt> great, thank you
21:16:32 <melwitt> gmann left a note on the agenda that there is no update for the API subteam this week
21:16:45 <melwitt> moving on
21:16:47 <melwitt> #topic Stuck Reviews
21:17:00 <melwitt> nothing in the agenda, so assuming no stuck reviews
21:17:15 <melwitt> #topic Open discussion
21:17:31 <melwitt> I have one item here I thought I'd ask about
21:17:38 <melwitt> (melwitt): I saw mnestratov update the patch (https://review.openstack.org/449818) for this bp https://blueprints.launchpad.net/nova/+spec/config-drive-support-for-virtuozzo-containers today. It's a driver feature parity bp AFAICT. Should we consider approving it since the implementation is already proposed and updated recently?
21:18:05 <mriedem> are you aware of the history?
21:18:08 <melwitt> I saw the patch update pop up in the nova channel and wondered
21:18:10 <melwitt> no
21:18:20 <mriedem> read the comments and/or talk to tonyb
21:18:33 <tonyb> say what?
21:18:36 <mriedem> i believe there was a security concern and the original attempt at this was reverted by mikal
21:18:47 <mriedem> tonyb: config drive support for virtuozzo (ploop)
21:19:15 <mriedem> https://review.openstack.org/#/c/204259/
21:19:35 * tonyb reads
21:19:38 <mriedem> maybe the new approach is fine, idk
21:20:44 <melwitt> ok. thanks for that context
21:21:36 <melwitt> my thought was if it's something simple, might be ok to consider approving if it's already implemented. but if it's complicated or otherwise fraught with peril, then yeah, different thing
21:21:54 <tonyb> The original one was reverted as it made ext4 a valid configdive format which we dont (didn't) want to do
21:22:20 <tonyb> the new version looks different and I *think* it addresses that issue
21:23:31 <melwitt> thanks
21:24:22 <melwitt> maybe I'll ML about it. not sure otherwise how to get in touch with mnestratov and potential reviewers
21:24:45 <melwitt> does anyone have anything else they'd like to talk about for open discussion before we wrap up?
21:24:50 <efried> Interesting bit of trivia I found out the other day. Maybe some of you already know about this.
21:24:50 <efried> In meetings, you can get the HTML logs to flush immediately with the #save command (normally they wait til #endmeeting to flush).
21:24:50 <efried> That doesn't work for normal channels, though, for some rather arcane reasons.
21:24:50 <efried> However, I discovered that the flush to eavesdrop for normal channels happens on the actual quarter hour (I had thought it just lagged randomly).
21:25:47 <efried> that is all
21:26:12 <melwitt> interesting. can anyone #save or just the chair?
21:27:05 <melwitt> anyway, if that was a request for periodic #save commands during the meeting, let me know later
21:27:12 <melwitt> thanks everyone!
21:27:18 <melwitt> #endmeeting