14:01:31 <efried> #startmeeting nova
14:01:33 <openstack> Meeting started Thu Sep  5 14:01:31 2019 UTC and is due to finish in 60 minutes.  The chair is efried. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:35 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:37 <openstack> The meeting name has been set to 'nova'
14:01:39 <cdent> hi
14:01:44 <mriedem> o/
14:01:45 <takashin> o/
14:02:12 <gmann> o/
14:02:29 <dansmith> o/
14:02:37 <efried> #link agenda https://wiki.openstack.org/wiki/Meetings/Nova#Agenda_for_next_meeting
14:02:45 <gibi> \o
14:03:05 <efried> #topic Last meeting
14:03:06 <efried> #link Minutes from last meeting: http://eavesdrop.openstack.org/meetings/nova/2019/nova.2019-08-29-21.01.html
14:03:29 <stephenfin> o/
14:03:39 <efried> Last week it was just me, mriedem, and aspiers. We decided not to approve https://blueprints.launchpad.net/nova/+spec/policy-rule-for-host-status-unknown for Train.
14:03:56 <efried> melwitt wasn't there to defend herself
14:04:18 <efried> #topic Release News
14:04:18 <efried> Feature freeze in one week.
14:05:16 <efried> We have many things that are pretty close.
14:06:25 <efried> It may be worthwhile to have a list of those things somewhere.
14:06:36 <dansmith> maybe we should call out some here?
14:06:44 <dansmith> I can start and summarize NUMA LM if you want
14:06:48 <efried> hit it
14:07:17 <efried> #link NUMA LM: https://review.opendev.org/#/q/status:open+project:openstack/nova+branch:master+topic:bp/numa-aware-live-migration
14:07:20 <mriedem> https://review.opendev.org/#/c/673133/ was +2 yesterday and i'll likely +2 today
14:07:21 <patchbot> patch 673133 - nova - Add delete_on_termination to volume-attach API - 16 patch sets
14:07:29 <dansmith> NUMA LM is close, has seen a lot of review, is four patches (not counting an extra test patch and a conf deprecation), and actually has CI tests that prove the new code in public
14:08:03 <dansmith> it enables us to migrate instances with numa topologies instead of silently screwing up hosts when we allow it to happen (as today) and moves that code to use the same claims process as other migrations
14:08:18 <dansmith> bottom three patches have a +2 from me, radeks is going to look today
14:08:20 <dansmith> fin.
14:08:29 <dansmith> whoopsie, mriedem  :)
14:09:03 <efried> #link AMD SEV https://review.opendev.org/#/q/status:open+project:openstack/nova+branch:master+topic:bp/amd-sev-libvirt-support
14:09:26 <mriedem> also seems like forbidden aggregates should get another push
14:09:28 <efried> This is close, has seen a lot of review
14:09:57 <efried> aspiers has been responsive to feedback. Much of the series has been +2ed at various points in the past.
14:10:00 <mriedem> i feel like there are new sev patches every day
14:10:17 <mriedem> but that's just because i see them posted to the bp in lp
14:10:26 <dansmith> I haven't followed the SEV stuff, but I thought it was still struggling
14:10:29 <mriedem> https://blueprints.launchpad.net/nova/+spec/support-move-ops-with-qos-ports is getting review from myself and bauzas, should be doable by next week
14:10:58 <gibi> I focus on that ^^
14:12:05 <efried> #link virtual persistent memory https://review.opendev.org/#/q/status:open+project:openstack/nova+branch:master+topic:bp/virtual-persistent-memory
14:12:42 <efried> stephenfin and I have been reviewing the bulk of the series. Otherwise need dansmith's nod on the bottom two patches.
14:12:57 <dansmith> I just would-be--2'd the second patch
14:13:16 <dansmith> because it stores an unversioned json blob in a string field
14:13:22 <dansmith> so some more object modeling is needed there
14:13:48 <efried> when that object is hypervisor-specific, is there still a way to model it generically at this level?
14:14:00 <dansmith> see the live migrate data object hierarchy
14:14:14 <efried> ack
14:14:26 <dansmith> json-in-a-string-field is never going to be the answer though
14:14:32 <efried> ack
14:15:28 <efried> #link forbidden aggregates https://review.opendev.org/#/q/status:open+project:openstack/nova+branch:master+topic:bp/placement-req-filter-forbidden-aggregates
14:15:47 <efried> has been really close for quite a while, is very simple, has had lots of +2s
14:16:38 <gibi> I can re-review that ^^
14:16:44 <dansmith> I will take a look at that when we're done here
14:16:48 <dansmith> at least the object stuff
14:16:52 <dansmith> object and b
14:17:05 <efried> IIRC I was basically +2 all the way up, just waiting for the other reviewers who have weighed in to make sure they're satisfied.
14:17:28 <efried> stephenfin: I think that's you on the bottom one?
14:17:42 <stephenfin> which bottom one?
14:17:43 <efried> and/or gibi, dansmith
14:17:47 <efried> stephenfin: https://review.opendev.org/#/c/671072/11
14:17:48 <patchbot> patch 671072 - nova - Nova object changes for forbidden aggregates reque... - 11 patch sets
14:18:13 <stephenfin> Sure. dansmith should look too though
14:18:23 <dansmith> yep, I will right after this
14:18:23 <efried> and top one
14:18:40 <efried> Okay, what else is close for FF?
14:19:26 <mriedem> https://blueprints.launchpad.net/nova/train is relatively up to date if that helps
14:19:30 <mriedem> for what's open
14:19:37 <mriedem> lots of things in there should probably just be deferred at this point
14:20:35 <efried> gadzooks
14:20:55 <efried> oh, ignore 'implemented'
14:21:01 <efried> phew, that's easier on the eyes.
14:21:21 <efried> still 23 opens
14:21:22 <dansmith> is the cyborg stuff not happening?
14:21:36 <dansmith> I haven't re-looked at that in a few weeks
14:21:48 <bauzas> I plan to do a couple of other reviews next week
14:21:59 <dansmith> but it seemed like not much review was going on at the time
14:22:00 <mriedem> i don't think any cores are reviewing the cyborg series
14:22:01 <efried> cyborg hasn't gotten enough review attention
14:22:01 <efried> yeah
14:22:09 <dansmith> so is that a defer already?
14:22:09 <bauzas> mriedem: I can do that if that helps
14:22:21 <mriedem> i would defer it,
14:22:26 <efried> Seems likely a defer, unfortunately.
14:22:28 <mriedem> the cyborg side patches for placement integration just merged this week
14:22:34 <bauzas> k
14:22:38 * bauzas bbiab
14:23:14 <mriedem> anywho, we shouldn't step through these one by one in this meeting,
14:23:25 <mriedem> this is where an etherpad of what's open and its status would be useful
14:23:33 <mriedem> to sort out what should be deferred and what's close
14:23:47 <efried> agreed. Can I get a volunteer to put that together?
14:23:47 <dansmith> maybe eric propose a list of things to go ahead and defer
14:23:50 <dansmith> and we can review it
14:24:31 <efried> I would hate for the time spent on PM crap to detract from review time to the point of affecting what is able to land.
14:24:35 <efried> and you can quote me on that.
14:24:47 <efried> but see the necessity.
14:25:27 <dansmith> well, don't do it then
14:25:55 <dansmith> we can just see what lands and then mark everything that doesn't after the dust settles
14:26:10 <efried> let me put it this way:
14:26:20 <mriedem> i'll defer cross-cell-resize i know that's not happening
14:26:50 <gibi> mriedem: at least we tried
14:27:30 <mriedem> gibi: it's a multi-release effort anyway, i have no illusions about that
14:28:07 <efried> I see the list exercise going one of two ways
14:28:07 <efried> 1) I (or someone) put together this list and prioritize it and the core team looks at it and reviews things in priority order.
14:28:07 <efried> 2) List is put together and we spend the next week arguing about priorities and not reviewing.
14:28:17 <efried> given history, which do you think is more likely?
14:28:26 <efried> so
14:28:52 <efried> let's take a spin through the blueprints today and defer the things that are obviously deferrable
14:29:07 <efried> and let the rest sit as dansmith suggests and sweep up the pieces after FF.
14:29:22 <mriedem> sounds good
14:29:29 <dansmith> to be clear, that was not my suggestion :)
14:29:45 <dansmith> that was my concession if we're not going to plan, but whatever :)
14:29:49 * gmann thinking about policy-defaults-refresh
14:30:51 <mriedem> gmann: if it hasn't had core review yet it's likely DOA for train
14:31:11 <efried> dansmith: concession is a good word for it. I'm in an unusually (for me) cynical mood at the moment, but I don't feel like "planning" is going to have an impact for the positive.
14:31:26 <gmann> mriedem: its lot of changes and first set and framework has one one +2
14:31:30 <dansmith> efried: roger that, as long as we're clear
14:31:40 <efried> I could go through and say "we're going to do these things, and we're not going to do these other things"
14:31:47 <dansmith> efried: and for the cliche auditors: failure to plan is planning to fail :P
14:32:05 <efried> but there's no way to enforce the plan
14:32:18 <dansmith> nope, it's lead by example
14:32:19 <dansmith> it's cool
14:32:27 <dansmith> I'm hip, let's just move on
14:33:10 <efried> give me a sec
14:35:10 <efried> #action efried to defer obviously-deferrable blueprints
14:35:30 <efried> #topic Bugs (stuck/critical)
14:35:30 <efried> No Critical bugs
14:35:30 <efried> #link 76 new untriaged bugs (+1 since the last meeting): https://bugs.launchpad.net/nova/+bugs?search=Search&field.status=New
14:35:30 <efried> #link 4 untagged untriaged bugs (-2 since the last meeting): https://bugs.launchpad.net/nova/+bugs?field.tag=-*&field.status%3Alist=NEW
14:36:06 <efried> any bugs we should be prioritizing in the next week?
14:36:09 <mriedem> someone more in the know should triage this https://bugs.launchpad.net/nova/+bug/1842616
14:36:09 <openstack> Launchpad bug 1842616 in OpenStack Compute (nova) "NUMA vcpus not correctly allocated against numa regions" [Undecided,New]
14:36:17 <mriedem> stephenfin: yonglihe: sean-k-mooney: ^
14:36:24 <efried> artom: ^
14:36:37 <artom> efried, looking
14:36:50 <efried> if possible I would like to reserve stephenfin for core reviews
14:36:52 <efried> thanks artom
14:37:13 <efried> #topic Gate status
14:37:13 <efried> #link check queue gate status http://status.openstack.org/elastic-recheck/index.html
14:37:13 <efried> #link 3rd party CI status (seems to be back in action) http://ciwatch.mmedvede.net/project?project=nova
14:37:36 <efried> anecdotally, grenade-y stuff failing pretty frequently of late. I haven't looked into it at all. mriedem, have you?
14:38:05 <mriedem> not off the top of my head
14:38:20 <mriedem> i've been looking at failures but not aware of anything obvious / known
14:38:31 <efried> ight. It can probably wait until crunch is over.
14:38:32 <cdent> a few days ago some cinder stuff was unhappy, but it cleared up.
14:38:43 <efried> #topic Reminders
14:38:44 <efried> Feature freeze in one week
14:38:47 <efried> any other reminders?
14:39:06 <efried> #topic Stable branch status
14:39:06 <efried> #link stable/stein: https://review.openstack.org/#/q/status:open+(project:openstack/os-vif+OR+project:openstack/python-novaclient+OR+project:openstack/nova)+branch:stable/stein
14:39:06 <efried> #link stable/rocky: https://review.openstack.org/#/q/status:open+(project:openstack/os-vif+OR+project:openstack/python-novaclient+OR+project:openstack/nova)+branch:stable/rocky
14:39:06 <efried> #link stable/queens: https://review.openstack.org/#/q/status:open+(project:openstack/os-vif+OR+project:openstack/python-novaclient+OR+project:openstack/nova)+branch:stable/queens
14:39:22 <efried> mriedem: anything in stable we can't ignore for a week?
14:39:40 <mriedem> i haven't looked lately so idk
14:39:52 <efried> k
14:39:53 <efried> #topic Sub/related team Highlights
14:39:53 <efried> Placement (cdent)
14:39:53 <efried> #link latest pupdate http://lists.openstack.org/pipermail/openstack-discuss/2019-August/008935.html
14:39:53 <efried> Consumer Types: cdent continuing this work
14:39:53 <efried> #link consumer types (in progress) https://review.opendev.org/#/q/status:open+project:openstack/placement+branch:master+topic:bp/support-consumer-types
14:39:56 <efried> cdent: your mic
14:40:27 <cdent> that consumer types stuff is basically done, so if people want something to look at in between things that are higher priority, it could become "ready for nova in U" pretty easily
14:41:00 <cdent> the only other thing is that placement is currently PTL-less for U, but there are a few plan bs available, waiting on more info to figure it out, not critical rush
14:41:28 <cdent> EOF
14:41:43 * mriedem read that as plan bullsh*t
14:41:51 <cdent> might work too
14:41:54 <cdent> but I meant Bs
14:41:58 <cdent> beeeeeees
14:42:03 <gibi> plan c can be the polite cannibalism..
14:42:08 <cdent> quite so
14:42:21 <efried> API (gmann)
14:42:21 <efried> did not get the chance to send updates on ML. Few highlights are:
14:42:21 <efried> microversion 2.78 is on gate: https://review.opendev.org/#/c/621476/ which need Brin 'delete_on_termination' to rebase.
14:42:21 <efried> Added policy-defaults-refresh BP in runway. First set and framework has +2 from kenichi and need second review.
14:42:22 <patchbot> patch 621476 - nova - Add server sub-resource topology API (MERGED) - 62 patch sets
14:42:34 <artom> This https://bugs.launchpad.net/nova/+bug/1842616 is invalid
14:42:34 <openstack> Launchpad bug 1842616 in OpenStack Compute (nova) "NUMA vcpus not correctly allocated against numa regions" [Undecided,Invalid]
14:42:36 <artom> *Think
14:42:42 * artom -> back to his corner
14:42:46 <gmann> main updates was for policy-defaults-refresh which i will wait for final decision
14:43:14 <gmann> it is updates for all the policies and we should do it in single cycle.
14:43:21 <gmann> for upgrade benefits
14:44:01 <efried> #link policy defaults refresh https://review.opendev.org/#/q/status:open+project:openstack/nova+branch:master+topic:bp/policy-defaults-refresh
14:44:30 <efried> gmann: how much of that are you realistically expecting for Train?
14:44:37 <gmann> efried: if i read it properly. tomorrow is going to be the list of possible go in Train ?
14:44:59 <mriedem> FF is next thursday
14:45:27 <mriedem> the question is how much should we spread the core team on things and risk not landing many, or rushing and merging regressions,
14:45:30 <efried> gmann: The only thing I'm going to do is defer things that are obviously not going to make it. Whatever's left is going to be wild west style. Because trying to organize anything more crisp is an exercise in futility and frustration.
14:45:35 <mriedem> or focusing on a smaller set that are already being actively reviewed
14:45:41 <gmann> till next Thursday will not be possible i think. we can get scope things in if we try but that also lot of patches
14:46:09 <mriedem> probably not a surprise that i'm goign to say i don't feel great about rushing in policy change stuff last minute
14:46:12 <mriedem> since that impacts upgrades
14:46:15 <gmann> ok, in that case I will say defer and get all policy changes in in ussuri
14:46:38 <gmann> mriedem: agree.
14:46:43 <efried> gmann: starting here https://review.opendev.org/#/c/674038/5 ?
14:46:44 <patchbot> patch 674038 - nova - Pass RequestContext to oslo_policy - 5 patch sets
14:47:14 <gmann> efried: yes
14:47:39 <gmann> till here it is for one API policy - https://review.opendev.org/#/c/648480/16
14:47:40 <patchbot> patch 648480 - nova - Add new default roles in os-services API policies - 16 patch sets
14:47:53 <gmann> kind of 4 patches per API policy
14:48:42 <efried> okay, I put a -2 on that patch, moved the bp to Needs Approval and targeted for series ussuri
14:48:50 <efried> mriedem: any other paperwork necessary to defer a thing?
14:49:29 <gmann> ok
14:50:00 <mriedem> efried: nope, i just leave a comment in the whiteboard saying why it's being deferred
14:50:06 <efried> thx
14:50:09 <efried> #topic Stuck Reviews
14:50:09 <mriedem> i just did that in the policy defaults bp
14:50:11 <efried> any?
14:50:34 <efried> mriedem: oh, no merge conflict in bp whiteboard, you overwrote my note
14:50:49 <mriedem> why don't they use generations?
14:51:18 <efried> #topic Open discussion
14:51:18 <efried> Move/kill 2100 meeting slot?
14:52:00 <mriedem> the alternative to that is leave 2100 and change this meeting to be more APAC/EU friendly
14:52:01 <mriedem> ?
14:52:14 <mriedem> obviously would need a different chair for that
14:52:16 <dansmith> so, once DST goes, I can't attend this slot
14:52:25 <dansmith> the 2100 one is the only one I would make
14:52:51 <gibi> I can chair an EU friendly slot
14:52:53 <dansmith> I expect that's the same for anyone in Pacific time
14:53:40 <efried> So I guess just making all the meetings be in this slot isn't an option. And I'm guessing the slots an hour or two later are probably pretty chocobloc
14:53:44 <cdent> so, for reference, the is the one openstack meeting I've ever attended that is actually useful
14:53:53 <mriedem> so maybe suggest options in the ML, see if there is interest in moving this meeting to APAC/EU friendly time and if so but after a month or two no one shows up we could cancel it - or just outright cancel this one
14:54:43 <cdent> maybe wait until after FF
14:54:46 <cdent> or even RC
14:54:48 <efried> yeah, let's do that.
14:55:13 <efried> It may have just been an anomaly (for several meetings in a row) that attendance at the later meeting was almost nonexistent.
14:55:21 <efried> (mriedem): Should we deprecate the xen driver before releasing Train? We added a quality warning https://review.opendev.org/#/c/662295/ with the idea of deprecating if no changes and there haven't been. Deprecation doesn't mean we remove in U but it leaves the option and sends a clear signal.
14:55:23 <patchbot> patch 662295 - nova - xenapi: log quality warning in init_host (MERGED) - 1 patch set
14:55:54 <mriedem> just following up on the plan from the ptg
14:56:00 <cdent> yes, follow through
14:56:06 <mriedem> quality warning post-ptg, deprecation by end of train of no improvement
14:56:12 <mriedem> *if
14:56:43 <efried> Yeah, I haven't seen any xen activity, so pull the trigger. Is this a trigger that can wait a week to be pulled?
14:56:44 * bauzas is back - sorry, taxi dad
14:57:31 <cdent> 3 minute warning
14:57:50 <efried> mriedem: that last question was for you. Guess it doesn't need to be answered right now
14:57:52 <efried> any other opens?
14:58:02 <efried> today is my birthday
14:58:19 <mriedem> well happy birthday
14:58:21 <efried> one year ago today I seem to recall we merged roughly my-age patches toward placement extraction
14:58:25 <gmann> happy birthday :)
14:58:26 <dansmith> efried: deprecation can be done now with no ill effects, not much point in waiting I think
14:58:28 <cdent> that was a year ago?
14:58:31 <cdent> jeebus
14:58:44 <efried> ikr, it must have been, but I had a hard time believing that
14:58:50 <cdent> happy birthday efried and placement extraction
14:59:00 <bauzas> good b'day
14:59:14 <efried> thanks all
14:59:14 <efried> Okay, if there's nothing else...?
14:59:29 <cdent> kill it
14:59:30 <efried> Oh, and I'm taking the afternoon off
14:59:35 <efried> o/
14:59:35 <efried> #endmeeting