21:00:05 <efried> #startmeeting nova
21:00:06 <openstack> Meeting started Thu Jan 16 21:00:05 2020 UTC and is due to finish in 60 minutes.  The chair is efried. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:07 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:09 <openstack> The meeting name has been set to 'nova'
21:01:26 <efried> #link agenda https://wiki.openstack.org/wiki/Meetings/Nova#Weekly_Nova_team_meeting
21:01:26 <melwitt> o/
21:02:39 <efried> #topic Last meeting
21:02:39 <efried> #link Minutes from last meeting: http://eavesdrop.openstack.org/meetings/nova/2020/nova.2020-01-09-14.00.html
21:02:39 <efried> #action efried to paw through blueprints and specs and reconcile
21:02:49 <efried> I didn't get around to that since last week :(
21:02:57 <efried> Any old business?
21:03:22 <efried> #topic Bugs (stuck/critical)
21:03:23 <efried> One Critical bug
21:03:24 <efried> https://bugs.launchpad.net/nova/+bug/1860021
21:03:25 <openstack> Launchpad bug 1860021 in devstack "nova-live-migration fails 100% with "mysql: command not found" on subnode" [Undecided,In progress] - Assigned to Radosław Piliszek (yoctozepto)
21:03:26 <gmann> o/
21:03:51 <efried> That's being worked via https://review.opendev.org/#/c/702960/ and tested via https://review.opendev.org/#/c/702961/
21:04:21 <efried> we think it's working, but rackcdn never works for me so I can't get to the logs and figure it out.
21:04:28 <efried> and when I can, I have to gunzip them.
21:04:41 <efried> Makes a person appreciate how nice our tools *usually* are.
21:05:26 <melwitt> +1 I'm going to be trying to learn how to convert jobs and get away from the gzipped files because it's killing me too trying to get some debug info on a different gate bug
21:06:11 <efried> oh, I also can't set up e-r for that bug, I suspect due to the gz-ness (logstash can't find that message, guessing because it only has access to the zipped versions of the files)
21:06:42 <efried> thanks melwitt, that would be super helpful.
21:06:58 <efried> #topic Reminders
21:06:59 <efried> 4 weeks to spec freeze.
21:07:44 <efried> As noted, any blueprints that are approved and still open at that time will be subject to a prioritization/scrubbing exercise.
21:08:09 <efried> i.e. just because your blueprint is definition:approved doesn't mean it'll wind up direction:approved for ussuri.
21:08:21 <efried> so you can cheat by getting your code merged before spec freeze.
21:08:30 <efried> other reminders?
21:08:43 <efried> #topic Sub/related team Highlights
21:08:43 <efried> Placement (tetsuro)
21:09:01 <efried> I think things are pretty quiet here. melwitt, did you want to mention consumer types?
21:09:08 <melwitt> tetsuro recently reviewed consumer types which is super cool. I'm gonna to update in response to his comments
21:09:19 <efried> good deal.
21:09:22 <efried> API (gmann)
21:09:35 <gmann> one update on policy refresh BP
21:09:44 <gmann> i have 4-5 APIs up for review for this
21:09:46 <gmann> #link https://review.opendev.org/#/q/status:open+project:openstack/nova+branch:master+topic:bp/policy-defaults-refresh
21:09:59 <efried> who's qualified to review those? (hint: I'm not)
21:10:10 <gmann> everyone :)
21:10:21 <efried> If we get desperate, I suppose I would proxy approval from a keystoner.
21:10:28 <gmann> stephenfin: john being reviewing the previous patches
21:10:43 <gmann> melwitt: ^^
21:11:23 <melwitt> yes, I want to help. I would feel better relying on john for the first pass though
21:11:51 <gmann> thanks.
21:12:03 <efried> Anything else gmann?
21:12:14 <gmann> one quick thing on BP status
21:12:33 <gmann> you said Direction field is imp not definition to select for ussuri ?
21:12:49 <gmann> definition is pending approval here so not sure if that musg be approved - https://blueprints.launchpad.net/nova/+spec/policy-defaults-refresh
21:12:51 <gmann> must
21:13:16 <gmann> and we do not get surprise at the last minute when you freeze the BP/spec things
21:13:17 <efried> both are important.
21:13:17 <efried> definition comes first, basically just means spec is approved. "If we're gonna do it, we know how we're gonna do it"
21:13:17 <efried> direction means "we're gonna do it in ussuri"
21:13:57 <gmann> ok in my case definition is pending which should be done. can you change ?
21:14:05 <efried> do you have a spec?
21:14:15 <efried> https://review.opendev.org/#/c/547850
21:14:16 <gmann> spec is merged. this is for policy referesh
21:14:24 <efried> cool, I'll mark definition:approved....
21:14:26 <gmann> yeah
21:14:28 <gmann> thanks
21:14:37 <efried> wait, that was train
21:14:42 <efried> do we have an ussuri rendition of it?
21:15:01 <melwitt> it's the same one, it was not approved in train
21:15:05 <gmann> https://review.opendev.org/#/c/686058/
21:15:18 <melwitt> meaning, this is the first time it's been approved and first time any impl has landed
21:15:35 <efried> now I'm confused
21:15:37 <melwitt> oh, am I wrong?
21:15:48 <efried> I think the first link above was the approved train spec, and the second is the approved ussuri spec.
21:15:52 <efried> I'll mark the bp...
21:15:53 <gmann> that was merged for train also and re-proposed merges in ussuri too - https://review.opendev.org/#/c/686058/
21:16:16 <melwitt> oh, geez. I didn't know it was previously approved. sorry
21:16:41 <melwitt> or more accurately, I forgot. sorry
21:16:58 <efried> okay, it looks like the fields were backwards; I fixed.
21:17:28 <efried> moving on?
21:17:37 <efried> #topic Stuck Reviews
21:17:39 <efried> any?
21:17:54 <efried> #topic Open discussion
21:17:57 <efried> any?
21:18:07 <alistarle> Yes
21:18:14 <efried> alistarle: your floor
21:18:31 <gmann> efried: now Direction became 'Need Approval'.
21:18:38 <alistarle> I have done the modification you told me last week about this spec (https://review.opendev.org/#/c/701763/)
21:18:53 <efried> gmann: yes. At spec freeze we'll either change that to Approved or punt the bp to the next release.
21:18:55 <alistarle> So microversion bump in code, and try to improve some things in the microversion docs
21:19:27 <efried> I spoiled you by responding quickly to your original code patch :)
21:19:54 <gmann> efried: ah i see, got it.
21:20:02 <melwitt> efried: so we're allowed to merge code that says 'Need Approval'? just to be clear
21:20:13 <alistarle> Yes I see that ;)  I see that blueprint must change status before reviewing, but I didn't see how to do it in the docs
21:20:38 <efried> melwitt: yeah, if you can get your code merged before we do the scrub, you're safe from the reaper's scythe.
21:20:51 <melwitt> ack
21:20:57 <efried> alistarle: I just tweaked the bp record to show up against ussuri
21:21:23 <efried> but yeah, the spec needs to be approved before we mark definition:approved
21:21:37 <efried> and assuming that happens, then in a month we'll decide whether we want it to happen in ussuri.
21:22:31 <melwitt> so once definition:approved, start merging code, then if direction changes to denied at spec freeze, no more code merges?
21:22:42 <alistarle> Ok fine, and do you think it is targetable before the spec freeze ? I see that it is in only 4 weeks, and it seems to be a lot of work here
21:23:51 <gmann> melwitt: efried  what if half of the code is merged which is highly possibilities for most of the BP. how we make decision on Direction then ?
21:24:36 <gmann> i thought having liaison in spec make it clear that it is ok and accepted for that cycle
21:24:51 <efried> nothing to do with liaisons
21:25:54 <efried> direction is a way for us to acknowledge at spec freeze time that we've bitten off more than we can reasonably chew for the release, and limit our scope to things we consider "above the line", so that a) we don't wind up with part-but-not-all of many things merged, and b) we increase the chance that the stuff that merges is the important stuff.
21:26:40 <efried> if there's a partially-merged blueprint that we decide to cut off, hopefully it's a blueprint that doesn't *need* to be all merged together (otherwise we should have -2ed the bottom until the series was ready, regardless of prioritization/dates/etc.)
21:28:06 <efried> alistarle: Don't know, sorry. As we get closer to spec freeze there will be a push to review pending specs. There's a lot going on, and unfortunately urgency tends to trump importance most of the time.
21:28:20 <efried> Like right now our gate is completely broken, so I'm not looking at specs.
21:28:22 <efried> kind of thing.
21:29:43 <alistarle> For sure I understand that, no problem :)
21:30:50 <efried> And, look, if I'm the only one standing around at spec freeze time foaming at the mouth about it not being okay to have more stuff approved than we can possibly merge, I'll back down and let the release fall into the tempestuous travesty it usually is.
21:31:03 <efried> so there
21:31:11 <efried> Any other opens?
21:31:37 <efried> #endmeeting