21:00:19 <efried> #startmeeting nova
21:00:19 <openstack> Meeting started Thu Jan 30 21:00:19 2020 UTC and is due to finish in 60 minutes.  The chair is efried. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:22 <openstack> The meeting name has been set to 'nova'
21:02:03 <melwitt> o/
21:02:09 <efried> #link agenda https://wiki.openstack.org/wiki/Meetings/Nova#Agenda_for_next_meeting
21:02:33 <efried> dansmith, sean-k-mooney, stephenfin, jroll:
21:02:35 <efried> anyone else around?
21:02:44 <dansmith> I'm /around/
21:02:52 <jroll> I'm kinda here, in another meeting
21:03:13 <efried> #topic Last meeting
21:03:13 <efried> #link Minutes from last last meeting (the last one was a no-op): http://eavesdrop.openstack.org/meetings/nova/2020/nova.2020-01-16-21.00.html
21:03:13 <efried> DONE efried to paw through blueprints and specs and reconcile
21:03:13 <efried> More on that ^ in a bit.
21:03:18 <efried> Any old business?
21:03:28 <efried> #topic Bugs (stuck/critical)
21:03:28 <efried> No Critical bugs
21:03:31 <efried> Bugs to bring up?
21:03:46 <efried> #topic Reminders
21:03:47 <efried> TWO weeks to spec freeze.
21:03:47 <efried> At that time I'd like to do a pass through the Definition:Approved specs and decide which we should Direction:Approve and which we should defer.
21:03:47 <efried> #link etherpad for working the scrub (feel free to leave notes etc.) https://etherpad.openstack.org/p/nova-ussuri-planning
21:04:37 <efried> I went through the
21:04:37 <efried> #link ussuri blueprints https://blueprints.launchpad.net/nova/ussuri
21:04:37 <efried> and the
21:04:37 <efried> #link nova-specs repo https://review.opendev.org/#/q/project:openstack/nova-specs+path:%255Especs/ussuri/approved/.*
21:04:37 <efried> and made sure everything with a spec had a bp and vice versa
21:04:48 <melwitt> that link doesn't seem to work?
21:04:49 <efried> except for that one I poked melwitt about earlier
21:04:55 <melwitt> oh nvm
21:05:08 <melwitt> the link from the etherpad came up as a blank list
21:05:43 <efried> etherpad is not smart enough to include the .* at the end
21:05:47 <sean-k-mooney> the .* does not work
21:05:48 <efried> sad face
21:05:50 <melwitt> yeah, I see
21:05:51 <melwitt> ok
21:06:23 <efried> melwitt: lmk when https://blueprints.launchpad.net/nova/+spec/nova-audit exists please
21:06:30 <melwitt> will do
21:06:32 <efried> until then...
21:06:54 <efried> we have 41 total blueprints targete for ussuri
21:06:54 <efried> 22 are Design:Approved, including 7 Implemented
21:06:58 <efried> targeted*
21:07:18 <efried> Of the remaining, most are in active review, but some appear dead.
21:07:42 <lyarwood> \o
21:07:43 <efried> Anybody want to talk about bp/spec process things? Or a specific bp/spec?
21:08:03 <efried> or other things under the Reminders topic?
21:08:15 <melwitt> to be clear, at spec freeze time my understanding is some things will get effectively un-approved
21:08:35 <melwitt> after the scrub
21:08:36 <efried> Yeah, that's my position.
21:08:47 <melwitt> ok, just wanted to put that out there in case anyone else didn't understand
21:08:47 <sean-k-mooney> efried: i noticed we still have not updated the implemented spec for train so ill try and do that tommorow
21:08:59 <sean-k-mooney> i just need to run the script and push the review
21:09:04 <efried> Definition:Approved: "If we're gonna do it, this is how"
21:09:04 <efried> Direction:Approved: "We're gonna do it in Ussuri"
21:09:07 <efried> Thanks sean-k-mooney
21:09:19 <efried> takashin-bot must be broken :P
21:09:44 <efried> #link Proposal to EM rocky on or around 2/24 http://lists.openstack.org/pipermail/openstack-discuss/2020-January/012207.html
21:09:44 <efried> #link open rocky patches https://review.opendev.org/#/q/status:open+(project:openstack/os-vif+OR+project:openstack/python-novaclient+OR+project:openstack/nova)+branch:stable/rocky
21:09:44 <efried> #help Volunteer to curate this list, decide what we'd like to merge before the cutover, etc. (Should probably be a stable.)
21:09:55 <efried> melwitt, lyarwood, dansmith: ^ ?
21:09:56 <lyarwood> ack I can take that
21:10:00 <efried> thanks lyarwood
21:10:07 <lyarwood> I was about to bring up the need for releases on train and stein anyway
21:10:14 <efried> #action sean-k-mooney to do the train implemented specs business
21:10:24 <efried> #action lyarwood to curate rocky EM list
21:10:34 <dansmith> lyarwood: yeah ping me if there's specific stuff for me to look at, I'm slacking in my stable dutiew
21:10:35 <efried> lyarwood: Because milestone?
21:10:36 <dansmith> *duties
21:10:52 <lyarwood> efried: no milestones for train and stein, just a build up of fixes
21:11:16 <efried> okay. Happy to PTL+1 a release patch.
21:11:29 <lyarwood> ack thanks, I'll draft them tomorrow and CC you in
21:11:42 <efried> #action lyarwood to propose train & stein releases
21:11:56 <efried> Cool, anything else release-y?
21:12:07 <efried> Anything else reminder-y?
21:12:15 <lyarwood> dansmith: ops missed your offer, ack will do :)
21:12:17 <sean-k-mooney> we will need to do a release of os-vif at m2 but that is not for two weeks
21:12:53 <efried> noted.
21:12:59 <melwitt> I think you have until after m2 https://wiki.openstack.org/wiki/Nova/Ussuri_Release_Schedule
21:12:59 <efried> well, in my head anyway.
21:13:18 <melwitt> if that date is right anyway
21:13:22 <efried> melwitt: I think there's a "release once per milestone" rule.
21:13:26 <efried> not just lib freeze
21:13:34 <melwitt> oh, ok
21:13:47 <sean-k-mooney> yes
21:13:48 <melwitt> it's a good thing to do but I didn't remember if it's required
21:13:51 <melwitt> k
21:14:07 <sean-k-mooney> well also its good to do with the python3 only goal
21:14:17 <efried> Moving on.
21:14:18 <sean-k-mooney> lib project were ment to complete that for m2
21:14:18 <efried> #topic Sub/related team Highlights
21:14:18 <efried> Placement (tetsuro)
21:14:41 <melwitt> tetsuro has reviewed consumer types and it's in my court to update the patches this week
21:14:43 <efried> melwitt: I think the only thing of significance going here is consumer types. melwitt, care to comment?
21:14:51 <efried> cool
21:15:00 <efried> API (gmann)
21:15:00 <efried> This week updates: http://lists.openstack.org/pipermail/openstack-discuss/2020-January/012260.html
21:15:04 <efried> comments, questions, concerns?
21:15:12 <gmann> o/
21:15:22 <gmann> forgot about meeting
21:15:39 <gmann> sent the summary on that ML for this week.
21:15:40 * melwitt needs to review policy scope patches 😬
21:15:56 <gmann> melwitt: thanks in advance :)
21:16:10 <efried> #topic Stuck Reviews
21:16:14 <efried> Nothing on the agenda. Anyone?
21:16:35 <efried> #topic Open discussion
21:16:45 <efried> There's an item here, but I think it's from a couple weeks ago...
21:16:50 <efried> Need discussion on https://review.opendev.org/#/c/694462/8/nova/db/sqlalchemy/api.py@2008, to finalize the approach (shilpasd)
21:17:07 <efried> This has reviews pretty recently, looked to me like it was waiting for alex_xu to answer a question.
21:17:25 <efried> They're on extended CNY break, so I wouldn't call this stuck just yet.
21:17:39 <efried> I have a topic.
21:18:29 <efried> Intel is doing a "workforce reduction" including their whole OpenStack mission. At least three nova players and at least one other stacker are affected, including myself.
21:18:57 <efried> This may affect the feasibility/prioritization of some blueprints.
21:19:37 <efried> Also, while I'm pursuing opporntinities that would allow me to continue as PTL and/or core, it wouldn't be a terrible idea for others to start considering the contingency that a new PTL will be needed mid cycle.
21:20:26 <efried> Sorry, I should clarify: "...whole *US* OpenStack mission." As of now, I have reason to believe the PRC side will survive.
21:20:29 <sean-k-mooney> there is precendent for PTLs to change but hopefully it wont come to that
21:21:20 <efried> Any questions on that?
21:21:33 <efried> Any other open topics?
21:22:24 <efried> alrightythen
21:22:24 <efried> o/
21:22:24 <efried> #endmeeting