16:00:09 <gibi> #startmeeting nova
16:00:10 <openstack> Meeting started Thu Mar 12 16:00:09 2020 UTC and is due to finish in 60 minutes. The chair is gibi. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:13 <openstack> The meeting name has been set to 'nova'
16:00:30 <gibi> o/
16:00:52 <bauzas> \o
16:01:00 <bauzas> (while on another team meeting)
16:01:25 <artom> Yeah, I failed to see this time change coming, so almost all of RH is on our internal team call as well
16:01:47 <gmann> o/
16:01:48 <gibi> #topic new meeting time
16:02:02 <gibi> artom: sorry to hear that. Can we do someting about it?
16:02:11 <gibi> artom: is it a permanently booked slot for RH?
16:03:10 <bauzas> gibi: artom: let's discuss this off this meeting
16:03:18 <gibi> bauzas: ack
16:03:31 <gibi> then lets get started
16:03:36 <gibi> #topic Last meeting
16:03:47 <gibi> Minutes from last meeting: http://eavesdrop.openstack.org/meetings/nova/2020/nova.2020-03-05-14.00.html
16:04:22 <gibi> You might noticed that since the last meeting I took over the PTL role from Eric
16:04:49 <gibi> I hope we can have a proper PTL election in April
16:04:58 <gibi> but until that you stuck with me
16:05:27 <gibi> Any other business we need to take up from the last meeting?
16:05:40 <johnthetubaguy> gibi: thank you for doing that :)
16:06:15 <lyarwood> \o
16:06:19 <gibi> lyarwood: o/
16:06:28 <lyarwood> joined the wrong channel sorry
16:06:28 <gibi> #topic Bugs (stuck/critical)
16:06:42 <gibi> we dont have critical bugs
16:06:55 <gmann> lyarwood: :) i was also looking into different one
16:06:56 <gibi> but we have an ever growing untriaged bug list
16:07:10 <gibi> #link 111 new untriaged bugs (+3 since the last meeting): https://bugs.launchpad.net/nova/+bugs?search=Search&field.status=New
16:07:33 <lyarwood> http://status.openstack.org/elastic-recheck/#1844929 & http://status.openstack.org/elastic-recheck/#1813789 keep coming up in my reviews btw
16:07:35 <gibi> do you have any idea how to tackle it?
16:07:38 <gmann> gibi: from you ML, idea is to rotate or single bug tracker or somthing
16:07:48 <gibi> gmann: yepp #link http://lists.openstack.org/pipermail/openstack-discuss/2020-March/013157.html
16:08:36 <gibi> I think rotation only works if there is enough people subscribing to it that it is not frequent for a single dev
16:08:48 <gmann> I can start on this but I would not be able to triage all area bugs and ping interested people for those to triage/discuss?
16:09:16 <gibi> gmann: trigaing some of the bug already helps
16:09:39 <gibi> gmann: and it is totally OK to involve others
16:09:39 <gmann> i mean if 'ping interested people for bugs which i cannot triage to triage/discuss? ' ok? or expectation is to triage all :)
16:09:44 <gmann> ok
16:09:56 <gibi> gmann: triage what you can. thanks!
16:09:59 <gmann> I will start from next week then.
16:10:07 <gmann> let's see how much help i can do
16:11:16 <gibi> if other are not subscribing it will be painful. I will try to dedicate my Thrusday morning for bugs
16:11:42 <gibi> anyhow moving on to lyarwood's issue
16:12:10 <johnthetubaguy> gmann: we used to add tags to unknown stuff, then ping experts in that area, but adding the tag is a step forward from being untouched
16:12:39 <gmann> johnthetubaguy: ok. that is nice.
16:12:52 <gibi> lyarwood: do you have a way forward with those failing tests or you need help?
16:12:56 <gmann> i remember the expert list area wise on wiki now
16:13:14 <lyarwood> gibi: I don't have a way forward, some ironic folks were also pinging in the channel about these earlier
16:13:20 <lyarwood> gibi: raising here for awareness
16:13:31 <lyarwood> gibi: I'll try to look again at the posted changes over the next week
16:14:57 <gibi> lyarwood: if nothing happens then please raise it again next week and I will try to dedicate some time
16:15:06 <lyarwood> ack will do thanks
16:15:22 <gibi> lyarwood: thanks for raising
16:15:33 <gibi> any other bugs that need discussion?
16:17:05 <gibi> #topic Release Planning
16:17:27 <gibi> Started Ussuri cycle highlight doc. So far I only added things that has already been merged.
16:17:33 <gibi> #link https://review.opendev.org/#/c/712498/
16:18:13 <gibi> anything about releases?
16:18:57 <gibi> #topic stable branches
16:19:09 <gibi> rocky is in extended maintenance mode. thanks lyarwood
16:19:20 <gibi> lyarwood: any newsworthy thing from stable?
16:19:37 <lyarwood> I was going to post to the ML about stable/pike and the LM job failing
16:19:43 <lyarwood> but nothing other than that
16:19:53 <lyarwood> I was going to suggest we make the stable/pike LM job NV btw
16:20:16 <gibi> lyarwood: thanks
16:20:17 <lyarwood> it's EM, I don't have any drive to fix it so unless others do I think it needs to be NV
16:20:22 <lyarwood> np
16:20:50 <gibi> my employer has some commitment towards pike so I will try to look at that and pull in elod as much as I can
16:20:52 <gmann> +1
16:21:11 <gibi> but end of the they I'm not against dropping LM job if we cannot fix it
16:21:32 <gibi> s/dropping/making non voting/
16:21:46 <lyarwood> ack understood
16:22:25 <gibi> #topic PTG/Summit planning
16:22:34 <gibi> #link PTG etherpad https://etherpad.openstack.org/p/nova-victoria-ptg
16:23:17 <gibi> I got the news that I cannot travel to Vancouver and I feel the fundation is also close to cancel the event
16:23:22 <gibi> so
16:23:29 <gibi> What are your feelings about the possibility of a virtual PTG?
16:23:51 <johnthetubaguy> very positive, from where I am sat, kolla have had some success
16:24:00 <gmann> i think that is good idea. even PTG happen and end up with small number of people
16:24:24 <johnthetubaguy> our numbers were too big before, but now I guess it seems like it might be manageable?
16:24:25 <gmann> yeah, and there is no harm in giving try.
16:24:25 <lyarwood> yup same, a time limited (~4 hour slot per day) virtual PTG would be a great way to go given the situation
16:24:41 <johnthetubaguy> of course, its going to suck for some people being up a silly o'clock
16:24:43 <gibi> I cannot really commit to a full video experience due to timezone issues.
16:25:12 <lyarwood> a movable 4 hour slot might make that easier but yeah it's always going to awkward with timezones
16:25:22 <sean-k-mooney> i have had some good experice with remote attending midcycles
16:25:27 <johnthetubaguy> its not quite as intrusive as several days away though
16:25:37 <gibi> I imagine topic are pre-discussed via ML and if a topic needs some face time then the involved people fined a timeslot
16:25:41 <sean-k-mooney> but im not sure how it would work for a full ptg were all are remote
16:25:48 <sean-k-mooney> i think its worth considering however
16:25:57 <bauzas> I provided my opinions
16:26:09 <johnthetubaguy> kolla have done it, it didn't seem too bad with full remote
16:26:10 <sean-k-mooney> there is a fondation wide converstaion too
16:26:24 <sean-k-mooney> so if the ptg is cancled we will have a different choice
16:26:29 <johnthetubaguy> the problem is tooling that doesn't exclude, etc, etc
16:26:33 <sean-k-mooney> either do no ptg or a virutal one
16:26:50 <gibi> bauzas: I just saw your mail
16:26:53 <bauzas> fwiw, I'm bit afraid of having a virtual PTG that would be a video meeting within say, US TZ
16:27:05 <johnthetubaguy> gibi: +1 of careful topic picks and time votes
16:27:07 <bauzas> I did this for a midcycle
16:27:08 <gmann> sean-k-mooney: but virtual one will be project own arrangement or foundation can do.
16:27:30 <sean-k-mooney> gmann: that is not clear currnetly
16:27:31 <gmann> i did see foundation can do in ML but may be once we decide no PTG
16:27:34 <gmann> yeah
16:27:42 <sean-k-mooney> gmann: if the fondation cancels the physical ptg
16:27:42 <bauzas> and I had issues with
16:27:51 <sean-k-mooney> then they may be able to help arrage a virtual one
16:28:03 <gmann> i have canceled QA one due to attendance but not thought of virtual one yet
16:29:01 <sean-k-mooney> people might want to follow http://lists.openstack.org/pipermail/openstack-discuss/2020-March/013127.html
16:29:02 <gibi> I think we can start the whole thing on the ML like a pre-ptg so everybody will have a way get involved
16:29:17 <gibi> sean-k-mooney: thanks
16:29:49 <sean-k-mooney> the pre-ptg emails is something we can do in either case
16:29:53 <gmann> +1
16:29:55 <gibi> sean-k-mooney: yeah
16:29:56 <sean-k-mooney> i find them hard to follow
16:30:08 <gibi> sean-k-mooney: me too but it is better than nothing
16:30:08 <sean-k-mooney> but i know other like it
16:30:13 <sean-k-mooney> ya
16:30:38 <gibi> sean-k-mooney: or we can just ping people to start discussing things on the etherpad
16:31:24 <gibi> anyhow we have still plenty of weeks to figure it out. but it is good that start the thinking
16:31:34 <gibi> I will summarize this back to the ML thread
16:31:37 <johnthetubaguy> I like the idea of a spec with disagreement being a good start to a video conversation, but yeah, another time
16:31:50 <gibi> johnthetubaguy: sure, that is a good indication
16:32:07 <johnthetubaguy> it means you did the pre work :)
16:32:09 <gibi> #action gibi to make a virtual ptg proposal to the ML thread with more detals
16:32:47 <gibi> #topic Sub/related team Highlights
16:32:54 <gibi> Placement (tetsuro)
16:33:11 <gibi> I saw melwitt and tetsuro working on the consumer_types series
16:33:22 <gibi> but I think that is basically all
16:34:01 <gibi> API (gmann)
16:34:10 <gmann> I did not send the updates on ML. API BPs are going with normal review and policy refresh: many of the patches are merged. I will continue on those
16:34:39 <gmann> there is nothing else from my side this week. may be johnthetubaguy can add something if he has any
16:34:44 <johnthetubaguy> gmann: policy refresh is exciting, been needing this for years :)
16:35:12 <gmann> yeah, I will burn more policy before cmg Monday
16:35:16 <johnthetubaguy> nothing more from me
16:35:18 <gibi> I'm happy to see that it is moving forward
16:35:25 <gibi> thanks
16:35:37 <gibi> #topic Stuck Reviews
16:35:47 <gibi> nothing on the agenda
16:36:11 <gibi> anything to add now?
16:36:55 <lyarwood> a quick one from me, not sure if this is the right section
16:36:59 <gibi> #topic Open discussion
16:37:07 <gibi> lyarwood: go
16:37:26 <lyarwood> https://review.opendev.org/#/q/status:open+topic:workaround_native_luksv1 - I'm trying to land some workaround options, I'm not sure if these need a bug or specless BP at the moment
16:38:07 <lyarwood> gibi: regardless I was going to ask for reviews shortly anyway but wanted to first workaround how to track this
16:38:17 <lyarwood> gibi: if a spec is required I'll punt to V
16:39:06 <gibi> lyarwood: I saw workaround flags appearing in bugfixs before
16:39:27 <gibi> like https://review.opendev.org/#/c/618478/
16:39:42 <lyarwood> gibi: ack I can write up a bug for this ten
16:39:44 <lyarwood> then*
16:40:05 <gibi> ack, bug works for me
16:40:05 <lyarwood> gibi: thanks
16:40:29 <gibi> and as I already promissed I will look at the fixes as it needs a non RH core
16:40:47 <lyarwood> https://review.opendev.org/#/q/status:open+branch:master+topic:bp/virt-bfv-instance-rescue - is also ready for non-RH core review FWIW
16:41:29 <gibi> lyarwood: noted :)
16:41:50 <lyarwood> many many thanks gibi, I hate begging for reviews but I guess needs must at the moment :)
16:42:06 <gibi> non RH core situation is not pretty so I understand
16:43:00 <gibi> anything else to discuss?
16:43:46 <gibi> going once
16:44:31 <gibi> going twice
16:44:44 <gibi> thank you all. see you around
16:44:56 <gmann> thanks gibi for chair
16:45:02 <gibi> #endmeeting