16:00:02 <bauzas> #startmeeting nova
16:00:02 <opendevmeet> Meeting started Tue Oct 26 16:00:02 2021 UTC and is due to finish in 60 minutes.  The chair is bauzas. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:02 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:02 <opendevmeet> The meeting name has been set to 'nova'
16:00:15 <gibi> o/
16:00:19 <bauzas> #link https://wiki.openstack.org/wiki/Meetings/Nova#Agenda_for_next_meeting
16:00:35 <bauzas> hola everyone, nice to see your virtual faces ;)
16:00:54 * bauzas wonders how many of us are jetlagged
16:01:26 <elodilles> o/
16:02:08 <bauzas> wow, not everyone at the same time :)
16:03:15 <gibi> maybe the rest of us had enough last week D:
16:03:30 <bauzas> :)
16:03:36 <bauzas> ok, then let's start :)
16:04:01 <bauzas> hopefully, it would be a small meeting :)
16:04:08 <bauzas> #topic Bugs (stuck/critical)
16:04:12 <bauzas> One Critical bug
16:04:20 <bauzas> https://bugs.launchpad.net/nova/+bug/1947687
16:04:33 * bauzas doesn't really know why he triaged it as Critical
16:04:41 <gibi> it is a gate bug
16:04:50 <gibi> but it does not hit us in every run
16:04:51 <bauzas> maybe because it was a gate bug, yes
16:04:58 <gibi> I agree to decrease this to High
16:05:03 <bauzas> yeah
16:05:07 <gibi> I have not seen it recently
16:05:16 <bauzas> ok done
16:05:31 <bauzas> gibi: maybe we could see whether logstash still works for this one
16:05:49 <gibi> bauzas: yeas a signture would be nice
16:06:07 <bauzas> gibi: can you test this and provide the logstash link ?
16:06:10 <gibi> sure
16:06:15 * gibi took a note
16:06:16 <bauzas> thanks++
16:06:35 <bauzas> okay, moved to High
16:06:42 <bauzas> anything to discuss about it now ?
16:06:52 <gibi> -
16:06:56 <bauzas> k
16:07:01 <bauzas> #link 24 new untriaged bugs (+6 since the last meeting): #link https://bugs.launchpad.net/nova/+bugs?search=Search&field.status=New
16:07:10 <bauzas> I triaged 6 or 7
16:07:25 <bauzas> (already, I mean)
16:07:35 <bauzas> I'll continue to triage a few of them tomorrow
16:08:00 <bauzas> but in case some contributors want to triage too, I'd be happy
16:08:11 <bauzas> for the moment, that's fine
16:08:17 <gibi> yeah I feel the pressure but still have other pressors
16:08:29 <bauzas> yeah, no urgency
16:08:46 <bauzas> gibi: I wasn't thinking about you
16:08:57 <gibi> I know
16:09:04 <gibi> still I feel responsible :)
16:09:13 <bauzas> but in case some contributors want to be better knowing about Nova, they can do this
16:09:22 <bauzas> anyway
16:09:27 <bauzas> moving now
16:09:34 <bauzas> 32 open stories in Storyboard for Placement # link https://storyboard.openstack.org/#!/project/openstack/placement
16:09:38 <bauzas> ^ this is new
16:09:41 <gibi> ohh a new one
16:09:42 <gibi> :)
16:09:51 <bauzas> as we agreed on the PTG to verify them
16:10:07 <bauzas> next week, I'll tell how many new stories we have
16:10:31 <bauzas> that said, with SB, I don't know whether it's a feature request or a bug
16:10:47 <gibi> we can start tagging them
16:10:52 <gibi> to differentiate
16:10:58 <bauzas> yeah... or moving to LP :p
16:11:14 <gibi> tagging is easier :D
16:11:23 <bauzas> I said I'll look at some script
16:11:32 <bauzas> let's not discuss this one now
16:11:39 <bauzas> as we don't have a lot of folks
16:11:54 <bauzas> but, yeah, maybe next week, we'll see what folks prefer
16:12:00 <gibi> sire
16:12:01 <gibi> sure
16:12:08 <bauzas> #topic Gate status
16:12:13 <bauzas> Nova gate bugs #link https://bugs.launchpad.net/nova/+bugs?field.tag=gate-failure
16:12:20 <bauzas> we already discussed one
16:12:28 <bauzas> nothing new, AFAIK
16:12:39 <bauzas> we fixed one during the PTG IIRC
16:13:05 <bauzas> Placement periodic job status #link https://zuul.openstack.org/builds?project=openstack%2Fplacement&pipeline=periodic-weekly
16:13:19 <bauzas> this goes well this time ^
16:13:29 <gibi> I have two gate fixers
16:13:35 <bauzas> the placement-nova-tox-functional-py38 job now works
16:13:52 <bauzas> gibi: loved
16:13:55 <gibi> 1) https://review.opendev.org/c/openstack/nova/+/814036
16:14:07 <gibi> this is ready to land
16:14:11 <gibi> 2) https://review.opendev.org/c/openstack/nova/+/814735
16:14:31 <gibi> this I will respin to add better commit message based on melwitt's findings and probably a poison to avoid breaking this again
16:14:39 <bauzas> oh thanks for both
16:14:46 <bauzas> I'll review them tomorrow morning
16:14:47 <gibi> melwitt: btw, thanks you helped a lot understanding what is happening
16:14:51 * kashyap waves hi, while distracted and hungry
16:15:00 * gibi waves back
16:15:01 <kashyap> Err, wrong channel
16:15:05 <kashyap> But the hi still stands :)
16:15:14 * gibi rolls back the waves
16:15:37 <kashyap> Haha, no
16:16:01 <gibi> :)
16:16:07 <bauzas> kashyap: you're still in the nova channel :p
16:16:17 <bauzas> welcome on the nova meeting :p
16:16:20 <gibi> and of course you are welcome here :)
16:16:31 <bauzas> moving fast
16:16:31 <kashyap> bauzas: Yeah, I had the scrollback a bit up at the bug triage part
16:16:41 <bauzas> #topic PTG summary
16:16:54 <bauzas> I wrote a summary and gibi nitpicked it :p
16:16:55 <bauzas> #link http://lists.openstack.org/pipermail/openstack-discuss/2021-October/025534.html
16:17:10 <gibi> bauzas: thanks for the summary and sorry for nitpicking :D
16:17:20 <bauzas> at least I know that people read my summary :p
16:17:21 <gibi> at least you know that somebody read it :D
16:17:25 <bauzas> that, yeah
16:17:27 <gibi> :D
16:17:50 <bauzas> I could have made jokes in the summary to keep people continuing to read it
16:18:07 <bauzas> nothing here to tell about the PTG besides the summary ?
16:18:34 <kashyap> I have a small "info" for the open topics
16:18:51 <gibi> bauzas: nothing from me for the PTG
16:18:52 <bauzas> my only concern about the agreements we made is that we don't have a lot of owners for ACTION items
16:19:09 <gibi> yeah, I think you should try to ask for owners
16:19:15 <gibi> maybe a reply to the mail
16:19:27 <bauzas> next PTG, we should try to ensure that when we set an agreement, we have an ACTION item and an owner
16:19:30 <gibi> I will talk to brinzhang about the OWNER things but he seems to be off
16:20:00 <gibi> I hope he can take the nova side of that too, but if not then I will write the spec
16:20:01 <bauzas> gibi: good call, I could ask by email but I wouldn't be surprised if nobody steps up :)
16:20:20 <gibi> I mean the OWNER trait thingy :D
16:20:38 <gibi> I won't be the owner of everything :D
16:20:45 <bauzas> gibi: or the OWNED_BY you rather mean ?
16:20:54 <bauzas> heh, see how an adjective is better :p
16:20:55 <gibi> :D
16:21:08 <bauzas> no confusion at all
16:21:14 <bauzas> anyway, was kidding
16:21:18 <gibi> sure :D
16:21:21 <bauzas> don't wanna talk about the sky color
16:21:28 <bauzas> #topic Release Planning
16:21:35 <bauzas> just a reminder
16:21:35 <bauzas> Yoga-1 is due Nova 18th #link https://releases.openstack.org/yoga/schedule.html#y-1
16:21:56 <gibi> just 3 weeks
16:22:02 <gibi> sh*t
16:22:05 <bauzas> kashyap: I haven't forgotten you, will ping you when we're at open discussion topic
16:22:11 <bauzas> gibi: YUUUUP
16:22:30 * gibi tries to remember where he put the cloning machine
16:22:31 <sean-k-mooney> time flys
16:22:55 <bauzas> and /me needs to propose Nov 16th for spec review day at the next meeting
16:23:18 <bauzas> gibi: I tried using the cloning machine, buy my clones don't wanna work on IT
16:23:33 <bauzas> this is sad
16:23:37 <bauzas> let's move one
16:23:41 <bauzas> on* even
16:23:45 <bauzas> #topic Review priorities
16:23:52 <bauzas> #link  https://review.opendev.org/q/status:open+(project:openstack/nova+OR+project:openstack/placement)+label:Review-Priority%252B1
16:24:00 <bauzas> I know we agreed on changing a few things
16:24:05 <gibi> I've reviewed some and marked some
16:24:12 <bauzas> I'll work on a doc change this week if I have time
16:24:31 <bauzas> gibi: I need to jump on my owns sooner than later
16:24:51 <gibi> bauzas: this has momentum now https://review.opendev.org/c/openstack/nova/+/815373 so I suggest to start with that
16:25:04 <bauzas> sean-k-mooney: once I'm done with proposing the doc change, feel free to write a dependent patch for the ACL thingies
16:25:22 <gibi> sorry wrong link
16:25:26 <bauzas> hah
16:25:34 <bauzas> was wondering why you were proposing this one
16:25:37 <gibi> the other mdev https://review.opendev.org/c/openstack/nova/+/810220
16:25:47 <gibi> I think there are issues to discuss there ^^
16:26:00 <gibi> I will check the mdev + resume soon too
16:26:06 <bauzas> ki
16:26:07 <bauzas> bk
16:26:21 <bauzas> gibi: yeah, I was thinking about it when reviewing
16:26:21 <sean-k-mooney> bauzas: sure we did it the otherway around the last time i kind of feel like gating the docs change on the porject config one is more correct but it really dose not matter
16:26:36 <bauzas> gibi: we need to test it with devstack
16:26:49 <bauzas> I'm not sure all the services are up and the RT running
16:26:55 <bauzas> when we call the methods
16:27:11 <bauzas> but this needs me looking at the code first before I reply
16:27:19 <sean-k-mooney> bauzas: the only way to test the mdev stuff in devstack is if we can use the fake mdev kernel modules
16:27:29 <gibi> bauzas: no before driver.init_host we should not call other driver methods and defintely there is no RT populated as we dont know about our nodes from the hypervisor
16:27:29 <sean-k-mooney> unless you mean just manually and not in ci
16:27:30 <bauzas> sean-k-mooney: or use my own env... :)
16:27:52 <bauzas> well, provided I'm able to create a devstack env
16:28:00 <bauzas> which I failed with rhel 8.2
16:28:05 <bauzas> but meh
16:28:21 <bauzas> #topic Stable Branches
16:28:23 <sean-k-mooney> bauzas: now that we have generic mdev support it might want to see if we can support the dummy kernel moduels at some point
16:28:30 <bauzas> elodilles: floor is yours
16:28:38 <elodilles> from xena till train the gates are not blocked
16:28:40 <kashyap> bauzas: On a phone call :-( Will come back here; it's not super urgent
16:28:42 <bauzas> sean-k-mooney: agreed
16:28:48 <kashyap> bauzas: In short, it's this one: http://lists.openstack.org/pipermail/openstack-discuss/2021-October/025500.html
16:28:49 <elodilles> stein and older stable branches are blocked, needs the setuptools pinning patch to unblock: https://review.opendev.org/q/I26b2a14e0b91c0ab77299c3e4fbed5f7916fe8cf
16:28:56 <kashyap> And it's resolved now.
16:29:12 <elodilles> Ussuri Extended Maintenance transition is in two weeks (Nov 12)
16:29:22 <kashyap> (The resolution: http://lists.openstack.org/pipermail/openstack-discuss/2021-October/025527.html)
16:29:29 <elodilles> we might not need another release on ussuri before the transition, as there are not that many patch merged since the last release from early October
16:29:52 <elodilles> (the list of open and unreleased patches anyway: https://etherpad.opendev.org/p/nova-stable-ussuri-em )
16:30:02 <elodilles> that's it ^^^
16:30:05 <gibi> elodilles: when you say not many, you mean zero bugfix?
16:30:07 <bauzas> elodilles: if you feel we need to do some reviewing efforts before EM, let me know
16:30:26 <elodilles> gibi: i mean 1 or 2 bugfix :)
16:30:29 <sean-k-mooney> elodilles: ack i might try to rebase and  submit the libvirt os-vif deleagtion patchs
16:30:51 <sean-k-mooney> before ussuri em if there is another release
16:30:56 <gibi> elodilles: hm if there are real fixes there then I might make sense to release them before we EM
16:31:11 <gibi> s/I/it/
16:31:19 <bauzas> agreed with gibi
16:31:25 <elodilles> yes, it makes sense to release,
16:31:55 <elodilles> though we shouldn't hurry with merging things if we are not sure that it won't cause any regression
16:32:05 <elodilles> as this will be the *final* release
16:32:39 <bauzas> elodilles: I'm a bit busy tomorrow as I promised many things but I'd appreciate if you could chase me and a couple of other cores about reviews either Thursday or next week
16:33:11 <elodilles> bauzas: sure,
16:33:28 <elodilles> there are some bug fixes that needs a 2nd +2
16:34:01 <elodilles> but if anyone see any other bugfix that would be good to merge, then let us know
16:34:14 <bauzas> cool
16:34:52 <bauzas> #topic Sub/related team Highlights
16:35:01 <bauzas> lyarwood is still on PTO
16:35:23 <bauzas> so I'll skip this part and I don't think we need to discuss about libvirt by now
16:35:30 <bauzas> #topic Open discussion
16:35:36 <bauzas> #agreed Reminder : The Asian-friendly meeting is now cancelled due to lack of presence.
16:35:56 <bauzas> so we won't run a meeting on Nov 4th
16:36:05 <bauzas> I'll send an email accordingly
16:36:57 <bauzas> just a personal note, I'll be on company PTO on Friday 29th and Nov 1st is bank holiday in France
16:37:15 <bauzas> so don't expect me between Thursday EOB and Tuesday
16:37:54 <bauzas> we have one item that was written in the wiki
16:38:01 <bauzas> add Support volumes backed by VStorageObject -> https://blueprints.launchpad.net/nova/+spec/vmware-fcd and https://review.opendev.org/c/openstack/nova/+/808791
16:38:37 <sean-k-mooney> yes so as far as i can tell i think they implemented the feature in cinder and likely the out of tree driver
16:38:39 <bauzas> not sure the proposer is around
16:38:49 <sean-k-mooney> now they are looking to add support in the intree one
16:38:53 <bauzas> I don't know his IRC nick
16:39:04 <bauzas> so I can't ping him
16:39:49 <gibi> looking at the patch the change is confined in the vmware driver
16:39:57 <sean-k-mooney> ya so i reviewed this and to me this si a feature not a bug so i assed them to raise this in this meeting
16:40:10 <gibi> so I think it is OK as a specless bp
16:40:13 <sean-k-mooney> im infavor of just proceeding with this as a speckless bp
16:40:52 <bauzas> OK, we don't have a lof of people around
16:40:58 <sean-k-mooney> its not a bug so it should not be backported but as i mentioned above i stonly suspect this was implemente din the out of tree driver and they are just closing the gap
16:40:59 <bauzas> but we can make it a specless BP
16:41:06 <bauzas> do people agree ?
16:41:48 <sean-k-mooney> yep
16:41:54 <bauzas> #agreed https://blueprints.launchpad.net/nova/+spec/vmware-fcd approved as a specless blueprint
16:41:54 <gibi> yep
16:42:01 <sean-k-mooney> the cinder feature was completed 4 years ago by the way https://review.opendev.org/c/openstack/cinder/+/521213/
16:42:32 <bauzas> (/me can't remember how to formally approve BPs in Launchpad but that's something I'll sort out after this meeting)
16:42:53 <sean-k-mooney> that one already is
16:42:58 <bauzas> I just did
16:43:04 <sean-k-mooney> ah
16:43:08 <bauzas> direction and definitions are now approved
16:43:24 <bauzas> but nevermind, will figure it out or will hassle gibi
16:43:25 <sean-k-mooney> you likely shoudl set the serise goal to yoga too
16:43:41 <gibi> bauzas: set approver, series goal, and maybe milestone target
16:43:55 <gibi> bauzas: you can also set implementation status as we have a patch already
16:44:09 <sean-k-mooney> right it should be in need_review
16:44:57 <bauzas> ok, done
16:45:00 <bauzas> anyway
16:45:23 <bauzas> kashyap: are you done chatting ? you said you had a thing to discuss
16:45:49 <kashyap> bauzas: Yes, here
16:45:51 <bauzas> #link http://lists.openstack.org/pipermail/openstack-discuss/2021-October/025500.html
16:45:54 <kashyap> bauzas: Sorry for "talking over" earlier
16:46:08 <bauzas> is this^ more a FYI ?
16:46:12 <kashyap> Yep
16:46:26 <kashyap> bauzas: In short: DevStack now defults to "Nehalem" CPU model for reasons outlined there.
16:46:43 <bauzas> kashyap: devstack/rhel you mean ?
16:46:47 <kashyap> No
16:46:50 <kashyap> DevStack upstream
16:47:06 <kashyap> I worked w/ Clark to get the patch merged in DevStack
16:47:20 <bauzas> I mean, devstack all distros or only upstream devstack with rhel ?
16:47:40 <kashyap> For all.
16:47:44 <bauzas> ack
16:47:54 <sean-k-mooney> for all on x86
16:47:57 <kashyap> Everything is summarized and resolved in that thread.
16:48:23 <kashyap> Yes, x86 is "implied architecture", when we don't name an arch :)
16:48:47 <bauzas> okay, do we need further actions, like documenting it ?
16:48:55 <bauzas> in our relnotes or in the install docs ?
16:49:07 <sean-k-mooney> no we dont need to document anythign in nova
16:49:15 <kashyap> Yep; nothing needs documentation in Nova
16:49:27 <bauzas> my confusion comes from the fact we changed default for all distros, not only rhel
16:49:27 <sean-k-mooney> rhel have documented there new compilation target already in a blog
16:49:37 <kashyap> bauzas: No further action; just an FYI here ... if anyone in case notices "why is DevStack giving me Nehalem by default"
16:49:48 <kashyap> Yep; linked to in the post to the upstream list
16:50:05 <bauzas> kashyap: little chances that people notice this change by looking at our meeting minutes, honestly
16:50:24 <bauzas> but okay, noted.
16:50:31 <kashyap> bauzas: I've notified the Whitebox / CI folks to change their scripts too
16:50:45 <kashyap> So, the right parties are notified.  I'm not expecting anyone to read these minutes here :)
16:50:54 <sean-k-mooney> bauzas: well honestly its a better default then qemu64 and its so old at this poitn everythign supprots it
16:51:02 <sean-k-mooney> bauzas: which is basicaly why it was done for all
16:51:30 <kashyap> bauzas: The change is a better default too.  Yes.  (Besides solving the switch to a new x86 baseline)
16:51:33 <sean-k-mooney> the jobs also might get slictly faster as a restult but that would just be a nice benift and not the intent
16:51:48 <kashyap> Yep; there will be slight improvement
16:52:15 <bauzas> OK, nice to hear
16:52:22 <bauzas> are we done ?
16:52:26 <kashyap> bauzas: That's all.  I don't want to take up more time.  But those interested / affected in CI/QE/Infra are notified, and I'm working w/ them.
16:52:31 <kashyap> Yep.
16:52:40 <bauzas> kashyap: excellent, thanks for providing guidance
16:52:54 <gibi> kashyap++
16:53:08 <bauzas> I think we can reasonably call this meeting a wrap
16:53:23 * gibi agrees
16:53:24 <bauzas> I was expecting it to be shorter, but meh, good talks
16:53:33 <bauzas> #endmeeting