16:00:00 <bauzas> #startmeeting nova
16:00:00 <opendevmeet> Meeting started Tue Nov 30 16:00:00 2021 UTC and is due to finish in 60 minutes.  The chair is bauzas. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:00 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:00 <opendevmeet> The meeting name has been set to 'nova'
16:00:12 <bauzas> #link https://wiki.openstack.org/wiki/Meetings/Nova#Agenda_for_next_meeting
16:00:19 <bauzas> good 'day, 'vyone
16:00:23 <gibi> \o
16:00:50 <ganso> o/
16:00:53 <elodilles> o/
16:01:37 <bauzas> okay, let's statry
16:02:13 * bauzas shouldn't wear mittens when typing
16:02:29 <bauzas> #topic Bugs (stuck/critical)
16:02:35 <bauzas> #info No Critical bug
16:02:40 <bauzas> #link https://bugs.launchpad.net/nova/+bugs?search=Search&field.status=New 23 new untriaged bugs (-6 since the last meeting)
16:02:53 <bauzas> thanks to all who helped
16:03:00 <bauzas> #help Nova bug triage help is appreciated https://wiki.openstack.org/wiki/Nova/BugTriage
16:03:33 <bauzas> #link https://storyboard.openstack.org/#!/project/openstack/placement 25 open stories (-8 since the last meeting) in Storyboard for Placement
16:03:37 <bauzas> ditto ^
16:03:47 <bauzas> impressive number
16:04:08 <bauzas> I know the names :p
16:04:27 <dansmith> o/
16:04:30 <bauzas> any particular bug to discuss before we move to the next topic ?
16:05:13 <bauzas> I guess no
16:05:20 <bauzas> #topic Gate status
16:05:27 <bauzas> #link https://bugs.launchpad.net/nova/+bugs?field.tag=gate-failure Nova gate bugs
16:05:43 <bauzas> no new gate bug I can see
16:05:51 <bauzas> #link https://zuul.openstack.org/builds?project=openstack%2Fplacement&pipeline=periodic-weekly Placement periodic job status
16:06:08 <bauzas> the issue we discussed last week is fixed ^
16:06:27 <bauzas> #info Please look at the gate failures, file a bug, and add an  elastic-recheck signature in the opendev/elastic-recheck repo (example: https://review.opendev.org/#/c/759967)
16:06:55 <bauzas> fwiw, I haven't see any specific issue with our gate
16:07:06 <gibi> bauzas: the issue is not fixed it just did not appear in the recent runs
16:07:21 <bauzas> ah right, it was a race
16:07:23 <gibi> I don't know about any active effor on our side making that fixed
16:07:32 <gibi> it was about the pmlogger service
16:07:39 <bauzas> right
16:08:18 <bauzas> ok, nothing else to tell ?
16:08:50 <bauzas> #topic Release Planning
16:09:03 <bauzas> #info Yoga-2 is due Jan 6th#link https://releases.openstack.org/yoga/schedule.html#y-2
16:09:05 <bauzas> #undo
16:09:05 <opendevmeet> Removing item from minutes: #info Yoga-2 is due Jan 6th#link https://releases.openstack.org/yoga/schedule.html#y-2
16:09:19 <bauzas> #info Yoga-2 is due Jan 6th
16:09:21 <bauzas> #link https://releases.openstack.org/yoga/schedule.html#y-2
16:09:37 <bauzas> #info Next spec review day to be planned for mid-Dec
16:09:41 <bauzas> so,
16:10:08 <bauzas> what do you think about Dec 14th for a new spec review day ?
16:10:21 <bauzas> the next week, I'll be off
16:10:23 <sean-k-mooney> +1 for 14th
16:10:44 <gibi> 14th works for me
16:10:49 <bauzas> we have a few open specs
16:10:58 <gibi> I'm off from the 20th
16:11:11 <bauzas> gibi: maybe like me
16:11:32 <bauzas> maybe I'll work on the Dec 22th day
16:11:38 <bauzas> but...
16:11:57 <bauzas> I'm not sure we would have quorum
16:12:09 <bauzas> ok, any other thought?
16:13:03 <bauzas> #agreed Next spec review day will be Tuesday Dec 14th
16:13:08 <gibi> I will not be around in the week of Yoga-2
16:13:19 <bauzas> I'll provide a new ML email
16:13:20 <gibi> I will be back on the 10th of Jan
16:13:32 <bauzas> gibi: oh, you're now living in France ?
16:13:37 <bauzas> :p
16:14:00 <gibi> I've just checked, no :D
16:14:21 <bauzas> anyway, no worries
16:14:37 <bauzas> we will only have the spec deadline for yoga-2
16:15:25 <gibi> I have two placement specs to get approved :)
16:15:31 <bauzas> I've seen them :p
16:15:50 <bauzas> anyway, moving on
16:16:08 <bauzas> #topic Review priorities
16:16:16 <bauzas> #link  https://review.opendev.org/q/status:open+(project:openstack/nova+OR+project:openstack/placement)+label:Review-Priority%252B1
16:16:22 <bauzas> #link https://review.opendev.org/c/openstack/nova/+/816861 bauzas proposing a documentation change for helping contributors to ask for reviews
16:16:32 <bauzas> I'm afraid I didn't had time to modify it
16:16:49 <bauzas> nothing to discuss then for this week
16:17:05 <bauzas> unless people want to have review priorities ?
16:17:46 <bauzas> fwiw, my main priority will be unified limits reviews
16:18:32 <bauzas> OK, next topic
16:18:39 <bauzas> #topic Stable Branches
16:18:48 <bauzas> I'm sitting down, listening to elodilles
16:18:52 <elodilles> #info stable gates are OK
16:19:00 <elodilles> stable/xena has ~3 merged bug fixes, maybe we can wait some more bug fix to land before we do a release
16:19:10 <elodilles> and that's it
16:20:12 <bauzas> I was triaging a bug related to the compute service delete issue, and I saw we hadn't yet merged https://review.opendev.org/c/openstack/nova/+/802847
16:20:55 <bauzas> I'll look at other backports that are fixing bad bugs, and I'll try to review them
16:21:25 <elodilles> thanks in advance \o/
16:22:01 <bauzas> well, no problem
16:22:08 <bauzas> moving on
16:22:16 <bauzas> #topic Sub/related team Highlights
16:22:24 <bauzas> Libvirt :lyarwood ?
16:22:33 <lyarwood> Nothing from me
16:22:36 <bauzas> cool
16:22:43 <bauzas> #topic Open discussion
16:22:48 <bauzas> (gmann) Specless BP approval request for RBAC community-wide goal
16:23:02 <bauzas> #link https://blueprints.launchpad.net/nova/+spec/policy-defaults-refresh-2
16:23:12 <bauzas> gmann: around ?
16:23:51 <dansmith> I am, if you have questions
16:24:09 <bauzas> honestly, I don't think I have any concerns
16:24:32 <dansmith> I've been working on a patch to get servers back to the place where we want it,
16:24:33 <bauzas> maybe one about upgrades and what it means for operators that were modifying the policies
16:24:35 <dansmith> as an example people can work from
16:24:39 <dansmith> and it's very close
16:24:51 <bauzas> but this is just changing the defaults
16:24:54 <dansmith> gmann and johnthetubaguy[m] are mostly happy I think, just working out one more functional thing
16:25:19 <dansmith> bauzas: well, this is pretty much all about defaults anyway,
16:25:34 <dansmith> and nobody could really have rolled to the new ones yet anyway, so not an upgrade concern, IMHO
16:25:46 <dansmith> but the revised plan involves less change when they do upgrade
16:26:31 <bauzas> dansmith: I guess you're referring to https://review.opendev.org/c/openstack/governance/+/815158/20/goals/proposed/consistent-and-secure-rbac.rst as the revised plan ?
16:26:40 <dansmith> yep
16:27:24 <bauzas> ok,
16:27:45 <bauzas> this plan isn't yet sold but whatever it will be, nothing will really change from nova
16:28:02 <dansmith> well, things have to change in nova of course,
16:28:08 <bauzas> so as you said, I don't think there is any upgrade concern then
16:28:29 <bauzas> nothing will really change from a nova perspective if you prefer
16:28:37 <dansmith> but mostly just undoing some of the proposed stuff that hasn't been able to be realized yet.. stepping back from some of that stuff that we merged proactively
16:28:40 <bauzas> things have to change, but upgrades aren't a concern either way
16:29:00 <dansmith> much less of a concern than what they were, but of the stuff we're keeping, no real change, yeah
16:29:24 <dansmith> and keystone will go first which will help our upgrade be even less impactful than it was going to be, if we ever got past the big bubble we had going
16:29:48 <bauzas> to answer the original paperwork question, I think there is no controversy to tell it's a specless BP and we don't to document this as we already have https://review.opendev.org/c/openstack/governance/+/815158/20/goals/proposed/consistent-and-secure-rbac.rst
16:30:02 <bauzas> we don't need* to
16:30:13 <dansmith> ++
16:30:44 <bauzas> that said, of course this work will need some release notes
16:30:54 <dansmith> obviously
16:30:55 <bauzas> to explain the changes to the operators
16:31:00 <bauzas> ok
16:31:04 <bauzas> anyone has other concerns N?
16:31:22 <bauzas> dang, I need to learn typing
16:31:58 <bauzas> (and that's what happens when you have a french keyboard with ? located near n and requiring shift)
16:32:08 <bauzas> anyway
16:32:41 <bauzas> #agreed https://blueprints.launchpad.net/nova/+spec/policy-defaults-refresh-2 accepted as a specless BP as the direction is already explained in https://review.opendev.org/c/openstack/governance/+/815158/
16:32:50 <bauzas> moving on, last topic
16:33:12 <bauzas> (ganso) Raising awareness of vif_multiqueue_enabled in flavor work that is ready to be reviewed/merged
16:33:15 <bauzas> ganso: around ?
16:33:21 <ganso> o/
16:33:34 <bauzas> #link https://blueprints.launchpad.net/nova/+spec/multiqueue-flavor-extra-spec
16:33:49 <ganso> so as the topic titles says: https://review.opendev.org/q/topic:%22bp%252Fmultiqueue-flavor-extra-spec%22+(status:open%20OR%20status:merged)
16:34:14 <ganso> we've discussed 2-3 weeks ago about this and that it could/may be specless, but it was approved to be specless ~6 months ago
16:34:20 <bauzas> ganso: nothing changed during the implementation phase requiring further discussion ?
16:34:45 <ganso> bauzas: as far as I know, nothing changed and the code is complete
16:35:05 <bauzas> the BP was previously approved as specless so I don't see problems approving it again providing there were no changes in design
16:35:08 <ganso> I rebased it and it is passing CI
16:35:13 <bauzas> (requiring further discussions)
16:36:11 <ganso> I'm pretty much shepherding this set of changes now, but the work was done by stephenfin
16:36:12 <bauzas> ganso: I guess you're taking over stephenfin's work ?
16:36:22 <ganso> yes
16:36:25 <bauzas> OK, that's crystal clear then
16:36:39 <bauzas> I don't have any problems reapproving it
16:36:49 <bauzas> anyone else disagreeing ?
16:36:49 <ganso> great =)
16:37:28 <bauzas> #agreed https://blueprints.launchpad.net/nova/+spec/multiqueue-flavor-extra-spec to approve it again as a specless BP for the yoga release cycle
16:37:50 <bauzas> we're at the end of the agenda, anything else to mention ?
16:38:15 <bauzas> I'm happy to say we were quick this time :)
16:38:24 <gibi> \o/
16:38:30 <bauzas> if not,
16:38:34 <bauzas> #endmeeting*