16:00:01 <bauzas> #startmeeting nova
16:00:01 <opendevmeet> Meeting started Tue Dec  7 16:00:01 2021 UTC and is due to finish in 60 minutes.  The chair is bauzas. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:01 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:01 <opendevmeet> The meeting name has been set to 'nova'
16:00:06 <gibi> o/
16:00:41 <bauzas> #link https://wiki.openstack.org/wiki/Meetings/Nova#Agenda_for_next_meeting
16:00:42 <elodilles> o/
16:00:50 <bauzas> hola everybody
16:01:14 <gmann> o/
16:01:32 <pslestang> hey
16:02:02 <bauzas> ok, looks like we can start
16:02:12 <bauzas> #topic Bugs (stuck/critical)
16:02:19 <bauzas> #info No Critical bug
16:02:24 <bauzas> #link https://bugs.launchpad.net/nova/+bugs?search=Search&field.status=New 24 new untriaged bugs (+1 since the last meeting)
16:02:30 <bauzas> #help Nova bug triage help is appreciated https://wiki.openstack.org/wiki/Nova/BugTriage
16:02:58 <kashyap> Do we have a lot of bugs coming in for triage?
16:03:00 <bauzas> the +1 is a new gate bug, but let's discuss it after
16:03:03 <kashyap> Okay, 24...
16:03:17 <bauzas> kashyap: we had 3 new bugs this week AFAIK
16:03:28 <bauzas> sometimes we have 10
16:03:47 <bauzas> #link https://storyboard.openstack.org/#!/project/openstack/placement 25 open stories (+0 since the last meeting) in Storyboard for Placement
16:04:17 <bauzas> anything to discuss about bugs but not the gate ones ?
16:05:20 <bauzas> looks not
16:05:27 <bauzas> #topic Gate status
16:05:33 <bauzas> #link https://bugs.launchpad.net/nova/+bugs?field.tag=gate-failure Nova gate bugs
16:05:47 <bauzas> so we now have https://bugs.launchpad.net/nova/+bug/1953478
16:06:30 <bauzas> I didn't had time to look at the CI
16:06:39 <bauzas> have someone looked at it ? ^
16:07:24 <bauzas> looks not
16:07:32 <bauzas> okay, I'll try to see whether logstash continues to work
16:07:51 <bauzas> and I'll tell it's a High bug
16:08:41 <bauzas> but ok, moving on
16:08:49 <bauzas> #link https://zuul.openstack.org/builds?project=openstack%2Fplacement&pipeline=periodic-weekly Placement periodic job status
16:09:02 <bauzas> this is fun, I got 503 ^
16:09:03 <kashyap> bauzas: Sorry, just reading back - the CI issue seems intermittent
16:09:19 <kashyap> (And I doubt there's much bandwidth for folks to debug intermittent issues :-()
16:10:06 <bauzas> yeah no worries
16:10:16 <bauzas> anyway, about placement jobs...
16:10:39 <bauzas> looks like we have a problem with the Zuul API
16:10:50 <gibi> yeah zuul dashboard seems to be down
16:10:58 <bauzas> will ping the infra folks after the meeting
16:11:46 <bauzas> #action bauzas to ask infra folks why Zuul dashboard returns HTTP503
16:11:59 <bauzas> moving on then
16:12:09 <bauzas> #info Please look at the gate failures, file a bug, and add an  elastic-recheck signature in the opendev/elastic-recheck repo (example: https://review.opendev.org/#/c/759967)
16:12:15 <bauzas> #topic Release Planning
16:12:20 <bauzas> #info Yoga-2 is due Jan 6th
16:12:25 <bauzas> #link https://releases.openstack.org/yoga/schedule.html#y-2
16:12:30 <bauzas> #info Next spec review day to happen next week on Dec 14th
16:12:34 <bauzas> sooooo
16:12:39 <bauzas> spec, spec, spec, folks
16:13:02 <bauzas> remember that we will have less reviews after Dec 20
16:13:12 <bauzas> as some folks are on holidays or off
16:13:20 <bauzas> so, prepare your specs in advance
16:14:08 <bauzas> #info Reminder that Spec Freeze deadline is at Yoga-2
16:14:28 <bauzas> anything to discuss about it ?
16:15:21 <bauzas> heh, no
16:15:27 <kashyap> bauzas: A quick one
16:15:27 <bauzas> #topic Review priorities
16:15:30 <bauzas> #undo
16:15:30 <opendevmeet> Removing item from minutes: #topic Review priorities
16:15:38 <bauzas> kashyap: sure ?
16:15:41 <kashyap> bauzas: Can the spec review days be moved somewhere in the 2nd week of Jan?
16:15:50 <kashyap> Many will be on PTO from late next week...
16:16:11 <bauzas> kashyap: that's why we have the spec review day on Dec 14th
16:16:23 <sean-k-mooney> kashyap: yep most should be around on the 14th
16:16:32 <bauzas> so people could provide new revisions after this day and cores could merge them after
16:16:34 <kashyap> bauzas: Nod.  Okay, you can move on to reviw prio
16:16:38 <kashyap> sean-k-mooney: I'm off from 14Dec myself
16:16:40 <bauzas> I mean, before Dec 20
16:17:18 <bauzas> but, that said, I'm not against moving the spec freeze deadline after Jan 6th if people really want but,
16:17:38 <bauzas> keep in mind we already have a good number of accepted bps that we need to review
16:17:40 <sean-k-mooney> lets see if there is a need after m2
16:18:01 <gibi> yeah, we can get back to this on 11th of Jan meeting
16:18:14 <sean-k-mooney> ya i think we likely will have enough on our plate but we can assess on the 11th
16:18:21 <bauzas> for the moment, those are the BPs we have for Yoga https://blueprints.launchpad.net/nova/yoga
16:18:32 <bauzas> but I need to add new BPs that specs were merged during this week
16:19:21 <sean-k-mooney> yep i also likly need to file 1-2 blueprints for heathchecks for one
16:19:32 <sean-k-mooney> ill try and do that soon
16:19:32 <bauzas> actually https://review.opendev.org/q/project:openstack/nova-specs+is:merged tells me that's it for the moment
16:19:41 <bauzas> so Launchpad is OK
16:19:47 <sean-k-mooney> ack
16:20:33 <bauzas> but ok, let's revisite this on Jan 4th and Jan 11th to see whether folks want some exceptions
16:20:59 <bauzas> this said, I have a point to discuss in this meeting about holidays, btw.
16:21:14 <bauzas> (in the open discussion section)
16:21:54 <bauzas> do people agree with it ? we will at least see what's going on with specs after the review day
16:22:33 <gmann> +1
16:22:35 <sean-k-mooney> yep +1
16:22:50 <bauzas> ok, moving on
16:23:15 <bauzas> #topic Review priorities
16:23:38 <bauzas> #link https://review.opendev.org/q/status:open+(project:openstack/nova+OR+project:openstack/placement)+label:Review-Priority%252B1
16:23:45 <bauzas> #link https://review.opendev.org/c/openstack/nova/+/816861 bauzas proposing a documentation change for helping contributors to ask for reviews
16:24:25 <bauzas> I'd appreciate a second core for https://review.opendev.org/c/openstack/nova/+/815373
16:24:53 <bauzas> also,
16:25:04 <gibi> bauzas: I will check that
16:25:10 <bauzas> no update coming from https://review.opendev.org/c/openstack/nova/+/790519 since more than one month, can we consider to remove the prio ?
16:25:42 * bauzas looks at some people he knows ;)
16:25:46 <gibi> yepp drop it from prio
16:25:59 <gibi> we can add it back once the dependecies are sorted out
16:26:33 <bauzas> yeah this is related to the centos9 devstack effort, right?
16:26:50 <gibi> im not sure
16:27:01 <bauzas> from adalee's last comment, looks like it
16:27:29 <bauzas> lyarwood: around ?
16:27:32 <gibi> ahh I see, yes
16:27:41 <lyarwood> yup /me reads
16:27:44 <bauzas> lyarwood: you could have more context than me on this FIPS job
16:28:00 <lyarwood> I've not touched the review in a while
16:28:21 <bauzas> lyarwood: well, looks like there are some deps issues
16:28:45 <lyarwood> kk well it's on Ade to push it forward tbh
16:30:04 <bauzas> agreed
16:30:11 <bauzas> so, I'll drop the review-prio flag
16:30:19 <bauzas> but I want to make sure there is progress on it
16:30:47 <bauzas> hopefully my gerrit update will remind Ade there is work to do
16:31:26 <gmann> there are few tempest one (in the series of those deps) also needs to merged before
16:31:36 <gmann> which is under review
16:32:16 <bauzas> yeah looks like there are deps
16:32:26 <bauzas> quite a massive work
16:32:38 <gmann> and this is goal proposal in case to know broader pic #link https://review.opendev.org/c/openstack/governance/+/816587
16:32:51 <bauzas> haha
16:32:53 <bauzas> gtk
16:33:50 <bauzas> thanks gmann
16:34:12 <bauzas> anyway, I think we discuss about all the subject, next one
16:34:19 <bauzas> discussed* (dang)
16:34:30 <bauzas> oh, my change
16:34:42 <bauzas> https://review.opendev.org/c/openstack/nova/+/816861 is ready for reviews
16:34:50 <bauzas> I dropped the whole "I'm the owner, help me" thing
16:35:28 <bauzas> so, this is now only about "I'm non-core and I like this change, so I'd appreciate if cores could review it given I commit myself to review it too"
16:35:56 <bauzas> good opportunity for review visibility, just sayin'
16:35:57 <sean-k-mooney> ya i think that is a good chagne
16:36:03 <gibi> bauzas: I will get back to that too
16:37:07 <bauzas> thanks
16:37:17 <sean-k-mooney> if we are more or less happy with it i can start drafting the project config change for it but ill waith until after the spec review day next week to work on it
16:37:34 <bauzas> the idea is to give visibility on review time for non-cores and giving them trust
16:37:59 <gmann> I think this is good. and if every non core adding RP as +1 on their patches then we can re-iterate it
16:38:08 <bauzas> so, if you're non-core and you'd appreciate some visibility on review time, this is for you
16:38:42 <sean-k-mooney> i think this is more or less like +1 ing your own patch and we can treat it as such
16:38:58 <gmann> yeah, 'yes i reviewed it and it looks important to me so can core have a look'
16:39:01 <sean-k-mooney> e.g. you should in general avoid it but you may still want to do it in some cases
16:39:11 <bauzas> sean-k-mooney: I punted this use case
16:39:20 <gmann> may be good to mention in that doc for more clarity
16:39:38 <sean-k-mooney> bauzas: ya that is ok
16:39:39 <bauzas> comments are then appreciated on the change itself :)
16:39:54 <bauzas> next one
16:39:56 <bauzas> #topic Stable Branches
16:40:05 <bauzas> elodilles: your dog.
16:40:26 <elodilles> well, this will be short as not so much happening around stable branches
16:40:34 <elodilles> * stable gates should be OK (though no patches have been merged in the last couple of days)
16:40:45 <elodilles> that's it ^^^
16:41:06 <bauzas> huzzah
16:41:28 <bauzas> I remember I promised some reviews
16:41:37 <bauzas> but lacked my homework
16:42:11 <bauzas> ok, moving on then
16:42:18 <bauzas> #topic Sub/related team Highlights
16:42:22 <bauzas> Libvirt (lyarwood)
16:42:27 <bauzas> nothing special to mention ?
16:42:43 <lyarwood> Nothing from me this week, FWIW we will need a new owner for this point in the future.
16:42:49 <lyarwood> I'll talk about that more later
16:43:03 <bauzas> you're right
16:43:12 <bauzas> or,
16:43:22 <bauzas> not sure we still need to have a subteam
16:43:37 <bauzas> given afaik only lee and me work on this :)
16:43:38 <lyarwood> Either or, it's up to the remaining team
16:43:46 <bauzas> who's teamed up ?
16:44:12 <bauzas> anyway, we could make a call at next meeting
16:44:15 <lyarwood> I mean the wider Nova team ;)
16:45:10 <bauzas> ahah
16:46:43 <bauzas> anyway, last topic
16:46:48 <bauzas> #topic Open discussion
16:46:53 <bauzas> (bauzas) Holiday period and nova audience for both reviews and meetings
16:47:07 <bauzas> so, we'll have less people around in the last weeks of Dec
16:48:17 <sean-k-mooney> i expect other then perhaps alex there will likely be no? cores around for the last 2 weeks
16:48:30 <bauzas> I dunnoi
16:48:35 <gibi> I will be off from 20th
16:48:36 <bauzas> we can discuss if people want
16:48:42 <gibi> and back at 10th
16:49:22 <sean-k-mooney> 17th -> 4th in my case.
16:49:34 <bauzas> ok, Dec 21 -> Jan 3rd for me
16:49:36 <sean-k-mooney> i dont think we really need to spend much time on it
16:49:47 <gmann> I will be on and off during last week dec
16:49:58 <lyarwood> 17th -> 4th here also
16:49:58 <sean-k-mooney> i assume we are going to cancel meetings for the last 2 weeks
16:50:15 <sean-k-mooney> the 21th and 28th
16:50:18 <bauzas> sean-k-mooney: yeah I was about to propose to cancel the meetings
16:50:28 <gibi> agree with cancelling those
16:50:30 <elodilles> (20th -> 4th)
16:50:53 <gmann> +1 on canceling
16:51:06 <elodilles> ++
16:51:10 <sean-k-mooney> unless there is an object i would suggest just sending a mail to the list to inform those that are not here
16:51:18 <gmann> 21 and 28 one right?
16:51:24 <bauzas> correct
16:51:29 <gmann> k
16:52:20 <bauzas> ok, looks like we have an agreement
16:53:02 <bauzas> #agreed Cancel Dec 21th and Dec 28th nova meetings given there are less audience
16:53:13 <bauzas> I'll write an email about it
16:53:56 <bauzas> and thanks for providing your time-offs, appreciated.
16:54:14 <bauzas> we can look at this meeting' notes to remember when people are around
16:54:43 <bauzas> last item on our agenda,
16:54:51 <bauzas> (pslestang) Specless BP approval request for soft deleting instance action
16:54:59 <bauzas> pslestang: your turn
16:55:07 <pslestang> sure
16:56:14 <pslestang> so at OVH we do not use the restore instance feature and we would like the instance action do be soft deleted when an instance is soft deleted, this is why we propose to add a configuration option to soft delete instance action on instance soft delete
16:56:29 <bauzas> this one, I'm OK with a specless BP
16:56:30 <bauzas> but,
16:56:39 <bauzas> "We should also implement the possibility to retrieve deleted instance actions as we do for instances." seems like an API change, right?
16:57:22 <sean-k-mooney> pslestang: so just to be clear the meaning of soft delete upstream is the row is kept in the db but marked as delete
16:57:40 <sean-k-mooney> so that it can be mared as not deleted again later
16:57:40 <pslestang> bauzas: I did not dive into the API so need to be checked
16:57:46 <pslestang> sean-k-mooney: yes
16:57:58 <bauzas> are we sure that instance-actions table is soft-deletable already ?
16:58:15 <sean-k-mooney> i tought it was
16:58:24 <bauzas> I dunno, hence my question
16:58:31 <pslestang> bauzas: yes it is
16:58:33 <bauzas> if yes, looks like a config option setting
16:58:35 <sean-k-mooney> so that if we resotred a soft deleted instance its action woudl be preserved
16:58:44 <bauzas> if no, this is a db change hence a spec required
16:59:00 <sean-k-mooney> pslestang: so today we shoudl be soft deleting them already
16:59:03 <pslestang> the instance_actions table is soft-deletable
16:59:15 <sean-k-mooney> and the new config option you would instead hard delete them
16:59:32 <bauzas> sean-k-mooney: yeah I'm assuming we would mark the records soft-deleted in the DB and we would also unmark them when undeleting
16:59:47 <bauzas> actually, we're at time
16:59:54 <bauzas> but we can continue off the meeting
17:00:09 <bauzas> #endmeeting