15:59:59 <bauzas> #startmeeting nova
15:59:59 <opendevmeet> Meeting started Tue Feb  1 15:59:59 2022 UTC and is due to finish in 60 minutes.  The chair is bauzas. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:59:59 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:59:59 <opendevmeet> The meeting name has been set to 'nova'
16:00:06 <bauzas> hello everybody
16:00:13 <bauzas> #link https://wiki.openstack.org/wiki/Meetings/Nova#Agenda_for_next_meeting
16:00:21 <elodilles> o/
16:00:25 <chateaulav> \o
16:00:33 <gibi> o/
16:01:34 <bauzas> ok let's start, should be quick hopefully
16:01:43 * kashyap waves, but will have to come and read back.  Have to be AFK
16:01:45 <bauzas> #topic Bugs (stuck/critical)
16:01:50 <bauzas> #info No Critical bug
16:01:54 <bauzas> #link https://bugs.launchpad.net/nova/+bugs?search=Search&field.status=New 39 new untriaged bugs (+3 since the last meeting)
16:01:58 <bauzas> #help Nova bug triage help is appreciated https://wiki.openstack.org/wiki/Nova/BugTriage
16:02:02 <bauzas> #link https://storyboard.openstack.org/#!/project/openstack/placement 27 open stories (+2 since the last meeting) in Storyboard for Placement
16:02:08 <bauzas> I need to do a bit of triage
16:02:28 <bauzas> but working on Tempest trampled me
16:02:57 <bauzas> anyway, we'll discuss about the new gate failure bug after this topic
16:03:08 <bauzas> any other bug to want to discuss ?
16:03:24 <opendevreview> Artom Lifshitz proposed openstack/nova master: WIP: live-migration: only wait for external events for active VIFs  https://review.opendev.org/c/openstack/nova/+/827314
16:04:02 <bauzas> looks not
16:04:07 <bauzas> #topic Gate status
16:04:12 <bauzas> #link https://bugs.launchpad.net/nova/+bugs?field.tag=gate-failure Nova gate bugs
16:04:35 <bauzas> gibi: do you want to discuss about https://bugs.launchpad.net/nova/+bug/1959677 ?
16:04:37 <ganso> o/
16:04:44 <gibi> bauzas: nope
16:04:48 <gibi> bauzas: I had not time to investigate
16:04:56 <gibi> bauzas: just so it happening and reported it
16:04:56 <bauzas> okay
16:05:03 <bauzas> I'll triage it btw.
16:05:05 <artom> Someone needs to tag https://bugs.launchpad.net/tempest/+bug/1959682 as a Nova gate failure, I don't have Tempest bug tagging powers
16:05:50 <gibi> artom: I added the tag but that does not mean much as the bug is against tempest project
16:06:09 <gibi> artom: btw, somebody was faster than you proposing the fix
16:06:13 <bauzas> is it a problem for nova ?
16:06:13 <artom> Yeah, and anyways it should go away quickly enough
16:06:13 <gibi> artom: I noted that in your fix
16:06:22 <gibi> bauzas: yes
16:06:25 <gibi> bauzas: nova-next is down
16:06:26 <bauzas> if so, should be a nova bug
16:06:39 * bauzas adds the nova project to the bug report
16:06:40 <gibi> bauzas: the actual fault is in the tempest code
16:06:55 <gibi> (we probalby overcomplicate :D)
16:07:13 <bauzas> okay, added nova to the bug
16:07:18 <bauzas> we'll need to triage it
16:07:22 <artom> gibi, well yeah, I spend most of my time writing up the commit message and bug report :P
16:07:31 <artom> Of course someone else was faster
16:07:33 <bauzas> if people want to triage it btw... :)
16:07:43 <gibi> artom: :)
16:07:50 * bauzas doesn't try to look at someone he knows
16:08:33 <bauzas> anyway
16:08:37 <bauzas> moving on ?
16:08:53 <sean-k-mooney> bauzas: its not a nova bug in this case
16:09:01 <sean-k-mooney> since the error is in tempest
16:09:07 <bauzas> sean-k-mooney: then please triage it
16:09:12 <sean-k-mooney> we can skip it tempoarlly as a workaround
16:09:36 <sean-k-mooney> we can move on
16:09:45 <bauzas> the question is, what project needs to be modified for this report ?
16:09:56 <sean-k-mooney> tempest
16:10:01 <bauzas> if it's not nova, then we can triage it simply
16:10:10 <bauzas> sean-k-mooney: then please do https://bugs.launchpad.net/nova/+bug/1959682
16:10:20 <sean-k-mooney> yep i have it open
16:10:27 <sean-k-mooney> ill mark it invalid and explian why
16:10:29 <bauzas> cool thanks
16:10:49 <bauzas> I just added nova to ask for it
16:10:56 <bauzas> anyway, moving
16:11:07 <sean-k-mooney> the only question is do we want to make it non-voting until tis fixed but it sound like it wont take long so let leave it for now and move on
16:11:21 <gibi> sean-k-mooney: it wont take long
16:11:33 <gibi> there is already two fixes up ;)
16:12:20 <bauzas> #link https://zuul.openstack.org/builds?project=openstack%2Fplacement&pipeline=periodic-weekly Placement periodic job status
16:12:26 <bauzas> #info Please look at the gate failures and file a bug report with the gate-failure tag.
16:12:36 <bauzas> nothing to tell about the periodic jobs, they work
16:12:51 <bauzas> #topic Release Planning
16:12:55 <bauzas> #link https://releases.openstack.org/yoga/schedule.html#y-ff FeatureFreeze in 3.5 weeks
16:12:59 <bauzas> #link https://etherpad.opendev.org/p/nova-yoga-blueprint-status Etherpad for blueprints tracking
16:13:16 <bauzas> as you can see, I tried to look at all the accepted blueprints
16:13:31 <bauzas> I saw some changes, but not for all the blueprints
16:14:03 <opendevreview> Artom Lifshitz proposed openstack/nova master: DNM: Test fix for bug 1959682  https://review.opendev.org/c/openstack/nova/+/827306
16:14:05 <gibi> bauzas: nice list!
16:14:22 <bauzas> #action if you are one of the owners of accepted blueprints for yoga, please modify https://etherpad.opendev.org/p/nova-yoga-blueprint-status to provide your changes
16:14:38 <bauzas> #info if we don't know your changes, we can't review them
16:14:46 <gibi> bauzas: does the order in the pad means some kind of priority order?
16:14:54 <bauzas> gibi: not for the moment
16:14:56 <gibi> ack
16:15:05 <bauzas> anyone can review what they want
16:15:28 <bauzas> next week, I could ask whether we would prefer to have some priorities
16:15:57 <bauzas> my only concern is that half of the blueprints seem not open yet
16:16:30 <bauzas> gibi: about https://blueprints.launchpad.net/nova/+spec/qos-minimum-guaranteed-packet-rate I'll mark it as complete, thanks
16:16:36 <gibi> bauzas: thanks
16:16:42 <gibi> bauzas: that is complete
16:16:49 <bauzas> saw it indeed
16:17:29 <bauzas> so again, I'm saying loud : please look at this etherpad and provide your changes if you're one owner and you don't see your changes in the etherpad
16:18:52 <bauzas> tbc, if Feb 15th (2 meetings from now), we're not able to see changes for a blueprint, I'll punt the blueprint as something not prioritary
16:19:17 <bauzas> as I don't want reviewers to be rushed by new changes coming down at the last minute
16:19:25 <gibi> agree
16:19:54 <bauzas> not saying we'll hold merging things for those last-minute changes
16:20:09 <bauzas> just telling this won't be prioritary
16:20:43 <bauzas> anyway, for the moment, we have enough to look at :)
16:21:05 <bauzas> anything to say else about blueprints ?
16:21:39 <bauzas> guess not
16:21:48 <bauzas> #topic Review priorities
16:21:56 <bauzas> #link https://review.opendev.org/q/status:open+(project:openstack/nova+OR+project:openstack/placement+OR+project:openstack/os-traits+OR+project:openstack/os-resource-classes+OR+project:openstack/os-vif+OR+project:openstack/python-novaclient+OR+project:openstack/osc-placement)+label:Review-Priority%252B1
16:22:13 <bauzas> some of the blueprints above are priorities
16:22:29 <sean-k-mooney> i guess we shoudl use ^ after the 15 to
16:22:42 <bauzas> sean-k-mooney: yeah, I was about to say it
16:23:02 <bauzas> and also, we should remove priorities for changes that are not blueprints
16:23:29 <bauzas> (I've 3 patches in mind)
16:23:34 <sean-k-mooney> we might want to make exception for gate issue but sure
16:23:41 <bauzas> but for the moment, I'm OK with leaving this list as it is
16:23:53 <bauzas> sean-k-mooney: oh, of course
16:24:17 <bauzas> point is, owners would appreciate if we say out loud that we prioritize blueprints before FeatureFreeze
16:24:44 <bauzas> I'll think about it during this week and I'll prepare something to discuss next week's meeting
16:25:02 <sean-k-mooney> by the way i have not had time to do the project-config change yet
16:25:08 <sean-k-mooney> but its still on my radar
16:25:16 <bauzas> sean-k-mooney: I don't think it's important for this cycle
16:25:23 <bauzas> we can hold until RC1
16:25:49 <bauzas> this is a bit late to be added this cycle, tbh
16:25:57 <sean-k-mooney> well its not really realted to the milestones we just need to land it in the proejct config repo
16:26:07 <sean-k-mooney> so ill work on it when i have time
16:26:36 <sean-k-mooney> just wanted to say its still on my todo list
16:26:39 <bauzas> sean-k-mooney: agreed but we need to document and explain what to do
16:27:19 <bauzas> people could be confused while we're close to featurefreeze and I want things crystal clear for the last two weeks
16:28:08 <bauzas> anyway, next topic
16:28:15 <bauzas> #topic Stable Branches
16:28:18 <bauzas> #topic Stable Branches
16:28:25 <elodilles> #info stable gates are not blocked completely, but it is hard to merge patches due to intermittent failures
16:28:28 <elodilles> :)
16:28:40 <bauzas> yeah...
16:28:56 <elodilles> that was my quick update
16:29:09 <gibi> yeah https://review.opendev.org/c/openstack/nova/+/820555 has 19 rechecks :/
16:29:18 <bauzas> appreciated
16:29:56 <bauzas> gibi: :-/
16:30:08 <elodilles> of course there were gate blocker issues meantime as well.. :X
16:30:28 <gibi> I will try to get some time spen on the gate status later this week
16:30:50 <bauzas> I can try to look at this but I promised code reviews as well
16:31:01 <bauzas> anyway
16:31:22 <bauzas> help is appreciated from anybody
16:31:41 <bauzas> #topic Sub/related team Highlights
16:31:45 <bauzas> #info No subteam left
16:31:49 <bauzas> #topic Open discussion
16:31:58 <bauzas> nothing on the agenda
16:32:12 <bauzas> wrapping up or someone yelling about something ?
16:32:37 <sean-k-mooney> elodilles: have the pip issue been adressed in ci yet
16:32:53 <sean-k-mooney> e.g. that pip does not supprot pyton 3.6 anymore
16:33:00 <elodilles> sean-k-mooney: if i'm not mistaken we don't have that in stable
16:33:31 <sean-k-mooney> we likely will in the future
16:33:45 <sean-k-mooney> but ok
16:33:49 <elodilles> e.g. gibi's linked patch (above^^^) just had a successful zuul run
16:33:57 <chateaulav> sean-k-mooney: I added it to the etherpad, but are we able to get a push from redhat for libvirt bug: https://bugzilla.redhat.com/show_bug.cgi?id=1432101
16:34:00 * sean-k-mooney is still woried more things will drop 3.6 support before end fo cycle
16:34:25 <sean-k-mooney> ack thats all i had for the meeting chateaulav  is your item for the meeting
16:34:30 <chateaulav> related to MIPs support for bp
16:34:59 <chateaulav> i huess for outside
16:35:09 <sean-k-mooney> we can continue discussing this on the channel i think
16:35:15 <sean-k-mooney> bauzas: if you you want to finsih up
16:35:16 <chateaulav> k
16:35:29 <bauzas> cool
16:35:35 <bauzas> I have to go to the post office
16:35:44 <bauzas> (absolutely needed to be known)
16:35:51 <bauzas> thanks all
16:35:54 <bauzas> #endmeeting