16:00:00 <bauzas> #startmeeting nova
16:00:00 <opendevmeet> Meeting started Tue Feb 15 16:00:00 2022 UTC and is due to finish in 60 minutes.  The chair is bauzas. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:00 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:00 <opendevmeet> The meeting name has been set to 'nova'
16:00:08 <gibi> o/
16:00:21 <bauzas> heya
16:00:27 <gmann> o/
16:00:27 <bauzas> #link https://wiki.openstack.org/wiki/Meetings/Nova#Agenda_for_next_meeting
16:00:42 <Uggla> o/
16:00:44 <chateaulav> \o
16:00:58 <elodilles> o/
16:01:44 <bauzas> ok, let's start
16:01:50 <bauzas> #topic Bugs (stuck/critical)
16:01:55 <bauzas> #info No Critical bug
16:01:58 <bauzas> #link https://bugs.launchpad.net/nova/+bugs?search=Search&field.status=New 42 new untriaged bugs (+3 since the last meeting)
16:02:02 <bauzas> #help Nova bug triage help is appreciated https://wiki.openstack.org/wiki/Nova/BugTriage
16:02:06 <bauzas> #link https://storyboard.openstack.org/#!/project/openstack/placement 27 open stories (+0 since the last meeting) in Storyboard for Placement
16:02:15 <bauzas> I had no time to look at the new bugs
16:02:27 <bauzas> any bug in particular to raise ?
16:02:37 <gibi> -
16:03:05 <bauzas> ok, moving on
16:03:06 <gibi> the centos-9 issue has been triaged we need the waiting for ssh tempest series to fix it
16:03:15 <bauzas> yeah
16:03:26 <bauzas> let's discuss this in the next topic
16:03:31 <bauzas> #topic Gate status
16:03:35 <bauzas> #link https://bugs.launchpad.net/nova/+bugs?field.tag=gate-failure Nova gate bugs
16:03:38 <bauzas> #link https://zuul.openstack.org/builds?project=openstack%2Fplacement&pipeline=periodic-weekly Placement periodic job status
16:03:43 <bauzas> #info Please look at the gate failures and file a bug report with the gate-failure tag.
16:04:21 <gmann> I did not get chance to check that series yet but will do this week or next for sure.
16:04:25 <bauzas> so, yeah we need the tempest series to be merged
16:04:32 <gibi> context https://bugs.launchpad.net/nova/+bug/1960346/
16:04:33 <gmann> gibi: should i rebase those and few are still WIP?
16:04:42 <gibi> and https://review.opendev.org/q/topic:wait_until_sshable_pingable
16:05:13 <gibi> bauzas: do you happen to know if somebody is taking over the tempest series from lyarwood ?
16:05:16 <bauzas> context https://review.opendev.org/q/topic:wait_until_sshable_pingable
16:05:23 <bauzas> damn burned
16:05:26 <gibi> :)
16:05:30 <bauzas> gibi: honestly, I dunno
16:05:36 <bauzas> if I can help, let's do it
16:05:39 <gmann> bauzas: gibi I can do
16:05:44 <bauzas> cool then
16:05:48 <gibi> gmann: cool. I can help
16:05:53 <gmann> late this week or early next week
16:05:57 <gmann> gibi: thanks
16:05:58 <gibi> awesome
16:06:00 <bauzas> I mean, let's discuss in between us then
16:06:04 <gmann> sure
16:06:08 <gibi> ack
16:06:13 <bauzas> lovely
16:06:16 <sean-k-mooney> i know we did not have anyone dowstream lined up to take it over
16:06:35 <sean-k-mooney> so im sure ye can work that out after the meeting
16:06:45 <gibi> ack
16:06:59 <bauzas> maybe after next Thursday, if people don't mind ;)
16:07:09 <bauzas> guess why :)
16:07:20 <gibi> no clue :)
16:07:29 <bauzas> damn
16:07:38 <bauzas> it was a good opportunity for jumping to the next agenda item
16:07:45 <bauzas> if so,
16:07:50 <bauzas> #topic Release Planning
16:07:54 <bauzas> #link https://releases.openstack.org/yoga/schedule.html#y-ff FeatureFreeze in 1.5 weeks
16:07:58 <bauzas> voilĂ  !
16:08:04 <bauzas> #link https://etherpad.opendev.org/p/nova-yoga-blueprint-status Etherpad for blueprints tracking
16:08:07 <gibi> ohh that?! :)
16:08:13 <gmann> :)
16:08:33 <bauzas> yeah, I'm quite diverted this week + some internal help I need to do for this week :)
16:08:44 <bauzas> anyway
16:08:46 <bauzas> so
16:08:57 <bauzas> sean-k-mooney had a thought on last Thursday
16:09:05 <bauzas> and I hadn't chance to talk about it
16:09:06 <bauzas> yet
16:09:20 <bauzas> what folks think about some specific implementation review day ?
16:10:07 <gibi> I'm up for it
16:10:15 <gibi> prefer not to have it on friday
16:11:12 <bauzas> this thursday? agreed on leaving friday off the table
16:11:29 <gibi> works for me
16:11:34 <bauzas> that would be a short notice
16:11:39 <bauzas> but later means nothing
16:11:45 <bauzas> also
16:11:53 <gmann> sounds good
16:11:57 <sean-k-mooney> friday is also a redhat internal PTO day
16:11:58 <bauzas> wait, before the also
16:12:06 * sean-k-mooney discoverd this this morning
16:12:10 <bauzas> sean-k-mooney: oh shit,you're right
16:12:12 <gibi> :)
16:12:20 * bauzas forgot about it
16:12:23 <sean-k-mooney> so thrusday is preferable
16:12:29 <bauzas> sounds a plan
16:12:30 <gibi> then let's have it on Friday and gmann and I will merge everything :D
16:12:45 <sean-k-mooney> :)
16:13:02 <bauzas> #agreed Implementation review day happening on Thursday Feb 17th, bauzas to communicate after the meeting
16:13:15 <bauzas> ok, next point
16:13:28 <bauzas> should we consider prioritizing some blueprints over some others ?
16:13:30 <bauzas> also,
16:13:53 <bauzas> should we start planning to look at all the API changes adding a new microversion ?
16:14:00 <bauzas> and asking the owners to rebase in between them ?
16:14:10 <gibi> do we have more than one series with microversion?
16:14:18 <bauzas> at least we have one largez
16:14:19 <gibi> I know about the tenant_id one
16:14:31 <gmann> yeah one is tenant-id i know of
16:14:42 <gibi> then no worries on the microversion bumpo
16:15:03 <gibi> but I agree to say out loud that bps without patches are now being ignored for the FF
16:15:18 <gibi> that is some level of prioritization :)
16:15:35 <bauzas> fine with me
16:15:39 <bauzas> I started to look at https://review.opendev.org/q/topic:bp%252Fremove-tenant-id
16:16:18 <bauzas> and I'll prioritize unified-limits, this one plus the policy changes and the any-traits support
16:16:27 <bauzas> at least for the 4 days
16:16:40 <gibi> I can be on the hook for chateaulav's series
16:16:43 <gibi> about emulation support
16:16:52 <gmann> +1, I have kept tenant-id first patch as -W until whole series is ready.
16:16:59 <chateaulav> gibi: appreciated
16:17:11 <gibi> and I'm also available for the unified-limits one
16:17:18 <bauzas> I already have 4 series on my plate
16:17:31 <bauzas> hence my question about who could cover the others
16:18:01 <bauzas> good (or bad) news are, 10 blueprints are showing no effort
16:18:24 <bauzas> and 2 need serious rework
16:18:53 <bauzas> so most of the things we can reasonably land are already marked up for reviews + wayward
16:18:58 <gibi> bauzas: if you seem some patch series that I haven't reviewed yet and not on your plate already then let me know and I will jump on it
16:19:20 <bauzas> the policy series is hard to review
16:19:29 <sean-k-mooney> i think some of the things without patche have patches we just have not linked them properly
16:19:34 <bauzas> so a second core with good knowledge is appreciated
16:19:48 <gmann> I will continue on tenant-id and more of pushing the policy and 'host info to project' changes by this week max.
16:19:49 <bauzas> sean-k-mooney: hence the etherpad
16:19:59 <bauzas> it's open to anyone
16:20:01 <sean-k-mooney> https://blueprints.launchpad.net/nova/+spec/multiqueue-flavor-extra-spec is an example. i added a new section at the top for things that are feature complete but have followup by the way
16:20:19 <gibi> bauzas: noted
16:20:30 <bauzas> sean-k-mooney: thanks, works with me
16:20:57 <gmann> bauzas: I will catch dansmith for policy one.
16:20:59 <bauzas> anyway, let's continue to chat on IRC
16:21:05 <bauzas> and keep the pace
16:21:37 <bauzas> any additional note to say ?
16:21:40 <sean-k-mooney> if there are no patches for https://blueprints.launchpad.net/nova/+spec/nova-change-default-overcommit-values i might do that quickly
16:22:44 <gibi> bauzas: do you still aiming to land https://blueprints.launchpad.net/nova/+spec/boot-vm-with-unaddressed-port ?
16:22:59 <bauzas> gibi: yes, I need to update based on your comment
16:23:02 <gibi> ack
16:23:04 <bauzas> was planning to do it today :)
16:23:10 <bauzas> as you see, I'm lagging :)
16:23:39 <bauzas> I have a tempest test for verifying https://blueprints.launchpad.net/nova/+spec/boot-vm-with-unaddressed-port that I need to make progress on
16:23:45 <gibi> cool
16:24:07 <bauzas> but given tempest is branchless, I guess people agreed this is not impacted by our milestones, right?
16:24:11 <bauzas> agree*
16:24:15 <gibi> right
16:24:29 <gibi> I was about to suggest to decouple tempest from the nova impl
16:24:47 <bauzas> ok, I'll try ty upload a WIP change against tempest as a proof of work
16:25:12 <gmann> feature flag is something you can try for branchless tempest
16:25:21 <bauzas> gmann: did that :)
16:25:27 <gmann> ohk
16:25:33 <bauzas> again, need to upload my WIP
16:25:43 <gmann> gibi: and this one? you are targeting for yoga ? I can skip re-review if not (for now :)) https://review.opendev.org/c/openstack/nova/+/821423
16:25:49 <bauzas> but it's far from being mergeable
16:26:46 <sean-k-mooney> bauzas: i don tthink we need the tempest test to merge the nova change
16:26:52 <gibi> gmann: that is a bugfix so we have an extra week for that after FF.
16:27:01 <gibi> gmann: but yes, I would like to have it
16:27:04 <gmann> gibi: yeah, ack
16:27:05 <sean-k-mooney> if you have a WIP patch and plan to work on it i think we can trust you to finish it
16:28:55 <bauzas> sean-k-mooney: yup indeed
16:29:01 <bauzas> anyway
16:29:09 <bauzas> any other blueprint to mention ?
16:29:13 <gibi> -
16:30:12 <bauzas> then,
16:30:23 <bauzas> #topic Review priorities
16:30:30 <bauzas> #link https://review.opendev.org/q/status:open+(project:openstack/nova+OR+project:openstack/placement+OR+project:openstack/os-traits+OR+project:openstack/os-resource-classes+OR+project:openstack/os-vif+OR+project:openstack/python-novaclient+OR+project:openstack/osc-placement)+label:Review-Priority%252B1
16:30:50 <bauzas> we said we could use this flag to tell things we plan to review
16:31:04 <bauzas> I'll do this then accordingly
16:31:17 <bauzas> at least for the 4 BPs I mentioned
16:31:42 <bauzas> any other point to mention ?
16:32:48 <bauzas> looks not
16:32:52 <bauzas> #topic Stable Branches
16:32:56 <bauzas> elodilles: ?
16:33:07 <elodilles> yes,
16:33:23 <elodilles> actually the state is more or less the same as last week
16:33:38 <elodilles> gates are OK, except queens and pike
16:34:03 <elodilles> I still not proposed a working fix for the docs job for them
16:34:07 <artom> Oh, wallaby has that same tagged attachment bug, I think
16:34:32 <elodilles> artom: hmmm
16:34:59 <elodilles> actually this one progressed a bit: https://review.opendev.org/q/topic:workaround-disable-apic
16:35:01 * artom should have come prepared with hard data
16:35:29 <elodilles> nova part in wallaby is on the gate,
16:35:39 <artom> OK, so maybe we won't need https://review.opendev.org/c/openstack/nova/+/828542
16:35:50 <elodilles> whenever that lands then we need the devstack part
16:36:55 <elodilles> artom: i think that is not needed in wallaby
16:37:05 <elodilles> but have to double check
16:37:22 <bauzas> ack
16:37:39 <artom> Anecdotally it seems that we do? But as I said, no hard data
16:37:53 <gmann> elodilles: is this ready? https://review.opendev.org/c/openstack/devstack/+/805632
16:37:59 <gmann> I can check devstack backports
16:38:33 <elodilles> gmann: i think yes, we can remove the Workflow label *when* the nova part has merged
16:38:48 <elodilles> gmann: i'll ping you
16:39:02 <artom> And yeah, if it's fixed by the apic workaround we can abandon
16:39:02 <gmann> elodilles: ack, thanks
16:39:12 <elodilles> gmann: thanks too :)
16:40:27 <bauzas> ok, done with that ?
16:40:36 <elodilles> sorry, yes
16:40:41 <elodilles> i don't have any other update
16:41:20 * elodilles needs to check the the wallaby issue what artom mentioned
16:41:39 <bauzas> cool
16:41:41 <bauzas> ,
16:41:42 <artom> elodilles, it's most likely related to our volume detachment woes
16:41:55 <artom> So I'm like 90% sure the apic workaround will make it go away
16:42:13 <bauzas> #topic Open discussion
16:42:17 <elodilles> artom: ack
16:42:22 <bauzas> Z release name should be known in 1 week-ish
16:42:30 <bauzas> that's it, we exhausted the agenda
16:42:30 <artom> Err, it's official Zed now?
16:42:49 <artom> And I have a last minute thing for the open discussion
16:43:04 <gmann> yes, its final. I will reply in email soon after meeting or so
16:43:06 <bauzas> oh damn, missed it
16:43:13 <bauzas> there it goes
16:43:22 <gmann> I do not think we can change it at this stage
16:43:23 <bauzas> #info Next release is named "Zed"
16:43:28 <gibi> Zed, boring, but at least short.
16:43:40 <artom> Also, name of the, err, chopper dude in Pul Fiction
16:43:43 <artom> *Pulp Fiction
16:43:52 <gmann> yeah, i was hoping zombie but not sure why i did not pass trademark checks
16:43:57 * artom won't mention what Zed was doing *before* getting his chopper stolen
16:43:58 <gibi> we could have a screening of that in Berlin :)
16:44:03 <gmann> *it did not
16:44:31 <bauzas> oh man
16:44:46 <bauzas> indeed, I remember the Zed character
16:45:06 <bauzas> anyway, will propose a patch for creating the zed directory against nova-specs
16:45:20 <bauzas> we can rename it if needed but I guess ship has sailed
16:45:49 * bauzas just wonders how Zombie got hit by trademarks while Zed did not
16:45:57 <bauzas> for Zen, it was obvious
16:46:14 <bauzas> for Zeta, nothing comes out of my mind
16:46:28 <artom> Aren't they a violent gang somewhere?
16:46:32 <bauzas> (fwiw, Zombie was a pun when I proposed it)
16:46:43 <artom> Yup https://en.wikipedia.org/wiki/Los_Zetas
16:46:43 <bauzas> because everybody else is saying OpenStack is dead
16:46:51 <gmann> true
16:47:02 <bauzas> I just wanted to tell that if OpenStack is dead, it's still alive
16:47:15 <bauzas> hence the pun
16:47:27 <bauzas> anyway, we're diverting
16:47:46 <bauzas> #action to propose a patch against nova-specs for creating the "zed" directory
16:48:27 <bauzas> artom: you had an item
16:48:50 <artom> Yeah, so this is last minute, but I want to start socializing this strawman idea
16:49:02 <artom> The tripleo folks often have bugs that block their CI
16:49:21 <artom> Sometimes those are Nova folks, or they initially think they're Nova bugs
16:49:30 <artom> The current process for those is... well, bad
16:49:50 <bauzas> having a boot failure isn't always due to Nova, y'know :)
16:50:06 <artom> I know, I Know
16:50:10 <artom> But like the volume detach issues
16:50:16 <artom> It blocked us, it blocked them as well
16:50:53 <artom> What they currently do is file bugs against the *tripleo* component, and get us, via a *downstream internal Red Hat call*, to look at those they think are Nova
16:51:41 <artom> Would there be willingness here in this community to get bugs filed againt *Nova*, with the gate-blocker tag, and to leverage the existing upstream bug triage process (however light it is)?
16:52:15 <bauzas> anyone can report a bug against nova :)
16:52:25 <bauzas> actually this is a good point
16:52:35 <gibi> artom: I'm OK with that, if they take the time to point to the nova part of the tripleo problem as I'm not familiar with tripelo
16:52:35 <bauzas> I won't refrain anyone to do this
16:52:46 <bauzas> the only problem is the triage capacity
16:52:54 <bauzas> I do it when I have time
16:52:55 <artom> Their expectation would be, as it's a gate-blocker for them, that we would prioritize triaging those, similar to how Neutron would do it for our gate blocker, for example
16:53:15 <artom> But yeah, we can definitely ask for high bug report quality
16:53:22 <bauzas> artom: I'd say it's worth adding nova as an impacted project, I agree
16:53:25 <gibi> artom: if they need priority I suggest to ping us with the gate bug here on irc
16:53:31 <bauzas> gibi: exactly
16:53:36 <bauzas> upstream first
16:53:45 <bauzas> file a LP bug, go shout the folks on IRC
16:53:50 <bauzas> and we'll triage it
16:54:03 <artom> ooo has a very... "flexible" concept of upstream/downstream
16:54:09 <gibi> :)
16:54:10 <artom> Since they're all Red Hat folks, essentially
16:54:13 <bauzas> expect the nova folks to magically triage this LP bug isn't exactly a good recipe for success
16:54:25 * gibi needs more magic
16:54:35 * bauzas just needs time or duplicity
16:55:01 <bauzas> anyway,
16:55:19 <artom> OK, so my takeaway would be "yes, do it upstream, but high quality bug reports please"
16:55:19 <bauzas> artom: feel free to tell them to file a launchpad bug against nova and ask us on IRC to look at it
16:55:27 <bauzas> artom: yes
16:55:31 <bauzas> 100% yes
16:55:33 <artom> Awesome, much thanks
16:55:34 <gibi> +1
16:56:00 <bauzas> artom: appreciated the thought
16:56:19 <bauzas> any last item to discuss before I call it a wrap ?
16:56:47 <bauzas> looks not
16:56:50 <bauzas> thanks all
16:56:53 <bauzas> #endmeeting