16:02:13 <bauzas> #startmeeting nova
16:02:14 <opendevmeet> Meeting started Tue Feb 22 16:02:13 2022 UTC and is due to finish in 60 minutes.  The chair is bauzas. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:02:14 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:02:14 <opendevmeet> The meeting name has been set to 'nova'
16:02:24 <bauzas> hey folks, sorry the delay
16:02:31 <gmann> o/
16:02:31 * bauzas looks at his coffee
16:02:35 <chateaulav> \o
16:02:42 <bauzas> that's its fault
16:03:00 <bauzas> #link https://wiki.openstack.org/wiki/Meetings/Nova#Agenda_for_next_meeting
16:03:10 <elodilles> o/
16:03:20 <bauzas> let's a quick meeting since we're close to some deadline :)
16:03:24 <bauzas> let's do*
16:03:30 <bauzas> #topic Bugs (stuck/critical)
16:03:35 <bauzas> #info No Critical bug
16:03:39 <bauzas> #link https://bugs.launchpad.net/nova/+bugs?search=Search&field.status=New 27 new untriaged bugs (-15 since the last meeting)
16:03:48 <bauzas> thanks gibi and others for having looked at the bugs
16:03:52 <bauzas> #help Nova bug triage help is appreciated https://wiki.openstack.org/wiki/Nova/BugTriage
16:03:57 <bauzas> link https://storyboard.openstack.org/#!/project/openstack/placement 27 open stories (+0 since the last meeting) in Storyboard for Placement
16:04:01 <bauzas> #link https://storyboard.openstack.org/#!/project/openstack/placement 27 open stories (+0 since the last meeting) in Storyboard for Placement
16:04:06 <bauzas> voila
16:04:10 <bauzas> any bugs to discuss ?
16:04:48 <bauzas> looks not
16:04:57 <bauzas> again, thanks for the folks who looked at the bugs
16:05:10 <bauzas> #topic Gate status
16:05:14 <bauzas> #link https://bugs.launchpad.net/nova/+bugs?field.tag=gate-failure Nova gate bugs
16:05:17 <bauzas> #link https://zuul.openstack.org/builds?project=openstack%2Fplacement&pipeline=periodic-weekly Placement periodic job status
16:05:21 <bauzas> #info Please look at the gate failures and file a bug report with the gate-failure tag.
16:05:37 <bauzas> so we had a few new gate failures
16:05:55 <bauzas> I saw gibi looking at one
16:06:10 <bauzas> any of them needing to be discussed ?
16:06:22 <gibi> I just did some bug triage and duplicated thing together
16:06:30 <gibi> I did not see a new failure this week
16:06:37 <gibi> * new type of failure
16:07:15 <bauzas> kk
16:07:32 <bauzas> ok, then moving to the next topic
16:07:39 <bauzas> #topic Release Planning
16:07:43 <bauzas> #link https://releases.openstack.org/yoga/schedule.html#y-ff FeatureFreeze in 2 days
16:07:47 <bauzas> #link https://etherpad.opendev.org/p/nova-yoga-blueprint-status Etherpad for blueprints tracking
16:07:58 <bauzas> so the FeatureFreeze will be on Thursday EOB
16:08:35 <bauzas> tbh, that means that nova-cores won't merge any feature change on Friday
16:08:48 <bauzas> unless we got a gate issue
16:09:08 <bauzas> do people have any concerns ?
16:09:17 <gibi> bauzas: you mean no +A on Friday
16:09:25 <bauzas> gibi: sorry yes
16:09:25 <gibi> except if rebase is needed
16:09:29 <bauzas> correct
16:09:32 <gibi> ack
16:09:34 <gibi> works for me
16:10:15 <gmann> ack
16:10:26 <bauzas> do people want to discuss about any blueprint here ?
16:10:38 <gmann> need more reviews on RBAC series https://review.opendev.org/q/topic:bp%252Fpolicy-defaults-refresh-2
16:10:40 <liorf95> yes please
16:10:44 <gmann> thanks gibi for reviews
16:10:44 <bauzas> yes, I'll do
16:10:48 <gmann> thanks
16:10:51 <liorf95> https://blueprints.launchpad.net/nova/+spec/nvmeof-multipath
16:10:57 <bauzas> liorf95: we'll discuss about your bp in the open discussion topic
16:10:58 <sean-k-mooney> liorf95: i think yours is in opendicuss at the end but we coudl bring it up now too
16:11:19 <liorf95> as you want
16:11:35 <bauzas> liorf95: that's in the agenda :)
16:11:39 <bauzas> anyway
16:11:49 <bauzas> secure RBAC, yes I'll review
16:12:04 <bauzas> we merged a few features before
16:12:19 <bauzas> I'll modify Launchpad on Friday
16:12:35 <chateaulav> just reviews for emulation to ensure nothing bltent sticks out
16:13:09 <bauzas> ok
16:14:03 <bauzas> ok, moving on then
16:14:14 <bauzas> #topic Review priorities
16:14:17 <bauzas> #topic Review priorities
16:14:25 <bauzas> #link https://review.opendev.org/q/status:open+(project:openstack/nova+OR+project:openstack/placement+OR+project:openstack/os-traits+OR+project:openstack/os-resource-classes+OR+project:openstack/os-vif+OR+project:openstack/python-novaclient+OR+project:openstack/osc-placement)+label:Review-Priority%252B1
16:14:36 <bauzas> most of the priorities were merged
16:15:05 <bauzas> nothing to tell here
16:15:10 <bauzas> let's continue to review
16:15:17 <bauzas> #topic Stable Branches
16:15:21 <bauzas> elodilles: your time
16:15:41 <elodilles> info stable/queens gate fix proposed: https://review.opendev.org/830327 (needs to backport to pike as well)
16:15:44 <elodilles> #info stable/xena gate should be better as Artom's workaround was merged (test_tagged_attachment)
16:15:47 <elodilles> #info stable/wallaby still needs the libvirt_disable_apic to merge + it seems the test_tagged_attachment issue is also present
16:15:50 <elodilles> oops
16:15:52 <elodilles> sorry
16:16:09 <elodilles> anyway, this is mostly it ^^^
16:16:50 <elodilles> we might need the workarounds to stable/victoria too
16:17:31 <elodilles> #info stable/queens gate fix proposed: https://review.opendev.org/830327 (needs to backport to pike as well)
16:17:40 <elodilles> (just to have it in the logs)
16:18:02 <bauzas> :)
16:19:44 <bauzas> thanks elodilles
16:19:50 <elodilles> np
16:19:58 <bauzas> #topic Open discussion
16:20:08 <bauzas> liorf95:  (lior Friedman) https://blueprints.launchpad.net/nova/+spec/nvmeof-multipath
16:20:14 <bauzas> liorf95: your turn
16:20:21 <liorf95> yes please
16:20:23 <bauzas> or I can explain
16:20:32 <bauzas> maybe some of them don't understand the contect
16:20:36 <bauzas> context
16:20:36 <bauzas> so,
16:20:47 <liorf95> we need this bp to be approved for https://review.opendev.org/c/openstack/nova/+/823941
16:21:34 <bauzas> basically we had https://review.opendev.org/c/openstack/nova/+/823941 that was reviewed
16:21:48 <bauzas> and stephenfin and sean-k-mooney accepted the change
16:21:49 <bauzas> but,
16:22:09 <bauzas> as you can look at the comments, we saw it was actually a feature
16:22:51 <bauzas> that's why I accepted to have a discussion in this meeting to see whether folks accept to merge this one even if we had not accepted the blueprint before
16:23:08 <bauzas> for the moment, there is a procedural -2 from me
16:23:38 <bauzas> but if folks agree here to have an exception for https://blueprints.launchpad.net/nova/+spec/nvmeof-multipath as a specless bp, then I could remove it
16:24:07 <bauzas> now, the question : is https://blueprints.launchpad.net/nova/+spec/nvmeof-multipath a specless BP and are folks accepting it as a exception ?
16:24:54 <gibi> I've nothing against it. It is just a volume driver so no spec needed. And the change is really small
16:25:12 <bauzas> correct
16:26:02 <bauzas> change is small and only touching a very few places
16:26:27 <sean-k-mooney> i am supprotive fo doign it as a specless blueprint
16:26:42 <bauzas> ok, anyone having concern ?
16:26:45 <sean-k-mooney> its after teh cutoff but the scale of it is small enought that i think an excption can be made
16:26:55 <bauzas> yeah
16:27:08 <opendevreview> Merged openstack/placement master: Extend the RP db query to support any-traits  https://review.opendev.org/c/openstack/placement/+/825848
16:27:10 <opendevreview> Merged openstack/placement master: DB layer should only depend on trait id not names  https://review.opendev.org/c/openstack/placement/+/826490
16:27:12 <bauzas> basically we have deadlines for accepted blueprints because they change lots of things
16:27:13 <opendevreview> Merged openstack/placement master: Enhance doc of _get_trees_with_traits  https://review.opendev.org/c/openstack/placement/+/825780
16:27:16 <opendevreview> Merged openstack/placement master: Extend the RP tree DB query to support any-traits  https://review.opendev.org/c/openstack/placement/+/825849
16:27:18 <opendevreview> Merged openstack/placement master: Add any-traits support for listing resource providers  https://review.opendev.org/c/openstack/placement/+/826491
16:27:45 <bauzas> so we're procedural not for the sake of being it, but for making sure we are sure how this works
16:27:57 <bauzas> here, I don't see a problem
16:28:04 <gibi> I agree
16:29:00 <bauzas> ok so,
16:30:25 <bauzas> #agreed specless BP for https://blueprints.launchpad.net/nova/+spec/nvmeof-multipath as an exception
16:30:35 <bauzas> liorf95: I'll then remove my -2
16:30:41 <bauzas> and +W it
16:30:45 <bauzas> that's it I had
16:31:00 <liorf95> Thanks a lot for your efforts here
16:33:28 <bauzas> any other topic to discuss as a last minute ?
16:33:36 <gibi> -
16:34:16 <bauzas> looks not
16:34:18 <bauzas> thanks all
16:34:22 <bauzas> #endmeeting