16:00:04 <bauzas> #startmeeting nova
16:00:04 <opendevmeet> Meeting started Tue Mar  8 16:00:04 2022 UTC and is due to finish in 60 minutes.  The chair is bauzas. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:04 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:04 <opendevmeet> The meeting name has been set to 'nova'
16:00:12 <bauzas> hello everyone
16:00:21 <bauzas> #link https://wiki.openstack.org/wiki/Meetings/Nova#Agenda_for_next_meeting
16:00:29 <elodilles> o/
16:01:03 <rribaud__> o/
16:01:09 <gibi> o/
16:01:20 <bauzas> let's start
16:01:28 <bauzas> #topic Bugs (stuck/critical)
16:01:31 <bauzas> damn
16:01:31 * kashyap waves
16:01:33 <bauzas> #topic Bugs (stuck/critical)
16:01:40 <bauzas> #info No Critical bug
16:01:46 <bauzas> #link https://bugs.launchpad.net/nova/+bugs?search=Search&field.status=New 28 new untriaged bugs (+0 since the last meeting)
16:01:50 <gmann> o/
16:01:52 <bauzas> #help Nova bug triage help is appreciated https://wiki.openstack.org/wiki/Nova/BugTriage
16:01:58 <bauzas> #link https://storyboard.openstack.org/#!/project/openstack/placement 26 open stories (-1 since the last meeting) in Storyboard for Placement
16:02:06 <bauzas> I triaged a few of them
16:02:10 <kashyap> bauzas: The call is only on IRC, should we perhaps send a reminder to the list too?
16:02:14 <bauzas> haven't seen any issue fwiw
16:02:24 <kashyap> By "call" I mean, call for helping triage.
16:02:45 <bauzas> kashyap: I see that gibi would be discussed about this during the PTG
16:02:50 <bauzas> discussing*
16:02:57 <gibi> yeah I added to topic
16:02:57 <kashyap> Nod, but that can go on parallely
16:03:39 <bauzas> for the moment, let's continue to do the same, but indeed we should think about it for the PTG
16:04:18 <bauzas> the problem is that I'm not sure that contributors are supported by their managers for upstream bug triage if they do it :)
16:04:53 <gibi> for me it is a bit about allocating a specific timeslot when I focus on bugs
16:04:56 <bauzas> anyway, let's not discuss this by now
16:05:02 <gibi> ack
16:05:18 <bauzas> any bug people want to discuss ?
16:05:21 <bauzas> I have one
16:05:32 <bauzas> #link https://bugs.launchpad.net/nova/+bug/1962726
16:06:14 <kashyap> Ouch
16:06:22 <gibi> that seems like a very valid bug
16:06:38 <kashyap> Yeah, definitely
16:06:40 <bauzas> yeah, but it should not be a bug
16:06:56 <kashyap> Don't say an "RFE"; it's definitely a bug in my eyes :)
16:07:07 <bauzas> at least, I'd say a Wishlist
16:07:18 <gibi> ssh key creation worked before should still work :)
16:07:25 <sean-k-mooney> well didnt we already agree not to add supprot for generating other keytypes
16:07:32 <bauzas> that ^
16:07:34 <sean-k-mooney> we talked about this for the fips work
16:07:42 <sean-k-mooney> and said we shoudl deprecate that part of the api
16:07:56 <sean-k-mooney> tempest was being modifed to generate teh keys its self
16:08:26 <gibi> ohh, so we support importing other ecdsa already
16:08:30 <bauzas> that's why I say it shouldn't be a bug
16:08:32 <gibi> *other like
16:08:55 <sean-k-mooney> nova will accpeat any public key you provide and we also support x509 certs for windows
16:09:13 <sean-k-mooney> we just dont support turning the parmaters if you ask nova ot generate the key
16:09:17 <gibi> then yeah, I can be convinced to drop the key generation support
16:09:30 <kashyap> gibi: Good to know; I've read somewhere (unless I'm hallucinating) that ECDSA keys weren't supported
16:09:38 <bauzas> importing should continue to work
16:09:46 <bauzas> generating should stop if so
16:09:49 <bauzas> but,
16:09:55 <sean-k-mooney> kashyap: there was a limiation imposed by pycryptography
16:10:00 <bauzas> "should" means a spec I guess
16:10:14 <bauzas> definitely not a bug
16:10:15 <sean-k-mooney> we use the ssh public key to encypt some things
16:10:35 <sean-k-mooney> so if you use a ECDSA key you need a pycryptography version that also supprot it
16:10:46 <sean-k-mooney> but i belive our min requiremnts cover that now
16:10:49 <gibi> bauzas: so a spec for removing ssh key generation support in a new microversion
16:10:57 <gibi> bauzas: as far as I understand
16:11:02 <sean-k-mooney> +1
16:11:05 <bauzas> yup
16:11:09 <gibi> works for me
16:11:38 <bauzas> I can ask the reporter at least but I'm not sure he would do it :)
16:12:04 <bauzas> if we really want to deprecate the generation, someone elso would need to provide the spec
16:12:08 <gibi> let's add it to the PTG etherpad to see if somebody volunteers
16:12:15 <bauzas> yup
16:12:28 <sean-k-mooney> i mean i can proably do it if no one else puts there hand pu
16:12:37 <bauzas> I'll close the bug and say we'll discuss this at the PTG
16:12:54 <gibi> sean-k-mooney: I will have free time too probably ;)
16:12:57 <bauzas> sean-k-mooney: I'm just afraid of deprecating it without explaining why correctly
16:13:07 <sean-k-mooney> im pretty sure we have a downstream bug for this which we set to wontfix
16:13:24 <sean-k-mooney> ack ya we shoudl explain the reasoning in the spec
16:13:32 <bauzas> anyway, closing the upstream bug and discussing this at the TPG
16:13:40 <bauzas> .
16:13:46 <bauzas> any other bug ?
16:13:50 <gibi> -
16:13:56 <bauzas> cool, moving on
16:14:09 <bauzas> #topic Gate status
16:14:14 <bauzas> #link https://bugs.launchpad.net/nova/+bugs?field.tag=gate-failure Nova gate bugs
16:14:19 <bauzas> #link https://zuul.openstack.org/builds?project=openstack%2Fplacement&pipeline=periodic-weekly Placement periodic job status
16:14:24 <bauzas> #info Please look at the gate failures and file a bug report with the gate-failure tag.
16:14:39 <bauzas> nothing new here
16:15:04 <bauzas> and I haven't seen any CI job failure for the moment
16:15:09 <bauzas> moving on, then ,
16:15:11 <bauzas> ?
16:16:01 <bauzas> looks so
16:16:14 <bauzas> there it goes to the crux
16:16:16 <bauzas> #topic Release Planning
16:16:19 <bauzas> #topic Release Planning
16:16:26 <bauzas> #link https://releases.openstack.org/yoga/schedule.html#y-rc1 RC1 is now due on March 10th
16:16:32 <bauzas> #link https://etherpad.opendev.org/p/nova-yoga-rc-potential Etherpad for RC tracking
16:16:50 <bauzas> the etherpad is pretty silent
16:16:59 <sean-k-mooney> i have one other bug to add to that
16:17:07 <bauzas> cool then
16:17:09 <opendevreview> sean mooney proposed openstack/nova master: reenable greendns in nova.  https://review.opendev.org/c/openstack/nova/+/830966
16:17:10 <sean-k-mooney> https://bugs.launchpad.net/nova/+bug/1964149
16:17:13 <sean-k-mooney> that one ^
16:17:21 <bauzas> we only have 2 days and fwiw the RC1 patch is already created
16:17:44 <bauzas> #link https://review.opendev.org/c/openstack/releases/+/832412 RC1 patch for nova
16:17:54 <bauzas> I'll -1 until we merge what we want
16:17:56 <bauzas> elodilles: ^
16:18:00 <elodilles> bauzas: ack
16:18:17 <gibi> sean-k-mooney: I will check after the meeting
16:18:44 <sean-k-mooney> gibi: ack
16:19:11 <bauzas> that being said, I'm happy with +1ing https://review.opendev.org/c/openstack/releases/+/832416
16:19:29 <bauzas> do people are afraid if we merge the placement RC1 change by now ?
16:19:49 <bauzas> I haven't seen any bugfixes so far needing to hold
16:20:08 <gibi> I have no objections
16:20:38 <sean-k-mooney> i dont think we have anything pendign for placement
16:20:42 <sean-k-mooney> so no objection
16:21:15 <bauzas> cool, will do after the meeting
16:21:45 <bauzas> so, I'll review the RC1 related bugs today and tomorrow
16:22:06 <bauzas> any other bug people think it would be needed to merge before RC1 ?
16:22:41 <bauzas> reminder, after RC1, we branch stable/yoga which means that only regression bugs would be accepted for RC2 and other RCs
16:23:22 <bauzas> any other bugfix would need to hold until Yoga GA (end of March) for being backported to stable/yoga
16:23:59 <bauzas> and those bugfixes wouldn't be within 25.0.0 release, but rather a later stable release (per say, 25.0.1 or other)
16:24:09 <elodilles> yes, that's an important info ^^^
16:24:35 <bauzas> I have said it loud
16:24:39 <elodilles> :]
16:24:56 <bauzas> if you care abour your bugs, it's your time
16:25:07 <bauzas> 1.
16:25:09 <bauzas> 2.
16:25:10 <bauzas> 3.
16:25:13 <bauzas> ok, done.
16:26:25 <bauzas> #info reminder, thursday is the last day for merging bugfixes in 25.0.0 release, other bugfixes would need to wait after Yoga GA (end of march) to be backported in a later stable release
16:26:52 <elodilles> thanks :]
16:27:03 <bauzas> #info as a notice, please provide the changes you'd like nova cores to look at before end of Wed in https://etherpad.opendev.org/p/nova-yoga-rc-potential
16:27:15 <bauzas> now, this is even louder
16:27:27 <elodilles> indeed
16:27:36 <bauzas> last item I have on RC1
16:27:52 <bauzas> #link https://review.opendev.org/c/openstack/nova/+/832292 Prelude patch that needs to be merged before RC1
16:28:06 <bauzas> I have seen gmann, dansmith and melwitt reviewing it
16:28:06 <gibi> bauzas: I left a comment before the meeting on the prelude
16:28:12 <bauzas> gibi: ack, will look
16:28:38 <bauzas> reminder, we need to merge this one *before RC1* or we wouldn't have a prelude for 25.0.0 and operators wouldn't like it :p
16:29:03 <bauzas> elodilles: as a reminder, this prelude patch is holding the RC1 patch
16:29:09 <gmann> policy statements lgtm, thanks bauzas
16:29:17 <bauzas> kk
16:29:28 <bauzas> let's continue to look at this change before end of Thursday then
16:29:33 <bauzas> that's it for me
16:29:33 <elodilles> bauzas: ack
16:29:59 <bauzas> next topic, I guess ?
16:30:11 <bauzas> this is time of the year
16:30:14 <bauzas> #topic PTG preparation
16:30:25 <bauzas> I've created an etherpad
16:30:27 <bauzas> #link https://etherpad.opendev.org/p/nova-zed-ptg Nova Zed PTG etherpad
16:30:56 <bauzas> and hopefully you saw that I provided 4 options for the PTG schedule
16:31:25 <bauzas> do people want me to tell them before we officially vote ?
16:31:44 <gmann> sure
16:31:55 <bauzas> Option A "The short one"  : we ask for 3 days from Wednesday to Friday with 4 hours each (13UTC-17UTC)
16:32:04 <bauzas> Option B "The week used": we ask for 4 days from Tuesday to Friday with 3 hours each (14UTC-17UTC)
16:32:12 <bauzas> Option C "The largest one" : we ask for 4 days from Tuesday to Friday with 4 hours each (13UTC-17UTC)
16:32:21 <bauzas> Option D "The Asian-nice one" : we ask for Wed to Friday with 3 hours each (14UTC-17UTC) but we also ask for Thursday with 2 hours (6UTC-8UTC)
16:32:29 <bauzas> take a few time to think about them
16:32:50 <bauzas> in 1 min, I'll start a vote
16:33:12 <bauzas> once we vote, I'll officially provide the schedule to the fondation folks
16:33:44 <bauzas> (hopefully meetbot will work this time with the startvote bot)
16:33:59 <bauzas> #link  http://lists.openstack.org/pipermail/openstack-discuss/2022-March/027529.html Proposed options for the PTG schedule
16:34:06 <bauzas> let's start the vote
16:34:14 <bauzas> #startvote Which schedule option do you prefer for the PTG ? (A, B, C, D, other)
16:34:14 <opendevmeet> Begin voting on: Which schedule option do you prefer for the PTG ? Valid vote options are , A, B, C, D, other, .
16:34:14 <opendevmeet> Vote using '#vote OPTION'. Only your last vote counts.
16:34:26 <bauzas> #vote B
16:34:40 <gmann> #vote B
16:34:41 <gibi> #vote B
16:34:54 <gibi> (or D if we forsee some topics from Asia)
16:34:55 <sean-k-mooney> #vote B
16:35:05 <elodilles> #vote B
16:35:18 <bauzas> gibi: I can ask for a specific timeslot if needed
16:35:22 <bauzas> after that
16:35:50 <bauzas> I'm pretty sure the foundation folks wouldn't be against
16:36:09 <gibi> yeah, I agree
16:36:14 <bauzas> ok, any other vote ? I'll close the vote in 30 sec
16:36:16 <gibi> and I can be present
16:36:20 <bauzas> me too
16:36:46 <bauzas> #endvote
16:36:46 <opendevmeet> Voted on "Which schedule option do you prefer for the PTG ?" Results are
16:36:46 <opendevmeet> B (5): gibi, sean-k-mooney, elodilles, bauzas, gmann
16:37:19 <bauzas> #agreed option B for the PTG schedule, we'll have 4 days from Tuesday to Friday with 3 hours each (14UTC-17UTC)
16:37:25 * gibi pats meetbot's head
16:37:43 <bauzas> I'm glad this worked
16:37:51 <bauzas> this was fun
16:37:55 <bauzas> moving on
16:37:55 <gmann> +1, better way to do than doodle :P
16:38:04 <bauzas> #topic Review priorities
16:38:04 <dansmith> gmann: :P
16:38:18 <bauzas> #link https://review.opendev.org/q/status:open+(project:openstack/nova+OR+project:openstack/placement+OR+project:openstack/os-traits+OR+project:openstack/os-resource-classes+OR+project:openstack/os-vif+OR+project:openstack/python-novaclient+OR+project:openstack/osc-placement)+label:Review-Priority%252B1
16:38:21 <sean-k-mooney> well the only advantage of doodle is its async if you cant be here
16:38:37 <bauzas> sean-k-mooney: that's why I said people can vote on the etherpad if they want
16:38:41 <dansmith> sean-k-mooney: doodle has been causing trouble lately
16:38:44 <sean-k-mooney> ah
16:38:50 <dansmith> hence my tongue-in-cheek
16:38:55 <sean-k-mooney> dansmith: ack
16:39:00 <bauzas> sean-k-mooney: but I haven't seen anyone doing it but me
16:39:37 <bauzas> ok, about the review prios, nothing to tell
16:39:51 <bauzas> I'm happy to see we have the important bugfixes related to RC1 be there
16:40:06 <bauzas> thanks to the one who labeled them
16:40:35 <bauzas> I guess we have nothing to say
16:40:40 <bauzas> so we can move on quickly
16:40:55 <bauzas> for the sake of the audience :)
16:41:14 <bauzas> #topic Stable Branches
16:41:19 <bauzas> elodilles: take the mic
16:41:23 <elodilles> #info queens and pike branches are blocked
16:41:31 <elodilles> #info stable/queens gate fix waiting for 2nd +2: https://review.opendev.org/830327 (needs to be backported to pike as well)
16:41:42 <elodilles> release patches (xena, wallaby, victoria): https://review.opendev.org/q/project:openstack/releases+intopic:nova+is:open
16:42:01 <elodilles> hopefully they will be accepted soon ^^^
16:42:04 <bauzas> for once, I'm happy to say I made my homework :)
16:42:09 <elodilles> by 2nd release core
16:42:22 <elodilles> bauzas: :) thanks! :)
16:42:46 <elodilles> though victoria patch could use a PTL-approved ;)
16:42:54 <elodilles> * flag :)
16:43:09 <bauzas> elodilles: yup, because the PTL said no before for the previous revision :p
16:43:24 <elodilles> true :)
16:43:28 <bauzas> but I have seen you rebased, so I'll vote
16:43:35 <bauzas> easy peasy
16:43:42 <elodilles> bauzas: ack, thx
16:43:44 <bauzas> nothing other to add ?
16:43:50 <elodilles> and i think that's it
16:43:59 <elodilles> nothing else
16:44:19 <bauzas> k
16:44:33 <bauzas> #topic Open discussion
16:44:38 <bauzas> nothing on the agenda
16:44:43 <bauzas> any item before we close ?
16:45:38 <bauzas> OK, if so
16:45:48 <bauzas> let's call it's 15 to beer o'clock
16:45:51 <bauzas> #endmeeting