16:00:16 <bauzas> #startmeeting nova
16:00:16 <opendevmeet> Meeting started Tue Mar 22 16:00:16 2022 UTC and is due to finish in 60 minutes.  The chair is bauzas. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:17 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:17 <opendevmeet> The meeting name has been set to 'nova'
16:00:21 <bauzas> hey ho
16:00:24 <elodilles> o/
16:00:26 <chateaulav> \o
16:00:33 <bauzas> #link https://wiki.openstack.org/wiki/Meetings/Nova#Agenda_for_next_meeting
16:00:45 <gmann> o/
16:00:50 <dansmith> o/
16:01:24 <artom> ~o~
16:01:30 <bauzas> ok, let's start
16:01:35 <bauzas> #topic Bugs (stuck/critical)
16:01:40 <bauzas> #info No Critical bug
16:01:44 <bauzas> #link https://bugs.launchpad.net/nova/+bugs?search=Search&field.status=New 28 new untriaged bugs (+0 since the last meeting)
16:01:48 <bauzas> #help Nova bug triage help is appreciated https://wiki.openstack.org/wiki/Nova/BugTriage
16:01:53 <bauzas> #link https://storyboard.openstack.org/#!/project/openstack/placement 26 open stories (0 since the last meeting) in Storyboard for Placement
16:02:02 <bauzas> any bug in particular to discuss ?
16:02:17 <bauzas> I triaged a few of them but I need to create some env for verifying some others
16:03:07 <bauzas> ok, looks not
16:03:10 <bauzas> next,
16:03:15 <bauzas> #topic Gate status
16:03:18 <bauzas> #link https://bugs.launchpad.net/nova/+bugs?field.tag=gate-failure Nova gate bugs
16:03:23 <bauzas> #link https://zuul.openstack.org/builds?project=openstack%2Fplacement&pipeline=periodic-weekly Placement periodic job status
16:03:26 <bauzas> #info Please look at the gate failures and file a bug report with the gate-failure tag.
16:03:33 <bauzas> I haven't seen any new problem
16:04:14 <gmann> one update for centos9 stream volume detach failure
16:04:35 <gmann> it is fixed now as SSH-able series is merged #link https://review.opendev.org/q/(topic:bug/1960346+OR+topic:wait_until_sshable_pingable)+status:merged
16:04:48 <gmann> I have made centos9-stream as voting job in tempest gate
16:04:53 <bauzas> \o/
16:05:05 <dansmith> gmann: really, that makes it all pass reliably?
16:05:16 <gmann> and proposed to be voting in devstack side too #link https://review.opendev.org/c/openstack/devstack/+/834546
16:05:22 <gmann> dansmith: for now yes:)
16:05:26 <dansmith> cool
16:05:49 <dansmith> fips job in glance was still failing this morning I think, but I will look and see if it ran against that or not
16:05:52 <gmann> and we will monitor it carefully now as we made it voting. n-v jobs always gets ignored somehow
16:05:57 <dansmith> yeah cool
16:06:13 <artom> So I wonder, would there be anything else to understand at the guest:host interaction level to understand why Ubuntu doesn't need to wait for SSHABLE?
16:06:43 <dansmith> artom: I'm super curious as well, as this seems like an odd thing to have changed with just newer libvirt/qemu, although certainly possible
16:06:54 <dansmith> we'll see if more weirdness comes out of running it in the full firehose
16:07:03 <gmann> dansmith: yeah, you can try with recheck. this patch fixed the last test #link https://review.opendev.org/c/openstack/tempest/+/831608
16:07:04 <bauzas> agreed, it's weird but ok
16:07:07 <dansmith> as I was seeing other problems (on stream 8 mind you) when we were running it voting
16:07:29 <bauzas> thanks gmann btw. for having worked on it :)
16:07:51 <gmann> np!, just carried lyarwood  work in this.
16:07:53 <bauzas> can we move ?
16:08:13 <gmann> yeah
16:08:40 <bauzas> kk
16:08:48 <bauzas> #topic Release Planning
16:08:50 <bauzas> shit
16:08:51 <bauzas> #topic Release Planning
16:08:56 <bauzas> #link https://releases.openstack.org/yoga/schedule.html#y-rc1 RC1 is past now
16:09:01 <bauzas> #link https://etherpad.opendev.org/p/nova-yoga-rc-potential Etherpad for RC tracking
16:09:05 <bauzas> #link https://bugs.launchpad.net/nova/+bugs?field.tag=yoga-rc-potential RC potential tags
16:09:14 <bauzas> this is Regression chasing time !
16:09:33 <bauzas> we only have 2 days to provide a RC2 if we find a regression
16:09:45 <bauzas> for the moment, we haven't see any of them
16:10:05 <bauzas> #info RC2 deadline is in 2 days, so we can only fix regressions before
16:10:21 <bauzas> actually, this is RC-deadline
16:10:28 <bauzas> not really a specific RC2
16:10:46 <bauzas> we could have a RC2 release tomorrow and then a RC2 on Thursday
16:10:51 <bauzas> shit, RC3 on Thurs
16:11:01 * dansmith watches where he steps in here
16:11:51 <bauzas> this is just, either we find regressions before Thursday and then we need to merge the changes before, or we would have a Yoga GA release with some known issue and we could only fix the regression by a next stable release
16:12:13 <bauzas> but, as you can see https://bugs.launchpad.net/nova/+bugs?field.tag=yoga-rc-potential is empty
16:12:41 <bauzas> anyway
16:13:02 <bauzas> that's it for me
16:13:25 <bauzas> any question or discussion for Yoga before we go to the next topic ?
16:14:19 <bauzas> looks not
16:14:37 <bauzas> #topic PTG preparation
16:14:44 <bauzas> #link https://etherpad.opendev.org/p/nova-zed-ptg Nova Zed PTG etherpad
16:15:27 <bauzas> nothing to say, please provide your topics you would like to discuss
16:16:03 <bauzas> the PTG will be in 2 weeks, so I'd prefer to see all the topics before end of the next week
16:16:08 <bauzas> for the moment, we only have a few of them
16:16:53 <bauzas> anything to discuss about the PTG ?
16:17:36 <bauzas> reminder, PTG will be April 4 - 8, 2022
16:17:42 <Uggla> bauzas, sorry for the noob question, will we review bp/specs for zed ?
16:18:06 <bauzas> Uggla: no worries, it's your first PTG
16:18:34 <Uggla> should we put the bp/specs in the agenda ?
16:18:34 <bauzas> Uggla: in general, we discuss about some specs if people have some stuff they'd like to see the community to find a consensus
16:18:51 <bauzas> Uggla: we don't generally look at all the open specs
16:19:15 <bauzas> people can also go and discuss about something they'd like to see or work, without having a spec yes
16:19:17 <bauzas> yet*
16:19:46 <bauzas> Uggla: look at the Xena PTG we had so you'll see what we discussed https://etherpad.opendev.org/p/nova-xena-ptg
16:20:58 <Uggla> bauzas, I will have a look, thanks.
16:21:07 <bauzas> ok, moving on, then
16:21:28 <bauzas> #topic Review priorities
16:21:34 <bauzas> #link https://review.opendev.org/q/status:open+(project:openstack/nova+OR+project:openstack/placement+OR+project:openstack/os-traits+OR+project:openstack/os-resource-classes+OR+project:openstack/os-vif+OR+project:openstack/python-novaclient+OR+project:openstack/osc-placement)+label:Review-Priority%252B1
16:22:16 <artom> (No osc/sdk in there?)
16:22:16 <bauzas> I have seen new changes
16:22:32 <artom> (What with moving towards deprecation of the novaclient CLI)
16:22:44 <bauzas> artom: nope
16:23:38 <bauzas> artom: osc is another community but I understand your point
16:23:58 <bauzas> artom: this is just, this label is only supported for our repos
16:24:10 <artom> Ah, right
16:24:11 <bauzas> (AFAIK)
16:24:22 <sean-k-mooney> artom: we deprecated teh novaclint cli already
16:24:30 <artom> Yeah, I wasn't sure
16:24:35 <bauzas> artom: but if you want us to look at OSC changes, we can do this by some etherpad
16:24:38 <sean-k-mooney> the python binding are still allowed to be extended
16:25:11 <bauzas> artom: but you know what ? let's discuss this at the PTG to see how the nova community can review those OSC changes :)
16:25:23 <bauzas> artom: hopefully you'll provide a topic, right?
16:25:24 <bauzas> :)
16:26:09 <artom> Shoudve kept my fat mouth shut :P
16:26:11 * artom will
16:26:24 <bauzas> artom: :p
16:26:29 <bauzas> moving on
16:26:34 <bauzas> #topic Stable Branches
16:26:37 <bauzas> elodilles: your point
16:26:41 <elodilles> #info xena branch seems to be blocked by nova-tox-functional-centos8-py36 job - https://zuul.opendev.org/t/openstack/builds?job_name=nova-tox-functional-centos8-py36
16:26:54 <elodilles> #info pike branch is blocked - fix: https://review.opendev.org/c/openstack/nova/+/833666
16:27:10 <elodilles> and finally a reminder:
16:27:15 <elodilles> Victoria Extended Maintenance transition is due ~ in a month (2022-04-27)
16:27:33 <bauzas> wow, time flies
16:27:44 <elodilles> yes yes
16:28:09 <elodilles> that's it i think
16:28:12 <bauzas> elodilles: can we make the centos8 job non-voting ?
16:28:23 <elodilles> bauzas: that's an option
16:28:43 <bauzas> does someone already look at the issue ?
16:28:53 <elodilles> i had a quick look only
16:29:07 <artom> Seems to be spurious...
16:29:11 <bauzas> elodilles: ping me tomorrow morning and we'll jump onto it
16:29:18 <artom> The last few runs passed
16:29:18 <elodilles> it seems to be related to some mirror issue, but not sure
16:29:28 <bauzas> artom: not the stable/xena branch
16:29:55 <gmann> yeah seems mirror issue otherwise we can see same version conflict in other places also
16:29:55 <elodilles> bauzas: sure, thanks
16:30:04 <artom> ... then which? stephenfin has a fix up for the pike one, looks like...
16:30:21 <artom> So 'NFO: pip is looking at multiple versions of openstack-placement' is new, no?
16:30:33 <bauzas> for the pike branch, agreed on reviewing the fix
16:30:35 <artom> On my laptop, for stable/ussuri, it's taking forever
16:30:58 <gmann> elodilles: let's wait for few more run.
16:31:10 <bauzas> I don't want us to dig into the job resolution for now
16:31:23 <bauzas> but people can start looking at it after the meeting if they want
16:31:40 <elodilles> gmann: ack
16:31:40 <bauzas> this is just, I don't want this branch holding because of one single job
16:32:06 <bauzas> gmann: elodilles: I'd appreciate some DNM patches to make sure we don't hit this every change
16:33:15 <bauzas> looks we discuss all the thingies by now
16:33:20 <bauzas> discussed*
16:33:25 <bauzas> can we move ?
16:33:30 <gmann> did recheck on 828413, let's see
16:33:54 <bauzas> gmann: ++
16:34:11 <elodilles> yes, thanks, let's move on
16:35:15 <bauzas> last topic then
16:35:21 <bauzas> #topic Open discussion
16:35:24 <bauzas> I have one
16:35:32 <bauzas> (bauzas) Upgrade our minimum service check https://review.opendev.org/c/openstack/nova/+/833440
16:35:50 <bauzas> takashi gently provided a changes for bumping our min version support
16:36:10 <bauzas> before merging it, I'd like to make sure all people here agree on it
16:36:24 <dansmith> so one thing we might want to consider,
16:36:32 <bauzas> (that said, there is a grenade issue on its change, so even with +Wing it...)
16:36:48 <dansmith> is a PTG topic about the check (and the problems with it that we didn't foresee) to see if there's any better way we could or should be doing that whole thing
16:36:56 <dansmith> and just punt on the patch until we have that discussion
16:37:34 <bauzas> I already opened a PTG topic
16:37:46 <bauzas> I'll add the service check in it
16:37:52 <dansmith> okay
16:39:00 <bauzas> just done
16:39:07 <bauzas> people agree with this plan ?
16:39:22 <bauzas> either way, as said the change itself has grenade issues that need to be fixed
16:39:43 <bauzas> and I don't see any reason for rushing on it being merged
16:39:49 <bauzas> we have the whole zed timeframe for this
16:40:05 <elodilles> (grenade issue might be because devstack does not have yet stable/yoga)
16:40:34 <elodilles> (so that should be OK in 1 or 2 days)
16:40:40 <bauzas> we haven't released stable/yoga
16:40:53 <bauzas> this will be done on next Wed
16:41:12 <bauzas> elodilles: but yeah, sounds this
16:41:30 <elodilles> ++
16:41:31 <gmann> yeah, we should do that soon, neutron face same ssue.
16:41:41 <gmann> elodilles: I will discuss in release channel
16:41:48 <elodilles> gmann: ack
16:43:18 <bauzas> ok, I guess we're done then
16:43:50 <artom> Oh, can we chat about https://review.opendev.org/c/openstack/nova/+/833453?
16:43:53 <bauzas> #agreed let's hold https://review.opendev.org/c/openstack/nova/+/833440 until we correctly discuss this at the PTG
16:44:21 * bauzas clicks on artom's patch
16:44:52 <artom> Really only bringing it up here because, as a periodic, we'd have to check up on the status, presumably here
16:44:56 <artom> Here == the meeting
16:45:13 <bauzas> artom: yeah, that's my point
16:45:24 <bauzas> we already do a few checks during the gate topic
16:45:45 <bauzas> but I wonder whether that wouldn't be better if we could agree on this at the PTG
16:46:19 <EugenMayer> is it possible to set the flavor of an instance manually using the api?
16:46:49 <EugenMayer> Oh - sorry. Still meeting time. Ignore me.
16:46:55 <artom> bauzas, doesn't seem controversial, but OK :)
16:47:07 <bauzas> artom: yup, I don't disagree
16:47:24 <bauzas> do people have concerns with adding a periodic check on whitebox ?
16:47:29 <artom> I guess the downside is CI resource usage, but... one nightly job seems OK?
16:47:58 <bauzas> I heard news of some CI resource shortage, but I'm not in the TC
16:48:10 <artom> Yet ;)
16:48:19 <bauzas> dansmith: gmann: can we just add a periodic job without being concerned ?
16:48:20 <artom> dansmith said someone is pulling out
16:48:31 <artom> (phrasing </archer>)
16:48:39 <dansmith> periodic is probably not a big deal I would imagine
16:48:54 <dansmith> I think we're going to need to trim down nova's per-patch jobs too, as it's getting pretty heavy
16:49:40 <bauzas> yeah, I don't think this is a big thing if we add a periodic
16:49:58 <bauzas> dansmith: adding a PTG topic about it fwiw
16:49:58 <gmann> yeah, and periodic also we can see if daily or weekly?
16:50:56 <bauzas> tbh, the only matter is how much we'll check its status and that will be weekly (during the team meeting)
16:51:04 <gmann> bauzas: artom along with periodic, add in experimental pipeline too for manual trigger. that helps to avoid adding it in check/gate pipeline if anyone want to run maually
16:51:38 <artom> bauzas, yep, no point in making it daily if we're only checking the status weekly
16:51:44 <artom> gmann, ack, can do
16:51:45 <gmann> +1
16:51:57 <dansmith> yeah daily seems excessive
16:53:07 <bauzas> artom: update this change with the weekly period time and mention in the commit msg we'll need to verify it during weekly meetings
16:53:34 * artom will have to find example of periodic weekly to figure out the correct Zuul words magic
16:53:43 <bauzas> look at the placement ones
16:53:50 <artom> Oh yeah!
16:53:56 <gmann> artom: https://github.com/openstack/placement/blob/master/.zuul.yaml#L64
16:54:00 <gmann> yeah
16:54:14 <artom> Hah, that was easy
16:54:15 <bauzas> this is another pipeline IIRC
16:54:20 <sean-k-mooney> by the way i think weekly jobs in general suit use better as we can review them in the weekly meeting
16:54:32 <sean-k-mooney> if we have a nightly we proably wont look at it every day
16:54:38 <bauzas> oh yeah
16:54:51 <bauzas> I just hope this meeting won't transform into some CI meeting
16:54:57 <chateaulav> artom: nova zuul has an example of weekly periodic now
16:55:02 <bauzas> if we start adding more periodics
16:55:22 <artom> I mean, feel free to nack the idea entirely :)
16:55:29 <sean-k-mooney> bauzas: well it should just be (are they green no we shoudl look at X after the meeting)
16:55:31 <artom> I'll obviously try to debate/convince you
16:55:37 <bauzas> artom: nah, I like the idea, I just want us to buy it
16:55:47 <artom> But if we think whitebox doesn't bring value to Nova CI, let's just not do it :)
16:56:04 <bauzas> we're approaching meeting's end time
16:56:14 <artom> End times are nigh
16:56:18 <bauzas> any other item to mention before we close ?
16:56:19 <sean-k-mooney> :)
16:56:27 * artom gets raptured
16:56:33 <sean-k-mooney> ah i actully had two blueprints i wanted to raise
16:56:47 <sean-k-mooney> we defered updating the defaults for allcoation ratios
16:57:00 <bauzas> sean-k-mooney: oh I forgot to mention I changed Launchpad to reflect zed as the active series
16:57:16 <sean-k-mooney> shall we proceed with that or discuss at ptg
16:57:29 <sean-k-mooney> also kasyaps blueprint for usign the new libvirt apis
16:57:35 <bauzas> we're a bit short in time for reapproving specless bps by now
16:57:37 <sean-k-mooney> can we retarget both to zed
16:57:45 <sean-k-mooney> ack
16:57:51 <bauzas> but we can look at them during next meeting
16:57:52 <sean-k-mooney> we can disucss it next week or at ptg
16:58:03 <bauzas> well, Zed is open
16:58:13 <bauzas> I'm OK with approving things by now
16:58:19 <bauzas> and the specs repo is ready
16:58:50 <bauzas> sean-k-mooney: just propose your two blueprints for the next meeting so we'll reapprove them (unless concerns of course)
16:59:04 <sean-k-mooney> ack
16:59:29 <bauzas> fwiw, I leave the non-implemented blueprints in Deferred state
17:00:01 <bauzas> once we start reapproving some, I'd change back their state
17:00:11 <bauzas> but anyway, we're on time
17:00:13 <bauzas> thanks all
17:00:16 <bauzas> #endmeeting