16:00:34 <bauzas> #startmeeting nova
16:00:34 <opendevmeet> Meeting started Tue Apr 19 16:00:34 2022 UTC and is due to finish in 60 minutes.  The chair is bauzas. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:34 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:34 <opendevmeet> The meeting name has been set to 'nova'
16:00:45 <bauzas> heya folks
16:00:51 <bauzas> #link https://wiki.openstack.org/wiki/Meetings/Nova#Agenda_for_next_meeting
16:01:02 <bauzas> who's around ?
16:01:04 <dansmith> o/
16:01:11 <chateaulav> \o
16:01:12 <elodilles> o/
16:01:15 <gibi> \o
16:02:05 <bauzas> okay I guess we can start
16:02:10 <bauzas> let's try to have a quick meeting
16:02:14 <bauzas> #topic Bugs (stuck/critical)
16:02:18 <bauzas> #info No Critical bug
16:02:22 <bauzas> #link https://bugs.launchpad.net/nova/+bugs?search=Search&field.status=New 35 new untriaged bugs (-3 since the last meeting)
16:02:26 <bauzas> #link https://storyboard.openstack.org/#!/project/openstack/placement 26 open stories (0 since the last meeting) in Storyboard for Placement
16:02:30 <bauzas> #info Add yourself in the team bug roster if you want to help https://etherpad.opendev.org/p/nova-bug-triage-roster
16:02:38 <bauzas> I did some triage this week
16:02:44 <bauzas> we had like 41 new bugs
16:02:54 <bauzas> so eventually I triaged 6 of them
16:03:15 <bauzas> I still need to create some environment for verifying some bugs
16:03:33 <bauzas> but now, I'll pass the bug triage baton to someone else as we agreed on the PTG :)
16:03:43 <gibi> I'm happy to take it :)
16:03:50 <bauzas> do we want to have a name for it ? :)
16:04:12 <bauzas> looks like bug czar is not accepted :p
16:04:25 <gibi> the-one-who-triage-the-bugs :D
16:04:29 <bauzas> lol
16:04:40 <bauzas> anyway,
16:05:02 <bauzas> #info Next bug triage baton is passed to gibi
16:05:15 <bauzas> voila
16:05:23 <bauzas> any bug to discuss ?
16:05:45 <bauzas> gibi: I'll try to help you btw. as I'm creating a new environment
16:05:54 <gibi> bauzas: thanks
16:06:02 <bauzas> next topic then
16:06:07 <bauzas> #topic Gate status
16:06:12 <bauzas> #link https://bugs.launchpad.net/nova/+bugs?field.tag=gate-failure Nova gate bugs
16:06:16 <bauzas> #link https://zuul.openstack.org/builds?project=openstack%2Fplacement&pipeline=periodic-weekly Placement periodic job status
16:06:21 <bauzas> #link https://zuul.opendev.org/t/openstack/builds?job_name=nova-emulation&pipeline=periodic-weekly&skip=0 Emulation periodic job runs
16:06:26 <bauzas> chateaulav: ^ ;)
16:06:31 <bauzas> #info Please look at the gate failures and file a bug report with the gate-failure tag.
16:06:35 <bauzas> #info STOP DOING BLIND RECHECKS aka. 'recheck' https://docs.openstack.org/project-team-guide/testing.html#how-to-handle-test-failures
16:06:50 <dansmith> ++
16:07:29 <gmann> ++
16:07:39 <bauzas> nothing to tell about the gate CI ?
16:07:57 <bauzas> chateaulav: looks like the periodic jobs work :)
16:08:12 <chateaulav> sure do
16:09:02 <bauzas> cool
16:09:14 <bauzas> #topic Release Planning
16:09:22 <bauzas> #link https://releases.openstack.org/zed/schedule.html
16:09:26 <bauzas> #info Zed-1 is due in 4 weeks
16:09:42 <bauzas> I'll ask next week for a spec review day
16:09:51 <bauzas> start to think about it
16:10:02 <bauzas> maybe sometimes around Zed-1
16:10:18 <bauzas> nothing to tell apart of this
16:11:46 <bauzas> ok, moving on
16:11:51 <bauzas> #topic Review priorities
16:11:57 <bauzas> #link https://review.opendev.org/q/status:open+(project:openstack/nova+OR+project:openstack/placement+OR+project:openstack/os-traits+OR+project:openstack/os-resource-classes+OR+project:openstack/os-vif+OR+project:openstack/python-novaclient+OR+project:openstack/osc-placement)+label:Review-Priority%252B1
16:12:17 <bauzas> I'll continue to review stephenfin's changes for SQLA
16:12:20 <bauzas> 2.0
16:13:02 <gibi> it is on my list too
16:13:42 <bauzas> cool
16:13:47 <bauzas> moving on again
16:13:54 <bauzas> #topic Stable Branches
16:13:57 <bauzas> elodilles: ^
16:14:06 <elodilles> #info xena branch is blocked until 'l-c drop' patches merge - https://review.opendev.org/q/I514f6b337ffefef90a0ce9ab0b4afd083caa277e
16:14:17 <elodilles> #info victoria and older branches are blocked by devstack issue - this needs to be backported for older branches (?): https://review.opendev.org/q/I941ef5ea90970a0901236afe81c551aaf24ac1d8
16:14:23 <elodilles> #info stable/victoria Extended Maintenance transition is due ~ in a week (2022-04-27) - we don't have much time to land patches and release them (especially with broken gate)
16:14:27 <elodilles> EOM
16:14:41 <dansmith> elodilles: I'll be glad to +2 those :)
16:14:56 <elodilles> dansmith: roger :)
16:14:56 <gmann> elodilles: victoria should be good now
16:15:01 <opendevreview> Erlon R. Cruz proposed openstack/nova stable/xena: stable/xena: Fix lower-constraint job  https://review.opendev.org/c/openstack/nova/+/838509
16:15:02 <opendevreview> Erlon R. Cruz proposed openstack/nova stable/xena: Fix pre_live_migration rollback  https://review.opendev.org/c/openstack/nova/+/836015
16:15:03 <opendevreview> Erlon R. Cruz proposed openstack/nova stable/xena: Adds regression test for bug LP#1944619  https://review.opendev.org/c/openstack/nova/+/838550
16:15:18 <elodilles> gmann: isn't that depend on ussuri?
16:15:24 <gmann> stable/ussuri or less are broken, I will backport the fix in stable/ussuri as I need to pin tempest there.
16:16:04 <elodilles> gmann: i mean, for stable/victoria gate to work in nova we should have devstack's stable/ussuri fixed
16:16:04 <gmann> but table/train or less, someone need to backport if we want to fix or just time to EOL?
16:16:07 <dansmith> is melwitt around?
16:16:26 <dansmith> I'm thinking that since these are just job removals we could just +W them all and let them land, potentially out of order without a problem
16:16:27 <gmann> elodilles: oh do we run nova grenade job in nova stable/victoria?
16:16:33 <dansmith> it's not a regression like might normally be the case
16:16:35 <gmann> dansmith: +1
16:16:36 <dansmith> elodilles: thoughts?
16:17:37 <elodilles> dansmith: sounds good
16:17:51 <elodilles> for the 'l-c drop' patches
16:17:53 <dansmith> okay, melwitt said she was waiting to +2, but I think we should just slam them in
16:18:25 <dansmith> you okay if I treat her +1 as a +2 and just +2+W straight away?
16:18:43 <bauzas> if I can help, lmk
16:18:47 <elodilles> gmann: i think in nova (and neutron) grenade is running back till queens
16:18:52 <gmann> elodilles: for git issue, you are right stable/victoria in nova is blocked as we have nova grenade job running https://github.com/openstack/nova/blob/stable/victoria/.zuul.yaml#L466
16:19:13 <gmann> elodilles: let me backport in ussuri today but no motivation for stable/train or less
16:19:44 <elodilles> gmann: understood, i can backport them further
16:19:55 <gmann> elodilles: :) no option for EOL?
16:20:14 <elodilles> gmann: well, the option is there :)
16:20:29 <elodilles> gmann: what i see is that no one is interested in pike
16:20:36 <gmann> ack
16:20:40 <gmann> your call.
16:20:46 <elodilles> gmann: so i'm anyway planning to propose pike EOL
16:20:58 <gmann> sounds good,
16:20:58 <elodilles> gmann: though i see patches for queens time to time
16:21:24 <elodilles> gmann: but if no one else is interested, then of course, let's EOL
16:21:45 <gmann> yeah, we have to do it at some point otherwise we end up spending time on those
16:21:53 <bauzas> well, I'm not interested at least :)
16:22:05 <bauzas> elodilles: but you can ask the community
16:22:24 <gmann> anyways may be we can discuss that in TC or release about how many we can EOL
16:22:28 <elodilles> bauzas: i'm planning to do that for pike (mass-EOL)
16:22:32 <gmann> yeah, +1 on ML asking
16:23:09 <elodilles> sure, will do
16:25:54 <bauzas> ok, I guess we can move
16:26:02 <bauzas> last item
16:26:05 <bauzas> #topic Open discussion
16:26:09 <bauzas> (artom) https://blueprints.launchpad.net/nova/+spec/libvirt-update-windows-englightenments
16:26:37 <bauzas> artom_: not sure you can hear us :)
16:26:45 <bauzas> but this is your time
16:26:49 <artom_> Yeah, I grew a tail since then
16:26:55 <opendevreview> David Hill proposed openstack/nova master: Add disable_cpu_type_validation to skip cpu type validation.  https://review.opendev.org/c/openstack/nova/+/838552
16:27:11 <artom_> So, yeah, we talked about it at PTG, I filed the BP, just looking for a yay/nay on the specless BP aspect
16:27:15 <opendevreview> Balazs Gibizer proposed openstack/nova master: Remove unavailable but not reported PCI devices at startup  https://review.opendev.org/c/openstack/nova/+/838553
16:27:15 <opendevreview> Balazs Gibizer proposed openstack/nova master: Simulate bug 1969496  https://review.opendev.org/c/openstack/nova/+/838554
16:27:16 <bauzas> ok, this is a specless BP approval
16:27:30 <artom_> We're basically updating the XML we pass to libvirt when the guest is Windows to be nicer to the guest
16:27:41 <artom_> And mimic the kind of virtual HW that hyperv gives it
16:27:54 <dansmith> only for windows guests or all?
16:27:55 <bauzas> looks enough trivial for me and uncontroversial as libvirt supports those enlightments with our bare minimum version
16:28:10 <bauzas> and we already add some of them
16:28:21 <bauzas> dansmith: only for windows guests, yay
16:28:43 <bauzas> dansmith: we have some conditional in the code that makes the windows guests half-smart
16:28:58 <bauzas> half-smart, because we only enable some and not all the enlightments
16:28:58 <dansmith> there was previously a strong desire from some ops to be able to avoid exposing more detail to guests for cases where software had arbitrary "not licensed for virtual environments" restrictions
16:29:08 <dansmith> okay
16:29:34 <bauzas> dansmith: the conditional is based on the image prop IIRC
16:29:55 <dansmith> some image prop indicating windows or that windows enlightenments should be added?
16:29:57 <bauzas> dansmith: so operators who don't want to expose such things don't have to mark the images accordingly
16:29:57 <dansmith> if so, then cool
16:30:00 <dansmith> ack
16:30:09 <bauzas> dansmith: no, windows IIRC
16:30:19 <bauzas> lemme try to see if I can dig the conditional
16:30:23 <dansmith> so if it's just enabling more of those on the same conditional, then that seems fine for specless
16:30:43 <artom_> dansmith, so we currently already add some bits based on the image property
16:30:49 <artom_> This is just updating/adding some newer bits
16:30:53 <bauzas> found
16:30:54 <dansmith> ack, cool
16:30:56 <bauzas> #link https://github.com/openstack/nova/blob/master/nova/virt/libvirt/driver.py#L6062
16:31:14 <dansmith> roger that
16:31:36 <bauzas> ok, any concern for the specless approval ?
16:31:42 <dansmith> nope
16:31:47 <dansmith> I mean.. nope from me ;)
16:31:53 <artom_> dansmith, https://opendev.org/openstack/nova/src/branch/master/nova/virt/libvirt/driver.py#L6062-L6084
16:32:00 <artom_> jinx :(
16:32:07 <bauzas> artom_: please confirm those enlightments are already provided with our minim libvirt version ?
16:32:15 <gibi> I'm OK to have this accepted as specless
16:32:22 <artom_> Is "Sean said they are" good enough? :)
16:32:50 <bauzas> as 'yeah, bauzas, we don't need to bump our minimum supported libvirt version for the sake of such small change'
16:32:52 <dansmith> we should confirm, and just say so in the bp
16:33:08 <bauzas> sounds reasonable
16:33:39 <bauzas> #agreed https://blueprints.launchpad.net/nova/+spec/libvirt-update-windows-englightenments approved as a specless BP provided our minimum libvirt version already supports such enlightments
16:33:56 <bauzas> that's all we had for the meeting
16:34:06 <bauzas> any other item before we call it a wrap ?
16:34:35 <bauzas> looks not,
16:34:43 <bauzas> thanks all !
16:34:47 <bauzas> #endmeeting